Subject: FW: ** As requested ** FW: [Megaco] ABNF doesn't support AuditCap abilities of inbuilt properties of T erminationState and LocalControl des criptors

From: Nigel Williams <[email-masked]>
Date: Tue, 9 Jul 2002 17:08:08 +0100

Guys
 
We have run into the same issue with multiple values in AuditCapabilities
replies that David Barr raised a couple of weeks ago.  However, we haven't
seen any comments on his email.  Can anybody clarify how this should work?
 
Thanks
Nigel
 
Nigel Williams 
Voice Networking Group 
Data Connection Ltd 
Tel: +44 20 8366 1177 
Fax: +44 20 8363 1039 
Email: [email-masked] 
Web: http://www.dataconnection.com <http://www.dataconnection.com/>  

-----Original Message-----
From: David Barr [mailto:[email-masked]]
Sent: 24 June 2002 14:43
To: [email-masked]'
Subject: [Megaco] ABNF doesn't support AuditCapabilities of inbuilt
properties of T erminationState and LocalControl descriptors

Hello megaco list, 

If an AuditCapabilities of the Media descriptor is requested, then the MG is
required (amongst other things) to return the possible values of the
"inbuilt" properties in the TerminationState and LocalControl descriptors,
i.e. ServicesStates, EventBufferControl,  Mode, ReserveGroup, ReserveValue.

However the ABNF in H.248v1 doesn't seem to allow multiple values to be
returned for these "inbuilt" properties. 

E.g. 
auditReturnParameter = (mediaDescriptor / ... etc ...) 
mediaDescriptor = MediaToken LBRKT mediaParm *(COMMA mediaParm) RBRKT 
mediaParm = (... etc ... / terminationStateDescriptor) 
terminationStateDescriptor = TerminateStateToken LBRKT terminationStateParm
*( COMMA terminationStateParm ) RBRKT 
terminationStateParm = (propertyParm / serviceStates / eventBufferControl) 
serviceStates = ServiceStatesToken EQUAL ( TestToken / OutOfSvcToken /
InSvcToken) 

As can be seen, serviceStates only allows one value, when AuditCapabilities
should be able to return all 3 in a list. 

Thanks, 
David Barr 
Nortel Networks

---

From: Nigel Williams <[email-masked]>
Date: Tue, 9 Jul 2002 17:08:08 +0100

Guys

Thanks
Nigel
 
Nigel Williams 
Voice Networking Group 
Data Connection Ltd 
Tel: +44 20 8366 1177 
Fax: +44 20 8363 1039 

-----Original Message-----
From: David Barr [mailto:[email-masked]]
Sent: 24 June 2002 14:43
To: [email-masked]'
Subject: [Megaco] ABNF doesn't support AuditCapabilities of inbuilt

Hello megaco list, 

E.g. 

Thanks, 
David Barr 
Nortel Networks