Subject: Re: [Megaco] how to create a user-defined termination

From: [email-masked]
Date: Wed, 10 Jul 2002 18:21:10 +0800

hi,christer
   in my case,the MG implement several kinds of ephemeral terminations,such
as RTP ,audio MIX,video
MIX etc.do u mean i can use the same 'Add = $' to create any kind of
Termination by providing different parameters.if so,MG must be able to
identify what kind of termination to create by the parameter difference.
   is it right?

regards

wu.y.m

                    Christer Holmberg                                                                     
                    <[email-masked]        收件人：     [email-masked]                  
                    icsson.se>                       抄送：  [email-masked]                              
                    发件人：                         主题：  Re: [Megaco] how to create a user-defined    
                    [email-masked]            termination                                          

                    2002-07-10 16:21                                                                      

Hi,

"$" does not always mean that an RTP termination will be created. The
created
termination type depends on the data values you provide in the Add command,
and
of course what kind of ephemeral terminations your MG is able to create for
that specific Context.

Regards,

Christer Holmberg
Ericsson Finland

[email-masked] wrote:

> hi,folks
>    i am a beginner to h.248,so my question may not really be a question.
>
>    as described in megaco text,use following command format to add a
> physical termination.
>   1)  Add = TerminationID,
>
>    use following command format to create and add a ephemeral
> termination(RTP).MG will
>    create a new termination and return the termination ID to MGC
>   2)  Add = $ {
>              media{
>               ....
>              }
>           }
>
>     if i define a kind of new termination which is ephemeral too. how can
i
> Add such kind of termination to a context? if i use  Add = $ format,MG
will
> create a RTP termination that is not my
> purpose.
>     one possible method is to name all this kind terminations.for
> example,EphA,EphB,..EphZ.
>     then use "Add = EphA {media{...}}" to add a termination to a context.
>     i don't know if the above method is feasible.
>     please give some help.thanks!
>
> wu.y.m
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 10 Jul 2002 13:36:36 +0300

Hi,

> identify what kind of termination to create by the parameter difference.

Basically, yes.

However, you can also define your termination names, so the name indicates the type. Ie:

RTP/$   //Note the slash

MIX/$

etc etc.

Note, however, that RTP$ and MIX$ is not allowed.

Regards,

Christer Holmberg
Ericsson Finland

>
>
> regards
>
> wu.y.m
>
>
>                     Christer Holmberg
>                     <[email-masked]        ÊÕ¼þÈË£º     [email-masked]
>                     icsson.se>                       ³ËÍ£º  [email-masked]
>                     ·¢¼þÈË£º                         Ö÷Ìâ£º  Re: [Megaco] how to create a user-defined

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 10 Jul 2002 13:36:36 +0300

Hi,

Basically, yes.

RTP/$   //Note the slash

MIX/$

etc etc.

Regards,

Christer Holmberg
Ericsson Finland