Subject: [Megaco] a question about support both MGCP&MEGACO: how to apply an RTP port after add the PT

From: "derrick.ding" <[email-masked]>
Date: Tue, 16 Jul 2002 11:2:55 +0800

Hi,all！                                   
   I have a problem for MGC to support both Megaco and MGCP 
   following call flow is supported by MEGACO, but can MGCP support?

the call flow is:
1. MGC add a permanent trunk termination, don't apply RTP port.
   Megaco: context $, add(T1/10)
   MGCP:   CRCX T1/10 
** no local option here

2. MGC find it's a cross-MGs call, RTP port is needed, now apply RTP port.
   Megaco: context1, add($), SDP 
Now can MGCP support this function? and which command is used?
   MGCP: CRCX T1/10 L:P:10, a:G711
or MGCP: MDCX T1/10 L:P:10, a:G711 

It's a critical problem, and hope you can help me and give me some advice. 

Thanks and Best Regards           

***************************************
**** derrick.ding
**** [email-masked]
**** TEL: 0755-6983555-3655
**** Addr:Shenzhen Hi-Tech Industry Park
****      Legend building 3Floor 
****      UTStarCom
**** ZIP: 518057
****************************************

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "derrick.ding" <[email-masked]>
Date: Wed, 17 Jul 2002 14:52:55 +0800

Hi,Flemming Andreasen！
   Thanks for your reply, And I have another question to ask:
1. To play a ring back tone to an Endpoint first, I use CRCX:
CRCX 1204 t1/1@mg1 MGCP 0.1
C:1
S:rt

2. I wanna stop the tone, use MDCX:
MDCX 1205 t1/1@mg1 MGCP 0.1
C:1
I:1
S:

Can it be like this, just set Signal request as NULL?

2002-07-16 08:22:00 you write：
>"derrick.ding" wrote:
>In the MGCP case, creating the connection will also create the RTP port
>(unless you specify network type "LOCAL"), however you can set the mode to
>"inactive" to prevent any packets from flowing on it. However, you are not
>achieving anything with the above, so I'm not sure why you want to do it (the
>trunk is already there in the form of the endpoint).
>
>>
>If you already created the connection, then use the ModifyConnection command
>(btw, the encoding method should be "PCMU", not "G711"). If you didn't, use
>CreateConnection to now create a connection.
>
>-- Flemming