Subject: RE: [Megaco] Wildcarded Action Reply

From: Carl Rutter <[email-masked]>
Date: Tue, 9 Jul 2002 09:41:43 -0400

Thanks,

We limit the wildcards to a T1 right now on our switch
so at most 24 replies would come back.

It would be nice to send back a transaction reply 
with a flag saying there is another transaction reply(same transaction #)
coming with more response data, or something like that??
This would then break the transaction ack etc.  But some concept
like this seems warranted??

Carl
-----Original Message-----
From: Christian Groves [mailto:[email-masked]]
Sent: Monday, July 08, 2002 8:22 PM
To: Carl Rutter
Cc: [email-masked]; [email-masked]
Subject: Re: [Megaco] Wildcarded Action Reply

G'Day Carl,

The work around would be to wildcard on a finer grain size. That way you can
manage the number of replies. The alternative is that the MGC shall known
the
relationship between Termination IDs and Contexts IDs and it can release
each as
appropriate.

Regards, Christian

Carl Rutter wrote:
> 
> This seems to be a significant flaw.
> If there are many contexts the transaction would be
> way too big.  This also would happen on Audits etc.
> Anyone have thoughts on how we avoid/work around this?
> 
> Carl
> 
> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Monday, July 08, 2002 1:36 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [Megaco] Wildcarded Action Reply
> 
> G'Day Ron,
> 
> Unfortunately as you have pointed out the wildcarded only works on a
command
> level and not a context level. So in the case you point out the response
> will be
> larger than the requests. The original intention of w- responses was to
> limit
> the sizes of Audit responses.
> 
> Unfortunately unless there is a protocol change you'll get a long response
> back
> for commands with wildcarded (ALL) contextIds.
> 
> Regards, Christian
> 
> Ron Stoughton wrote:
> >
> > Greeting Megaconians:
> >
> > If our MG desires to take an interface out of service that has active
> > circuits engaged in calls on it, it very likely would send a command to
> the
> > MGC that looks like the following:
> >
> >     MEGACO/2 <mg1.acc.com>:16384
> >     Transaction = 6 {
> >             Context = - {
> >                     W-ServiceChange = DS1/3/1/* {
> >                             Services {
> >                                     Method = Forced,
> >                                     Reason = 905
> >                             }
> >                     }
> >             }
> >             Context = * {
> >                     W-ServiceChange = DS1/3/1/* {
> >                             Services {
> >                                     Method = Forced,
> >                                     Reason = 905
> >                             }
> >                     }
> >             }
> >     }
> >
> > My question is, what should I expect the transaction reply to look like?
> I
> > would prefer to receive something like the following:
> >
> >     MEGACO/2 <xanadu>:2944
> >     Reply = 6 {
> >             Context = - {
> >                     ServiceChange = DS1/3/1/*
> >           },
> >             Context = * {
> >                     ServiceChange = DS1/3/1/*
> >           }
> >     }
> >
> > However, the ABNF does not appear to provide a way to ask for a
wildcarded
> > action reply (e.g. by sending "W-Context = *"), so I think I am more
> likely
> > to get something like:
> >
> >     MEGACO/2 <mgc.acc.com>:2944
> >     Reply = 6 {
> >             Context = - {
> >                     ServiceChange = DS1/3/1/*
> >           },
> >             Context = 2 {
> >                     ServiceChange = DS1/3/1/3
> >           },
> >             Context = 5 {
> >                     ServiceChange = DS1/3/1/11
> >           },
> >             Context = 6 {
> >                     ServiceChange = DS1/3/1/13
> >           },
> >             Context = 9 {
> >                     ServiceChange = DS1/3/1/14
> >           }
> >     }
> >
> > assuming the MG has 4 active terminations on the interface.
> >
> > Is there any way to request a wildcarded reply?
> >
> > Ron Stoughton
> > [email-masked]
> >
> > _______________________________________________
> > Megaco mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/megaco
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Aleksandr Ryabin <[email-masked]>
Date: Tue, 09 Jul 2002 10:39:06 -0400

Hi,

         What I thin would work here is "enumeration". That is MGC
would send "start enumeration" flag for a transaction which would
let MG know to return an "enumeration handle".
Then MGC sets this "enumeration handle" in the next transaction
request (same as before, but differ in transaction id and the "handle")
such that MG would know where to continue from. Current
"enumeration handle" will continue be sent back and forth until MGC
would get reply with "enumeration end" indication, which could be
indicated by MG, for example, by not sending "enumeration handle".

This would not break transaction flow, but would need an extension
to be defined for this "enumeration" mechanism.

Comments?

Thanks
         Aleks

---

From: Aleksandr Ryabin <[email-masked]>
Date: Tue, 09 Jul 2002 10:39:06 -0400

Hi,

Comments?

Thanks
         Aleks