Subject: [Megaco] Which procedure should be done to cancel Add command ?

From: "Ryan Cho" <[email-masked]>
Date: Tue, 30 Jul 2002 18:06:24 +0900 (KST)

Hi,

1. suppose that MGC received R2/sz and R2/address from physical termination, and MGC need to reject the incoming call. MGC should send Modify with R2/clear signal but need to send subtract this physical termination with NULL context ID ?

2. Which procedure should be done to cancel Add command (including both of ephemeral and physical termination) before receive Reply ??? 

Regards,

Ryan

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 30 Jul 2002 07:31:10 -0400

Inline.

-----Original Message-----
From: Ryan Cho [mailto:[email-masked]]
Sent: Tuesday, July 30, 2002 5:06 AM
To: [email-masked]
Subject: [Megaco] Which procedure should be done to cancel Add command ?

Hi, 

1. suppose that MGC received R2/sz and R2/address from physical
termination, and MGC need to reject the incoming call. MGC should send
Modify with R2/clear signal but need to send subtract this physical
termination with NULL context ID ? 
[PTT]
Subtract from NULL context is not valid.  If you are trying to restore the
termination to its pre-seizure state you have to do it through Modify.  If
the signal type of R2/clear is BR or TO, it will complete on its own, so
you don't need to do anything with theSignals Descriptor.

2. Which procedure should be done to cancel Add command (including both of
ephemeral and physical termination) before receive Reply ??? 
[PTT]
There is no cancellation procedure.  Unless you know all the identifiers
involved, you just have to wait for the Reply.  If you do know the context
and termination identifiers, you can send a Subtract.

Regards, 

Ryan

���̹�-���ѹα� ��ǥ �˻�����, ���̹�
Ư���� e ������ ���� ��, ���׷��̵� ���̹� ����
http://www.naver.com

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Wed, 31 Jul 2002 09:37:39 +0530

Hi Rajeev

I don't think one can rely on the sending SUBTRACT with context=* without
waiting for ADD command response. If the commands reaches MG out of sequence
i.e., SUBTRACT followed by ADD, then MG will return error for the SUBTRACT
command. I think it is always better to wait for the ADD response before sending
SUBTRACT.

Regards
Vivek

NGN Group
Hughes Software Systems
Off: +91-124-6346666 Extn 3603
www.hssworld.com

Rajeev K R <[email-masked]> on 07/31/2002 06:38:53 AM

To:   Tom-PT Taylor <[email-masked]>, "'Ryan Cho'"
      <[email-masked]>, [email-masked]
cc:    (bcc: Vivek Bansal/HSS)

Subject:  Re: [Megaco] Which procedure should be done to cancel Add command ?

Hi Cho,
This is a very tricky implementation scenario.(cancel Add command)
But from the MGC side this is somewhat common where it want to release the
call
immediately after giving the add command. One option is as Tom has
mentioned, wait for the
add response, then issue subtract command with the actual context id. But
this will make the
implementation complex as you have to remember that this call has to be
subtracted when you get add response.

Another option is doing a subtract with context=*.
Here the action will be carried out since the termination is not in NULL
context.
But the response will contain action failures corresponding to all the other
contexts(Termination not in this context)  and success
for the one context for which the termination is present. This can be used
if your MG is small.
For large MGs the response will be too large.
Rajeev

----- Original Message -----
From: "Tom-PT Taylor" <[email-masked]>
To: "'Ryan Cho'" <[email-masked]>; <[email-masked]>
Sent: Tuesday, July 30, 2002 7:31 PM
Subject: RE: [Megaco] Which procedure should be done to cancel Add command ?

> and termination identifiers, you can send a Subtract.

³×ÀÌ¹ö-´ëÇÑ¹Î±¹ ´ëÇ¥ °Ë»öÆ÷ÅÐ, ³×ÀÌ¹ö
> Æ¯º°ÇÑ e ¸ÞÀÏÀ» ¿øÇÒ ¶©, ¾÷±×·¹ÀÌµå ³×ÀÌ¹ö ¸ÞÀÏ
> http://www.naver.com
>

---

From: [email-masked]
Date: Wed, 31 Jul 2002 09:37:39 +0530

Hi Rajeev

Regards
Vivek

NGN Group
Hughes Software Systems

Hi Cho,