Subject: [Megaco] Scope of StreamId

From: Raphael Tryster <[email-masked]>
Date: Sun, 7 Jul 2002 11:32:54 +0200

"If a termination is moved from one context to another, the effect on the
context to which the termination is moved is the same as in the case that a
new termination were added with the same StreamIDs as the moved
termination". 

Question:  If StreamID has context scope, then how do we prevent a clash
between the StreamID of a termination moved from context A to context B, and
the StreamID of a termination that was already present in context B prior to
the move?

Raphael Tryster
	
	-----Original Message-----
	From:	Christer Holmberg [SMTP:[email-masked]]
	Sent:	Thursday, 23 May, 2002 12:03 PM
	To:	Raphael Tryster
	Cc:	[email-masked]; Peter Farnell
	Subject:	Re: [Megaco] Local and remote descriptors

	Streams with the same StreamID are associated with each other within
the
	scope of a Context.

	Regards,

	Christer Holmberg
	Ericsson Finland

---

From: Christian Groves <[email-masked]>
Date: Mon, 08 Jul 2002 11:20:14 +1000

Hello Raphael,

I don't think there is a problem here. You probably actually want a clash
between stream IDs. ie. if you move a termination with stream ID=1 into another
context that also has streamID=1 then the streams will be mixed. This is
desirable behaviour for conference, 3pty etc.

Regards, Christian

Raphael Tryster wrote:
> new termination were added with the same StreamIDs as the moved termination".
> 
>      Streams with the same StreamID are associated with each other within the
>      scope of a Context.
> 
>      Regards,
> 
>      Christer Holmberg
>      Ericsson Finland

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Mon, 08 Jul 2002 11:20:14 +1000

Hello Raphael,

Regards, Christian