Subject: [Megaco] Command Replys

From: "gokulc" <[email-masked]>
Date: Wed, 24 Jul 2002 16:02:48 +0530

Hi,

I would like to know what would be valid reply for the following command:

Transaction = 1 {
Context = $ {
Add = TermA {
Media { LocalControl { Mode = ReceiveOnly} },
Modem = V18
}
}
}

Case 1:
Reply = 1 {
Context = 1 {
Add = TermA
}
}

Case 2:
Reply = 1 {
Context =1 {
Add = TermA {
Media { LocalControl { Mode = ReceiveOnly} },
Modem = V18
}
}
}

Which is valid case 1 or case 2.

gokul

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Aleksandr Ryabin <[email-masked]>
Date: Wed, 24 Jul 2002 11:27:46 -0400

Hi,

 From "7.2.1 Add"
    "The AuditDescriptor is optional. If present, the command will return
    descriptors as specified in the AuditDescriptor."

Thus case 1 will be used.
If you were to add Audit { Media, Modem } to Add command request
then case 2 would be used.

         Aleks

---

From: Aleksandr Ryabin <[email-masked]>
Date: Wed, 24 Jul 2002 11:27:46 -0400

Hi,

 From "7.2.1 Add"

         Aleks

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Wed, 24 Jul 2002 10:48:57 -0700

Hi Gokul,
Case 1 is the valid response. The response will have descriptors only when
they are fully specified by the MG (due to over or underspecification by
MGC) or when Audit descriptor lists the respective descriptors in its list.
Since in the example, all the parameters are fully specified there wont be
any descriptors in response.
Regards
Madhubabu Brahmanapally.

Syndeo Corporation
695 Campbell Technology Parkway
Campbell, CA 95008
Phone 408.376.1151
Fax 408.861.9801

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
gokulc
Sent: Wednesday, July 24, 2002 3:33 AM
To: [email-masked]
Subject: [Megaco] Command Replys

Hi,

Transaction = 1 {
Context = $ {
Add = TermA {

Case 1:
Reply = 1 {
Context = 1 {
Add = TermA
}
}

Case 2:
Reply = 1 {
Context =1 {
Add = TermA {

gokul

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Wed, 24 Jul 2002 10:48:57 -0700

Hi Gokul,

Syndeo Corporation

-----Original Message-----

Hi,

Transaction = 1 {
Context = $ {
Add = TermA {

Case 1:
Reply = 1 {
Context = 1 {
Add = TermA
}
}

Case 2:
Reply = 1 {
Context =1 {
Add = TermA {

gokul

---

From: Preeti Sharma <[email-masked]>
Date: Thu, 25 Jul 2002 18:58:15 -0400

Now that ServiceChangeProfile is represented as :

ServiceChangeProfile ::= SEQUENCE
{
 profileName   IA5String(SIZE (1..67))

 -- 64 characters for name, 1 for "/", 2 for verison to match ABNF
}

Can the ABNF rule for serviceChangeProfile look like :

serviceChangeProfile =  ProfileToken EQUAL NAME

instead of :

serviceChangeProfile =  ProfileToken EQUAL NAME SLASH Version

Preeti.

---

From: Preeti Sharma <[email-masked]>
Date: Thu, 25 Jul 2002 18:58:15 -0400

instead of :

Preeti.