Subject: [Megaco] About reply for AuditValue command?

From: [email-masked]
Date: Mon, 15 Jul 2002 15:16:37 +0900

Hi, list.

I have a question.
If a MGC issues AuditValue command following way,
ContextID=ALL,
TerminationID=Root,

As you know, a MG reply with list of all context ids as shown Section 7.2.5
in megaco 1.0 corr.

Under that condition, If the MG does not have any context. 
then, What is reply supposed to be?
Is it treated as an error? If so, which error code?

this question can be expanded in all case which using wildcard.
Generally speaking, if there is no matching termination id/context id when
the mgc using wildcard,
How for the MG to make transaction reply?

TIS.

---

From: Aleksandr Ryabin <[email-masked]>
Date: Mon, 15 Jul 2002 13:06:03 -0400

Hi,
         Please see my comments inline.

At 02:16 AM 7/15/2002, [email-masked] wrote:

>As you know, a MG reply with list of all context ids as shown Section 
>7.2.5 in megaco 1.0 corr.
>

Reply with error is returned.
I think error 411 "Unknown ContextID" is appropriate for this case.

>How for the MG to make transaction reply?

Reply with one of the wildcard related errors returned (on appropriate level).
For example, 431 "No TerminationID matched wildcard".
See H.248.8 (old H.248, Annex L) "Error codes and service change reason
description" for more details.

Cheers.
         Aleks

---

From: Aleksandr Ryabin <[email-masked]>
Date: Mon, 15 Jul 2002 13:06:03 -0400

Hi,

Cheers.
         Aleks