Subject: Re: ** As requested ** FW: [Megaco] ABNF doesn't support AuditCapabilities of inbuilt properties of T erminationState and LocalControl des criptors

From: [email-masked]
Date: Wed, 10 Jul 2002 10:22:27 +0200

Hi,

This would workaround the AuditCapabilities problem, but
I believe the same problem applies to wildcarded AuditValue,
where a union of property values is to be returned.
This is not supported in the syntax for the built-in properties like
ServiceState...

Regards,
Marc.

Christian Groves <[email-masked]>@ietf.org on 10/07/2002
02:48:23

Sent by:  [email-masked]

To:   Kevin Boyle <[email-masked]>
cc:   Nigel Williams <[email-masked]>, "[email-masked]'"
      <[email-masked]>
Subject:  Re: ** As requested ** FW: [Megaco] ABNF doesn't support
      AuditCapabilities of inbuilt properties of T erminationState and
      LocalControl des criptors

G'Day,

I agree with Kevin. It seems pretty pointless to AuditCapabilities a
property
whose values you already know through the protocol specification.

Regards, Christian

Kevin Boyle wrote:
>
> It seems to me that an MGC should already know the "capabilities" of the
> built-in properties in TermState and LocalControl.  Why should they be
> returned?  There is absolutely no benefit to performing AC on these
> particular properties.
>
> Instead of adding a bunch of syntax for these, can we just say explicitly
in
> Section 7.2.6 that the built-in properties cannot be singly audited (by
AC)
> and are not returned if the entire descriptor is audited?
>
> Kevin
>
> -----Original Message-----
> From: Nigel Williams [mailto:[email-masked]]
> Sent: Tuesday, July 09, 2002 12:08 PM
> To: [email-masked]'
> Subject: FW: ** As requested ** FW: [Megaco] ABNF doesn't support
AuditCap
> abilities of inbuilt properties of T erminationState and LocalControl des
> criptors
>
> Guys
>
> We have run into the same issue with multiple values in AuditCapabilities
> replies that David Barr raised a couple of weeks ago.  However, we
haven't
> seen any comments on his email.  Can anybody clarify how this should
work?
>
> Thanks
> Nigel
>
> Nigel Williams
> Voice Networking Group
> Data Connection Ltd
> Tel: +44 20 8366 1177
> Fax: +44 20 8363 1039
> Email: [email-masked]
> Web: http://www.dataconnection.com
>
> -----Original Message-----
> From: David Barr [mailto:[email-masked]]
> Sent: 24 June 2002 14:43
> To: [email-masked]'
> Subject: [Megaco] ABNF doesn't support AuditCapabilities of inbuilt
> properties of T erminationState and LocalControl descriptors
>
> Hello megaco list,
> If an AuditCapabilities of the Media descriptor is requested, then the MG
is
> required (amongst other things) to return the possible values of the
> "inbuilt" properties in the TerminationState and LocalControl
descriptors,
> i.e. ServicesStates, EventBufferControl,  Mode, ReserveGroup,
ReserveValue.
> However the ABNF in H.248v1 doesn't seem to allow multiple values to be
> returned for these "inbuilt" properties.
> E.g.
> auditReturnParameter = (mediaDescriptor / ... etc ...)
> mediaDescriptor = MediaToken LBRKT mediaParm *(COMMA mediaParm) RBRKT
> mediaParm = (... etc ... / terminationStateDescriptor)
> terminationStateDescriptor = TerminateStateToken LBRKT
terminationStateParm
> *( COMMA terminationStateParm ) RBRKT
> terminationStateParm = (propertyParm / serviceStates /
eventBufferControl)
> serviceStates = ServiceStatesToken EQUAL ( TestToken / OutOfSvcToken /
> InSvcToken)
> As can be seen, serviceStates only allows one value, when
AuditCapabilities
> should be able to return all 3 in a list.
> Thanks,
> David Barr
> Nortel Networks
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Wed, 10 Jul 2002 10:22:27 +0200

Hi,

Regards,
Marc.

G'Day,

Regards, Christian

in
AC)
AuditCap
haven't
work?
is
descriptors,
ReserveValue.
terminationStateParm
eventBufferControl)
AuditCapabilities