Subject: [RE] [Megaco] About reply for AuditValue command?

From: [email-masked]
Date: Tue, 16 Jul 2002 21:42:28 +0900

Actually, I've tried to find out whether the Megaco grammer support this or
not.
But, I could not figure out this.
In Megaco v1.0 syntax. As far as I concerned, the actionReplyList must
contain at least one the actionReply.

--------- Original Message --------
From: Tom-PT Taylor[[email-masked]]
To: [email-masked]; [email-masked]
Subject: RE: [Megaco] About reply for AuditValue command?

If the MG has no contexts, it should not report an error -- none has 
occurred.  That is a statement of principle.  I suppose I should check the 
syntax to see if an empty audit result can actually be reported back. 
  
-----Original Message----- 
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, July 15, 2002 2:17 AM 
To: [email-masked] 
Subject: [Megaco] About reply for AuditValue command?

Hi, list. 
I have a question. 
If a MGC issues AuditValue command following way, 
ContextID=ALL, 
TerminationID=Root, 
As you know, a MG reply with list of all context ids as shown Section 7.2.5 
in megaco 1.0 corr. 
Under that condition, If the MG does not have any context. 
then, What is reply supposed to be? 
Is it treated as an error? If so, which error code? 
this question can be expanded in all case which using wildcard. 
Generally speaking, if there is no matching termination id/context id when 
the mgc using wildcard, 
How for the MG to make transaction reply? 
TIS.

---

From: Aleksandr Ryabin <[email-masked]>
Date: Tue, 16 Jul 2002 12:28:47 -0400

Hi,

         In my opinion an error did occur in this case: wildcard did not match.
My assumption is: any command containing wildcard ether returns a valid
response, or an appropriate "no match" error.

Also as "[email-masked]" correctly noted that reply must contain
at least one action reply (or context properties, which does not apply
in this case). Action reply can not specify "no contexts" context id,
so the only way is to specify that by including error descriptor.

Thanks
         Aleks

At 08:42 AM 7/16/2002, [email-masked] wrote:

>Actually, I've tried to find out whether the Megaco grammer support this 
>or not.
>From: [email-masked] [<mailto:[email-masked]>mailto:[email-masked]]

---

From: Aleksandr Ryabin <[email-masked]>
Date: Tue, 16 Jul 2002 12:28:47 -0400

Hi,

Thanks
         Aleks