Subject: [Megaco] Clarification: termination updates

From: "Vamsi Krishna Pottangi" <[email-masked]>
Date: Wed, 17 Jul 2002 10:31:49 +0530

Hi All,

Clarification required

Say, a MG with 100 terminations is registered to a MGC.
A change in the state of any one of 100 terminations 
would be conveyed to MGC by MG though the ServiceChange message.
This is fine according to the standards.

Now say, MGC has restarted . In this case MG gets registered again.
What about the 100 terminations ??? 
(a)IS MG supposed to inform the MGC about these terminations or 
(b) MGC needs to audit the MG for all the 100 terminations 

I was not able to make out this from RFC-3015
Please let me know what is the proposed behaviour and
any pointers to this would be thankful.

Thanks,
- Vamsi

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Thu, 18 Jul 2002 10:50:52 +0530

Hi

At the time of MG restart, when MG registers with the MGC (service change method
used is RESTART), MGC would assume all the terminations to be in-service. For
the terminations which are out-of-service, MG needs to send service change to
indicate its state.

But in case of scenarios where MG is trying to recover the control association
i.e., either in case of handoff or looking for secondary MGC or trying to
reconnect to the same MGC (where service change method is one of FAILOVER,
HANDOFF or DISCONNECTED), it is MGC's responsibility to audit the states of the
individual terminations at MG.

Regards
Vivek Bansal

NGN Group
Hughes Software Systems
www.hssworld.com

"Vamsi Krishna Pottangi" <[email-masked]> on 07/17/2002 10:31:49 AM

To:   [email-masked]
cc:    (bcc: Vivek Bansal/HSS)

Subject:  [Megaco] Clarification: termination updates

Hi All,

Clarification required

Thanks,
- Vamsi

---

From: [email-masked]
Date: Thu, 18 Jul 2002 10:50:52 +0530

Hi

Regards
Vivek Bansal

NGN Group
Hughes Software Systems
www.hssworld.com

To:   [email-masked]

Hi All,

Clarification required

Thanks,
- Vamsi