Subject: [Megaco] a question about package

From: "yongming wu" <[email-masked]>
Date: Sat, 29 Jun 2002 09:39:14 +0000

hi,all
    can i define packages for RTP termination? further more,how can a mgc 
know that some packages are defined for RTP termination?
    how to audit which packages are implemented on ROOT termination?some 
examples are given in the megaco draft to describe how to audit packages for 
a termination.but the example is for permanent termination.not for RTP 
termination and ROOT termination.
    at last,i feel a mgc is difficult to know how many and which packages 
are implemented on a MG.
    please give me some advice.

wu.y.m

_________________________________________________________________
Send and receive Hotmail on your mobile device: http://mobile.msn.com

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 1 Jul 2002 17:46:18 -0400

> know that some packages are defined for RTP termination?
Well you can define a package by writing a document, as defined
in the protocol.  You might want to get such a package published,
and of course you want some MG and/or MGC vendors to implement it.
If it's usefull enough, it might be.

Since a package to be implemented on RTP ephemerals would be
defined that way, auditing root for packages would tell you
if your RTP package was implemented on the gateway.
In most gateways Context=*{Modify=rtp*{Audit{Packages}}} will work
if rtp ephemerals are named rtp000 or something like it.

> termination and ROOT termination.
Auditing ROOT gives you all packages implemented on the gateway.

>     please give me some advice.
As above, I think it's easy.

Of course the really easy way is to use a Profile, which tells you
that all the packages defined in the profile are implemented.
I believe that is the actual way most systems work.

Brian

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 1 Jul 2002 17:46:18 -0400

Brian