Subject: RE: [Megaco] Specifying values in AuditCapabilities responses

From: Nigel Williams <[email-masked]>
Date: Wed, 24 Jul 2002 12:05:01 +0100

Christian, List,

Thank you for the advice, this is very helpful.  I have a couple of
follow-up questions.

- Is "$" (CHOOSE) (or even "*" (ALL)) valid as a value in an
AuditCapabilities reply?  This would save sending [0:18446744073709551616]
for properties that are defined as being of type double.  A wildcard would
be even more useful in a case where a property takes a string value.

- I'm not sure what you mean by "7.2.6 is only relevant in the case that you
audit different descriptors in the one audit".  This seems to imply that
auditing multiple descriptors could/would make it necessary to repeat single
descriptors.  Am I interpreting this correctly?  It would be great if you
(or anyone else) could expand on this.

Thanks in advance
Nigel

Nigel Williams
Network Protocols Group
Data Connection Ltd
Tel: +44 20 8366 1177
Fax: +44 20 8363 1039
Email: [email-masked]
Web: http://www.dataconnection.com

-----Original Message-----
From: Christian Groves [mailto:[email-masked]]
Sent: 22 July 2002 08:12
To: Nigel Williams
Cc: [email-masked]'
Subject: Re: [Megaco] Specifying values in AuditCapabilities responses

G'Day Nigel,

I don't recall any text forbidding you to use ranges in this respect, so
thus I
would consider this valid. The text you refer to in 7.2.6 is only relevant
in
the case that you audit different descriptors in the one audit.

Regards, Christian

Nigel Williams wrote:
> 
> Hello List,
> 
> When auditing capabilities it is possible that the MG supports multiple
> values for a property or parameter.  The RFC says the following on this.
> 
>   7.2.6 AuditCapabilities
> 
>    [...] Descriptors may be repeated where there are multiple possible
> values.
> 
> If the AuditCapabilities reply only includes a single property or
parameter
> with a value then this is practical.  For example, it would be possible to
> return one Media Descriptor with Echo Cancellation (from the TDM Circuit
> Package) set to "On" and another with it set to "Off".  However, if there
> are many possible values or many properties and parameters then there seem
> to be two issues.
> 
> 1. If the value type is a number then an unfeasibly large number of
> descriptors would be required.
> 
> 2. If there is more than one property or parameter that takes a value then
> it would be necessary to enumerate the different combinations of the
> supported values.  This could lead to an even larger number of descriptors
> being required.
> 
> The obvious solution to this is to use ranges or lists of values.
However,
> the RFC says the following on this.
> 
>    Values assigned to Properties may be simple values
>    (integer/string/enumeration) or may be underspecified, where more
>    than one value is supplied and the MG may make a choice: [...]
> 
> This does not mention AuditCapablities.  Does anyone have an opinion on
> whether using lists and/or ranges for AuditCapabilities should be
considered
> valid?
> 
> Another possible solution would be to use the CHOOSE wildcard ("$") in
cases
> where all values are valid.  This could save sending a long list of
> enumerated type values or a range such as [0:4294967295].  Does anyone
have
> any comments on whether this should be considered valid?
> 
> Thanks in advance
> Nigel
> 
> Nigel Williams
> Voice Networking Group
> Data Connection Ltd
> Tel: +44 20 8366 1177
> Fax: +44 20 8363 1039
> Email: [email-masked]
> Web: http://www.dataconnection.com
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Wed, 24 Jul 2002 12:24:32 -0700

HI Nigel,

Its is not valid to send "$" CHOOSE (or any other wildcard) in
AuditCapabilities response.

Regards
Madhubabu Brahmanapally.

Syndeo Corporation
695 Campbell Technology Parkway
Campbell, CA 95008
Phone 408.376.1151
Fax 408.861.9801

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Nigel Williams
Sent: Wednesday, July 24, 2002 4:05 AM
To: [email-masked]'; [email-masked]'
Subject: RE: [Megaco] Specifying values in AuditCapabilities responses

Christian, List,

Thanks in advance
Nigel

Nigel Williams
Network Protocols Group
Data Connection Ltd
Tel: +44 20 8366 1177
Fax: +44 20 8363 1039

-----Original Message-----
From: Christian Groves [mailto:[email-masked]]
Sent: 22 July 2002 08:12
To: Nigel Williams
Cc: [email-masked]'
Subject: Re: [Megaco] Specifying values in AuditCapabilities responses

G'Day Nigel,

Regards, Christian

parameter
However,
considered
cases
have

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Wed, 24 Jul 2002 12:24:32 -0700

HI Nigel,

Regards
Madhubabu Brahmanapally.

Syndeo Corporation

-----Original Message-----

Christian, List,

Thanks in advance
Nigel

Nigel Williams
Network Protocols Group
Data Connection Ltd
Tel: +44 20 8366 1177
Fax: +44 20 8363 1039

-----Original Message-----
From: Christian Groves [mailto:[email-masked]]
Sent: 22 July 2002 08:12
To: Nigel Williams
Cc: [email-masked]'
Subject: Re: [Megaco] Specifying values in AuditCapabilities responses

G'Day Nigel,

Regards, Christian

parameter
However,
considered
cases
have

---

From: Christian Groves <[email-masked]>
Date: Thu, 25 Jul 2002 10:48:42 +1000

Hello Nigel,

As Madhu has stated a wildcard return is not allowed. 

On the second point I meant that if you send an AuditValue (localDescriptor,
remoteDescriptor, LocalControl) then the response would have the
localDescriptor, RemoteDescriptor and LocalControl descriptor. Thus the reply
would need multiple descriptors in answer to the auditvalue. I believe that the
text in 7.2.6 describes this situation not the case where you use multiple
instances of a single descriptor, which would be an error case.

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Thu, 25 Jul 2002 10:48:42 +1000

Hello Nigel,

Regards, Christian