Subject: Re: [Megaco] Wildcarded Action Reply

From: Christian Groves <[email-masked]>
Date: Mon, 08 Jul 2002 15:35:51 +1000

G'Day Ron,

Unfortunately as you have pointed out the wildcarded only works on a command
level and not a context level. So in the case you point out the response will be
larger than the requests. The original intention of w- responses was to limit
the sizes of Audit responses.

Unfortunately unless there is a protocol change you'll get a long response back
for commands with wildcarded (ALL) contextIds. 

Regards, Christian

Ron Stoughton wrote:
> 
> Greeting Megaconians:
> 
> If our MG desires to take an interface out of service that has active
> circuits engaged in calls on it, it very likely would send a command to the
> MGC that looks like the following:
> 
>     MEGACO/2 <mg1.acc.com>:16384
>     Transaction = 6 {
>             Context = - {
>                     W-ServiceChange = DS1/3/1/* {
>                             Services {
>                                     Method = Forced,
>                                     Reason = 905
>                             }
>                     }
>             }
>             Context = * {
>                     W-ServiceChange = DS1/3/1/* {
>                             Services {
>                                     Method = Forced,
>                                     Reason = 905
>                             }
>                     }
>             }
>     }
> 
> My question is, what should I expect the transaction reply to look like?  I
> would prefer to receive something like the following:
> 
>     MEGACO/2 <xanadu>:2944
>     Reply = 6 {
>             Context = - {
>                     ServiceChange = DS1/3/1/*
>           },
>             Context = * {
>                     ServiceChange = DS1/3/1/*
>           }
>     }
> 
> However, the ABNF does not appear to provide a way to ask for a wildcarded
> action reply (e.g. by sending "W-Context = *"), so I think I am more likely
> to get something like:
> 
>     MEGACO/2 <mgc.acc.com>:2944
>     Reply = 6 {
>             Context = - {
>                     ServiceChange = DS1/3/1/*
>           },
>             Context = 2 {
>                     ServiceChange = DS1/3/1/3
>           },
>             Context = 5 {
>                     ServiceChange = DS1/3/1/11
>           },
>             Context = 6 {
>                     ServiceChange = DS1/3/1/13
>           },
>             Context = 9 {
>                     ServiceChange = DS1/3/1/14
>           }
>     }
> 
> assuming the MG has 4 active terminations on the interface.
> 
> Is there any way to request a wildcarded reply?
> 
> Ron Stoughton
> [email-masked]
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Mon, 08 Jul 2002 15:35:51 +1000

G'Day Ron,

Regards, Christian