Subject: Re: Segmentation (was Re: [Megaco] Wildcarded Action Reply)

From: [email-masked]
Date: Fri, 19 Jul 2002 10:06:58 +0530

Christian,
        I have a small doubt in relation to the proposal below of (almost)
mandating SCTP or TCP.
 Does use of SCTP or TCP permit Hot Swap configuration of the MGC (assuming Hot
Swap
  to mean that MG is transparent to switchover happening at the MGC in the
context of this
 discussion thread) ?

Rgds,

Vikas Bajaj

Christian Groves <[email-masked]> on 07/18/2002 09:17:32 AM

To:   Kevin Boyle <[email-masked]>
cc:   Christer Holmberg <[email-masked]>, Tom-PT Taylor
      <[email-masked]>, Aleksandr Ryabin <[email-masked]>,
      [email-masked] (bcc: Vikas Bajaj/HSS)

Subject:  Re: Segmentation  (was Re: [Megaco] Wildcarded Action Reply)

G'Day Kevin,

I think what you have is a fair summary. I agree that we can't remove UDP from
v1 or v2. Perhaps in v3 (whenever it comes) we'll remove the requirement that if
you support IP you have to support UDP. I think the first 2 requirements listed
below are probably a good idea. I'm not sure what the effects of your third
requirement are. I assume that if we support UDP we still have to be compliant
to ALF defined in v1 and v2.

Regards, Christian

> That being said, I, personally, have no problem with saying that this should
> be handled via transport.  But, keep in mind that:
>
> 1) MGs may choose to support only UDP,
> 2) MGCs cannot establish TCP/SCTP connections to MGs -- they have to be
> established by the MG,
> 3) we can't remove UDP from v1 and v2.
>
> I believe that if we are going to allow the use of UDP, and we are going to
> allow the construction of giant messages, that we should be able to send
> those messages.
>
> Here's a couple additional thoughts on requirements for a potential
> segmentation solution:
>
> The MG should be able to initiate segmentation on its own, not depend on the
> MGC segmenting the request upon receipt of an error.
> Not only should segmentation/reassembly errors be detected, the mechanism
> should gracefully recover from those errors.
> Since this would apply to UDP, the exisiting ALF mechanism should be reused
> with as little change as possible.
>
> I am not so attached to having a unified solution for all versions.  Part of
> the point of a new version is adding enhancements that were overlooked in
> the previous ones, such as individual property audit.  This seems, to me, to
> be one of those kinds of enhancements.
>
> Kevin
>

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Mon, 22 Jul 2002 16:34:20 +1000

G'Day Vikas,

I can't see why not, so long as the signalling association is maintained.

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Mon, 22 Jul 2002 16:34:20 +1000

G'Day Vikas,

Regards, Christian

---

From: Aleksandr Ryabin <[email-masked]>
Date: Mon, 22 Jul 2002 11:10:07 -0400

Hi,

I agree that theoretically it should be no problem. Although while for UDP 
it is might be
quite trivial to maintain signalling association since there is no physical 
connection and
the most MG will have to do an ARP if hardware (ethernet) address of MGC 
changes,
in case of other protocols it might not be trivial to maintain physical 
connection
state on MGC (that is transport protocol data). Thus for hot swap systems 
which
currently use UDP it might not be trivial to move to other protocols if MEGACO
drops UDP support.

I know this is out of scope for MEGACO, but figured it would be worth saying
to make the protocol more implementation/realization friendly :)

Thanks
         Aleks.

---

From: Aleksandr Ryabin <[email-masked]>
Date: Mon, 22 Jul 2002 11:10:07 -0400

Hi,

Thanks
         Aleks.