Subject: [Megaco] Maximum MGC message buffer size

From: Hebden Ed-bluw41 <[email-masked]>
Date: Fri, 19 Jul 2002 13:00:12 +0100

Hi List

There has been much discussion of what the MG should do when a message's length exceeds the maximum message length allowed. The assumption here is that this length is 64kBytes as there is only a 2byte field available for the message length. This does not take account however of MGCs for which the maximum message length is less that 64k. For example we are using a windows based test tool to act as an MGC for some of our testing, this has a maximum message buffer size of 4096bytes due to a limitation of the windows socket layer.

Whilst a windows based MGC is unlikely shouldn't the protocol either:
- Explicitely say that the maximum message length must be 64k, or
- provide a mechanism by which the MGC tells the MG what the maximum message length is. One possibility would be for another property in the Base Root Package: maximumMGCBufferLength.

Does anyone have a view on this?

Ed Hebden

Motorola Computer Group
Loughborough PArk
Ashby Road
Loughborough
Leics
LE11 3NE
01509 634373

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Sat, 20 Jul 2002 18:11:26 -0400

The maximum buffer length property sounds like an interesting idea for TCP
or SCTP transport.  The current discussion has been regarding UDP, where it
is a good idea to stay below path MTU.  This is generally going to be
smaller than buffer size, and has to be discovered.

-----Original Message-----
From: Hebden Ed-bluw41 [mailto:[email-masked]]
Sent: Friday, July 19, 2002 8:00 AM
To: [email-masked]
Subject: [Megaco] Maximum MGC message buffer size

Hi List

There has been much discussion of what the MG should do when a message's
length exceeds the maximum message length allowed. The assumption here is
that this length is 64kBytes as there is only a 2byte field available for
the message length. This does not take account however of MGCs for which the
maximum message length is less that 64k. For example we are using a windows
based test tool to act as an MGC for some of our testing, this has a maximum
message buffer size of 4096bytes due to a limitation of the windows socket
layer.

Whilst a windows based MGC is unlikely shouldn't the protocol either:
- Explicitely say that the maximum message length must be 64k, or
- provide a mechanism by which the MGC tells the MG what the maximum message
length is. One possibility would be for another property in the Base Root
Package: maximumMGCBufferLength.

Ed Hebden

Motorola Computer Group
Loughborough PArk
Ashby Road
Loughborough
Leics
LE11 3NE
01509 634373

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Sat, 20 Jul 2002 18:11:26 -0400

-----Original Message-----
From: Hebden Ed-bluw41 [mailto:[email-masked]]
Sent: Friday, July 19, 2002 8:00 AM
To: [email-masked]
Subject: [Megaco] Maximum MGC message buffer size

Hi List

Ed Hebden

Motorola Computer Group
Loughborough PArk
Ashby Road
Loughborough
Leics
LE11 3NE
01509 634373

---

From: Aleksandr Ryabin <[email-masked]>
Date: Mon, 22 Jul 2002 10:55:59 -0400

Hi,

         Even though the current discussion is regarding MTU limitation for UDP
it is a very valid point that application can have its own limitation on 
buffer size.

Also it might be feasible, even if transport does not have MTU limitation,
to operate with smaller buffers. For example, if smaller buffers benefit in
smaller packet loss ratio (for a particular implementation).

This adds to the list of pros to have MEGACO protocol based solution
for "segmentation" problem.

Thanks
         Aleks

PS. If we are to have "split" package this property could go into it.

---

From: Aleksandr Ryabin <[email-masked]>
Date: Mon, 22 Jul 2002 10:55:59 -0400

Hi,

Thanks
         Aleks