Subject: [Megaco] Re: Regarding IPsec and interim AH

From: [email-masked]
Date: Tue, 30 Jul 2002 14:57:09 +0530

Hi All

This thread discussed about AH sometime early this year.

Is it concluded that interim AH header will be deprecated in V2 ?
Will we see it in any subsequent draft succeeding
draft-ietf-megaco-h248v2-01.txt ?
(except some comments for backwards compatibility)

Regards
Shiv Kumar
Hughes Software Systems

Matt Holdrege <[email-masked]> on 01/23/2002 12:30:39 AM

To:   "Tom-PT Taylor" <[email-masked]>, [email-masked]
cc:    (bcc: megaco_maillist)

Subject:  RE: [Megaco] Regarding IPsec and interim AH

Since I think it never should have been there, I can certainly make a
motion to depreciate it. I don't know how important it is to depreciate it,
but it certainly couldn't hurt. At least it would/could stop all the
questions about it.

At 10:25 AM 1/22/2002, Tom-PT Taylor wrote:
>Would people accept deprecation?  How many implementations are out there
>using interim AH and unable to switch to full IPSEC?  People can reply to me
>privately if they wish.
>
>-----Original Message-----
>From: Kaul, Bharat [mailto:[email-masked]]
>Sent: Friday, January 18, 2002 6:12 PM
>To: 'Matt Holdrege'; Narendra Babu; [email-masked]
>Subject: RE: [Megaco] Regarding IPsec and interim AH
>
>
>I remember long time back on this list it was being discussed that AH scheme
>will be deprecated. However, I still see its mention in v2.
>
>- Bharat
>
>-----Original Message-----
>From: Matt Holdrege [mailto:[email-masked]]
>Sent: Friday, January 18, 2002 5:26 AM
>To: Narendra Babu; [email-masked]
>Subject: Re: [Megaco] Regarding IPsec and interim AH
>
>
>At 10:36 PM 1/17/2002, Narendra Babu wrote:
> >Hi all,
> >
> >         I am a newbie to this mail list as well as megaco.
> >
> >We are developing a megaco stack.My doubt is whether
> >we have to implement full IPsec(RFC 2401-RFC 2411) or
> >only interim AH as a secrity support? Please clarify  this as early as
> >possible.
>
>I always thought interim AH wasn't a good idea and I think it is now
>clarified as a temporary scheme that is no longer needed. So your choices
>are IPsec or perhaps some less onerous scheme such as SSH.
>
>Anybody else?
>
>
>_______________________________________________
>Megaco mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/megaco
>
>_______________________________________________
>Megaco mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

DISCLAIMER: This message is proprietary to Hughes Software Systems
Limited (HSS) and is intended solely for the use of the individual
to whom it is addressed. It may contain  privileged or confidential
information  and should not be circulated or used for any purpose other
than for what it is intended. If you have received this message in error,
please notify the originator immediately. If you are not the intended
recipient, you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. HSS accepts
no responsibility for loss or damage arising from the use of the information
transmitted by this email including damage from virus.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Tue, 30 Jul 2002 14:57:09 +0530

Hi All

Regards
Shiv Kumar
Hughes Software Systems

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 30 Jul 2002 07:35:53 -0400

What you see in draft-ietf-megaco-h248v2-01.txt is what the ITU-T approved
on this topic.  In other words, we did not feel we could deprecate interim
AH, because there might be implementations out there.  However, no new
implementations should use it.

Perhaps we should have been a bit bolder.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, July 30, 2002 5:27 AM
To: [email-masked]
Subject: [Megaco] Re: Regarding IPsec and interim AH

Hi All

Regards
Shiv Kumar
Hughes Software Systems

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 30 Jul 2002 07:35:53 -0400

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, July 30, 2002 5:27 AM
To: [email-masked]
Subject: [Megaco] Re: Regarding IPsec and interim AH

Hi All

Regards
Shiv Kumar
Hughes Software Systems