Subject: Re: [Megaco] Megaco CAS support

From: Tom Taylor <[email-masked]>
Date: Tue, 13 May 2003 08:38:10 -0400

The day this was written, I was on the operating table.  Today is the first day I 
have been in a position to respond.

Kevin's frustration with the IETF process is my fault for not providing adequate 
leadership.  For that I apologize.  It stems to some extent from a confusion of 
objectives in my own working life.  That said:
-- the IESG has been unwilling to expand the Megaco charter to include packages
-- at this point, the IESG is ready to terminate the Working Group (BUT KEEP THE LIST).

It is up to us to determine a working relationship with the ITU-T that will keep the 
work moving in everybody's best interest.  I should point out that SG 16 itself is 
not having an easy time of it -- attendance has dropped drastically in the last 
couple of years.  The ITU-T is approaching one of those intervals when it considers 
reorganization, and we could find ourselves dealing with a different Study Group 
next year.

I'll ask a couple of questions to shape discussion of how we should proceed from here:

-- It seems self-evident to me that the Megaco list should continue to be the 
primary source of material for the Implementor's Guide.  Any disagreement?

-- Should we ask the ITU-T to allow us to derive I-Ds from new ITU-T Annexes so they 
can be reviewed by IETF process?  I did that sort of transcription early on, but 
didn't continue because I wasn't sure our agreement with the ITU-T allowed it.

-- Package documents in general have been individual drafts, since we couldn't add 
them to the WG charter.  This means the authors were free to submit them to the IESG 
without my intervention.  With that in mind, does anyone believe that there is an 
IETF role for creation of package documents independently of the ITU-T?

Michael DiGioia wrote:
> Kevin,
> 
>>> IETF does not seem interested in standardizing any packages.
> 
> 
> I don't believe I understand your comment. For many years the IETF has 
> had a well know process of making protocols into drafts and then into 
> approved standard RFC specifications. Do you imply by this that we 
> should trash IETF? I would think not since we produced the Internet as 
> it exists today.
> 
>> From a telephony standpoint, I think I can see your point since the 
>> ITU is 
> 
> the standards body for the telephony world. However, its a closed 
> organization that tends to be run by the large telephone companies - 
> i.e., not open to world participation without the necessary fees.
> 
> This whole idea was accepted by this group back in 99/00 to have 
> concurrent standards. Are we all now in agreement that this was a 
> mistake? I was with the minority then against this idea and for a quick 
> standard, produced by only the IETF, since this is how we (IETF) have 
> been so successful in the past.
> 
> I produced for my company the first IpTelephone which was at the first 
> Bakeoff in NH. However, by that time, the idea of an IpTelephone using 
> the media gateway protocols was not accepted by the larger community.
> 
> Where is Vince, Tom, and Brian now?
> 
> /mpd
> 
> 
> 
> 
> 
> 
>> From: "Kevin Boyle" <[email-masked]>
>> To: Michael DiGioia <[email-masked]>, 
>> [email-masked],   [email-masked], [email-masked]
>> CC: [email-masked]
>> Subject: RE: [Megaco] Megaco CAS support
>> Date: Tue, 22 Apr 2003 17:26:15 -0400
>>
>> With all due respect, the IETF had its chance to progress these (and many
>> other) packages.  In the interests of the larger community, I have 
>> taken the
>> packages to the ITU for standardization, since the IETF does not seem
>> interested in standardizing any packages.
>>
>> The work in the IETF is not "up and running".  The drafts published by
>> Hughes were published after the CAS packages were submitted to the ITU.
>>
>> Given that the working group is in the process of winding down, I do 
>> not see
>> any benefit to anyone in continuing to allow the IETF to hold up
>> standardization when the ITU is prepared to consider and advance the 
>> work.
>>
>> Kevin
>>
>> -----Original Message-----
>> From: Michael DiGioia [mailto:[email-masked]]
>> Sent: Tuesday, April 22, 2003 5:01 PM
>> To: [email-masked]; [email-masked]; 
>> [email-masked]
>> Cc: [email-masked]
>> Subject: Re: [Megaco] Megaco CAS support
>>
>>
>>
>> Christian,
>>
>> I agree, CAS should be part of the IETF similar to the original MEGACO 
>> draft
>>
>> work that held both organizations in sync.
>>
>> /mpd
>>
>>
>>
>>
>> >From: Aleksandr Ryabin <[email-masked]>
>> >To: Christian Groves <[email-masked]>,
>> >[email-masked]
>> >CC: Brad Steinka <[email-masked]>
>> >Subject: Re: [Megaco] Megaco CAS support
>> >Date: Tue, 22 Apr 2003 10:30:01 -0400
>> >
>> >Hi Christian,
>> >
>> >Then why are these brand new revisions of drafts were just recently
>> >submitted?
>> >
>> >http://www.ietf.org/internet-drafts/draft-ietf-megaco-r2package-03.txt
>> >http://www.ietf.org/internet-drafts/draft-laha-megaco-cas-mntc-00.txt
>> >
>> >More over a quick look through reveals that some of the package items
>> >in
>> >icas
>> >(ITU) the same as in r2 (IETF) up to the extent of exactly the same
>> >wording.
>> >
>> >Same AVD-2316 ITU doc mentions "CAS Blocking" package in summary which
>> >does not seem to be defined in the document and also "conflicts" with
>> >above IETF "CAS Maintenance Package".
>> >
>> >There is also reference to r2 package in AVD-2316 nowhere found in ITU.
>> >
>> >Also basic CAS packages draft still available at:
>> >http://www.ietf.org/internet-drafts/draft-manyfolks-megaco-caspackage-0
>> >2.txt
>> >but it is slightly different (outdated?) from AVD-2315 ITU version 
>> you have
>>
>> >specified.
>> >
>> >The recent submission of the above drafts had lead me to believe that
>> >CAS work is still quite "up and running" in IETF. This is all very
>> >confusing. When was it decided to move the work to ITU? Could someone
>> >point me out to some references (in IETF) of that please?
>> >
>> >My two cents on this topic: CAS is not an isolated package and in my
>> >opinion
>> >it would be much more productive to keep it on both channels (ITU and 
>> IETF)
>> >and in sync, similar to some other items done so far in H.248/MEGACO.
>> >What other folks think about it?
>> >
>> >Also in any case can the authors of ITU and IETF CAS related packages
>> >work together to come up with some kind of game plan and post it to the
>> >list to avoid any further confusion and inconsistencies?
>> >
>> >Thanks!
>> >         Aleks
>> >
>> >At 07:54 PM 4/21/2003, Christian Groves wrote:
>> >>G'Day Brad and Karl,
>> >>
>> >>I believe the intention is to move the CAS work into the ITU. The
>> >>contributions
>> >>containing the latest drafts can be found at:
>> >>ftp://standard.pictel.com/avc-site/0302_San/
>> >>
>> >>AVD-2312        MF Tone Generation and Detection Packages
>> >>AVD-2315        Basic CAS Packages
>> >>AVD-2316        International CAS Packages
>> >>AVD-2317        Enhanced Analog Line Packages
>> >>
>> >>Regards, Christian
>> >>
>> >>Brad Steinka wrote:
>> >> >
>> >> > There were several RFC draft document that described various
>> >> > packages
>> >>to
>> >> > support CAS, R1, R2, BCAS, etc.
>> >> > Most of these drafts have expired.
>> >> >
>> >> > Can anyone tell me what the latest RFCs are that support CAS calls
>> >> > and
>> >>where
>> >> > they are in the standards process?
>> >> >
>> >> > Thanks
>> >> >
>> >> > Brad Steinka
>> >> > Director - Software Engineering
>> >> > 734 Forest Street, Building G, Suite 100
>> >> > Marlboro, Ma.   01752
>> >> > Tel:  508-480-0909  x154
>> >> > Email: [email-masked] <mailto:[email-masked]>
>> >> > Web:   www.telica.com <http://www.telica.com>
>> >> >
>> >> > _______________________________________________
>> >> > Megaco mailing list
>> >> > [email-masked] https://www1.ietf.org/mailman/listinfo/megaco
>> >>_______________________________________________
>> >>Megaco mailing list
>> >>[email-masked]
>> >>https://www1.ietf.org/mailman/listinfo/megaco
>> >
>> >_______________________________________________
>> >Megaco mailing list
>> >[email-masked]
>> >https://www1.ietf.org/mailman/listinfo/megaco
>>
>>
>> _________________________________________________________________
>> MSN 8 with e-mail virus protection service: 2 months FREE*
>> http://join.msn.com/?page=features/virus
>>
>> _______________________________________________
>> Megaco mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/megaco
>> _______________________________________________
>> Megaco mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/megaco
> 
> 
> 
> _________________________________________________________________
> The new MSN 8: smart spam protection and 2 months FREE*  
> http://join.msn.com/?page=features/junkmail
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Tom Taylor <[email-masked]>
Date: Tue, 13 May 2003 08:38:10 -0400