Subject: [Megaco] MG registration procedure

From: Kalleitner Franz <[email-masked]>
Date: Mon, 12 May 2003 17:44:11 +0200

Hi Megaco-List-members,

a MG may register (not speaking from cold start) according to the shown
examples below using the ServicChangeMethod=Restart on its Root termination.
I didn't found any statement in the specification which contextID shall be
used either NULL or ALL wildcard.
Therefore it seems to be possible to start a correct registration procedure
using the ALL wildcard too, as shown in example2 
Concerns about exampel1:
However an MG may be assembled as pure packet oriented node and offers only
ephemeral resources, without any circuted switched resources.
I think this kind of MG will not be aware to process resources in NULL
Context?
Concerns about example2:
An alternative would be the use of ALL wildcard , but as far as I understood
the ALL wildcard does not include resources which
are in the NULL context.
However, which registration may be more appropriate. The example flows shows
the H248 uses as ContextID = NULL and in comparison e.g with
the ITU-T Q1950, which defined ALL wildcard for that procedure.
I think most implementations uses the NULL for MGW registration, but a
statement in the IG would help to close this ambiguity, at least that both
methods
would have the same outcome.
Comments ?
Franz
example 1:
MEGACO/1 [124.124.124.222]
Transaction = 9998 {
    Context = - {
        ServiceChange = ROOT {Services {
            Method=Restart, 
            ServiceChangeAddress=55555, Profile=ResGW/1}
        }
    }
}
example 2: 
MEGACO/1 [124.124.124.222]
Transaction = 9998 {
    Context = * {
        ServiceChange = ROOT {Services {
            Method=Restart, 
            ServiceChangeAddress=55555, Profile=ResGW/1}
        }
    }
}

---

From: Christian Groves <[email-masked]>
Date: Tue, 13 May 2003 12:39:31 +1000

Hello Franz,

The revised Q.1950 now lists the context ID as "value not significant". When
termination id "root" is used the value of context id is insignificant as you
are talking about the gateway as a whole.

Regards, Christian

>             ServiceChangeAddress=55555, Profile=ResGW/1}
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Tue, 13 May 2003 12:39:31 +1000

Hello Franz,

Regards, Christian