Subject: RE: [Megaco] H.248 equivalent of MGCP Delete from MG

From: Raphael Tryster <[email-masked]>
Date: Wed, 10 Sep 2003 09:25:45 +0200

Retransmitting due to lack of response.

Raphael Tryster

	-----Original Message-----
	From:	Raphael Tryster [SMTP:[email-masked]]
	Sent:	Monday, 30 June 2003 12:36
	To:	'Madhu Babu Brahmanapally'; 'David Barr'; 'megaco'
	Subject:	RE: [Megaco] H.248 equivalent of MGCP Delete from MG

	It won't help to put qualert in the event buffer descriptor unless
it is also requested in the events descriptor, so the MGC can receive it.
It seems to me David has a valid point about nt/qualert only becoming known
if it is actually asked for, and the sample call flows don't.  If the MGC
constantly asks for a set of maintenance type parameters, it could make
messages rather large.  Can anyone tell me if this feature is used in
practice?

	Raphael Tryster 

	-----Original Message----- 
	From:   Madhu Babu Brahmanapally [SMTP:[email-masked]] 
	Sent:   Tuesday, 14 August 2001 20:10 
	To:     'David Barr'; 'megaco' 
	Subject:        RE: [Megaco] H.248 equivalent of MGCP Delete from MG

	HI David/All, 
	  
	MGC, if interested to receive such events, has to sent those events
in the events descriptor or event buffer descriptor (Not shown in Example
call flows). Both "netfail" and "quality alert" can be used for this
purpose.(as applicable).  The method of calculating the threshold for
percent of quality loss is based on some provisional method. (I initially
thought that the protocol will suggest few methods for this calculation, I'm
not sure how this calculation is done.)

	Regards 
	Madhubabu 

		-----Original Message-----
		From: David Barr [ mailto:[email-masked]
<mailto:[email-masked]> ]
		Sent: Tuesday, August 14, 2001 12:12 PM
		To: 'Madhu Babu Brahmanapally'; megaco
		Subject: RE: [Megaco] H.248 equivalent of MGCP Delete from
MG

		So in my cases below, I assume you mean using nt/qualert
with threshold=100% ... is this correct? 
		  
		For case (1), I would think nt/netfail would also be a
suitable event ... correct? 
		  
		However there is a problem with using events to do this.  If
the MGC doesn't request the event, it obviously won't get informed of the
problem and therefore the call won't be cleared (... well, not until the
users hang-up in frustration.)

		The advantage of the MGCP approach was that the MGC got to
know about the problem without explicitly having to ask for it everytime it
set up a connection.

		Ok, back to nt/qualert ... is it standard practice for the
MGC to request this?  None of the example call flows I have seen show the
MGC requesting nt/qualert.

		Regards, 
		Dave. 
		  
		-----Original Message-----
		From: Madhu Babu Brahmanapally [
mailto:[email-masked] <mailto:[email-masked]> ]
		Sent: Tuesday, August 14, 2001 4:45 PM
		To: Barr, David [HAL02:HF22:EXCH]; megaco
		Subject: RE: [Megaco] H.248 equivalent of MGCP Delete from
MG

		Hi David, 
		In H.248, its only the MGC that can subtract the
terminations from the context. In case of packet-side failure/comfort noise
or any other case MG has to only indicate using the quality alert event and
MGC will take the necessary action. 

		Regards 
		Madhubabu 

			-----Original Message-----
			From: [email-masked] [
mailto:[email-masked] <mailto:[email-masked]> ]On Behalf Of
David Barr
			Sent: Tuesday, August 14, 2001 11:20 AM
			To: [email-masked]'
			Subject: [Megaco] H.248 equivalent of MGCP Delete
from MG

			Hello list, 

			MGCP has the concept of a Delete from the MG to the
MGC. 

			So what do we do for H.248 ?  The Subtract command
is intended for MGC to MG only. 

			The MG may need to use this under certain
circumstances.  Examples are:
			(1) If there is detection of a packet-side bearer
failure which affects a ephemeral termination within a current context.

			(2) If the MG fails to detect voice (or comfort
noise) on a bearer connection after a certain amount of time -- this may be
due to a problem with the peer MG, rather than anything wrong with the
network.

			(3) A temporary MG resource issue which caused it to
drop the call, but shouldn't affect future calls. 

			Is there a standardised way for the MG to convey
this infomation to the MGC -- i.e. one which all MGCs will understand? 

			Thanks.

---

From: "Anil Jangam" <[email-masked]>
Date: Wed, 10 Sep 2003 12:00:32 +0530

RE: [Megaco] H.248 equivalent of MGCP Delete from MGCan we make this event as a default event for the call? Although the concept of 'persistent' event is not included in Megaco, I think this would certainly help in simplifying this situation. Also as Raphael's comment on the size of the message, it would help to keep it in control.

/anil.

  ----- Original Message ----- 
  From: Raphael Tryster 
  To: 'megaco' 
  Sent: Wednesday, September 10, 2003 11:40 AM
  Subject: RE: [Megaco] H.248 equivalent of MGCP Delete from MG

  Raphael Tryster 

    -----Original Message----- 
    From:   Raphael Tryster [SMTP:[email-masked]] 
    Sent:   Monday, 30 June 2003 12:36 
    To:     'Madhu Babu Brahmanapally'; 'David Barr'; 'megaco' 
    Subject:        RE: [Megaco] H.248 equivalent of MGCP Delete from MG 

    It won't help to put qualert in the event buffer descriptor unless it is also requested in the events descriptor, so the MGC can receive it.  It seems to me David has a valid point about nt/qualert only becoming known if it is actually asked for, and the sample call flows don't.  If the MGC constantly asks for a set of maintenance type parameters, it could make messages rather large.  Can anyone tell me if this feature is used in practice?

    Raphael Tryster 

    -----Original Message-----
    From:   Madhu Babu Brahmanapally [SMTP:[email-masked]]
    Sent:   Tuesday, 14 August 2001 20:10
    To:     'David Barr'; 'megaco'
    Subject:        RE: [Megaco] H.248 equivalent of MGCP Delete from MG 

    HI David/All,
     
    MGC, if interested to receive such events, has to sent those events in the events descriptor or event buffer descriptor (Not shown in Example call flows). Both "netfail" and "quality alert" can be used for this purpose.(as applicable).  The method of calculating the threshold for percent of quality loss is based on some provisional method. (I initially thought that the protocol will suggest few methods for this calculation, I'm not sure how this calculation is done.)

    Regards
    Madhubabu 

      -----Original Message-----
      From: David Barr [ mailto:[email-masked]]
      Sent: Tuesday, August 14, 2001 12:12 PM
      To: 'Madhu Babu Brahmanapally'; megaco
      Subject: RE: [Megaco] H.248 equivalent of MGCP Delete from MG

      So in my cases below, I assume you mean using nt/qualert with threshold=100% ... is this correct?
       
      For case (1), I would think nt/netfail would also be a suitable event ... correct?
       
      However there is a problem with using events to do this.  If the MGC doesn't request the event, it obviously won't get informed of the problem and therefore the call won't be cleared (... well, not until the users hang-up in frustration.)

      The advantage of the MGCP approach was that the MGC got to know about the problem without explicitly having to ask for it everytime it set up a connection.

      Ok, back to nt/qualert ... is it standard practice for the MGC to request this?  None of the example call flows I have seen show the MGC requesting nt/qualert.

      Regards,
      Dave.
       
      -----Original Message-----
      From: Madhu Babu Brahmanapally [ mailto:[email-masked]]
      Sent: Tuesday, August 14, 2001 4:45 PM
      To: Barr, David [HAL02:HF22:EXCH]; megaco
      Subject: RE: [Megaco] H.248 equivalent of MGCP Delete from MG

      Hi David,
      In H.248, its only the MGC that can subtract the terminations from the context. In case of packet-side failure/comfort noise or any other case MG has to only indicate using the quality alert event and MGC will take the necessary action. 

      Regards
      Madhubabu 

        -----Original Message-----
        From: [email-masked] [ mailto:[email-masked]]On Behalf Of David Barr
        Sent: Tuesday, August 14, 2001 11:20 AM
        To: [email-masked]'
        Subject: [Megaco] H.248 equivalent of MGCP Delete from MG

        Hello list, 

        MGCP has the concept of a Delete from the MG to the MGC. 

        So what do we do for H.248 ?  The Subtract command is intended for MGC to MG only. 

        The MG may need to use this under certain circumstances.  Examples are:
        (1) If there is detection of a packet-side bearer failure which affects a ephemeral termination within a current context.

        (2) If the MG fails to detect voice (or comfort noise) on a bearer connection after a certain amount of time -- this may be due to a problem with the peer MG, rather than anything wrong with the network.

        (3) A temporary MG resource issue which caused it to drop the call, but shouldn't affect future calls. 

        Is there a standardised way for the MG to convey this infomation to the MGC -- i.e. one which all MGCs will understand? 

        Thanks.

---

From: "Anil Jangam" <[email-masked]>
Date: Wed, 10 Sep 2003 12:00:32 +0530

/anil.

  ----- Original Message ----- 
  From: Raphael Tryster 
  To: 'megaco' 
  Sent: Wednesday, September 10, 2003 11:40 AM
  Subject: RE: [Megaco] H.248 equivalent of MGCP Delete from MG

  Raphael Tryster 

    -----Original Message----- 
    From:   Raphael Tryster [SMTP:[email-masked]] 
    Sent:   Monday, 30 June 2003 12:36 
    To:     'Madhu Babu Brahmanapally'; 'David Barr'; 'megaco' 
    Subject:        RE: [Megaco] H.248 equivalent of MGCP Delete from MG 

    Raphael Tryster 

    -----Original Message-----
    From:   Madhu Babu Brahmanapally [SMTP:[email-masked]]
    Sent:   Tuesday, 14 August 2001 20:10
    To:     'David Barr'; 'megaco'
    Subject:        RE: [Megaco] H.248 equivalent of MGCP Delete from MG 

    HI David/All,

    Regards
    Madhubabu 

      -----Original Message-----
      From: David Barr [ mailto:[email-masked]]
      Sent: Tuesday, August 14, 2001 12:12 PM
      To: 'Madhu Babu Brahmanapally'; megaco
      Subject: RE: [Megaco] H.248 equivalent of MGCP Delete from MG

       

      Regards,
      Dave.
       
      -----Original Message-----
      From: Madhu Babu Brahmanapally [ mailto:[email-masked]]
      Sent: Tuesday, August 14, 2001 4:45 PM
      To: Barr, David [HAL02:HF22:EXCH]; megaco
      Subject: RE: [Megaco] H.248 equivalent of MGCP Delete from MG

      Hi David,

      Regards
      Madhubabu 

        -----Original Message-----
        From: [email-masked] [ mailto:[email-masked]]On Behalf Of David Barr
        Sent: Tuesday, August 14, 2001 11:20 AM
        To: [email-masked]'
        Subject: [Megaco] H.248 equivalent of MGCP Delete from MG

        Hello list, 

        Thanks.