Subject: RE: [Megaco] about parellel operation of command

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 4 Sep 2003 06:27:04 -0400

Be very careful here.  If an Add and a Subtract are sent in different
Transactions, there is NO guarantee as to which order the commands will be
executed.
 
To summarize ordering in H.248:
 
Commands in an action must be executed in order.
Actions in a transaction must be executed in order.
Transactions, whether in the same or different messages, may be executed in
any order.
 
Now, if a message contains both Transactions and Transaction Replies, the
Replies should be processed before the Transactions.
 
So, if I have two transactions, each of which have one action with one
command, those may be processed in either order.
 
Kevin

-----Original Message-----
From: Anil Jangam [mailto:[email-masked]] 
Sent: Thursday, September 04, 2003 5:08 AM
To: [email-masked]; [email-masked]
Subject: Re: [Megaco] about parellel operation of command

Hi Rui Suying,
 
See answers inline with [AJ].
 
/anil.

----- Original Message ----- 
From: [email-masked] <mailto:[email-masked]>  
To: [email-masked] <mailto:[email-masked]>  
Sent: Thursday, September 04, 2003 1:44 PM
Subject: [Megaco] about parellel operation of command

Hi all, 

        this question is about implementation of megaco. 

        RFC 3525 mentions the ordering of commands, but does not mentions
parellel. 
 
[AJ] The commands in given Context are supposed to be executed in sequence
only. The commands in a Context/Transaction can not be (rather should not
be) executed in parallel. This is something against the Megaco rules. 
 
In implementation,  a "add" command is followed by a "sub" command to the
same TM, while add command is still in operation, what will happen? 

[AJ] The 'Add' command will be executed first and then 'Subtract' command.
As these two command will be executed in sequence, there will be not
conflict. 

        while implementation, commands should be gathered and dealed with by
TMID or CONTEXTID? 
 
[AJ] Yes, they (commands) are first related by Context-Id and then by
Transaction-Id.

        thanks for answering my question. 
 
[AJ] Hope this answers your questions.

**********************************************
                Rui Suying
   SoftSwitch Software Design Department
            Nanjing R&D Center 
                ZTE Co. China
   Mobile: 13851939625 (China only)    
**********************************************

*********************************************************
Disclaimer

This message (including any attachments) contains 
confidential information intended for a specific 
individual and purpose, and is protected by law. 
If you are not the intended recipient, you should 
delete this message and are hereby notified that 
any disclosure, copying, or distribution of this
message, or the taking of any action based on it, 
is strictly prohibited.

*********************************************************
Visit us at http://www.mahindrabt.com

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Anil Jangam" <[email-masked]>
Date: Thu, 11 Sep 2003 16:36:06 +0530

MessageHi Kevin,

Need a small update on the following sequence you have mentioned.

As it is mentioned in the rfc (rfc 3525-p67) that all the Commands in the given Transaction should be executed in sequence, does it implies that all the Actions in a Transaction are executed in sequence?? 

My question is: Can MG execute Actions in parallel? IMO as the given Termination can not be present in more than one Context at given point of time, even if it executes the Actions parallely, its not going to conflict. Also the possibility of having two Actions with same ContextId seems very rare. 

Is the above consideration holds good enough to execute two Actions parallely?

/anil.

  ----- Original Message ----- 
  From: Kevin Boyle 
  To: Anil Jangam ; [email-masked] ; [email-masked] 
  Sent: Thursday, September 04, 2003 4:01 PM
  Subject: RE: [Megaco] about parellel operation of command

  Be very careful here.  If an Add and a Subtract are sent in different Transactions, there is NO guarantee as to which order the commands will be executed.

  Commands in an action must be executed in order.
  Actions in a transaction must be executed in order.
  Transactions, whether in the same or different messages, may be executed in any order.

  Now, if a message contains both Transactions and Transaction Replies, the Replies should be processed before the Transactions.

  So, if I have two transactions, each of which have one action with one command, those may be processed in either order.

  Kevin
    -----Original Message-----
    From: Anil Jangam [mailto:[email-masked]] 
    Sent: Thursday, September 04, 2003 5:08 AM
    To: [email-masked]; [email-masked]
    Subject: Re: [Megaco] about parellel operation of command

    Hi Rui Suying,

    /anil.

      ----- Original Message ----- 
      From: [email-masked] 
      To: [email-masked] 
      Sent: Thursday, September 04, 2003 1:44 PM
      Subject: [Megaco] about parellel operation of command

      Hi all, 

              RFC 3525 mentions the ordering of commands, but does not mentions parellel. 

      [AJ] The commands in given Context are supposed to be executed in sequence only. The commands in a Context/Transaction can not be (rather should not be) executed in parallel. This is something against the Megaco rules. 

      In implementation,  a "add" command is followed by a "sub" command to the same TM, while add command is still in operation, what will happen? 
      [AJ] The 'Add' command will be executed first and then 'Subtract' command. As these two command will be executed in sequence, there will be not conflict. 

              while implementation, commands should be gathered and dealed with by TMID or CONTEXTID? 

      [AJ] Yes, they (commands) are first related by Context-Id and then by Transaction-Id.

---

From: "Anil Jangam" <[email-masked]>
Date: Thu, 11 Sep 2003 16:36:06 +0530

MessageHi Kevin,

/anil.

  ----- Original Message ----- 
  From: Kevin Boyle 
  To: Anil Jangam ; [email-masked] ; [email-masked] 
  Sent: Thursday, September 04, 2003 4:01 PM
  Subject: RE: [Megaco] about parellel operation of command

  Kevin
    -----Original Message-----
    From: Anil Jangam [mailto:[email-masked]] 
    Sent: Thursday, September 04, 2003 5:08 AM
    To: [email-masked]; [email-masked]
    Subject: Re: [Megaco] about parellel operation of command

    Hi Rui Suying,

    /anil.

      ----- Original Message ----- 
      From: [email-masked] 
      To: [email-masked] 
      Sent: Thursday, September 04, 2003 1:44 PM
      Subject: [Megaco] about parellel operation of command

      Hi all,