Subject: [Megaco] about parellel operation of command

From: [email-masked]
Date: Thu, 4 Sep 2003 16:06:22 +0800

Hi all,

        this question is about implementation of megaco.

        RFC 3525 mentions the ordering of commands, but does not mentions 
parellel. In implementation,  a "add" command is followed by a "sub" 
command to the same TM, while add command is still in operation, what will 
happen?
        while implementation, commands should be gathered and dealed with 
by TMID or CONTEXTID?

        thanks for answering my question.

**********************************************
                 Rui Suying
    SoftSwitch Software Design Department
             Nanjing R&D Center 
                 ZTE Co. China
    Mobile: 13851939625 (China only) 
**********************************************

---

From: "Anil Jangam" <[email-masked]>
Date: Thu, 04 Sep 2003 14:38:23 +0530

Hi Rui Suying,

See answers inline with [AJ].

/anil.

  ----- Original Message ----- 
  From: [email-masked] 
  To: [email-masked] 
  Sent: Thursday, September 04, 2003 1:44 PM
  Subject: [Megaco] about parellel operation of command

  Hi all, 

          RFC 3525 mentions the ordering of commands, but does not mentions parellel. 

  [AJ] The commands in given Context are supposed to be executed in sequence only. The commands in a Context/Transaction can not be (rather should not be) executed in parallel. This is something against the Megaco rules. 

  In implementation,  a "add" command is followed by a "sub" command to the same TM, while add command is still in operation, what will happen? 
  [AJ] The 'Add' command will be executed first and then 'Subtract' command. As these two command will be executed in sequence, there will be not conflict.

          while implementation, commands should be gathered and dealed with by TMID or CONTEXTID? 

  [AJ] Yes, they (commands) are first related by Context-Id and then by Transaction-Id.

  [AJ] Hope this answers your questions.

*********************************************************
Disclaimer

This message (including any attachments) contains 
confidential information intended for a specific 
individual and purpose, and is protected by law. 
If you are not the intended recipient, you should 
delete this message and are hereby notified that 
any disclosure, copying, or distribution of this
message, or the taking of any action based on it, 
is strictly prohibited.

*********************************************************
Visit us at http://www.mahindrabt.com

---

From: "Anil Jangam" <[email-masked]>
Date: Thu, 04 Sep 2003 14:38:23 +0530

Hi Rui Suying,

/anil.

  ----- Original Message ----- 
  From: [email-masked] 
  To: [email-masked] 
  Sent: Thursday, September 04, 2003 1:44 PM
  Subject: [Megaco] about parellel operation of command

  Hi all,