Subject: [Megaco] RE: +AFs-Megaco+AF0- H.248 equivalent of MGCP Delete from MG

From: "FND-AD Wang JuLin" <[email-masked]>
Date: Wed, 10 Sep 2003 17:40:00 +0800

IMO, it is reasonable for gateway to inform MGC that there is something deadly  wrong with itself no matter does it  sends svc or notify message. What decision for MGC  to make is another case. Even as the master,mgc is not omnipotent .It can not request gateway to detect all the exceptional events. Thus ,such events are defined in package but never used in application if mgc never requested them. Another way is to extend the ServiceChangeReason parameter to depict such failure.  

>-----Original Message-----
>From: Kevin Boyle [mailto:[email-masked]]
>Sent: Wednesday, September 10, 2003 5:05 PM
>To: FND-AD Wang JuLin; Anil Jangam; Raphael Tryster; megaco
>Cc: [email-masked]
>Subject: RE: [Megaco] H.248 equivalent of MGCP Delete from MG
>
>
>The MGC is responsible for asking the MG to notify about 
>events the MGC has
>interest in.  There may be a very good reason why the MGC 
>doesn't wish to
>know about a network failure or quality degradation.  It isn't 
>up to the MG
>to decide what the MGC wants to know.
> 
>Further, the definition of a network failure will largely 
>depend upon the
>network in question -- it is perfectly normal for RTP to stop 
>flowing at
>times, but AAL2 requires constant packet transmission.  How 
>the failure is
>determined is outside the scope of the protocol, and is left to the
>implementations.
> 
>For message size, if it is really a problem, then there are 
>several steps
>that can be taken to minimize it: 1. Use short-form tokens; 2. 
>Remove all
>non-essential whitespace, ESPECIALLY "pretty formatting" and 
>the comment
>construct; 3. utilize a segmenting transport, such as 
>segmented UDP, TCP or
>SCTP.
> 
>Finally, which termination the event is applied to would 
>depend on where you
>would like to detect the event.  For instance, you would put 
>the event on
>the ephemeral if you wished to detect a bearer failure (RTP, 
>ATM, whatever).
>If you place it on the physical, you will be detecting for a 
>failure on that
>side (typically TDM, though it could be other things).
> 
>Kevin
>
>-----Original Message-----
>From: FND-AD Wang JuLin [mailto:[email-masked]] 
>Sent: Wednesday, September 10, 2003 3:17 AM
>To: Anil Jangam; Raphael Tryster; megaco
>Cc: [email-masked]; [email-masked]
>Subject: RE: [Megaco] H.248 equivalent of MGCP Delete from MG
>
>
>I agree with anil on this point since MGC don't  know the time 
>that the rtp
>stream  is failed or not.MG reporting exceptional events to 
>MGC as default
>cases increase the efficiency of stable communication and at 
>the same time,
>decrease the algorithm complexity for MGC.
>Another question is that such events are applied to rtp termination or
>physcial termination? Thanks a lot!
>
>-----Original Message-----
>From: Anil Jangam [mailto:[email-masked]]
>Sent: Wednesday, September 10, 2003 2:50 PM
>To: Raphael Tryster; 'megaco'
>Cc: [email-masked]; [email-masked]
>Subject: Re: [Megaco] H.248 equivalent of MGCP Delete from MG
>
>
>Can we make this event as a default event for the call? 
>Although the concept
>of 'persistent' event is not included in Megaco, I think this would
>certainly help in simplifying this situation. Also as 
>Raphael's comment on
>the size of the message, it would help to keep it in control.
> 
>/anil.
> 
>
>----- Original Message ----- 
>From: Raphael  <mailto:[email-masked]> Tryster 
>To: 'megaco' <mailto:[email-masked]>  
>Sent: Wednesday, September 10, 2003 11:40 AM
>Subject: RE: [Megaco] H.248 equivalent of MGCP Delete from MG
>
>
>
>Retransmitting due to lack of response. 
>
>Raphael Tryster 
>
>
>	BM__MailData-----Original Message----- 
>From:   Raphael Tryster [SMTP:[email-masked]] 
>Sent:   Monday, 30 June 2003 12:36 
>To:     'Madhu Babu Brahmanapally'; 'David Barr'; 'megaco' 
>Subject:        RE: [Megaco] H.248 equivalent of MGCP Delete from MG 
>
>	It won't help to put qualert in the event buffer 
>descriptor unless
>it is also requested in the events descriptor, so the MGC can 
>receive it.
>It seems to me David has a valid point about nt/qualert only 
>becoming known
>if it is actually asked for, and the sample call flows don't.  
>If the MGC
>constantly asks for a set of maintenance type parameters, it could make
>messages rather large.  Can anyone tell me if this feature is used in
>practice?
>
>	Raphael Tryster 
>
>	BM__MailData-----Original Message-----
>From:   Madhu Babu Brahmanapally [SMTP:[email-masked]]
>Sent:   Tuesday, 14 August 2001 20:10
>To:     'David Barr'; 'megaco'
>Subject:        RE: [Megaco] H.248 equivalent of MGCP Delete from MG 
>
>	HI David/All,
> 
>MGC, if interested to receive such events, has to sent those 
>events in the
>events descriptor or event buffer descriptor (Not shown in Example call
>flows). Both "netfail" and "quality alert" can be used for 
>this purpose.(as
>applicable).  The method of calculating the threshold for 
>percent of quality
>loss is based on some provisional method. (I initially thought that the
>protocol will suggest few methods for this calculation, I'm 
>not sure how
>this calculation is done.)
>
>	
>Regards
>Madhubabu 
>
>	-----Original Message-----
>From: David Barr [  <mailto:[email-masked]>
>mailto:[email-masked]]
>Sent: Tuesday, August 14, 2001 12:12 PM
>To: 'Madhu Babu Brahmanapally'; megaco
>Subject: RE: [Megaco] H.248 equivalent of MGCP Delete from MG
>
>
>So in my cases below, I assume you mean using nt/qualert with 
>threshold=100%
>... is this correct?
> 
>For case (1), I would think nt/netfail would also be a 
>suitable event ...
>correct?
> 
>However there is a problem with using events to do this.  If 
>the MGC doesn't
>request the event, it obviously won't get informed of the problem and
>therefore the call won't be cleared (... well, not until the 
>users hang-up
>in frustration.)
>
>	
>The advantage of the MGCP approach was that the MGC got to 
>know about the
>problem without explicitly having to ask for it everytime it set up a
>connection.
>
>	
>Ok, back to nt/qualert ... is it standard practice for the MGC 
>to request
>this?  None of the example call flows I have seen show the MGC 
>requesting
>nt/qualert.
>
>	
>Regards,
>Dave.
> 
>-----Original Message-----
>From: Madhu Babu Brahmanapally [  <mailto:[email-masked]>
>mailto:[email-masked]]
>Sent: Tuesday, August 14, 2001 4:45 PM
>To: Barr, David [HAL02:HF22:EXCH]; megaco
>Subject: RE: [Megaco] H.248 equivalent of MGCP Delete from MG
>
>
>Hi David,
>In H.248, its only the MGC that can subtract the terminations from the
>context. In case of packet-side failure/comfort noise or any 
>other case MG
>has to only indicate using the quality alert event and MGC 
>will take the
>necessary action. 
>
>	Regards
>Madhubabu 
>
>	-----Original Message-----
>From: [email-masked] [  <mailto:[email-masked]>
>mailto:[email-masked]]On Behalf Of David Barr
>Sent: Tuesday, August 14, 2001 11:20 AM
>To: [email-masked]'
>Subject: [Megaco] H.248 equivalent of MGCP Delete from MG
>
>
>
>	Hello list, 
>
>	MGCP has the concept of a Delete from the MG to the MGC. 
>
>	So what do we do for H.248 ?  The Subtract command is 
>intended for
>MGC to MG only. 
>
>	The MG may need to use this under certain 
>circumstances.  Examples
>are:
>(1) If there is detection of a packet-side bearer failure 
>which affects a
>ephemeral termination within a current context.
>
>	(2) If the MG fails to detect voice (or comfort noise) 
>on a bearer
>connection after a certain amount of time -- this may be due 
>to a problem
>with the peer MG, rather than anything wrong with the network.
>
>	(3) A temporary MG resource issue which caused it to 
>drop the call,
>but shouldn't affect future calls. 
>
>	Is there a standardised way for the MG to convey this 
>infomation to
>the MGC -- i.e. one which all MGCs will understand? 
>
>	Thanks. 
>
>
>	
>
>
>_______________________________________________
>Megaco mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/megaco
>

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "FND-AD Wang JuLin" <[email-masked]>
Date: Wed, 10 Sep 2003 17:40:00 +0800