Subject: RE: [Megaco] Use of Mux Descriptor

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Thu, 4 Sep 2003 10:18:23 +0200

Hi,

>1. About Mux Type(H.221,H.223,H.226,V.76), what
>are these devices? What reference can we use in our study?

Those "devices" are different ways of doing multiplexing, and are described in the ITU-T recomendations with the same numbers (H.221, H.223, etc).

>2. What is the advantage/disadvantage using 1 RTP (for
>Audio and Video), and 2 RTP (1 for Audio and 1 for Video)?

I think the depends on your implementation and your use cases.

>Can I have a sample sequence of commands in connecting
>terminations from a audio,video, and control signals
>to a Mux Descriptor and passing audio and video using a
>Stream Descriptor to a RTP.

You can find examples in H.248.20.

Regards,

Christer Holmberg
Ericsson Finland

> 
> Thanks in advance!!!
> 
> 
> 
> 
> "Christer Holmberg (JO/LMF)" wrote:
> 
> > Hi,
> >
> > >What is the main use of the Mux Descriptor
> >
> > You use it when you need to do multiplexing in your context.
> >
> > >and how to use it?
> >
> > As the spec defines to use it.
> >
> > If you have more specific questions, please let me know.
> >
> > Regards,
> >
> > Christer Holmberg
> > Ericsson Finland
> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Donaldo Martinez" <[email-masked]>
Date: Fri, 5 Sep 2003 16:29:20 +0800

Good afternoon.

I'd like to learn more about the sample figures between pages 19-20 of the
RFC3525.

On page 19, Figure 4 illustrates a Multiplexed Termination Scenario, in
which
labels named "Str 1" are shown.

Please refer to the figure below (I took the liberty to copy it from the
text):

--------------------------> cut here <------------------------------

                  +-----------------------------------+
                  | Context     +-------+             |
                 +----+         |       |             |
   Circuit 1 -|--| TC1|---------+ Tmux  |             |
              |  +----+ (Str 1) |       |  Audio    +-----+
              |   |             |       +-----*-----+     |-----
              |  +----+         | H.22x | Stream 1  |     |
   Circuit 2 -|--| TC2|---------+ multi-|           | TR1 |
              |  +----+ (Str 1) | plex  |           |(RTP)|
              |   |             |       |  Video    |     |
              |  +----+         |       +-----*-----+     |-----
   Circuit 3 -|--| TC3|---------+       | Stream 2  |     |
              /  +----+ (Str 1) |       |           +-----+
             /    |             +-------+             |
            /     +-----------------\-----------------+
   Audio, video, and control         \
   signals are carried in frames    Tmux is an ephemeral with two
   spanning the circuits.           explicit Stream Descriptors
                                    and a Multiplex Descriptor.

      Figure 4: Multiplexed Termination Scenario - Circuit to Packet
              (Asterisks * denote the centre of the context)

--------------------------> cut here <------------------------------

These labels, "Str 1", show a relationship between TC1, TC2, and TC3 to
the TMux.

What do these labels supposedly represent?

From the figure, I assume that the "Str 1" represents streams (possibly
of diffent types) that flow from TC1, TC2, and TC3 to the Tmux, but does
it mean that it collectively represents one stream (which is actually
multiplexed) as viewed by the Tmux?

A similar example was shown on ITU-T Rec. H.248.20 (11/2002), which is
Figure 2 on page 10, but I have a hard time relating the two.

It's rather confusing.  Could anyone please explain in detail, at least
for these two examples?

Regards,
Don Martinez

---

From: "Donaldo Martinez" <[email-masked]>
Date: Fri, 5 Sep 2003 16:29:20 +0800

Good afternoon.

Regards,
Don Martinez

---

From: Christian Groves <[email-masked]>
Date: Tue, 09 Sep 2003 16:46:53 +1000

Hello Donaldo,

Please see my replies below [CHG].

Regards, Christian

Donaldo Martinez wrote:

> Good afternoon.
> 
> I'd like to learn more about the sample figures between pages 19-20 of 
> the RFC3525.
> 

[CHG] These labels repesent a stream on a termination.
> multiplexed) as viewed by the Tmux?

[CHG] Each Str 1 on TC1, TC2 and TC3 is a seperate circuit (stream) of 64Kbits.
Collectively these 3 seperate circuits carry information that when demultiplexed
results in 2 stream (1 audio, 1 video).

---

From: Raymond Javier <[email-masked]>
Date: Wed, 10 Sep 2003 13:24:52 +0800

Hi,

Using Figure 4, the TC1, TC2, and TC3 have their own circuit streams.

In the TMux, can we use the following StreamIds in the Stream Descriptor?

    StreamId = 1      ; for TC1
    StreamId = 2      ; for TC2
    StreamId = 3      ; for TC31
    StreamId = 4      ; for RTP (audio stream)
    StreamId = 5      ; for RTP (video stream)

I'm really confused by the labels in the diagram.

Regards,
Raymond Javier

---

From: Raymond Javier <[email-masked]>
Date: Wed, 10 Sep 2003 13:24:52 +0800

Hi,

    StreamId = 1      ; for TC1
    StreamId = 2      ; for TC2
    StreamId = 3      ; for TC31

Regards,
Raymond Javier

---

From: Christian Groves <[email-masked]>
Date: Wed, 10 Sep 2003 16:55:13 +1000

Hello Javier,

In Tmux you would use only StreamID 4 & 5. In the multiplex descriptor you would
reference TC1, TC2 and TC3.

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Wed, 10 Sep 2003 16:55:13 +1000

Hello Javier,

Regards, Christian

---

From: Raymond Javier <[email-masked]>
Date: Thu, 11 Sep 2003 09:33:30 +0800

Hi again,

According to H.248.20 (see figure below)
Stream 1 is used in TermTDM and TermMUX(Stream Descriptor). Also TermTDM
is referenced in the multiplex descriptor of TermMUX.

If we cannot assign StreamIDs to TC1, TC2, and TC3,
can I say that TC1, TC2 and TC3 are not TermTDM's?
And what circuits are these?

When we describe the streams on the TMux (via StreamDescriptors),
do we need to include/describe the streams between the TCx to TMux?

Can we use the TerminationState Descriptor in the TCx instead of
Stream Descriptor and referenced these TCx in the TMux?

Regards, Raymond

---

From: Raymond Javier <[email-masked]>
Date: Thu, 11 Sep 2003 09:33:30 +0800

Hi again,

Regards, Raymond

---

From: Christian Groves <[email-masked]>
Date: Thu, 11 Sep 2003 11:33:27 +1000

Hello,

TC1 stands for "Termination Circuit 1". This could be equivalent to TermTDM (TDM
Termination". These labels are just an abstract name for the terminations
connected to the TDM network.

For these TDM terminations you can use what ever stream label you like. ie. 1,5,
20002. The multiplex termination makes a reference to these TDM terminations in
the multiplex descriptor. The multiplex termination needs to have the same
streamIDs as the RTP terminations so that data (audio/video) can flow. So in
your example there is no need to include/describe the streams between TCx to
TMux on the Tmux termination.

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Thu, 11 Sep 2003 11:33:27 +1000

Hello,

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Tue, 09 Sep 2003 16:46:53 +1000

Hello Donaldo,

Regards, Christian