Subject: [Megaco] CAS Metering Pulse support

From: Aleksandr Ryabin <[email-masked]>
Date: Tue, 16 Sep 2003 09:34:02 -0400

Hi all,

Below are excerpts from a previous exchange related to defining of
CAS Metering Pulse procedures in MEGACO.

Now that CAS packages related work has been moved to ITU has
anyone done and/or planned anything in the direction to define
CAS Metering Pulse procedures/package for MEGACO?

Thanks
         Aleks

>From: [email-masked]
>To: Aleksandr Ryabin <[email-masked]>
>cc: [email-masked], [email-masked], [email-masked]
>Date: Tue, 4 Mar 2003 12:47:37 +0530
>Subject: Re: [Megaco] Re: draft-ietf-megaco-r2package-03.txt : Difference
>         from previous revision
...
>Aleksandr Ryabin <[email-masked]> on 03/03/2003 10:43:20 PM
...
>3. I can't seem to find a way to implement "Metering Pulse" procedure defined
>for some R2 variants using ether bcas or R2 packages? For example, one
>of the definitions of such a pulse is a "seizure ack" pulse from a terminating
>end on a circuit in connected/answer state.
>
>[Kushanava] Metering is not specific to R2. It may be present in any CAS
>signaling. Moreover not all flavours of R2 permit metering to be mandatory.
>There should be therefore a general philosophy of attacking this problem
>common to all CAS signaling. The solution should be sensitive to
>a) Realizing that MGC is the master for collecting and generating charging
>information
>b) Interworking of the CAS "metering pulse" signals with other signaling
>(both PDN and PSTN)
>c) Optimizing the network traffic if metering information is transported to
>and fro between MGC and MG
>d) Latency, if metering information is transported to and fro between MGC
>and MG
>We are working towards a separate package that addresses this issue.
>Any suggestions?
...

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 16 Sep 2003 10:00:55 -0400

H.248.27 has a metering package (automatic metering package or amet).  This
package may address your needs.

Kevin

-----Original Message-----
From: Aleksandr Ryabin [mailto:[email-masked]] 
Sent: Tuesday, September 16, 2003 9:34 AM
To: [email-masked]
Subject: [Megaco] CAS Metering Pulse support

Hi all,

Below are excerpts from a previous exchange related to defining of CAS
Metering Pulse procedures in MEGACO.

Now that CAS packages related work has been moved to ITU has anyone done
and/or planned anything in the direction to define CAS Metering Pulse
procedures/package for MEGACO?

Thanks
         Aleks

...
...
>3. I can't seem to find a way to implement "Metering Pulse" procedure 
>defined for some R2 variants using ether bcas or R2 packages? For 
>example, one of the definitions of such a pulse is a "seizure ack" 
>pulse from a terminating end on a circuit in connected/answer state.
>
>[Kushanava] Metering is not specific to R2. It may be present in any 
>CAS signaling. Moreover not all flavours of R2 permit metering to be 
>mandatory. There should be therefore a general philosophy of attacking 
>this problem common to all CAS signaling. The solution should be 
>sensitive to
...

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 16 Sep 2003 10:00:55 -0400

Kevin

-----Original Message-----
From: Aleksandr Ryabin [mailto:[email-masked]] 
Sent: Tuesday, September 16, 2003 9:34 AM
To: [email-masked]
Subject: [Megaco] CAS Metering Pulse support

Hi all,

Thanks
         Aleks

...
...
...

---

From: Aleksandr Ryabin <[email-masked]>
Date: Tue, 16 Sep 2003 10:32:16 -0400

Hi,

I guess you meant H.248.26.
Yes it seem to address the needs assuming it is extended to digital lines 
as well.

BTW IANA registry should be updated with H.248.26 and H.248.27
http://www.iana.org/assignments/megaco-h248

Thanks,
         Aleks

At 10:00 AM 9/16/2003, Kevin Boyle wrote:

>H.248.27 has a metering package (automatic metering package or 
>amet).  This package may address your needs.
>
>Kevin
>
>From: Aleksandr Ryabin [<mailto:[email-masked]>mailto:[email-masked]]
><https://www1.ietf.org/mailman/listinfo/megaco>https://www1.ietf.org/mailman/listinfo/megaco 
>

---

From: Aleksandr Ryabin <[email-masked]>
Date: Tue, 16 Sep 2003 10:32:16 -0400

Hi,

Thanks,
         Aleks

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 16 Sep 2003 10:38:41 -0400

Ummm... yeah.  That's what I get for not looking it up before sending the
message. :)  While amet is defined in the "Extended Analog Lines Packages"
doc, there is nothing in the amet package that actually limits it to analog
lines.
 
The updates for all the new (as of May) H.248 Sub-series Recommendations
have already been requested of IANA.  If it is updated by the end of the
month, I'll ping them again.
 
Kevin

-----Original Message-----
From: Aleksandr Ryabin [mailto:[email-masked]] 
Sent: Tuesday, September 16, 2003 10:32 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; [email-masked]
Subject: RE: [Megaco] CAS Metering Pulse support

Hi,

I guess you meant H.248.26.
Yes it seem to address the needs assuming it is extended to digital lines as
well.

BTW IANA registry should be updated with H.248.26 and H.248.27 
http://www.iana.org/assignments/megaco-h248
<http://www.iana.org/assignments/megaco-h248> 

Thanks,
        Aleks

Kevin 

-----Original Message----- 
From: Aleksandr Ryabin [mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Tuesday, September 16, 2003 9:34 AM 
To: [email-masked] 
Subject: [Megaco] CAS Metering Pulse support 

Hi all, 

Thanks 
         Aleks 

... 
... 

... 

_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco
<https://www1.ietf.org/mailman/listinfo/megaco>

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 16 Sep 2003 10:38:41 -0400

Kevin

-----Original Message-----
From: Aleksandr Ryabin [mailto:[email-masked]] 
Sent: Tuesday, September 16, 2003 10:32 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; [email-masked]
Subject: RE: [Megaco] CAS Metering Pulse support

Hi,

Thanks,
        Aleks

Kevin 

-----Original Message----- 

Hi all, 

Thanks 
         Aleks 

... 
... 

...

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 16 Sep 2003 10:46:15 -0400

If it is NOT updated, that is. (Apparently, it's going to be one of those
days!)

Kevin

-----Original Message-----
From: Boyle, Kevin [NCRTP:3Z40:EXCH] 
Sent: Tuesday, September 16, 2003 10:39 AM
To: Aleksandr Ryabin; [email-masked]
Subject: RE: [Megaco] CAS Metering Pulse support

 
Kevin

-----Original Message-----
From: Aleksandr Ryabin [mailto:[email-masked]] 
Sent: Tuesday, September 16, 2003 10:32 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; [email-masked]
Subject: RE: [Megaco] CAS Metering Pulse support

Hi,

Thanks,
        Aleks

Kevin 

-----Original Message----- 

Hi all, 

Thanks 
         Aleks 

... 
... 

...

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 16 Sep 2003 10:46:15 -0400

Kevin

-----Original Message-----
From: Boyle, Kevin [NCRTP:3Z40:EXCH] 
Sent: Tuesday, September 16, 2003 10:39 AM
To: Aleksandr Ryabin; [email-masked]
Subject: RE: [Megaco] CAS Metering Pulse support

 
Kevin

-----Original Message-----
From: Aleksandr Ryabin [mailto:[email-masked]] 
Sent: Tuesday, September 16, 2003 10:32 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; [email-masked]
Subject: RE: [Megaco] CAS Metering Pulse support

Hi,

Thanks,
        Aleks

Kevin 

-----Original Message----- 

Hi all, 

Thanks 
         Aleks 

... 
... 

...

---

From: Aleksandr Ryabin <[email-masked]>
Date: Tue, 16 Sep 2003 10:50:42 -0400

It is updated with H.248.22 and 25, but not with 23, 24, 26, 27
while all of them are dated in ITU the same. Strange.
         Aleks

At 10:46 AM 9/16/2003, Kevin Boyle wrote:

>doc, there is nothing in the amet package that actually limits it to 
>analog lines.
>
>
><http://www.iana.org/assignments/megaco-h248>http://www.iana.org/assignments/megaco-h248 
>
>From: Aleksandr Ryabin 
>[<mailto:[email-masked]>mailto:[email-masked]

---

From: Aleksandr Ryabin <[email-masked]>
Date: Tue, 16 Sep 2003 10:50:42 -0400