Subject: [Megaco] H.248 v2 digitmap puzzle to be clarified

From: Zhao Bo <[email-masked]>
Date: Tue, 23 Sep 2003 10:00:18 +0800

hi, all:
 
i have read the h.248 version 2 document from ITU-T and have some puzzles to be clarified.
in section 7.1.14.4, we see the following sentenses:
 
    If EventBufferControl is OFF, if the active EventsDescriptor did not change, and if individual digit events are not 
    enabled within that descriptor, then digit buffering will be initiated.  Buffering will continue until the buffering 
    time specified in the original digit map completion event has expired or until the active EventsDescriptor is 
    replaced.
 
in above specification, some words as "buffering time specified in the original digit map completion event" is brought out
to us. until now, in my view, there is only one digitmap completion event which is defined in the DTMF detectin package
of H.248 annex E.6 .  but when referring to the definition of that package, we can not find even one word describing 
buffering time. are there any enhanced versions of digitmap completion event which are defined in some newly submitted 
extension packages ? if so, which package? or otherwise, maybe this buffering time is referred to as one of digitmap 
timers: start timer, short timer or long timer. but which one? no words in h248 text explicitly or indefinitely caters 
to this opnion.

and in the same section, we find some other text:
 
     Buffering time defaults to zero (no buffering) unless explicitly set otherwise within the digit map completion event.
 
if all the assumptions aforementioned can not come into existence, what should MGW alike equipments do with digit buffering ? 
no buffering as if buffering time defaults to zero ?
 
thanks for listening! it will be my pleasure if you responds!
                                                                                                             zhaobo
                                                                                                            2003.09.19

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 22 Sep 2003 23:25:34 -0400

H.248.16 defines two packages with digitmap completion events.  H.248.16 is
hardly new -- it has been a Recommendation since November 2002.

Generally speaking, the MG ought to hold digits until it receives some
indication that the MGC is really done collecting them.  Otherwise, digits
are likely to be lost, and the translations will fail.  Generally, a MG can
tell the MGC is finished with digit collection once an Events descriptor
without a digit event or digitmap completion event is sent to the MG.

Of course, implementations vary, and it may be that a particular
implementation will collect only the digits in a digitmap and no more.  So
it may be that a given implementation can safely ignore any extra digits.
However, many of the world's dial plans are immensely complex, and would be
very cumbersome, if not impossible, to express in a single digitmap.

Kevin

-----Original Message-----
From: Zhao Bo [mailto:[email-masked]] 
Sent: Monday, September 22, 2003 10:00 PM
To: [email-masked]
Subject: [Megaco] H.248 v2 digitmap puzzle to be clarified

hi, all:
 
i have read the h.248 version 2 document from ITU-T and have some puzzles to
be clarified. in section 7.1.14.4, we see the following sentenses:
 
    If EventBufferControl is OFF, if the active EventsDescriptor did not
change, and if individual digit events are not 
    enabled within that descriptor, then digit buffering will be initiated.
Buffering will continue until the buffering 
    time specified in the original digit map completion event has expired or
until the active EventsDescriptor is 
    replaced.
 
in above specification, some words as "buffering time specified in the
original digit map completion event" is brought out to us. until now, in my
view, there is only one digitmap completion event which is defined in the
DTMF detectin package of H.248 annex E.6 .  but when referring to the
definition of that package, we can not find even one word describing 
buffering time. are there any enhanced versions of digitmap completion event
which are defined in some newly submitted 
extension packages ? if so, which package? or otherwise, maybe this
buffering time is referred to as one of digitmap 
timers: start timer, short timer or long timer. but which one? no words in
h248 text explicitly or indefinitely caters 
to this opnion.

     Buffering time defaults to zero (no buffering) unless explicitly set
otherwise within the digit map completion event.
 
if all the assumptions aforementioned can not come into existence, what
should MGW alike equipments do with digit buffering ? 
no buffering as if buffering time defaults to zero ?

zhaobo
 
2003.09.19

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 22 Sep 2003 23:25:34 -0400

Kevin

-----Original Message-----
From: Zhao Bo [mailto:[email-masked]] 
Sent: Monday, September 22, 2003 10:00 PM
To: [email-masked]
Subject: [Megaco] H.248 v2 digitmap puzzle to be clarified

hi, all:

 

 

zhaobo
 
2003.09.19