Subject: RE: [Megaco] end of Megaco message

From: Raphael Tryster <[email-masked]>
Date: Thu, 25 Sep 2003 08:46:53 +0200

Guru,

I changed the subject line, because subject lines should help identify
topics of interest, even years later.  Subject lines like "Hi there" seen
recently don't advance this goal.

A Megaco message is contained in an IP packet, whose header indicates its
length.  So, end of packet means end of message.
 
Raphael Tryster

	-----Original Message-----
	From:	guru prasad [SMTP:[email-masked]]
	Sent:	Thursday, 25 September 2003 7:05
	To:	[email-masked]
	Subject:	[Megaco] megaco queries

	hello all,
	i have 2 queries to make.
	1: how do v detect the end of a megaco msg?
	 i.e., how do v know that a transaction is the last one present in
the msg? is it implementation specific or is there a standard?

	2:the rfc does not mention as to how the mgc discovers the
terminations of the mg. could u pls reply as to how this happens?

	regards,
	guru prasad
	-- 
	______________________________________________
	http://www.india.com
	Now with POP3/SMTP access for only US$14.95/yr

	Powered by Outblaze

	_______________________________________________
	Megaco mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/megaco

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 25 Sep 2003 08:46:53 +0200

Guru,

 
Raphael Tryster

	-----Original Message-----
	From:	guru prasad [SMTP:[email-masked]]
	Sent:	Thursday, 25 September 2003 7:05
	To:	[email-masked]
	Subject:	[Megaco] megaco queries

	hello all,

	regards,
	guru prasad

	Powered by Outblaze

---

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 25 Sep 2003 10:30:31 -0400

Hi,

I would like to clarify that this applies for MEGACO over UDP.
When using TCP from RFC 3525 "D.2   Using TCP":

"...TPKT, according to RFC 1006, SHALL be used to delineate
    messages within the TCP stream."

Regards,
         Aleks

At 02:46 AM 9/25/2003, Raphael Tryster wrote:

>-----Original Message----- From:   guru prasad 
>[SMTP:[email-masked]] Sent:   Thursday, 25 September 2003 7:05 
>To:     [email-masked] Subject:        [Megaco] megaco queries
>
>hello all, i have 2 queries to make. 1: how do v detect the end of a 
>megaco msg?  i.e., how do v know that a transaction is the last one 
>present in the msg? is it implementation specific or is there a standard? 
>2:the rfc does not mention as to how the mgc discovers the terminations of 
>the mg. could u pls reply as to how this happens? regards, guru prasad 
>--  ______________________________________________ 
><http://www.india.com>http://www.india.com Now with POP3/SMTP access for 
>only US$14.95/yr
>
>Powered by Outblaze
>
>_______________________________________________ Megaco mailing list 
>[email-masked] 
><https://www1.ietf.org/mailman/listinfo/megaco>https://www1.ietf.org/mailman/listinfo/megaco 
>

---

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 25 Sep 2003 10:30:31 -0400

Hi,

Regards,
         Aleks