Subject: RE: [Megaco] Query Related to Automatic Metering

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 5 Jan 2004 10:06:24 -0500

The way to correct Recommendations in the H.248 subseries is to insert an
item in the IG for that Recommendation.  This would go in the IG in a
chapter for H.248.26.  More comments inline. [KJBII]
 
Kevin

  _____  

From: Dal Chohan [mailto:[email-masked]] 
Sent: Monday, January 05, 2004 7:23 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; Taylor, Tom-PT [CAR:5N00:EXCH];
[email-masked]
Cc: [email-masked]
Subject: Re: [Megaco] Query Related to Automatic Metering

Shouldn't the clause 7.5 paragraph 5 procedures in the "amet" package be
modified so that they don't override the standard Events
Descriptor/KeepActive flag procedures defined in Megaco rather than
specifying something in the Implementation Guide? I recommend that the
offending sentence of clause 7.5 paragraph 5 "The detection of event pr
shall not cause the termination of the signal em or signal mbp, even if the
KeepActive flag is not set for the pr event" is deleted from the "amet"
package.
[KJBII] See above. 
 
In addition there is a similar problem with clause 7.5 paragraph 4 of the
"amet" package which also potentially overrides the standard Megaco Events
Descriptor/KeepActive flag and Signal Descriptor/KeepActive flag
procedures.
 
"If the value of the parameter pc is zero or if this parameter is not
supplied by the MGC, then the repetitive application of metering pulses
should continue until either an event (other than pr) is detected, or until
the SignalsDescriptor is replaced with a new SignalsDescriptor that does not
include the signal em. Any pulses applied due to a concurrent mpb signal
shall be in addition to the required repetitive pulses applied for the em
signal".
 
For example the meter pulses will continue even when an on-hook event is
detected providing the events descriptor that armed the on-hook event had
the KeepActive flag set. This action may be required for certain territories
where all outstanding meter pulses must be delivered even when the analogue
line is in the on-hook state.
[KJBII] I'm not sure what this example has to do with the problem mentioned
above -- the package already functions this way. 
 
Again the sentence above defining the SignalDescriptor procedures in the
"amet" package does not define anything new which is not already specified
in the standrad Megaco procedures. Hence I recommend that clause 7.5
paragraph 4 of the "amet" package be modified to read as:
 
"If the value of the parameter pc is zero or if this parameter is not
supplied by the MGC, then any pulses applied due to a concurrent mpb signal
shall be in addition to the required repetitive pulses applied for the em
signal"
[KJBII] This would be a natural extension of the above correction. 

Regards,

Dal Chohan.

----- Original Message ----- 
From: "Kevin Boyle" < <mailto:[email-masked]>
[email-masked]>
To: "Tom-PT Taylor" < <mailto:[email-masked]>
[email-masked]>; < <mailto:[email-masked]>
[email-masked]>
Cc: < <mailto:[email-masked]> [email-masked]>
Sent: Friday, January 02, 2004 3:19 PM
Subject: RE: [Megaco] Query Related to Automatic Metering

> Do we need an IG item?  I can add one for the upcoming meeting, if we
> believe that this should be fixed.
> 
> I would rather not have use of KA mandated.  Let the implementor decide
how
> the event should interact with any signals.
> 
> Kevin
> 
> -----Original Message-----
> From: Taylor, Tom-PT [CAR:5N00:EXCH] 
> Sent: Monday, December 22, 2003 11:53 AM
> To:  <mailto:[email-masked]> [email-masked]
> Cc:  <mailto:[email-masked]> [email-masked]
> Subject: Re: [Megaco] Query Related to Automatic Metering
> 
> I think you make a good point.  It's desirable to keep the protocol
intact,
> rather than define exceptions within individual packages.
> 
>  <mailto:[email-masked]> [email-masked] wrote:
> 
> > 
> > 
> > 
> > Hi List,
> > 
> > 
> > this is a query regarding Periodic report event 'pr' defined in AMET 
> > package .the package procedure says that
> > 
> > "the detection of event pr shall not cause the termination of the 
> > signal em or signal mbp, even if the KeppActive(KA) flag is not set 
> > for the pr event"
> > 
> > what i feel is that the detection of the 'pr' event shall not cause 
> > the termination of any of the signals.
> > 
> > pls tell me if this is a correct assumption?
> > 
> > if yes, then i think here the package procedures should have mandated 
> > the use of KA flag with this event. Doing this will keep the protocol 
> > rules intact.
> > 
> > 
> > 
> > Regards
> > Sachin Gupta
> > 
> > "DISCLAIMER: This message is proprietary to Hughes Software Systems 
> > Limited
> > (HSS) and is intended solely for the use of the individual to whom it 
> > is addressed. It may contain  privileged or confidential information 
> > and should not be circulated or used for any purpose other than for 
> > what it is intended. If you have received this message in error, 
> > please notify the originator immediately. If you are not the intended 
> > recipient, you are notified that you are strictly prohibited from 
> > using, copying, altering, or disclosing the contents of this message. 
> > HSS accepts no responsibility for loss or damage arising from the use 
> > of the information transmitted by this email including damage from
virus."
> > 
> > 
> > _______________________________________________
> > Megaco mailing list
> >  <mailto:[email-masked]> [email-masked]
> >  <https://www1.ietf.org/mailman/listinfo/megaco>
https://www1.ietf.org/mailman/listinfo/megaco
> > 
> 
> 
> _______________________________________________
> Megaco mailing list
>  <mailto:[email-masked]> [email-masked]
>  <https://www1.ietf.org/mailman/listinfo/megaco>
https://www1.ietf.org/mailman/listinfo/megaco
> 
> _______________________________________________
> Megaco mailing list
>  <mailto:[email-masked]> [email-masked]
>  <https://www1.ietf.org/mailman/listinfo/megaco>
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Dal Chohan" <[email-masked]>
Date: Mon, 5 Jan 2004 15:36:57 -0000

Please can you specify what text you will be including in the IG - Also see in-line comments.,

Regards,

Dal Chohan
  ----- Original Message ----- 
  From: Kevin Boyle 
  To: Dal Chohan ; Tom-PT Taylor ; [email-masked] 
  Cc: [email-masked] 
  Sent: Monday, January 05, 2004 3:06 PM
  Subject: RE: [Megaco] Query Related to Automatic Metering

  The way to correct Recommendations in the H.248 subseries is to insert an item in the IG for that Recommendation.  This would go in the IG in a chapter for H.248.26.  More comments inline. [KJBII]

  Kevin

----------------------------------------------------------------------------
    From: Dal Chohan [mailto:[email-masked]] 
    Sent: Monday, January 05, 2004 7:23 AM
    To: Boyle, Kevin [NCRTP:3Z40:EXCH]; Taylor, Tom-PT [CAR:5N00:EXCH]; [email-masked]
    Cc: [email-masked]
    Subject: Re: [Megaco] Query Related to Automatic Metering

    Shouldn't the clause 7.5 paragraph 5 procedures in the "amet" package be modified so that they don't override the standard Events Descriptor/KeepActive flag procedures defined in Megaco rather than specifying something in the Implementation Guide? I recommend that the offending sentence of clause 7.5 paragraph 5 "The detection of event pr shall not cause the termination of the signal em or signal mbp, even if the KeepActive flag is not set for the pr event" is deleted from the "amet" package.
    [KJBII] See above. 

    In addition there is a similar problem with clause 7.5 paragraph 4 of the "amet" package which also potentially overrides the standard Megaco Events Descriptor/KeepActive flag and Signal Descriptor/KeepActive flag  procedures.

    "If the value of the parameter pc is zero or if this parameter is not supplied by the MGC, then the repetitive application of metering pulses should continue until either an event (other than pr) is detected, or until the SignalsDescriptor is replaced with a new SignalsDescriptor that does not include the signal em. Any pulses applied due to a concurrent mpb signal shall be in addition to the required repetitive pulses applied for the em signal".

    For example the meter pulses will continue even when an on-hook event is detected providing the events descriptor that armed the on-hook event had the KeepActive flag set. This action may be required for certain territories where all outstanding meter pulses must be delivered even when the analogue line is in the on-hook state.
    [KJBII] I'm not sure what this example has to do with the problem mentioned above -- the package already functions this way. 

    [DC] This item is related to this e-mail topic, because if you read the current amet procedures in clause 7.4 para 4, they effectively say that an event such as on-hook will interrupt the meter pulse even if the KeepActive flag is set. This clearly overrides the standard H.248/Megaco EventDescriptor/KeepActive flag procedures in a similar fashion to the item being discussed. 

    Again the sentence above defining the SignalDescriptor procedures in the "amet" package does not define anything new which is not already specified in the standrad Megaco procedures. Hence I recommend that clause 7.5 paragraph 4 of the "amet" package be modified to read as:

    "If the value of the parameter pc is zero or if this parameter is not supplied by the MGC, then any pulses applied due to a concurrent mpb signal shall be in addition to the required repetitive pulses applied for the em signal"
    [KJBII] This would be a natural extension of the above correction. 

    [DC] - Okay - that would address the concerns raised by my second point.

    Regards,

    Dal Chohan.

    ----- Original Message ----- 
    From: "Kevin Boyle" <[email-masked]>
    To: "Tom-PT Taylor" <[email-masked]>; <[email-masked]>
    Cc: <[email-masked]>
    Sent: Friday, January 02, 2004 3:19 PM
    Subject: RE: [Megaco] Query Related to Automatic Metering

    > I would rather not have use of KA mandated.  Let the implementor decide how
    > To: [email-masked]
    > I think you make a good point.  It's desirable to keep the protocol intact,
    > [email-masked] wrote:
    > 
    > > 
    > > 
    > > 
    > > Hi List,
    > > 
    > > 
    > > of the information transmitted by this email including damage from virus."
    > > 
    > >

---

From: "Dal Chohan" <[email-masked]>
Date: Mon, 5 Jan 2004 15:36:57 -0000

Regards,

Dal Chohan
  ----- Original Message ----- 
  From: Kevin Boyle 
  To: Dal Chohan ; Tom-PT Taylor ; [email-masked] 
  Cc: [email-masked] 
  Sent: Monday, January 05, 2004 3:06 PM
  Subject: RE: [Megaco] Query Related to Automatic Metering

  Kevin

    Regards,

    Dal Chohan.