Subject: [Megaco] Megaco, caller id and VoIP

From: Samuel Tardieu <[email-masked]>
Date: Wed, 28 Jan 2004 01:33:19 +0100

Hi.

I am discovering Megaco and I have a few (probably trivial)
questions:

  - in a VoIP only application, is it possible to use a textual string
    instead of digits to designate the recipient?

  - at what time will the caller id and the callee id be presented to
    the callee (e.g., to let a MG which acts as a gateway to another
    system present the callee phone number to the external system)

  Sam
-- 
Samuel Tardieu -- [email-masked] -- http://www.rfc1149.net/sam

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 29 Jan 2004 06:38:07 -0500

Caller ID destined for CPE equipment is passed according to H.248.23.  This
specifies that the CallerID info is passed as hex data formatted in
accordance with the generally accepted CLASS modem requirements.

For other applications, other methods are necessary.  For instance, if ISUP
is being utilized, the caller information is passed out of band utilizing
methods outlined in the Q-series of ITU Recommendations.

You should explore the requirements of your locality for appropriate methods
to use to pass this info and the timing of those methods based upon your
application.

Kevin

-----Original Message-----
From: Samuel Tardieu [mailto:[email-masked]] 
Sent: Tuesday, January 27, 2004 7:33 PM
To: [email-masked]
Subject: [Megaco] Megaco, caller id and VoIP

Hi.

  Sam

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 29 Jan 2004 06:38:07 -0500

Kevin

-----Original Message-----
From: Samuel Tardieu [mailto:[email-masked]] 
Sent: Tuesday, January 27, 2004 7:33 PM
To: [email-masked]
Subject: [Megaco] Megaco, caller id and VoIP

Hi.

  Sam