Subject: [Megaco] Megaco/h.248

From: "luka" <[email-masked]>
Date: Sun, 18 Jan 2004 22:55:13 -0200

Hi, folks.

I am doing an article about Megaco and I´d like to get information about Set-top Box.
How does Set-top Box work? 
What are the Megaco commands used in this application? ( between MG and MGC) 

Could you tell me where I  get this information from Internet?   

Thanks a lot

Luka

---

From: Tom Taylor <[email-masked]>
Date: Mon, 19 Jan 2004 10:01:40 -0500

The obvious starting point is the PacketCable work on telephony over cable.  You 
can get their specifications at http://www.packetcable.com/specifications/, and 
the specification for the set-top box control in particular at 
http://www.packetcable.com/downloads/specs/PKT-SP-MGCP-I09-040113.pdf

Unfortunately from the Megaco point of view, PacketCable chose to go with MGCP 
rather than Megaco as the basis of their control protocol.

luka wrote:

> Hi, folks.
>  
> I am doing an article about Megaco and I´d like to 
> get information about* Set-top Box.*

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Tom Taylor <[email-masked]>
Date: Mon, 19 Jan 2004 10:01:40 -0500

---

From: "Sampath Komanduri" <[email-masked]>
Date: Wed, 21 Jan 2004 12:20:37 -0800

Hi all,
It was my understanding that Megaco doesn't allow any persistent events.
If my understanding is correct... Could someone pls. clarify what the
following paragraph in H.248.10 mean?

ITU-T Rec. H.248.10 (07/2001) 1

4.2 Events
        4.2.1 MGCongestion
                Event name: MGCon
                        EventID: mgcon, (0x0001)
                        Description:
This event occurs when the MG requires that the MGC start or finish load
reduction
towards the MG or to adjust the Load Reduction Percentage. The event is
ordered by the
MGC or provisioned.
                        EventsDescriptor Parameters: None
                        ObservedEventsDescriptor Parameters 
 
Thanks,
Sampath

---

From: "Sampath Komanduri" <[email-masked]>
Date: Wed, 21 Jan 2004 12:20:37 -0800

Hi all,

4.2 Events
        4.2.1 MGCongestion
                Event name: MGCon
                        EventID: mgcon, (0x0001)
                        Description:
 
Thanks,
Sampath

---

From: "Anil Jangam" <[email-masked]>
Date: Thu, 22 Jan 2004 09:47:17 +0530

Hi Kevin,
 
There is a link on the discussion of persistent event.
http://www1.ietf.org/mail-archive/working-groups/megaco/current/msg04494
.html (first para)
As it was indicated, I think there is some kind of inconsistency with
these two statements. Is there any different aspect to the
'provisioning' in the case below??
 
/anil.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Sampath Komanduri
Sent: Thursday, January 22, 2004 1:51 AM
To: [email-masked]
Subject: [Megaco] Can chp/mgcon event be persistent event?

Hi all,

4.2 Events
        4.2.1 MGCongestion
                Event name: MGCon
                        EventID: mgcon, (0x0001)
                        Description:
 
Thanks,
Sampath

---

From: "Anil Jangam" <[email-masked]>
Date: Thu, 22 Jan 2004 09:47:17 +0530

Hi Kevin,

/anil.

-----Original Message-----

Hi all,

4.2 Events
        4.2.1 MGCongestion
                Event name: MGCon
                        EventID: mgcon, (0x0001)
                        Description:
 
Thanks,
Sampath

---

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 22 Jan 2004 11:19:06 -0500

Hi,

Persistent events in MGCP are defined by package specs.
Provisioned events in MEGACO are configured by an MG operator.
As for any descriptor default EventsDescriptor values can be
provisioned on MG to be non-empty.

The only question here which RequestID to use for such pre-provisioned events?
The common consensus on the list was that 0 is a reasonable default value to
use in such cases, but of course can also be provisioned to something else
by an MG operator.

Regards,
         Aleks

---

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 22 Jan 2004 11:19:06 -0500

Hi,

Regards,
         Aleks