Subject: [Megaco] H.248.1 generic package - signal completion event

From: "Dal Chohan" <[email-masked]>
Date: Tue, 13 Jan 2004 11:29:27 -0000

RE: H.248.1 E.1 Generic Package "Signal Completion" event

The package description suggests that the signal completion event can only be sent when the notifyCompletion parameter is included. However, clause 7.1.11 of H.248 version 2 indicates that a signal completion/termination event can be sent, even when the "notifyCompletion" parameter was not present in the situation the signal stopped and was never started for other reason (i.e. Meth = NC), . 

In addition the package contains references to 7.1.1, 7.1.17 and 7.2.7, but no reference to "7.1.11 Signal Descriptor" where the procedures for signal completion are defined.

I guess a note in the IG should be included to take into account the above comments and re-word the text in the package to say something along the lines "Indicates the termination of a signal and is this event is sent as defined in the procedures of 7.1.11".

Dal Chohan

---

From: Christian Groves <[email-masked]>
Date: Thu, 15 Jan 2004 13:59:04 +1100

Resend due to error.

Christian Groves wrote:

> Hello Dal,
> 
> Yes this seems to be somewhere were the text can be improved. I would 
> actually propose to change 7.1.1 to 7.1.11. It looks like a '1' was 
> dropped off the reference.
> 
> Kevin could you please add this to your IG list?
> 
> Regards, Christian
> 
> Dal Chohan wrote:
> 
>> The package description suggests that the signal completion event can 
>> only be sent when the notifyCompletion parameter is included. However, 
>> clause 7.1.11 of H.248 version 2 indicates that a signal 
>> completion/termination event can be sent, even when the 
>> "notifyCompletion" parameter was not present in the situation the 
>> signal stopped and was never started for other reason (i.e. Meth = NC), .
>>  
>> In addition the package contains references to 7.1.1, 7.1.17 and 
>> 7.2.7, but no reference to "7.1.11 Signal Descriptor" where the 
>> procedures for signal completion are defined.
>>  
>>  
>> I guess a note in the IG should be included to take into account the 
>> above comments and re-word the text in the package to say something 
>> along the lines "Indicates the termination of a signal and is this 
>> event is sent as defined in the procedures of 7.1.11".
>>  
>>  
>>  
>> Dal Chohan
> 
> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Thu, 15 Jan 2004 13:59:04 +1100

Resend due to error.