Subject: [Megaco] Mandatory serviceChangeReason parameter?

From: Samuel Tardieu <[email-masked]>
Date: Thu, 29 Jan 2004 01:37:50 +0100

In the ASN.1 description of RFC3525, I understand that the
serviceChangeReason parameter is mandatory:

      serviceChangeReason     Value,
   -- A serviceChangeReason consists of a numeric reason code
   -- and an optional text description.

However, in appendix I, the example does not mention one:

   ServiceChange = ROOT {Services {
       Method=Restart,
       ServiceChangeAddress=55555, Profile=ResGW/1}
   }

Is there an error in the example?

  Sam
-- 
Samuel Tardieu -- [email-masked] -- http://www.rfc1149.net/sam

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Rasool Wani" <[email-masked]>
Date: Thu, 29 Jan 2004 11:56:37 +0800

Value is SEQUENCE OF Octet String.
A value of zero Octet String can be transmitted.

---

From: "Rasool Wani" <[email-masked]>
Date: Thu, 29 Jan 2004 11:56:37 +0800

---

From: Samuel Tardieu <[email-masked]>
Date: Thu, 29 Jan 2004 12:43:55 +0100

>>>>> "Rasool" == Rasool Wani <[email-masked]> writes:

> Value is SEQUENCE OF Octet String.  A value of zero Octet String can
> be transmitted.

This is not how I understand the comment in the grammar:

   -- The serviceChangeReason SHALL be a string consisting of
   -- a decimal reason code, optionally followed by a single
   -- space character and a textual description string.
   -- This string is first BER-encoded as an IA5String.

 Sam

---

From: Samuel Tardieu <[email-masked]>
Date: Thu, 29 Jan 2004 12:43:55 +0100

Sam