Subject: RE: [Megaco] Mandatory serviceChangeReason parameter?

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 29 Jan 2004 04:37:30 -0500

ServiceChangeReason is mandatory.  The example in Appendix I has an error.

It is important to note that the Appendix is not normative text.  It only
provides guidance as to one possible protocol use, but should not be taken
as mandatory usage.

Kevin 

-----Original Message-----
From: Rasool Wani [mailto:[email-masked]] 
Sent: Wednesday, January 28, 2004 10:57 PM
To: [email-masked]; Samuel Tardieu
Subject: Re: [Megaco] Mandatory serviceChangeReason parameter?

Value is SEQUENCE OF Octet String.
A value of zero Octet String can be transmitted.

----- Original Message -----
From: "Samuel Tardieu" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, January 29, 2004 8:37 AM
Subject: [Megaco] Mandatory serviceChangeReason parameter?

> In the ASN.1 description of RFC3525, I understand that the
> serviceChangeReason parameter is mandatory:
> 
>       serviceChangeReason     Value,
>    -- A serviceChangeReason consists of a numeric reason code
>    -- and an optional text description.
> 
> However, in appendix I, the example does not mention one:
> 
>    ServiceChange = ROOT {Services {
>        Method=Restart,
>        ServiceChangeAddress=55555, Profile=ResGW/1}
>    }
> 
> Is there an error in the example?
> 
>   Sam
> -- 
> Samuel Tardieu -- [email-masked] -- http://www.rfc1149.net/sam
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Samuel Tardieu <[email-masked]>
Date: Thu, 29 Jan 2004 12:44:59 +0100

>>>>> "Kevin" == Kevin Boyle <[email-masked]> writes:

> ServiceChangeReason is mandatory.  The example in Appendix I has an
> error.  It is important to note that the Appendix is not normative
> text.  It only provides guidance as to one possible protocol use,
> but should not be taken as mandatory usage.

Sure, but as I guess many people, I started to play with Megaco by
encoding/decoding the example given in the RFC :-) Any chance to have
a corrected example in Megaco v2 ? (if it is not too late)

  Sam

---

From: Samuel Tardieu <[email-masked]>
Date: Thu, 29 Jan 2004 12:44:59 +0100

Sam