Subject: [Megaco] disabled terminations

From: Troy Cauble <[email-masked]>
Date: Mon, 05 Jan 2004 17:34:10 -0500

(Re-sending after bounces...)

If an MG is configured (via SNMP for example) to have some terminations
disabled, and has sent the ServiceChange { Method = Forced } messages,
what error should it return if it receives subsequent Add/Move/Modify/etc. ?

?	430 Unknown TerminationID	?
?	530 Service Changing		?

Similarly, if it receives a wildcard command or a wildcard return command
should it behave as if those terminations don't exist or should errors be
returned?

-troy

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Sampath Komanduri" <[email-masked]>
Date: Mon, 5 Jan 2004 15:07:44 -0800

I guess 502.

Here is the text from H.248.8...

4.2.37	Error Code #: 502 Name: Not ready
Definition: The command directed to a termination was not executed
because of the service state of the termination.
Package: -
Reference: -
Error Text in the error Descriptor: The service state is indicated in
the error text in the error descriptor.
Comment: -

Thanks,
Sampath

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Troy Cauble
Sent: Monday, January 05, 2004 2:34 PM
To: MEGACO list
Subject: [Megaco] disabled terminations

If an MG is configured (via SNMP for example) to have some terminations
disabled, and has sent the ServiceChange { Method = Forced } messages,
what error should it return if it receives subsequent
Add/Move/Modify/etc. ?

Similarly, if it receives a wildcard command or a wildcard return
command
should it behave as if those terminations don't exist or should errors
be
returned?

-troy

---

From: "Sampath Komanduri" <[email-masked]>
Date: Mon, 5 Jan 2004 15:07:44 -0800

I guess 502.

Thanks,
Sampath

-----Original Message-----

-troy

---

From: Christian Groves <[email-masked]>
Date: Tue, 06 Jan 2004 10:16:52 +1100

Hello Troy,

502 would be most appropriate:
"4.2.37	Error Code #: 502 Name: Not ready
Definition: The command directed to a termination was not executed because of 
the service state of the termination.
Package: –
Reference: –
Error Text in the error Descriptor: The service state is indicated in the error 
text in the error descriptor.
Comment: –"

Christian

---

From: Christian Groves <[email-masked]>
Date: Tue, 06 Jan 2004 10:16:52 +1100

Hello Troy,

Christian