Subject: RE: [Megaco] Re: Mandatory serviceChangeReason parameter?

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 30 Jan 2004 03:47:12 -0500

Thanks.  I will bring these up as editorial issues with the TSB so that
these are corrected in the published version.

Kevin 

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]] 
Sent: Thursday, January 29, 2004 3:07 PM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]
Cc: [email-masked]
Subject: Re: [Megaco] Re: Mandatory serviceChangeReason parameter?

Kevin Boyle wrote:

> The Corrigendum for V2 has gone for consent.  If there are no 
> objections, I will enter this as the first item in the new IG which 
> would get Approved in November.
> 
> Kevin

Kevin,

Here are some typos I posted recently that should be addressed as well.

> I was reading the V2 doc and spotted the following minor items...
> 
> In Annex B, auditItem was added to serviceChangeParm.  The 
> at-most-once comment doesn't really apply to auditItem; possibly to 
> the elements of auditItem.
> 
> In Annex B, where indAudterminationAudit was added to X there's a typo 
> -- an extra paren.
> 
> In Annex A, where comments discuss "X-" and "X+", there's a 
> typo/problem with the "-".
> 
> In Appendix I, the call flow examples all show "MEGACO/1"
> instead of "MEGACO/2".  Also the registration ServiceChange message 
> does not use the mandatory ServiceChangeVersion param.
> 
>   (From 11.3: "A ServiceChange command from a MG that registers
>   with an MGC shall contain the version number of the protocol
>   supported by the MG in the ServiceChangeVersion parameter.")
> 
> -troy

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Dal Chohan" <[email-masked]>
Date: Fri, 30 Jan 2004 16:11:48 -0000

Kevin,

A point for clarification on this email - I assume that the first two flows
in Appendix I (i.e. ServiceChange Comand and the Service Change Reply) will
still specify "MEGACO/1".

By the clause 11.3 does not explicitly state that the "Service Change Reply"
should also be encoded as version 1. It would be useful to make this clear
in the procedures of clause 11.3.

Regards,

Dal Chohan

---

From: "Dal Chohan" <[email-masked]>
Date: Fri, 30 Jan 2004 16:11:48 -0000

Kevin,

Regards,

Dal Chohan