Subject: RE: [Megaco] Can chp/mgcon event be persistent event?

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 22 Jan 2004 13:22:07 -0500

Provisioning something other than 0 will lead to rejection by the MGC.
Further, provisioning is done at the MG's own risk, as there is no way the
MG can know ahead of time that the MGC supports the package in question.
 
Basically, the MG can have events provisioned, but all bets are off as to
whether the MGC will accept or reject the event.  My personal feeling is
that MGCs should ask for events they wish to see, and not rely upon any
"event provisioning".
 
Kevin

  _____  

From: Aleksandr Ryabin [mailto:[email-masked]] 
Sent: Thursday, January 22, 2004 11:19 AM
To: [email-masked]; [email-masked]
Subject: Re: [Megaco] Can chp/mgcon event be persistent event?

Hi,

Persistent events in MGCP are defined by package specs.
Provisioned events in MEGACO are configured by an MG operator.
As for any descriptor default EventsDescriptor values can be
provisioned on MG to be non-empty.

The only question here which RequestID to use for such pre-provisioned
events?
The common consensus on the list was that 0 is a reasonable default value to

use in such cases, but of course can also be provisioned to something else
by an MG operator.

Regards,
        Aleks

At 03:20 PM 1/21/2004, Sampath Komanduri wrote:

Hi all,
It was my understanding that Megaco doesn't allow any persistent events. If
my understanding is correct... Could someone pls. clarify what the following
paragraph in H.248.10 mean?

ITU-T Rec. H.248.10 (07/2001) 1

4.2 Events
        4.2.1 MGCongestion
                Event name: MGCon
                        EventID: mgcon, (0x0001)
                        Description:
This event occurs when the MG requires that the MGC start or finish load
reduction
towards the MG or to adjust the Load Reduction Percentage. The event is
ordered by the
MGC or provisioned.
                        EventsDescriptor Parameters: None
                        ObservedEventsDescriptor Parameters 
 
Thanks,
Sampath

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Carl Rutter <[email-masked]>
Date: Thu, 22 Jan 2004 13:45:36 -0500

I guess my only concern here is the overhead
involved in the MGC asking for events in some cases.
ie) High-Density Gateway running CAS.
As densities increase we may want to foster a 
better MG event provisioning approach.

Carl

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, January 22, 2004 1:22 PM
To: Aleksandr Ryabin; [email-masked]; [email-masked]
Subject: RE: [Megaco] Can chp/mgcon event be persistent event?

 
Kevin

  _____  

Hi,

Regards,
        Aleks

Hi all,

4.2 Events
        4.2.1 MGCongestion
                Event name: MGCon
                        EventID: mgcon, (0x0001)
                        Description:
 
Thanks,
Sampath

---

From: Carl Rutter <[email-masked]>
Date: Thu, 22 Jan 2004 13:45:36 -0500

Carl

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, January 22, 2004 1:22 PM
To: Aleksandr Ryabin; [email-masked]; [email-masked]
Subject: RE: [Megaco] Can chp/mgcon event be persistent event?

 
Kevin

  _____  

Hi,

Regards,
        Aleks

Hi all,

4.2 Events
        4.2.1 MGCongestion
                Event name: MGCon
                        EventID: mgcon, (0x0001)
                        Description:
 
Thanks,
Sampath

---

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 22 Jan 2004 13:53:03 -0500

0 is an arbitrary number and not better then anything else.
As long as an MG and an MGC have a bilateral agreement
what the number is everyone will be happy.

I agree that generally pre-provisioned events should be avoided,
but in certain cases events pre-provisioning can have benefits.

Consider a large MG which supports CAS and for some reason
termination wildcarding is not an option for requesting initial events.
In this case pre-provisioning of events will avoid huge number of Modifies
after a cold boot otherwise needed to be exchanged in order to
setup/arm every termination for CAS.

         Aleks

At 01:22 PM 1/22/2004, Kevin Boyle wrote:
>Provisioning something other than 0 will lead to rejection by the 
>MGC.  Further, provisioning is done at the MG's own risk, as there is no 
>way the MG can know ahead of time that the MGC supports the package in 
>question.
>
>----------
>The only question here which RequestID to use for such pre-provisioned events?
>>It was my understanding that Megaco doesn't allow any persistent events. 
>>If my understanding is correct... Could someone pls. clarify what the 
>>following paragraph in H.248.10 mean?
>>

---

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 22 Jan 2004 13:53:03 -0500

Aleks

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 23 Jan 2004 03:51:01 -0500

The MGC is capable of sending a wildcarded Modify command requesting the MG
look for events on multiple terminations.  To reduce the message reply size,
the MGC can request a wildcarded response as well.  Is there some further
problem?

Kevin 

-----Original Message-----
From: Carl Rutter [mailto:[email-masked]] 
Sent: Thursday, January 22, 2004 1:46 PM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; Aleksandr Ryabin; [email-masked];
[email-masked]

I guess my only concern here is the overhead involved in the MGC asking for
events in some cases.
ie) High-Density Gateway running CAS.
As densities increase we may want to foster a better MG event provisioning
approach.

Carl

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, January 22, 2004 1:22 PM
To: Aleksandr Ryabin; [email-masked]; [email-masked]
Subject: RE: [Megaco] Can chp/mgcon event be persistent event?

 
Kevin

  _____  

Hi,

Regards,
        Aleks

Hi all,

4.2 Events
        4.2.1 MGCongestion
                Event name: MGCon
                        EventID: mgcon, (0x0001)
                        Description:
 
Thanks,
Sampath

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 23 Jan 2004 03:47:51 -0500

Provisioned events and persistent events are two different things.
Persistent events (in the world of MG control) implies that MGCs
automatically know about those events and will handle them at any time --
that is, MGs can depend on having those events handled.  Provisioned events
are items that the MG is set up to detect, but that the MG CANNOT depend on
having handled, as the MGC may not even support the package in question.
 
One other point: MGCs are not required to take any particular action with
regard to a Notify command.  If the Notify comes from a registered MG, then
the MGC ought to reply either affirmatively or with an error.  If the Notify
comes from an unregistered entity, then the MGC reserves the right to send
an error or not respond at all.
 
The key point is that MGs cannot depend upon any particular MGC behavior
when it comes to provisioned events.
 
Kevin

  _____  

From: Aleksandr Ryabin [mailto:[email-masked]] 
Sent: Thursday, January 22, 2004 2:16 PM
To: [email-masked]; [email-masked]
Subject: RE: [Megaco] Can chp/mgcon event be persistent event?

Hi Sampath,

a) MGC can ether accept it, i.e. 1), or reject with error 458 (Unexpected
Event/RequestID).
b) Any

Regards,
        Aleks

At 01:48 PM 1/22/2004, Sampath Komanduri wrote:

Aleks and Kevin,
Thanks for responding. I do understand that in the absence of MGC requested
event, if MG has to generate a notification, it would use RequestID 0.
However, I don't see anything with respect to RequestID 0 handling in the
spec. other than the following text in Section 7.2.7:
    "Procedures for sending Notify commands with RequestID equal to 0 are
for futher study."
 
a) What is the action *required* by the MGC upon recieving a notify with
requestID 0?
    1) Is MGC supposed to do what it would have done if it had explicitly
asked for the eventNotification? In our example, is MGC "required" to take
the *same actions* to reduce congestion on MG (upon receipt of unsolicited
notification) which it would have taken if MGC had "solicited" the
notification? OR
    2) MGC must just respond to the Notification and *not* do anything with
respect to helping MG in reducing the congestion.
    3) MGC can choose to *not* to even respond to the Notify? I hope this is
not the case, since it would result in a DISCONNECTED association.
 
b) Which events qualify to be notified to MGC with RequestID 0?
    Only events on ROOT? Only event on ROOT and Analog lines? Any events?
 
It would be good to see some supporting text in the Spec. if the authors
decide to leave the support of persistent events in Megaco.
 
Thanks,
Sampath

 -----Original Message-----

From: Kevin Boyle [mailto:[email-masked]
<mailto:[email-masked]> ] 

Sent: Thursday, January 22, 2004 10:22 AM

  

  

Kevin

  _____  

From: Aleksandr Ryabin [mailto:[email-masked]
<mailto:[email-masked]> ] 

Hi,

by an MG operator.

Regards,

        Aleks

Hi all,

4.2 Events

        4.2.1 MGCongestion

                Event name: MGCon

                        EventID: mgcon, (0x0001)

                        Description:

MGC or provisioned.

  

Thanks,

Sampath

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 23 Jan 2004 08:48:51 -0500

There is no concept of a persistent event in H.248.  The way to do this
would be to modify the termination with a new Events descriptor upon its
subtraction.  One possibility would be:

!/1 [12.34.56.78]:2944 T=123{C=12{S=term{}},C=-{MF=term{E=123{pkg/event}}}}

Kevin

-----Original Message-----
From: Carl Rutter [mailto:[email-masked]] 
Sent: Friday, January 23, 2004 7:50 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; Aleksandr Ryabin; [email-masked];
[email-masked]

Kevin,

How would the MGC request a persistent event?
I think this is what we are looking for.
Events that hang around even after the
termination is subtracted back to the NULL context.

Thx,
Carl

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Kevin
Boyle
Sent: Friday, January 23, 2004 3:48 AM
To: Aleksandr Ryabin; [email-masked]; [email-masked]
Subject: RE: [Megaco] Can chp/mgcon event be persistent event?

Kevin

  _____

Hi Sampath,

Regards,
        Aleks

Aleks and Kevin,

Thanks,
Sampath

 -----Original Message-----

Kevin

  _____

Hi,

by an MG operator.

Regards,

        Aleks

Hi all,

4.2 Events

        4.2.1 MGCongestion

                Event name: MGCon

                        EventID: mgcon, (0x0001)

                        Description:

MGC or provisioned.

Thanks,

Sampath

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 23 Jan 2004 08:48:51 -0500

Kevin

-----Original Message-----
From: Carl Rutter [mailto:[email-masked]] 
Sent: Friday, January 23, 2004 7:50 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; Aleksandr Ryabin; [email-masked];
[email-masked]

Kevin,

Thx,
Carl

-----Original Message-----

Kevin

  _____

Hi Sampath,

Regards,
        Aleks

Aleks and Kevin,

Thanks,
Sampath

 -----Original Message-----

Kevin

  _____

Hi,

by an MG operator.

Regards,

        Aleks

Hi all,

4.2 Events

        4.2.1 MGCongestion

                Event name: MGCon

                        EventID: mgcon, (0x0001)

                        Description:

MGC or provisioned.

Thanks,

Sampath

---

From: Carl Rutter <[email-masked]>
Date: Fri, 23 Jan 2004 08:58:37 -0500

OK,
 
Provisioned events have not been well defined per the RFC and
only rscID 0 can be used.  To your point
these should be avoided since the MGC may not know about them.
So maybe in the future we could have a mechanism so that the
MGC could specify pesistent events to the MG.  There could be
different flavors, one being reappy event when transistioning to the 
NULL context etc. Provisioned events would not be allowed. 
Comments?
 
Carl

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Friday, January 23, 2004 8:49 AM
To: Carl Rutter; Aleksandr Ryabin; [email-masked]; [email-masked]
Subject: RE: [Megaco] Can chp/mgcon event be persistent event?

Kevin 

-----Original Message----- 
From: Carl Rutter [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Friday, January 23, 2004 7:50 AM 
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; Aleksandr Ryabin; [email-masked];
[email-masked] 

Kevin, 

Thx, 
Carl 

-----Original Message----- 
From: [email-masked] [ mailto:[email-masked]
<mailto:[email-masked]> ]On Behalf Of Kevin Boyle 
Sent: Friday, January 23, 2004 3:48 AM 
To: Aleksandr Ryabin; [email-masked]; [email-masked] 
Subject: RE: [Megaco] Can chp/mgcon event be persistent event? 

Kevin 

  _____ 

From: Aleksandr Ryabin [ mailto:[email-masked]

Hi Sampath, 

Regards, 
        Aleks 

Aleks and Kevin, 

Thanks, 
Sampath 

 -----Original Message----- 

From: Kevin Boyle [ mailto:[email-masked]
<mailto:[email-masked]>  < mailto:[email-masked]
<mailto:[email-masked]> > ] 

Kevin 

  _____ 

From: Aleksandr Ryabin [ mailto:[email-masked]
<mailto:[email-masked]>  < mailto:[email-masked]
<mailto:[email-masked]> > ] 

Hi, 

by an MG operator. 

Regards, 

        Aleks 

Hi all, 

4.2 Events 

        4.2.1 MGCongestion 

                Event name: MGCon 

                        EventID: mgcon, (0x0001) 

                        Description: 

MGC or provisioned. 

Thanks, 

Sampath 

_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco
<https://www1.ietf.org/mailman/listinfo/megaco>

---

From: Carl Rutter <[email-masked]>
Date: Fri, 23 Jan 2004 08:58:37 -0500

OK,

Carl

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Friday, January 23, 2004 8:49 AM
To: Carl Rutter; Aleksandr Ryabin; [email-masked]; [email-masked]
Subject: RE: [Megaco] Can chp/mgcon event be persistent event?

Kevin 

-----Original Message----- 
From: Carl Rutter [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Friday, January 23, 2004 7:50 AM 
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; Aleksandr Ryabin; [email-masked];
[email-masked] 

Kevin, 

Thx, 
Carl 

-----Original Message----- 

Kevin 

  _____ 

Hi Sampath, 

Regards, 
        Aleks 

Aleks and Kevin, 

Thanks, 
Sampath 

 -----Original Message----- 

Kevin 

  _____ 

Hi, 

by an MG operator. 

Regards, 

        Aleks 

Hi all, 

4.2 Events 

        4.2.1 MGCongestion 

                Event name: MGCon 

                        EventID: mgcon, (0x0001) 

                        Description: 

MGC or provisioned. 

Thanks, 

Sampath