Subject: RE: [Megaco] Can chp/mgcon event be persistent event?

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 23 Jan 2004 03:51:01 -0500

The MGC is capable of sending a wildcarded Modify command requesting the MG
look for events on multiple terminations.  To reduce the message reply size,
the MGC can request a wildcarded response as well.  Is there some further
problem?

Kevin 

-----Original Message-----
From: Carl Rutter [mailto:[email-masked]] 
Sent: Thursday, January 22, 2004 1:46 PM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; Aleksandr Ryabin; [email-masked];
[email-masked]
Subject: RE: [Megaco] Can chp/mgcon event be persistent event?

I guess my only concern here is the overhead involved in the MGC asking for
events in some cases.
ie) High-Density Gateway running CAS.
As densities increase we may want to foster a better MG event provisioning
approach.

Carl

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, January 22, 2004 1:22 PM
To: Aleksandr Ryabin; [email-masked]; [email-masked]
Subject: RE: [Megaco] Can chp/mgcon event be persistent event?

Provisioning something other than 0 will lead to rejection by the MGC.
Further, provisioning is done at the MG's own risk, as there is no way the
MG can know ahead of time that the MGC supports the package in question.
 
Basically, the MG can have events provisioned, but all bets are off as to
whether the MGC will accept or reject the event.  My personal feeling is
that MGCs should ask for events they wish to see, and not rely upon any
"event provisioning".
 
Kevin

  _____  

From: Aleksandr Ryabin [mailto:[email-masked]]
Sent: Thursday, January 22, 2004 11:19 AM
To: [email-masked]; [email-masked]
Subject: Re: [Megaco] Can chp/mgcon event be persistent event?

Hi,

Persistent events in MGCP are defined by package specs.
Provisioned events in MEGACO are configured by an MG operator.
As for any descriptor default EventsDescriptor values can be
provisioned on MG to be non-empty.

The only question here which RequestID to use for such pre-provisioned
events?
The common consensus on the list was that 0 is a reasonable default value to

use in such cases, but of course can also be provisioned to something else
by an MG operator.

Regards,
        Aleks

At 03:20 PM 1/21/2004, Sampath Komanduri wrote:

Hi all,
It was my understanding that Megaco doesn't allow any persistent events. If
my understanding is correct... Could someone pls. clarify what the following
paragraph in H.248.10 mean?

ITU-T Rec. H.248.10 (07/2001) 1

4.2 Events
        4.2.1 MGCongestion
                Event name: MGCon
                        EventID: mgcon, (0x0001)
                        Description:
This event occurs when the MG requires that the MGC start or finish load
reduction
towards the MG or to adjust the Load Reduction Percentage. The event is
ordered by the
MGC or provisioned.
                        EventsDescriptor Parameters: None
                        ObservedEventsDescriptor Parameters 
 
Thanks,
Sampath

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Carl Rutter" <[email-masked]>
Date: Fri, 23 Jan 2004 07:53:21 -0500

RE: [Megaco] Can chp/mgcon event be persistent event?Yea,

On a large scale system we may want to apply different events
to many different T1s as they go back to the null context.
You mentioned persistent events from the MGC which
sounds like something we are looking for.

Thx,
Carl
  -----Original Message-----
  From: Kevin Boyle [mailto:[email-masked]]
  Sent: Friday, January 23, 2004 3:51 AM
  To: Carl Rutter; Aleksandr Ryabin; [email-masked]; [email-masked]
  Subject: RE: [Megaco] Can chp/mgcon event be persistent event?

  The MGC is capable of sending a wildcarded Modify command requesting the
MG look for events on multiple terminations.  To reduce the message reply
size, the MGC can request a wildcarded response as well.  Is there some
further problem?

  Kevin

  -----Original Message-----
  From: Carl Rutter [mailto:[email-masked]]
  Sent: Thursday, January 22, 2004 1:46 PM
  To: Boyle, Kevin [NCRTP:3Z40:EXCH]; Aleksandr Ryabin; [email-masked];
[email-masked]

  I guess my only concern here is the overhead involved in the MGC asking
for events in some cases.
  ie) High-Density Gateway running CAS.
  As densities increase we may want to foster a better MG event provisioning
approach.

  Carl

  -----Original Message-----
  From: Kevin Boyle [mailto:[email-masked]]
  Sent: Thursday, January 22, 2004 1:22 PM
  To: Aleksandr Ryabin; [email-masked]; [email-masked]
  Subject: RE: [Megaco] Can chp/mgcon event be persistent event?

  Kevin

    _____

  Hi,

  The only question here which RequestID to use for such pre-provisioned
  events?
  The common consensus on the list was that 0 is a reasonable default value
to

  Regards,
          Aleks

  Hi all,
  It was my understanding that Megaco doesn't allow any persistent events.
If
  my understanding is correct... Could someone pls. clarify what the
following
  paragraph in H.248.10 mean?

  4.2 Events
          4.2.1 MGCongestion
                  Event name: MGCon
                          EventID: mgcon, (0x0001)
                          Description:

  Thanks,
  Sampath

---

From: "Carl Rutter" <[email-masked]>
Date: Fri, 23 Jan 2004 07:53:21 -0500

Thx,
Carl
  -----Original Message-----
  From: Kevin Boyle [mailto:[email-masked]]
  Sent: Friday, January 23, 2004 3:51 AM
  To: Carl Rutter; Aleksandr Ryabin; [email-masked]; [email-masked]
  Subject: RE: [Megaco] Can chp/mgcon event be persistent event?

  Kevin

  -----Original Message-----
  From: Carl Rutter [mailto:[email-masked]]
  Sent: Thursday, January 22, 2004 1:46 PM
  To: Boyle, Kevin [NCRTP:3Z40:EXCH]; Aleksandr Ryabin; [email-masked];
[email-masked]

  Carl

  -----Original Message-----
  From: Kevin Boyle [mailto:[email-masked]]
  Sent: Thursday, January 22, 2004 1:22 PM
  To: Aleksandr Ryabin; [email-masked]; [email-masked]
  Subject: RE: [Megaco] Can chp/mgcon event be persistent event?

  Kevin

    _____

  Hi,

  Regards,
          Aleks

  Hi all,

  4.2 Events
          4.2.1 MGCongestion
                  Event name: MGCon
                          EventID: mgcon, (0x0001)
                          Description:

  Thanks,
  Sampath

---

From: "Sampath Komanduri" <[email-masked]>
Date: Fri, 23 Jan 2004 09:53:08 -0800

Yes Kevin,
There are other problems as well. For large MG's which are configured in
a redundant setup, these events have to be journaled on a per event per
termination basis every time they change. 
 
Example for CAS calls:
Across switchovers, in order to maintain *at least* the calls where the
voice path is cut-through, MG has to journal
on-hook/off-hook/idle/clear-forward/clear-backward events (based on the
variants supported on different terminations/lines) or MGC has to re-arm
the terminations with all these events.
At that time the wild-carded Modify trick may not work since different
terminations will be in different stages of call setup. MG and MGC have
to exchange lot of messages in order come in sync. with each other.
 
Regarding provisioned vs.. persistent events, I don't see any difference
between them. From MG's point of view, both are same and it would be
better if it can expect that such notifications are handled by MGC in
the same way as they were for solicited events.
 
Another note: Your statement that "MG doesn't know which package is
configured on MGC" is only partly true. The user who is "provisioning"
the event and/or package on termination (on MG)  *must* know that these
events would be generated towards MGC and if it is supported by MGC. 
There are only two possibilities:
    a) If H.248 gives user the ability to "provision" events on MG, it
*should expect* the user to know whether MGC supports this package or
not. Thereby implicitly telling the MG that MG should notify MGC upon
detection of these events.
    b) If H.248 wants to hide these details i.e. which package is
supported by MG/MGC (I don't know how it can do that) from user, we
shouldn't allow even the "provisioned" events in the protocol model.
 
Rgds,
Sampath

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]] 
Sent: Friday, January 23, 2004 12:51 AM
To: Carl Rutter; Aleksandr Ryabin; [email-masked]; [email-masked]
Subject: RE: [Megaco] Can chp/mgcon event be persistent event?

The MGC is capable of sending a wildcarded Modify command requesting the
MG look for events on multiple terminations.  To reduce the message
reply size, the MGC can request a wildcarded response as well.  Is there
some further problem?

Kevin 

-----Original Message----- 
From: Carl Rutter [mailto:[email-masked]] 
Sent: Thursday, January 22, 2004 1:46 PM 
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; Aleksandr Ryabin;
[email-masked]; [email-masked] 
Subject: RE: [Megaco] Can chp/mgcon event be persistent event? 

I guess my only concern here is the overhead involved in the MGC asking
for events in some cases. 
ie) High-Density Gateway running CAS. 
As densities increase we may want to foster a better MG event
provisioning approach. 

Carl 

-----Original Message----- 
From: Kevin Boyle [mailto:[email-masked]] 
Sent: Thursday, January 22, 2004 1:22 PM 
To: Aleksandr Ryabin; [email-masked]; [email-masked] 
Subject: RE: [Megaco] Can chp/mgcon event be persistent event? 

Provisioning something other than 0 will lead to rejection by the MGC. 
Further, provisioning is done at the MG's own risk, as there is no way
the MG can know ahead of time that the MGC supports the package in
question.

Basically, the MG can have events provisioned, but all bets are off as
to whether the MGC will accept or reject the event.  My personal feeling
is that MGCs should ask for events they wish to see, and not rely upon
any "event provisioning".

Kevin 

  _____  

Hi, 

The only question here which RequestID to use for such pre-provisioned 
events? 
The common consensus on the list was that 0 is a reasonable default
value to 

use in such cases, but of course can also be provisioned to something
else 
by an MG operator. 

Regards, 
        Aleks 

Hi all, 

4.2 Events 
        4.2.1 MGCongestion 
                Event name: MGCon 
                        EventID: mgcon, (0x0001) 
                        Description: 

reduction 
  
Thanks, 
Sampath

---

From: "Sampath Komanduri" <[email-masked]>
Date: Fri, 23 Jan 2004 09:53:08 -0800

Yes Kevin,
 
Example for CAS calls:

 
Rgds,
Sampath

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]] 
Sent: Friday, January 23, 2004 12:51 AM
To: Carl Rutter; Aleksandr Ryabin; [email-masked]; [email-masked]
Subject: RE: [Megaco] Can chp/mgcon event be persistent event?

Kevin 

-----Original Message----- 
From: Carl Rutter [mailto:[email-masked]] 
Sent: Thursday, January 22, 2004 1:46 PM 
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; Aleksandr Ryabin;

Carl 

-----Original Message----- 
From: Kevin Boyle [mailto:[email-masked]] 
Sent: Thursday, January 22, 2004 1:22 PM 
To: Aleksandr Ryabin; [email-masked]; [email-masked] 
Subject: RE: [Megaco] Can chp/mgcon event be persistent event? 

Kevin 

  _____  

Hi, 

Regards, 
        Aleks 

Hi all, 

4.2 Events 
        4.2.1 MGCongestion 
                Event name: MGCon 
                        EventID: mgcon, (0x0001) 
                        Description: 

reduction 
  
Thanks, 
Sampath