Subject: RE: [Megaco] Add and CHOOSE

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 2 Jan 2004 10:44:02 -0500

I will add an IG item for this, since I have heard nothing to the contrary.

If anyone objects to Tom's wording, speak now!

Kevin

-----Original Message-----
From: Taylor, Tom-PT [CAR:5N00:EXCH] 
Sent: Friday, December 19, 2003 7:58 AM
To: [email-masked]
Subject: [Megaco] Add and CHOOSE

Denis Osadchy has spotted an inaccuracy in section 7.2.1 as it relates to
wildcarding of terminationIDs.

-------- Original Message --------
Subject: Re[2]:
Date: Fri, 19 Dec 2003 12:09:52 +0600
From: äÅÎÉÓ ïÓÁÄÞÉÊ <[email-masked]>
Reply-To: äÅÎÉÓ ïÓÁÄÞÉÊ <[email-masked]>
To: Taylor, Tom-PT [CAR:5N00:EXCH]<[email-masked]>
References: <[email-masked]>
<[email-masked]>

Hello Tom,
I'm fully agree. It will be more clearly.

Thursday, December 18, 2003 tou wrote:

TT> You are right that there is a contradiction.  However, I would
suggest a
TT> different way to fix the paragraph.

TT> Let me suggest a situation you might want to think about, and one
that I
TT> think is quite realistic: that you want the MG to choose a 
TT> particular circuit from a group, where the terminationID consists of 
TT> the circuit group name concatenated with the individual circuit name or
number.
TT> Then what the Add command would have is a partially specified 
TT> terminationID with the choose wildcard replacing the circuit
name/number
TT> portion.

TT> If you agree with this possible application, the paragraph should 
TT> instead be fixed by changing the sentence to read:

TT> "For an existing termination, the TerminationID SHALL be specific or 
TT> partially specified."

TT> Again, if you agree, we should forward this exchange of notes to the 
TT> Megaco list.

TT> äÅÎÉÓ ïÓÁÄÞÉÊ wrote:

>> Hello, I have question: by protocol
>> 
>> " 7.2.1   Add ... The TerminationID specifies the termination to be
>>  added to the Context.  The Termination is either created, or taken  
>> from the null Context.  For an existing Termination, the 
>> TerminationID would be specific. For a Termination that does not yet 
>> exist, the TerminationID is specified as CHOOSE  in the command. ... 
>> "
>> 
>> If terminationID is CHOOSE then it's request to add ephemeral 
>> termination? If i'm right then in this text we shall use SHALL (not  
>> would)? "For an existing Termination, the TerminationID would be 
>> specific."
>> 
>> 
>> Denis
>> 
>> 
>> 
>> 

÷ÓÅÇÏ ÎÁÉÌÕÞÛÅÇÏ,
äÅÎÉÓ ïÓÁÄÞÉÊ                          mailto:[email-masked]

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 2 Jan 2004 10:44:02 -0500

Kevin

-------- Original Message --------
Subject: Re[2]:
Date: Fri, 19 Dec 2003 12:09:52 +0600
From: äÅÎÉÓ ïÓÁÄÞÉÊ <[email-masked]>
Reply-To: äÅÎÉÓ ïÓÁÄÞÉÊ <[email-masked]>
To: Taylor, Tom-PT [CAR:5N00:EXCH]<[email-masked]>
References: <[email-masked]>

Hello Tom,

÷ÓÅÇÏ ÎÁÉÌÕÞÛÅÇÏ,