Subject: RE: [Megaco] Re: Mandatory serviceChangeReason parameter?

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 29 Jan 2004 08:48:48 -0500

The Corrigendum for V2 has gone for consent.  If there are no objections, I
will enter this as the first item in the new IG which would get Approved in
November.

Kevin

-----Original Message-----
From: Samuel Tardieu [mailto:[email-masked]] 
Sent: Thursday, January 29, 2004 6:45 AM
To: [email-masked]
Subject: [Megaco] Re: Mandatory serviceChangeReason parameter?

>>>>> "Kevin" == Kevin Boyle <[email-masked]> writes:

> ServiceChangeReason is mandatory.  The example in Appendix I has an 
> error.  It is important to note that the Appendix is not normative 
> text.  It only provides guidance as to one possible protocol use, but 
> should not be taken as mandatory usage.

Sure, but as I guess many people, I started to play with Megaco by
encoding/decoding the example given in the RFC :-) Any chance to have a
corrected example in Megaco v2 ? (if it is not too late)

  Sam
--
Samuel Tardieu -- [email-masked] -- http://www.rfc1149.net/sam

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Thu, 29 Jan 2004 15:07:19 -0500

> will enter this as the first item in the new IG which would get Approved in

Kevin,

Here are some typos I posted recently that should be addressed as well.

> I was reading the V2 doc and spotted the following minor items...
> 
> In Annex B, auditItem was added to serviceChangeParm.  The
> at-most-once comment doesn't really apply to auditItem;
> possibly to the elements of auditItem.
> 
> In Annex B, where indAudterminationAudit was added to X
> there's a typo -- an extra paren.
> 
> In Annex A, where comments discuss "X-" and "X+", there's
> a typo/problem with the "-".
> 
> In Appendix I, the call flow examples all show "MEGACO/1"
> instead of "MEGACO/2".  Also the registration ServiceChange
> message does not use the mandatory ServiceChangeVersion param.
> 
>   (From 11.3: "A ServiceChange command from a MG that registers
>   with an MGC shall contain the version number of the protocol
>   supported by the MG in the ServiceChangeVersion parameter.")
> 
> -troy

---

From: Troy Cauble <[email-masked]>
Date: Thu, 29 Jan 2004 15:07:19 -0500

Kevin,