Subject: [Megaco] Mandatory serviceChangeReason parameter?

From: Samuel Tardieu <[email-masked]>
Date: Thu, 29 Jan 2004 01:37:50 +0100

In the ASN.1 description of RFC3525, I understand that the
serviceChangeReason parameter is mandatory:

      serviceChangeReason     Value,
   -- A serviceChangeReason consists of a numeric reason code
   -- and an optional text description.

However, in appendix I, the example does not mention one:

   ServiceChange = ROOT {Services {
       Method=Restart,
       ServiceChangeAddress=55555, Profile=ResGW/1}
   }

Is there an error in the example?

  Sam
-- 
Samuel Tardieu -- [email-masked] -- http://www.rfc1149.net/sam

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 29 Jan 2004 04:37:30 -0500

ServiceChangeReason is mandatory.  The example in Appendix I has an error.

It is important to note that the Appendix is not normative text.  It only
provides guidance as to one possible protocol use, but should not be taken
as mandatory usage.

Kevin 

-----Original Message-----
From: Rasool Wani [mailto:[email-masked]] 
Sent: Wednesday, January 28, 2004 10:57 PM
To: [email-masked]; Samuel Tardieu
Subject: Re: [Megaco] Mandatory serviceChangeReason parameter?

Value is SEQUENCE OF Octet String.
A value of zero Octet String can be transmitted.

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 29 Jan 2004 08:48:48 -0500

The Corrigendum for V2 has gone for consent.  If there are no objections, I
will enter this as the first item in the new IG which would get Approved in
November.

Kevin

-----Original Message-----
From: Samuel Tardieu [mailto:[email-masked]] 
Sent: Thursday, January 29, 2004 6:45 AM
To: [email-masked]
Subject: [Megaco] Re: Mandatory serviceChangeReason parameter?

>>>>> "Kevin" == Kevin Boyle <[email-masked]> writes:

> ServiceChangeReason is mandatory.  The example in Appendix I has an 
> error.  It is important to note that the Appendix is not normative 
> text.  It only provides guidance as to one possible protocol use, but 
> should not be taken as mandatory usage.

Sure, but as I guess many people, I started to play with Megaco by
encoding/decoding the example given in the RFC :-) Any chance to have a
corrected example in Megaco v2 ? (if it is not too late)

  Sam

---

From: Carl Rutter <[email-masked]>
Date: Thu, 29 Jan 2004 10:11:56 -0500

As a general question to the group
I'd like to get an idea how quickly
companies and Stack vendors are and will be adding V2
support.

Thx,
Carl

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Kevin Boyle
Sent: Thursday, January 29, 2004 8:49 AM
To: Samuel Tardieu; [email-masked]
Subject: RE: [Megaco] Re: Mandatory serviceChangeReason parameter?

Kevin

-----Original Message-----
From: Samuel Tardieu [mailto:[email-masked]] 
Sent: Thursday, January 29, 2004 6:45 AM
To: [email-masked]
Subject: [Megaco] Re: Mandatory serviceChangeReason parameter?

  Sam

---

From: Carl Rutter <[email-masked]>
Date: Thu, 29 Jan 2004 10:11:56 -0500

Thx,
Carl

-----Original Message-----

Kevin

-----Original Message-----
From: Samuel Tardieu [mailto:[email-masked]] 
Sent: Thursday, January 29, 2004 6:45 AM
To: [email-masked]
Subject: [Megaco] Re: Mandatory serviceChangeReason parameter?

  Sam

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 30 Jan 2004 03:47:12 -0500

Thanks.  I will bring these up as editorial issues with the TSB so that
these are corrected in the published version.

Kevin 

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]] 
Sent: Thursday, January 29, 2004 3:07 PM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]
Cc: [email-masked]
Subject: Re: [Megaco] Re: Mandatory serviceChangeReason parameter?

Kevin Boyle wrote:

> The Corrigendum for V2 has gone for consent.  If there are no 
> objections, I will enter this as the first item in the new IG which 
> would get Approved in November.
> 
> Kevin

Kevin,

Here are some typos I posted recently that should be addressed as well.

> I was reading the V2 doc and spotted the following minor items...
> 
> In Annex B, auditItem was added to serviceChangeParm.  The 
> at-most-once comment doesn't really apply to auditItem; possibly to 
> the elements of auditItem.
> 
> In Annex B, where indAudterminationAudit was added to X there's a typo 
> -- an extra paren.
> 
> In Annex A, where comments discuss "X-" and "X+", there's a 
> typo/problem with the "-".
> 
> In Appendix I, the call flow examples all show "MEGACO/1"
> instead of "MEGACO/2".  Also the registration ServiceChange message 
> does not use the mandatory ServiceChangeVersion param.
> 
>   (From 11.3: "A ServiceChange command from a MG that registers
>   with an MGC shall contain the version number of the protocol
>   supported by the MG in the ServiceChangeVersion parameter.")
> 
> -troy

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 30 Jan 2004 11:26:05 -0500

I have submitted the changes mentioned by Troy and Samuel as last-second
editorial revisions to the TSB.  It is now too late to make any changes to
the Corrigendum as it has Consented.

I can affirm that the first two messages in the example flow start MEGACO/1,
in compliance with the registration and version negotiation procedures.

Kevin

-----Original Message-----
From: Dal Chohan [mailto:[email-masked]] 
Sent: Friday, January 30, 2004 11:12 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; Troy Cauble
Cc: [email-masked]
Subject: Re: [Megaco] Re: Mandatory serviceChangeReason parameter?

Kevin,

A point for clarification on this email - I assume that the first two flows
in Appendix I (i.e. ServiceChange Comand and the Service Change Reply) will
still specify "MEGACO/1".

By the clause 11.3 does not explicitly state that the "Service Change Reply"
should also be encoded as version 1. It would be useful to make this clear
in the procedures of clause 11.3.

Regards,

Dal Chohan