Subject: RE: [Megaco] TPKT value for H.248 over TCP

From: Steve Cipolli <[email-masked]>
Date: Wed, 14 Jan 2004 16:25:35 -0500

A colleague of mine suggested to simply interpret a TPKT packetlength of 0
(currently not legal since the TPKT header length is included in the
packetlength) as an indication of that the message is continued in the next
TPKT and that the packet length of this PDU is 65524.  This scheme allows
infinitely long messages and provides backward compatibility for packets
under 65524 bytes.   Compatibility may be important since there is no way to
negotiate which version of TPKT MEGACO entities should use and asking for
more well-known ports from IANA for a new version of TPKT for MEGACO
transport may be tough to come by.

--Stephen

> -----Original Message-----
> From: Troy Cauble [mailto:[email-masked]]
> Sent: Wednesday, January 14, 2004 3:57 PM
> To: Raju
> Cc: [email-masked]; 'Kevin Boyle'; 'MEGACO list'
> Subject: Re: [Megaco] TPKT value for H.248 over TCP
> 
> 
> 
> 
> Raju wrote:
> > Troy,
> > 
> > I doubt if we ever reach 32-bit length range (32 Gaga bytes in
> > one single h248 msg?! if a GW ever needs to send such a huge msg
> > then  there must be some other big problems in dealing with
> > such a huge msg!!).
> > 
> > Besides that, if we all want, we can even have a 8-byte length
> > field in TPKT version 4 (which can hold trillions o f bytes).
> > 
> > Kevin,
> > Can you please resend the proposal you made to overcome this 64k
> > limitation.
> > 
> > Thanks
> > Raju
> 
> 
> Well, I would have said the same for 64K, which was really my point.
> It already seems like a hypothetical issue to me.
> 
> But I guess I work with smaller gateways than some people.
> 
> 
> (Hi Raju!  Still employed I see!)
> 
> -troy
> 
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Rashim Anand" <[email-masked]>
Date: Wed, 14 Jan 2004 16:50:34 -0800

Hi,

Could the authors of the Dynamic Tone Definition (H.248.6) package please
clarify the possible values of the tid property (0x0001) in the dtd (dynamic
tone definition) package. This is what the document says -

Type:         expanding enumeration
Possible Values:
   Existing package_id, tone id described in supported packages that extend
tonegen or new tones to be added.

This description is not very clear. Could you also provide some examples of
the values of tid? Also, what is the meaning of "expanding" in the
"expanding enumeration" type?

Thanks,

Rashim Anand

---

From: "Rashim Anand" <[email-masked]>
Date: Wed, 14 Jan 2004 16:50:34 -0800

Hi,

Thanks,

Rashim Anand

---

From: Christian Groves <[email-masked]>
Date: Thu, 15 Jan 2004 14:27:05 +1100

G'Day all,

Rather than tweaking one transport to carry infinitely long messages I think we 
should look at a solution that would allow very long messages to be carried 
across all the defined transports. I think Kevin has started the discussion 
through his contribution. I personally would like to a solution that doesn't 
need H.248.1 to manage segmentation for one particular transport.

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Thu, 15 Jan 2004 14:27:05 +1100

G'Day all,

Regards, Christian