Subject: Re: [Megaco] Add command with NULL context

From: 杨先波 <[email-masked]>
Date: Fri, 16 Jul 2004 10:49:06 +0800

Right, sorry, I ignored the command is add, if servicechange command ,it can do 

-----原始邮件-----
发件人: Kevin Boyle [mailto:[email-masked]]
发送时间: 2004年7月16日 10:39
收件人: 杨先波; [email-masked]
主题: RE: [Megaco] Add command with NULL context

Regardless of which termination it is, Add to NULL is illegal.  An Add of ROOT to anything is also illegal.  The question was what the response to such a command would be.

Note that an Add to ALL is guaranteed to return an error, except in the case of there being only a single context.  So that is a fairly silly combination as well.

Kevin 

-----Original Message----- 
From: [email-masked] [ mailto:[email-masked]] 
Sent: Thursday, July 15, 2004 9:18 PM 
To: [email-masked] 
Subject: Re: [Megaco] Add command with NULL context 

But as I know, if termination is ROOT, it presents the MGW, so context should be null,which is not necessary; if specific, CHOOSE or ALL, context not null.Just my viewpoint.

-----原始邮件----- 
发件人: [email-masked] [ mailto:[email-masked]]代表 [email-masked] 
发送时间: 2004年7月16日 0:12 
收件人: [email-masked] 
主题: Megaco Digest, Vol 3, Issue 9 

Send Megaco mailing list submissions to 
        [email-masked] 

To subscribe or unsubscribe via the World Wide Web, visit 
        https://www1.ietf.org/mailman/listinfo/megaco 
or, via email, send a message with subject or body 'help' to 
        [email-masked] 

You can reach the person managing the list at 
        [email-masked] 

When replying, please edit your Subject line so it is more specific than "Re: Contents of Megaco digest..." 

Today's Topics: 

   1. RE: Add command with NULL context (Kevin Boyle) 

---------------------------------------------------------------------- 

Message: 1 
Date: Wed, 14 Jul 2004 13:06:51 -0400 
From: "Kevin Boyle" <[email-masked]> 
Subject: RE: [Megaco] Add command with NULL context 
To: Csaba Koppany <[email-masked]>, [email-masked] 
Message-ID: 
        <[email-masked]> 

Seems to me that this would be a protocol error (401). 

Try: !/1 [12.34.56.78]:2944 P=10003{C=-{ER=401{"That's not allowed!"}}} 

Kevin 

-----Original Message----- 
From: Csaba Koppany [ mailto:[email-masked]] 
Sent: Wednesday, July 14, 2004 9:35 AM 
To: [email-masked] 
Subject: [Megaco] Add command with NULL context 

Hi List, 
  
can someone clarify hat would be the correct answer to message below? 

MEGACO/2 [123.123.123.4]:55555 
Transaction = 10003 { 
    Context = - { 
       Add = $ { 
          .... 
       } 
    } 
}  

I guess using NULL context in an add command is an error, independently the value of the termination Id. 
It is written hat if the ROOT termination is addressed the 410 "Incorrect identifier" Shall be returned, but what are the error codes in case of using a specific, CHOOSE or ALL wildcards? 

It is also my question if this error description should be on the command or Action level, as by the syntax it is possible to include an error descriptor inside the ActioReply with an empty list of command.

Thank you for any suggestions! 
Best regards, 
  Csaba Koppany 

_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco 

------------------------------ 

_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco 

End of Megaco Digest, Vol 3, Issue 9 
************************************ 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Fri, 16 Jul 2004 09:31:00 +0530

Hi
      Not only ServiceChange command, a MODIFY command can also come with
ALL, PartialALL, Specific, Null for context ids and ALL, PartialALL,
Specific for terminationIDs. CHOOSE is not a valid option for Modify
command both for Context and Termination ids.

Regards
B Venkat S.R Swamy
Hughes Software Systems
Phone:  +91-124-2455555 Extn 3620
Fax: +91-124-2455345
web: www.hssworld.com

             杨先波                                                        
             <[email-masked]>                                             
             Sent by:                                                   To 
             megaco-bounces@ie         "Kevin Boyle"                       
             tf.org                    <[email-masked]>,        
                                       <[email-masked]>                   
                                                                        cc 
             07/16/2004 08:19                                              
             AM                                                    Subject 
                                       Re: [Megaco] Add command with NULL  
                                       context                             

                                                                           

Right, sorry, I  ignored the command is add, if servicechange command ,it
can do
-----原始邮件-----
发件人: Kevin Boyle  [mailto:[email-masked]]
发送时间: 2004年7月16日  10:39
收件人: 杨先波; [email-masked]
主题: RE: [Megaco] Add  command with NULL context

Regardless of which termination it is, Add to NULL is  illegal.  An Add of
ROOT to anything is also illegal.  The question  was what the response to
such a command would be.

Note that an Add to ALL is guaranteed to return an error,  except in the
case of there being only a single context.  So that is a  fairly silly
combination as well.

Kevin

-----Original Message-----
From:  [email-masked] [mailto:[email-masked]]
Sent: Thursday, July 15, 2004 9:18 PM
To: [email-masked]
Subject: Re: [Megaco] Add  command with NULL context

But as I know, if termination is ROOT, it presents the MGW, so  context
should be null,which is not necessary; if specific, CHOOSE or ALL,  context
not null.Just my viewpoint.

-----原始邮件-----
发件人:  [email-masked] [mailto:[email-masked]]代表
[email-masked]
发送时间: 2004年7月16日 0:12
收件人: [email-masked]
主题: Megaco  Digest, Vol 3, Issue 9

When replying, please edit your Subject line so it is more  specific than
"Re: Contents of Megaco digest..."

Today's Topics:

Message: 1

Kevin

-----Original Message-----
From: Csaba  Koppany [mailto:[email-masked]]
Sent: Wednesday, July 14, 2004 9:35 AM
To: [email-masked]
Subject: [Megaco] Add  command with NULL context

Hi List,

I guess using NULL context in an add command is an error,  independently
the value of the termination Id.
It is  written hat if the ROOT termination is addressed the 410 "Incorrect
identifier" Shall be returned, but what are the error codes in case of
using a  specific, CHOOSE or ALL wildcards?

It is also my question if this error description should be on  the command
or Action level, as by the syntax it is possible to include an  error
descriptor inside the ActioReply with an empty list of  command.