Subject: [Megaco] GCP Message Priority handling

From: "Michael Weilandt (AC/EDD)" <[email-masked]>
Date: Tue, 20 Jul 2004 13:06:35 +0200

Hello,

to my knowledge there is no mention in H.248.5 of a dedicated
setting of the MTP message priority when sending a GCP message over
MTP3b.
For ANSI ISUP such concept is used to give messages associated with
an ongoing or already establish call higher priority. In other words
IAM message may be dropped or treated with lower priority.

Has there ever been considerations to give a lower priority to
an ADD than to a MOD or SUB command; or in general to make some
distinction between "new" requests towards the MG as opposed to
"modfications" of existing contexts?

Best regards,
/Michael

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 20 Jul 2004 11:25:40 -0400

Messages do not have a priority that is transmitted via protocol.  The
priority of a context can be set freely.

The determination to shed particular messages would be an implementation
detail of the overload protection function of the entity in question.

Kevin 

-----Original Message-----
From: Michael Weilandt (AC/EDD) [mailto:[email-masked]] 
Sent: Tuesday, July 20, 2004 7:07 AM
To: [email-masked]
Subject: [Megaco] GCP Message Priority handling

Hello,

to my knowledge there is no mention in H.248.5 of a dedicated setting of the
MTP message priority when sending a GCP message over MTP3b.
For ANSI ISUP such concept is used to give messages associated with an
ongoing or already establish call higher priority. In other words IAM
message may be dropped or treated with lower priority.

Has there ever been considerations to give a lower priority to an ADD than
to a MOD or SUB command; or in general to make some distinction between
"new" requests towards the MG as opposed to "modfications" of existing
contexts?

Best regards,
/Michael

---

From: "Michael Weilandt (AC/EDD)" <[email-masked]>
Date: Thu, 22 Jul 2004 10:52:13 +0200

Hi Kevin,
 
what I meant here was not the context-related priority >inside< the GCP transaction
but the priority scheme offered by MTP, i.e. the signalling transport for GCP. Please
read for example ITU-T Q.704 (chapter 2.3.5) or Q.2150.1.
 
In high-load situation in the signalling network, when (e.g.) an STP may decide to discard
messages, it could indead be better to through away GCP transactions requesting a new
context rather than transactions that modifiy or subtract an existing context. The MTP priority
setting would be up to the MGC which should have an idea on what requests belong to
an "ongoing call" an which belong to a new one "to be established".
 
BR,
/Michael

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Tuesday, July 20, 2004 5:26 PM
To: Michael Weilandt (AC/EDD); [email-masked]
Subject: RE: [Megaco] GCP Message Priority handling

Messages do not have a priority that is transmitted via protocol.  The priority of a context can be set freely. 

The determination to shed particular messages would be an implementation detail of the overload protection function of the entity in question.

Kevin 

-----Original Message----- 
From: Michael Weilandt (AC/EDD) [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Tuesday, July 20, 2004 7:07 AM 
To: [email-masked] 
Subject: [Megaco] GCP Message Priority handling 

Hello, 

to my knowledge there is no mention in H.248.5 of a dedicated setting of the MTP message priority when sending a GCP message over MTP3b.

For ANSI ISUP such concept is used to give messages associated with an ongoing or already establish call higher priority. In other words IAM message may be dropped or treated with lower priority.

Has there ever been considerations to give a lower priority to an ADD than to a MOD or SUB command; or in general to make some distinction between "new" requests towards the MG as opposed to "modfications" of existing contexts?

Best regards, 
/Michael 

_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco <https://www1.ietf.org/mailman/listinfo/megaco>

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 22 Jul 2004 09:37:51 -0400

MTP priority handling is outside the scope of H.248.  If your implementation
wishes to distinguish between Adds and other kinds of H.248 commands to
determine how to set the priority indicator in MTP, then great.
 
I don't see where it is our place to specify overload control behavior with
regard to which commands are more acceptable to throw away (if any).  That
would depend heavily upon the details of a particular implementation.
 
Kevin

  _____  

From: Michael Weilandt (AC/EDD) [mailto:[email-masked]] 
Sent: Thursday, July 22, 2004 4:52 AM
To: [email-masked]
Subject: RE: [Megaco] GCP Message Priority handling

Hi Kevin,
 
what I meant here was not the context-related priority >inside< the GCP
transaction
but the priority scheme offered by MTP, i.e. the signalling transport for
GCP. Please
read for example ITU-T Q.704 (chapter 2.3.5) or Q.2150.1.
 
In high-load situation in the signalling network, when (e.g.) an STP may
decide to discard
messages, it could indead be better to through away GCP transactions
requesting a new
context rather than transactions that modifiy or subtract an existing
context. The MTP priority
setting would be up to the MGC which should have an idea on what requests
belong to
an "ongoing call" an which belong to a new one "to be established".
 
BR,
/Michael

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Tuesday, July 20, 2004 5:26 PM
To: Michael Weilandt (AC/EDD); [email-masked]
Subject: RE: [Megaco] GCP Message Priority handling

Kevin 

-----Original Message----- 
From: Michael Weilandt (AC/EDD) [mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Tuesday, July 20, 2004 7:07 AM 
To: [email-masked] 
Subject: [Megaco] GCP Message Priority handling 

Hello, 

Best regards, 
/Michael 

_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco
<https://www1.ietf.org/mailman/listinfo/megaco>