Subject: Re: [Megaco] Which error to use for errors in Topology descriptor?

From: Christian Groves <[email-masked]>
Date: Thu, 01 Jul 2004 15:38:10 +1000

Hello Aleksandr,

How about:
Additional to H.248.8:

4.2.5x	Error Code #: 522 Name: Invalid Topology
Definition: The MG was unable execute the action as it was unable to apply the 
requested context topology.
Package: –
Reference: –
Error Text in the error Descriptor: <TBD>
Comment: –

Do people want something to be returned in the Error descriptor? ie. the triple 
that caused the problem. I tend to think that as the "topology" is the group of 
triple its enough not to have anything. Thoughts?

Regards, Christian

Aleksandr Ryabin wrote:

> Hi Christinan,
> 
> Can we agree on the error code number now and the document this is to 
> added?
> Can the editor of the appropriate document (i.e. IG, or H.248.8 update) 
> please assign the number?
> 
> Thanks
>         Aleks
> 
> At 11:38 PM 6/23/2004, Christian Groves wrote:
> 
>> Hello Aleksandr,
>>
>> Sounds like a reasonable thing to add.
>>
>> Christian
>>
>> Aleksandr Ryabin wrote:
>>
>>> Hi Christian,
>>> Yes, exactly, "invalid topology" or something like "could not apply 
>>> topology"
>>> Regards,
>>>         Aleks
>>> At 07:08 PM 6/23/2004, Christian Groves wrote:
>>>
>>>> Hello Aleksandr,
>>>>
>>>> What sort of error were you thinking about?
>>>>
>>>> If there's something wrong with the syntax then this can be covered 
>>>> with 422 syntax error in action. Invalid termination/stream ID can 
>>>> be covered by other errors.
>>>>
>>>> Is the error something like "invalid topology" where the MG can't 
>>>> connect terminations according to the MGC's wishes?
>>>>
>>>> Regards, Christian
>>>>
>>>> Aleksandr Ryabin wrote:
>>>>
>>>>> Hi,
>>>>> Which error should be used to report errors detected within 
>>>>> TopologyDescriptor?
>>>>> If there are none yet, can one be added to H.248.8?
>>>>> Thanks
>>>>>     Aleks
>>>>>
>>>>> _______________________________________________
>>>>> Megaco mailing list
>>>>> [email-masked]
>>>>> https://www1.ietf.org/mailman/listinfo/megaco
> 
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 01 Jul 2004 10:00:50 -0400

Hi Christian,

Sounds good.
Error can contain one, or more triples that caused the problem, i.e:

Error Text in the error Descriptor: invalid triples

Regards,
         Aleks

At 01:38 AM 7/1/2004, Christian Groves wrote:
>Definition: The MG was unable execute the action as it was unable to apply 
>the requested context topology.
>Package: 
>Reference: 
>Comment: 
>Do people want something to be returned in the Error descriptor? ie. the 
>triple that caused the problem. I tend to think that as the "topology" is 
>the group of triple its enough not to have anything. Thoughts?
>
>Regards, Christian
>
>Aleksandr Ryabin wrote:
>
>>Hi Christinan,
>>Can we agree on the error code number now and the document this is to added?
>>>>>with 422 syntax error in action. Invalid termination/stream ID can be 
>>>>>covered by other errors.
>>>>>