Subject: RE: [Megaco] ABNF encoding of Boolean Values

From: "Kevin Boyle" <[email-masked]>
Date: Sat, 10 Jul 2004 12:06:21 -0400

Appendix A is binary encoding, not text encoding.  Appendix B is text
encoding.  The sections are not contradictory.

Kevin 

-----Original Message-----
From: Balasubramanian Pitchandi [mailto:[email-masked]] 
Sent: Saturday, July 10, 2004 8:39 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Megaco] ABNF encoding of Boolean Values

Hello,

RFC3525 has two contradicting sections (A.1.2 & B.2) with respect to the
encoding of boolean values.

A.1.2 states that ObservedEvents parameter should be encoded as

init = false

whereas the section B.2 clearly states that all boolean values should be
encoded as either "on" or "off", which would mean that the same would be
encoded as

init = off

Which one of this is correct?

Thanks
Bala

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "atto" <[email-masked]>
Date: Tue, 13 Jul 2004 13:25:54 +0800

hi, kevin,

I am confused by some conflict in rfc3525.

by B.2 comment, the text encoding boolean should be "on"/"off", 

but by definition of  cd/on{init}, the value of boolean is  "true"/"false".

	ObservedEventsDescriptor parameters
		Initial State
		ParameterID: init (0x0002)
		Type: Boolean
		Possible values:
		"True" means that the event was reported because the line was already on-hook when the events descriptor containing this event was activated;
		"False" means that the event represents an actual state transition to on-hook.

and some examples of cd/on{init} also show  that "true"/"false" should be used. (in rfc3525 page 186/191/193)

MEGACO/1 [125.125.125.111]:55555 Transaction = 50008 {
      Context = 5000 {
          Notify = A5555 {ObservedEvents =1235 {
             19990729T24020002:al/on(init=false)}
          }
      } }

is it a mistake of rfc3525? 
or the boolean can be either on/off or true/false, just according by the definition?

thanks
atto

-----原始邮件-----
发件人: [email-masked] [mailto:[email-masked]]代表
Kevin Boyle
发送时间: 2004年7月11日 0:06
收件人: [email-masked]; [email-masked]
抄送: [email-masked]; [email-masked]
主题: RE: [Megaco] ABNF encoding of Boolean Values

Kevin 

-----Original Message-----
From: Balasubramanian Pitchandi [mailto:[email-masked]] 
Sent: Saturday, July 10, 2004 8:39 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Megaco] ABNF encoding of Boolean Values

Hello,

init = false

init = off

Thanks
Bala

---

From: "Balasubramanian Pitchandi" <[email-masked]>
Date: Tue, 20 Jul 2004 05:49:25 -0400

Kevin/List,

Would you please clarify this confusion regarding the encoding of Boolean values?
 
Thanks,
Bala

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of atto
Sent: Tuesday, July 13, 2004 1:26 AM
To: Kevin Boyle
Cc: bala; [email-masked]
Subject: 答复: [Megaco] ABNF encoding of Boolean Values

hi, kevin,

thanks
atto

-----原始邮件-----

Kevin 

-----Original Message-----
From: Balasubramanian Pitchandi [mailto:[email-masked]] 
Sent: Saturday, July 10, 2004 8:39 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Megaco] ABNF encoding of Boolean Values

Hello,

init = false

init = off

Thanks
Bala