Subject: [Megaco] Require clarification on Audit of Statistics

From: Jagan Mohan <[email-masked]>
Date: Tue, 26 Oct 2004 11:22:01 +0530

Hi,

  I have a H.248 VoIP call b/w 2 gateways. Say, the RTP termination on
one gateway goes down and it's reported to the MGC. Now, the MGC
should send a SUBTRACT message to the gateway for subtracting the RTP
termination.

  Here, a normal subtract command from MGC would mean that Audit of
Statistics should be done on the gateway. But since the RTP
termination has gone down, Audit of statistics would fail on the
gateway.

  So, should the MGC send 

(A) SUBTRACT command  

MEGACO/1 [10.10.10.1]:2944
Transaction = 11025 {
    Context = 4 {
            Subtract = R10
    }
}

OR 

(B) SUBTRACT command and Audit with no descriptor.

MEGACO/1 [10.10.10.1]:2944
Transaction = 11025 {
    Context = 4 {
            Subtract = R10 { Audit { } }
    }
}

Regards,
Jagan

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Tue, 26 Oct 2004 19:35:24 +0530

Hello Jagan,

I agree with you that since RTP termination has gone down,  gateway may 
not have information for all the statistics when the termination gets 
subtracted by MGC. However, some statistics like call duration can be 
calculated by gateway internally by taking time stamps at the start and 
the end of the call. So it would still be possible for the media gateway 
to report these statistics.

So I think sending (A) would not be a bad idea. Gateway would in this case 
fill a zero for all other statistics except for the ones which it has 
information on like  "duration of time the termination has been in the 
context".

Regards,
Saurabh
Hughes Software Systems
www.hssworld.com

Please respond to Jagan Mohan <[email-masked]>

Sent by:        [email-masked]
To:     MEGACO list <[email-masked]>
cc:      

Subject:        [Megaco] Require clarification on Audit of Statistics

Hi,

So, should the MGC send

(A) SUBTRACT command

OR

Regards,
Jagan

*****************    HSS-Unclassified    *************

"Please note:The email domain of Hughes Software Systems Ltd. has been changed to "hssworld.com" from hss.hns.com"

"DISCLAIMER: This message is proprietary to Hughes Software Systems Limited (HSS) and is intended 
solely for the use of the individual to whom it is addressed. It may contain  privileged or 
confidential information and should not be circulated or used for any purpose other than for 
what it is intended. If you have received this message in error, please notify the originator 
immediately. If you are not the intended recipient, you are notified that you are strictly 
prohibited from using, copying, altering, or disclosing the contents of this message. HSS 
accepts no responsibility for loss or damage arising from the use of the information transmitted 
by this email including damage from virus."