Subject: [Megaco] ISDN support with Megaco

From: "Matia Marcu" <[email-masked]>
Date: Mon, 18 Oct 2004 13:58:12 +0200

Dear Megaco-list members,

Two main options have been proposed for ISDN phone /PBX support: Q,931 signaling conversion to MGCP /Megaco or Q.931 signaling transport over the IP network to a softswitch that supports Q.931 network side (Q.931 /IUA /SCTP).

I'll describe part of the transport option as we figured it out and ask questions where we have a dilemma:

1. Tone generation

Outgoing call process: the ISDN entity sends a SETUP to the softswitch, which responds with SETUP ACKNOWLEDGE; concerning dial tone, the softswitch may do as follows:
*	instruct the VoIP gateway to apply dial tone and inform the ISDN entity that in-band indication is expected
*	instruct the ISDN entity to apply dial tone towards the user side (ISDN phones have this capability, so do PBXs)

In the first case, the gateway would apply the tone as for analog interfaces - phones and trunks. The difference appears when dial tone must stop. For analog interfaces, the gateway performs both tone generation and event detection, meaning that digit detection would stop dial tone. For ISDN, the softswitch would receive the first digit signaled as Q.931 INFORMATION message and would instruct the gateway to stop the dial tone. If this command to the gateway gets lost, the user would be stuck with dial tone - at best for a short time, till the retransmitted command is received, at worst for a longer time...The same applies for other combinations of signals and events.

If the ISDN entity applies the tone, the problem is that the ISDN tone range is narrower than the tone range generated by CO (and consequently by VoIP gateway) and this would leave ISDN users with poorer functionality.

Which option is preferable? Should vendors support both options and decide at deployment time - based on the concrete network and the actual risk of retransmission /network failure?

2. Service state management

This question is intended for the US market, where ISDN PRI standards include a B-channel maintenance procedure. How should this procedure be harmonized with Megaco ServiceChange (in the signaling transport option)? Give up the B-channel maintenance altogether? Or use it - but then it should be clear which VoIP entity is responsible to solve mismatches - and how?

Thank you,

Matia Marcu
Teledata Networks

This mail was sent via Teledata-Networks.com

************************************************************************************
This footnote confirms that this email message
has been scanned by InterScan Messaging suite
for the presence of malicious code, vandals & computer viruses.
************************************************************************************

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Tue, 19 Oct 2004 08:02:41 +0200

Hi Matia,

I'm only aware of defined technologies for the 2nd option (SIGTRAN IUA or
DUA).

The first case, meaning relaying CCS over GCPs (Common Channel Signalling
via Gateway Control Protocol) is not supported ("because this scenario is
questionable because of the "CCS protocol suite" approach, - where's
typically at least layer 2 and layer 3 signalling, plus layer management"
for CCS's like DSS1, PSS1, V5, GR-303, or SS7; please note that this is a
significant differences of (3) CCS to (1) Analog Line Signalling and (2)
CAS; guess you know that (1) & (2) are inherently supported by H.248).

Conclusion:
the Call/Session Control Server housing the Q.931/IUA endpoint AND the
H.248 MGC endpoint is the responsible coordination instance between
out-of-band signalling events (D channel) and corresponding inband
signalling (B channel; terminated in H.248 MG, remotely controlled by MGC).

Do I miss sth.?

Regards
Albrecht

|---------+----------------------------------->
|         |           "Matia Marcu"           |
|         |           <Matia.Marcu@Teledata-Ne|
|         |           tworks.com>             |
|         |           Sent by:                |
|         |           [email-masked] |
|         |                                   |
|         |                                   |
|         |           18.10.2004 13:58        |
|---------+----------------------------------->
  >-------------------------------------------------------------------------------------------------------------------------------|
  |                                                                                                                               |
  |        To:      <[email-masked]>                                                                                             |
  |        cc:                                                                                                                    |
  |        Subject: [Megaco] ISDN support with Megaco                                                                             |
  >-------------------------------------------------------------------------------------------------------------------------------|

Two main options have been proposed for ISDN phone /PBX support: Q,931
signaling conversion to MGCP /Megaco or Q.931 signaling transport over the
IP network to a softswitch that supports Q.931 network side (Q.931 /IUA
/SCTP).

I'll describe part of the transport option as we figured it out and ask
questions where we have a dilemma:

1. Tone generation

Outgoing call process: the ISDN entity sends a SETUP to the softswitch,
which responds with SETUP ACKNOWLEDGE; concerning dial tone, the softswitch
may do as follows:
      instruct the VoIP gateway to apply dial tone and inform the ISDN
      entity that in-band indication is expected
      instruct the ISDN entity to apply dial tone towards the user side
      (ISDN phones have this capability, so do PBXs)

In the first case, the gateway would apply the tone as for analog
interfaces - phones and trunks. The difference appears when dial tone must
stop. For analog interfaces, the gateway performs both tone generation and
event detection, meaning that digit detection would stop dial tone. For
ISDN, the softswitch would receive the first digit signaled as Q.931
INFORMATION message and would instruct the gateway to stop the dial tone.
If this command to the gateway gets lost, the user would be stuck with dial
tone - at best for a short time, till the retransmitted command is
received, at worst for a longer time...The same applies for other
combinations of signals and events.

If the ISDN entity applies the tone, the problem is that the ISDN tone
range is narrower than the tone range generated by CO (and consequently by
VoIP gateway) and this would leave ISDN users with poorer functionality.

Which option is preferable? Should vendors support both options and decide
at deployment time - based on the concrete network and the actual risk of
retransmission /network failure?

This question is intended for the US market, where ISDN PRI standards
include a B-channel maintenance procedure. How should this procedure be
harmonized with Megaco ServiceChange (in the signaling transport option)?
Give up the B-channel maintenance altogether? Or use it - but then it
should be clear which VoIP entity is responsible to solve mismatches - and
how?

Thank you,

Matia Marcu

Teledata Networks

 ************************************************************************** 
 **********                                                                 
 This footnote confirms that this email message                             

 for the presence of malicious code, vandals & computer viruses.            
 ************************************************************************** 
 **********