Subject: RE: [Megaco] definition on parameter and property

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 4 Oct 2004 10:17:51 -0400

Some of the parameters you specifically mention (gain, jitterbuf) are
handled via packages defined in H.248.1 Annex E.  The others you mention
(silence suppression, encryption) have SDP attributes already defined.

You will have to do some research on what is defined and applicable for your
implementation.  Note that most packages defined for H.248 are in the H.248
subseries, with several in Q.1950.

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Gillian Wang
Sent: Monday, October 04, 2004 3:45 AM
To: Christian Groves
Cc: Megaco@Ietf. Org
Subject: [Megaco] definition on parameter and property

Christian, thanks for the clarification.

For the second question, based on my understanding of the Megaco protocol,
properties are related to the packages; parameters are grouped into
descriptors. In that case, I thought that the Annex C might specify the
parameters which belonged to different descriptors, although some not to
existing descriptors. However, your answer provides a different
implementation approach of these parameters/properties. Thanks for that! By
the way, are there any clear definitions on parameters and properties from
implementation's point of view?

Regards
Gillian

-----Original Message-----
From: Christian Groves [mailto:[email-masked]]
Sent: Monday, 4 October 2004 4:37 PM
To: Gillian Wang
Cc: [email-masked]
Subject: Re: [Megaco] Text encoding format

G'Day Gillian,

The hexadecimal format should be used whereever Octet String encoding is
defined. See H.248.1 sect 12.2, "Octet String: A number of octets. See Annex
A and B.3 for encoding"

In H.248.1v3 we clarified the use of Annex C to be:
"The referencing of Annex C properties follows the PackageID/PropertyID
structure; however Annex C is not in itself a package. Annex C is considered
to have PackageID 0x0000 for binary encoding and "anxc" for text encoding.
For text encoding of H.248.1, Annex C shall only be used in the case that
the required property is not already defined by a package or represented by
SDP. The nesting of one Annex C property inside another is forbidden."

Regards, Christian

Gillian Wang wrote:

> Dear Megaco members,
>
> My questions here are regarding the information provided in Annex B 
> and Annex C of the H.248.1 v2 standard.
>
> In H.248.1 Annex B.2, text encoding format is specified. There is 
> another hexadicimal octet coding specified in B.3. Can you please 
> advise where
this
> hexadecimal octet coding should be used for the megaco message structure?
>
> Are the attributes defined in Annex C for binary encoding only? if 
> yes,
how
> to set these attributes for the text encoding? like Gain, jitterbuff, 
> Silencesupp or encrptkey, etc. If not, can we use the PropertyID and
values
> for the text encoding?
>
> Thanks for the clarification.
>
> Regards
> Gillian
>
>
>
>
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
>

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Tue, 05 Oct 2004 09:30:37 +1000

G'Day Gillian,

Properties belong to descriptors (local, remote, local control, term state)
Parameters belong to signals and events.

Annex C describes properties (unfortunately it uses the word 'parameter' 
occasionally in the text).

Regards, Christian

Kevin Boyle wrote:

> You will have to do some research on what is defined and applicable for 
> your implementation.  Note that most packages defined for H.248 are in 
> the H.248 subseries, with several in Q.1950.
> 
> Kevin
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf 
> Of Gillian Wang
> For the second question, based on my understanding of the Megaco 
> protocol, properties are related to the packages; parameters are grouped 
> into descriptors. In that case, I thought that the Annex C might specify 
> the parameters which belonged to different descriptors, although some 
> not to existing descriptors. However, your answer provides a different 
> implementation approach of these parameters/properties. Thanks for that! 
> By the way, are there any clear definitions on parameters and properties 
> from implementation's point of view?
> 
> Regards
> Gillian
> 
> 
> 
> defined. See H.248.1 sect 12.2, "Octet String: A number of octets. See 
> Annex A and B.3 for encoding"
> 
> structure; however Annex C is not in itself a package. Annex C is 
> considered to have PackageID 0x0000 for binary encoding and "anxc" for 
> text encoding. For text encoding of H.248.1, Annex C shall only be used 
> in the case that the required property is not already defined by a 
> package or represented by SDP. The nesting of one Annex C property 
> inside another is forbidden."
> 
> Regards, Christian
> 
> Gillian Wang wrote:
> 
>  > Dear Megaco members,
>  >

---

From: "Gillian Wang" <[email-masked]>
Date: Tue, 5 Oct 2004 16:42:29 +1000

Hi Christian,

Do you mean that properties and parameters are same, all belonging to
descriptors, depending on what kind of descriptors they belong, they are
referred as different name?

As in section 7.1 of H.248.1, "The parameters to a command are termed
Descriptors", I got confused.

Regards
Gillian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf
Of Christian Groves
Sent: Tuesday, 5 October 2004 9:31 AM
To: Gillian Wang
Cc: Megaco@Ietf. Org; Kevin Boyle
Subject: Re: [Megaco] definition on parameter and property

G'Day Gillian,

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Tue, 05 Oct 2004 17:03:14 +1000

Hello Gillian,

I like to think "Properties of a termination or stream, parameters of an event 
or signal". Unfortunately the use of "parameter" is a little loose in the 
specification. This is a little bit acedemic as packages describe where the 
parameter or property live.

Christian

---

From: "Gillian Wang" <[email-masked]>
Date: Tue, 12 Oct 2004 15:24:58 +1000

Dear Megaco members,

Can anybody advise that if H.248 protocol supports the indication of the
redundant voice payload transmission?

Regards
Gillian

---

From: Tom Taylor <[email-masked]>
Date: Tue, 12 Oct 2004 10:32:12 -0400

That would be in the payload description in the SDP of the Local and Remote 
descriptors.  Nothing really to do with the H.248 protocol itself.