Subject: [Megaco] Conformance tests question

From: [email-masked]
Date: Thu, 26 May 2005 14:47:08 +0300

Hello all

I was performing conformance tests for the MEGACO according ETSI TS 101
889-2 v1.1.1 (2002-08).
I have a question regarding some of the expected results appeared on this
tests:
On error tests (BI type) there are several tests that send request with
ContextID set to CHOOSE ($).
The expected results on the tests contain action reply with ContextID set
to CHOOSE.
Here is an example for this tests :

TP/MG/AD/BI-01 Reference: ITU-T Recommendation H.248.1 [3] clause 7.2.1
Selection criteria: ROOT termination implemented
Initial condition: any
Ensure that the IUT, on receipt of a Transaction Request containing
      • Action request with
            o CID set to CHOOSE
            o ADD Command request with
             TID set to ROOT
sends a Transaction Reply containing
      • Action reply with
            o CID set to CHOOSE
            o ADD Command reply with
             TID set to ROOT
             Error descriptor (e.g. value 401 "Protocol Error")

The H.248.1 v1 spec mandate that transaction reply may only contain a
specific
ContextID, ALL (*), or NULL (-).

Here's the relevant text from the H.248.1 v1 spec:
8.2.2     TransactionReply
...
The ContextID parameter must specify a value to pertain to all Responses
for the action. The ContextID may be specific, all or null.

The following 19 items are the test cases with this requirement.

1.    TP/MG/AD/BI-01
2.    TP/MG/AC/BI-01
3.    TP/MG/AC/BI-02
4.    TP/MG/AC/BI-03
5.    TP/MG/AC/BI-04
6.    TP/MG/AV/BI-01
7.    TP/MG/AV/BI-02
8.    TP/MG/AV/BI-03
9.    TP/MG/AV/BI-04
10.   TP/MG/MD/BI-01
11.   TP/MG/MD/BI-02
12.   TP/MG/MD/BI-03
13.   TP/MG/MD/BI-09
14.   TP/MG/SU/BI-01
15.   TP/MG/SU/BI-02
16.   TP/MG/SU/BI-03
17.   TP/MG/SU/BI-04
18.   TP/MG/MV/BI-01
19.   TP/MG/MV/BI-02

Please help me to clear this issue.

Thanks

Seraya

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "B Venkat S.R Swamy" <[email-masked]>
Date: Thu, 26 May 2005 17:55:08 +0530

Hi

IMO it is perfectly valid to specify CHOOSE for contextID in response to
the test cases you have mentioned below.  As far as the protocol text you
have mentioned it applies mostly to those scenario where you a valid
context Id(includes wildcard also) or Null context. Where MG has never been
able to create a context why should it return any other value.

Even the ABNF and ASN grammar in Appendix does not put any limitation on
the set of values that can be used in the Reply messages.

I however do agree that the relevant text should be modified to clarify
these scenario and request authors to take this in IG or upcoming V3
document.

regards
B Venkat S.R Swamy
Senior Technical Leader
Flextronics Software Systems
Phone:  +91-124-2455555 Extn 3620
Fax: +91-124-2455345
web: www.hssworld.com

             Seraya.Miletzki@e                                             
             citele.com                                                    
             Sent by:                                                   To 
             megaco-bounces@ie         [email-masked]                     
             tf.org                                                     cc 
                                                                           
                                                                   Subject 
             05/26/2005 05:17          [Megaco] Conformance tests question 
             PM                                                            

Hello all

            o ADD Command request wi
            o ADD Command reply wi
RO

1.    TP/MG/AD/BI-01
2.    TP/MG/AC/BI-01
3.    TP/MG/AC/BI-02
4.    TP/MG/AC/BI-03
5.    TP/MG/AC/BI-04
6.    TP/MG/AV/BI-01
7.    TP/MG/AV/BI-02
8.    TP/MG/AV/BI-03
9.    TP/MG/AV/BI-04
10.   TP/MG/MD/BI-01
11.   TP/MG/MD/BI-02
12.   TP/MG/MD/BI-03
13.   TP/MG/MD/BI-09
14.   TP/MG/SU/BI-01
15.   TP/MG/SU/BI-02
16.   TP/MG/SU/BI-03
17.   TP/MG/SU/BI-04
18.   TP/MG/MV/BI-01
19.   TP/MG/MV/BI-02

Thanks

Seraya_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

***********************  FSS-Restricted   ***********************
"DISCLAIMER: This message is proprietary to Hughes Software Systems Limited
(HSS) and is intended solely for the use of the individual to whom it is
addressed. It may contain  privileged or confidential information and
should not be circulated or used for any purpose other than for what it is
intended. If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient, you are
notified that you are strictly prohibited from using, copying, altering, or
disclosing the contents of this message. HSS accepts no responsibility for
loss or damage arising from the use of the information transmitted by this
email including damage from virus."
"DISCLAIMER: This message is proprietary to Flextronics Software 
Systems Limited (FSS) and is intended solely for the use of the  
individual to whom it is addressed. It may contain  privileged or 
confidential information and should not be circulated or used for 
any purpose other than for what it is intended. If you have received 
this message in  error, please notify the originator immediately. 
If you are not the intended recipient, you are notified that you are
strictly  prohibited  from  using, copying, altering, or disclosing
the contents of this message.  FSS  accepts no  responsibility  for
loss or damage arising from the use of  the information transmitted
by this email including damage from virus."
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco