Subject: Re: [Megaco] Individual audit: differences in text & binary

From: Christian Groves <[email-masked]>
Date: Mon, 16 May 2005 11:42:47 +1000

Hello Frank,

Sorry for the delay but as you probably seen I've been on holidays for a few 
weeks. Thanks for doing the thorough review. Please see my replies below.

Regards, Christian

Frank Reno wrote:

> Thanks for the reply Christian.
> 
> 1 & 2.  Are you saying that items in the Events,
> Signals, and EventBuffer descriptors should have
> optionally one stream ID and no other parameters?

[CHG] Yes. I think the you can get any required information you need about a 
signal/event by auditing the event or signal itself.

> 
> 3. Ok, but why is the requestID optional in binary and
> required in text?

[CHG] The Text should be optional as well to align with the text of H.248.1 sect 
7.2.5 . This will be picked up in the IG.

> 
> 4. Here's another difference I noted. Binary mode can
> audit one entire signal list (providing the list ID
> but omitting the signal ID). This is not possible in
> text mode.

[chg] It should be possible to audit a signal list without specifying a signal 
in the list. This will be picked up in the IG.

> 
> Frank
> 
> --- Christian Groves <[email-masked]>
> wrote:
> 
>>Hello Frank,
>>
>>The Invidual audits for text and binary should have
>>the equivalent functionality 
>>  (apart from Local and Remote). Please see my
>>comments below.
>>
>>Regards, Christian
>>
>>Frank Reno wrote:
>>
>>>I've noticed some differences between what can be
>>>specified in an individual audit between the text
>>
>>and
>>
>>>binary encodings. Was this an oversight or
>>>intentional?
>>>
>>>1. StreamID can be specified for events and
>>
>>signals in
>>
>>>binary mode only.
>>
>>[CHG] This does appear to be case. It seems that
>>something like below is needed:
>>
>>; StreamID only in sigParameter or EventParameter
>>indAudsignalRequest	= signalName [LBRKT sigParameter
>>*(COMMA sigParameter) RBRKT]
>>indAudrequestedEvent	= pkgdName [LBRKT
>>eventParameter *(COMMA eventParameter) RBRKT]
>>
>>
>>
>>>2. Event buffer's event parameters can be
>>
>>specified in
>>
>>>text mode only.
>>
>>[CHG] The text does allow this to happen. However I
>>think that the only 
>>parameter that should be able to be given is the
>>"streamID". This would be the 
>>same in (1) above. By references the
>>"eventParameter" construct you 
>>automatically get the ability to audit signal and
>>event parameters.
>>
>>
>>>3. RequestID is optional in binary and required in
>>>text.
>>>
>>>There were a couple of earlier threads discussing
>>
>>item
>>
>>>3, but I didn't understand the responses. What is
>>
>>the
>>
>>>correct way to handle the requestID when received
>>
>>in
>>
>>>an audit descriptor? Is it:
>>>
>>>a. the specified requestID is ignored and the
>>
>>event is
>>
>>>always audited
>>>b. the event is only audited if the specified
>>>requestID is the requestID of the termination's
>>>current event descriptor. (Can '*' be used for the
>>>requestID in this case?)
>>>c. something else
>>
>>[CHG] I would say b. Rather than use '*' just
>>perform a descriptor audit.
>>
>>
>>>Many thanks,
>>>Frank
>>>
> 
> 
> 
> 
> 		
> __________________________________ 
> Do you Yahoo!? 
> Plan great trips with Yahoo! Travel: Now over 17,000 guides!
> http://travel.yahoo.com/p-travelguide
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: jijo <[email-masked]>
Date: Tue, 17 May 2005 12:38:58 +0530

Hi All,

What's latest RFC Version for Megaco from ITU-T and IETF?
I got confused with ITU-T and IETF.. According to my understanding ITU 
H.248.1 (05/02) is the Version 2 of Gateway control protocol. The RFC 
3525 is the version 1 of Megaco from IETF and Version 2 is not  yet 
released. Am i correct??

Please let me know asap.

Thanks
Jijo