Subject: [Megaco] ASN.1 Universal vs Context-Specific

From: "Garber, Zeev" <[email-masked]>
Date: Fri, 20 May 2005 11:40:09 -0400

This is a question about ASN.1 interpretation of H.248.

According to the spec it uses automatic tags, which means I guess that
absence of the tag assumes Context-Specific tag class.

However in a Megaco message I've seen Action request encoded as
Universal and Command Request encoded as Context specific.

Why this would be the case? Both constructed type look very similar in
terms of ASN.1 structure.

My understanding is that Universal means that this construct can be used
elsewhere. Is this the case with ActionRequest vs CommandRequest?

Regards,

Ze'ev Garber 
Software Engineer
EMPIRIX
Communications Infrastructure Group 
p: 781.266.3256 f: 781.266.3656
email: [email-masked] 
20 Crosby Drive - Bedford, MA 01730 
http://www.empirix.com <http://www.empirix.com/> 

Hammer Call Analyzer 1.4...winner of two Product of the Year Awards. Get
your free trial version at http://www.callanalyzer.com
<http://www.callanalyzer.com/> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Terry L Howe <[email-masked]>
Date: Fri, 20 May 2005 10:14:11 -0600

I normally post to inspire someone post the correct response and
it has been a while since I worked with ASN.1, but...

As I recall, universal tags are used in SEQUENCE OFs and automatic
tags are used in other contexts.  So, if a ActionRequest or 
CommandRequest was in a SEQUENCE OF, it would start with a
universal tag and if it was not, it would start with an automatic
tag.

On Fri, 2005-05-20 at 09:40, Garber, Zeev wrote:
> However in a Megaco message I’ve seen Action request encoded as
> My understanding is that Universal means that this construct can be
> used elsewhere. Is this the case with ActionRequest vs CommandRequest?
> 
>  
> 
> Regards,
> 
> Ze'ev Garber
> Software Engineer
> EMPIRIX
> 20 Crosby Drive- Bedford, MA 01730
> http://www.empirix.com
> 
> Hammer Call Analyzer 1.4...winner of two Product of the Year Awards.
> Get your free trial version at http://www.callanalyzer.com
> 
>  
> 
> 
> 
> ______________________________________________________________________
-- 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 
Terry L Howe                                    [email-masked] 
http://www.jeeptech.com/          http://www.tiptoprockracing.com/ 
~                 http://www.tiptopsoftware.biz/                 ~