Subject: RE: [Megaco] about ReserveValue

From: Kapil Nayar <[email-masked]>
Date: Tue, 2 Aug 2005 15:55:39 +0100 (BST)

Hi Kevin

The new version doesnot allow multiple m= lines in a
session description. 
Just to confirm - if you are implying that RG value
shall apply in case multiple session descriptions
(delimited by v= line and each containing a single m=
line) are specified in LOCAL descriptor.

best regards,
-kapil

--- Kevin Boyle <[email-masked]> wrote:

> I disagree.  There are two payload formats specified
> in this SDP: 8
> (G.711a) and 97 (dynamically assigned to RFC2833
> event detection).
> Therefore, there are two property values.  If you
> want both to be
> reserved for the stream, RV needs to be set to ON. 
> With RV set to ON,
> the MG is obligated to reserve resources for both
> payload formats if it
> can.  With RV set to OFF, the MG is free to pick one
> and discard the
> other.  RG would only apply if there were multiple
> property groups,
> i.e., multiple m= lines.
> 
> Kevin
> 
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]] On Behalf
> Of Maridi R. Makaraju (Raju)
> Sent: Thursday, July 28, 2005 9:33 AM
> To: Neal Zhu; [email-masked]
> Subject: RE: [Megaco] about ReserveValue 
> 
> Neal,
> 
> > i have a doublt.in this message
> > MEGACO/1 [182.20.20.1]:2944
> >
>
T=369361899{C=${A=A1{M{O{MO=IN,RV=OFF,RG=OFF}},E=369098762{tonedet/std
> > {tl=*},al/*},SG{}},A
> > =${M{O{MO=RC,RV=OFF,RG=OFF},L{v=0
> >
> > c=IN IP4 $
> > m=audio $ RTP/AVP 8 97
> > a=ptime:20
> > a=rtpmap:97 telephone-event
> > a=fmtp:97 0-15
> > }}}}}
> >
> > mgc wants a audio call using G.711 and support
> RFC2833 to detect DTMF 
> > at the same time . what is the correct value of
> ReserveValue ?
> > ON or OFF??
> 
> It should be OFF. The reason is as follows:
> The H.248 spec says...
> "If the value of a Reserve property is True, the MG
> SHALL reserve
> resources for all alternatives specified in the
> Local and/or Remote
> descriptors for which it currently has resources
> available."
> 
> The "alternative" should be applied to each type of
> resource, i.e. audio
> codecs, DTM etc.
> For DTMF there is no alternative, it's just RFC2833.
> So MG should
> allocate resources for
> RFC2833 if available and return payload 97 in the
> response. If no
> RFC2833(DTMF) resources available then it should
> omit payload 97 in the
> response.
> 
> Thanks
> Raju
> 
> 
> >
> >
>
_________________________________________________________________
> > Ãâ·ÑÏÂÔØ MSN Explorer:  
> http://explorer.msn.com/lccn/
> >
> >
> > _______________________________________________
> > Megaco mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/megaco
> >
> 
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 

___________________________________________________________ 
How much free photo storage do you get? Store your holiday 
snaps for FREE with Yahoo! Photos http://uk.photos.yahoo.com

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 2 Aug 2005 12:28:07 -0400

Right.  Multiple m= lines requires multiple session descriptions.  RG
would apply to these, as multiple descriptions in a single descriptor
(Local *or* Remote) would be potential alternatives.

Kevin 

-----Original Message-----
From: Kapil Nayar [mailto:[email-masked]] 
Sent: Tuesday, August 02, 2005 10:56 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; Maridi R. Makaraju (Raju); Neal Zhu;
[email-masked]

Hi Kevin

The new version doesnot allow multiple m= lines in a session
description. 
Just to confirm - if you are implying that RG value shall apply in case
multiple session descriptions (delimited by v= line and each containing
a single m=
line) are specified in LOCAL descriptor.

best regards,
-kapil

--- Kevin Boyle <[email-masked]> wrote:

> I disagree.  There are two payload formats specified in this SDP: 8
> (G.711a) and 97 (dynamically assigned to RFC2833 event detection).
> Therefore, there are two property values.  If you want both to be 
> the MG is obligated to reserve resources for both payload formats if 
> it can.  With RV set to OFF, the MG is free to pick one and discard 
> the other.  RG would only apply if there were multiple property 
> groups, i.e., multiple m= lines.
> 
> Kevin
> 
> [mailto:[email-masked]] On Behalf Of Maridi R. Makaraju 
> (Raju)
> "If the value of a Reserve property is True, the MG SHALL reserve 
> resources for all alternatives specified in the Local and/or Remote 
> descriptors for which it currently has resources available."
> 
> The "alternative" should be applied to each type of resource, i.e. 
> audio codecs, DTM etc.
> RFC2833 if available and return payload 97 in the response. If no
> RFC2833(DTMF) resources available then it should omit payload 97 in 
> the response.
> 
> Thanks
> Raju
> 
> 
> >
> >
>

___________________________________________________________
How much free photo storage do you get? Store your holiday snaps for
FREE with Yahoo! Photos http://uk.photos.yahoo.com