Subject: [Megaco] default parameter handing

From: "Kalleitner Franz" <[email-masked]>
Date: Thu, 11 Aug 2005 16:41:25 +0200

Dear
megaco-list members,

I have one question
concerning the default parameter handing.

Let’s assume that
within a descriptor a couple of parameters/properties are defined and some
of them have default values assigned but others have not.

I would be
interested in the correct behavior of the MG if a descriptor has been
received with a missing parameter which has no default value
assigned.

I could imagine the
following reactions:

1.) those values must
be pre-provisioned at the MG

2.) the MG should ignore
the descriptor

3.) the MG should respond
an error

4.) or can such a situation
never occur ?

Thanks a lot in
advance

Franz

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Stephen Mell" <[email-masked]>
Date: Thu, 11 Aug 2005 17:53:33 +0100

Its up to each particular package descriptions to describe the behaviour 
under these circumstances for each parameter/property (although many do 
not seem to).

If a mandatory parameter is missing then (3) would be appropriate

See the package writing guidlines in the Spec.,    in particular 12.1.2 
and 12.2    "Possible values:   ... "