Subject: [Megaco] some questions on rfc3264 and ts29.232

From: "Atto Mu" <[email-masked]>
Date: Thu, 4 Aug 2005 20:35:56 +0800

Hi, List

I have two questions, need your help,

1. RFC3264 gives out an Offer-Answer model with SDP. 
Is it MUST to SDP with MEGACO?

2. Refer to 3GPP TS29.232, MEGACO will run over M3UA for Mc interface,
Is there any standard defined MEGACO stack action when over M3UA,
H248.4?

thanks
atto

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Thu, 4 Aug 2005 14:51:40 +0200

Comments inline.
Albrecht

ALCATEL

                      "Atto Mu"                                                                                                       
                      <atto.mu@utstar.         To:      <[email-masked]>                                                             
                      com>                     cc:                                                                                    
                      Sent by:                 Subject: [Megaco] some questions on rfc3264 and ts29.232                               
                      megaco-bounces@i                                                                                                
                      etf.org                                                                                                         

                      04.08.2005 14:35                                                                                                

Hi, List

[AS] H.248 is using SDP according RFC 2327. The negotiation model defined
by RFC 3264 is NOT adapted to H.248, rather procedures given by $
7.1.8/H.248.1 are applicable.
The basic point is that there might be TWO SDP segments: SIP/SDP and
H.248/SDP.
When RFC 3264 is applied on the SIP/SDP session, when where needs to be a
mapping of negotiation procedures between the SIP UA/proxy & H.248 MGC.

The mapping of the two SDP segments is sometimes also called as "SDP
Broker".

[AS] Guess you are refering to the H.248/M3UA/SCTP option defined by 3GPP
29.202?
If yes, this has nothing to do with H.248.4 (= direct H.248/SCTP
transport).

thanks
atto

---

From: Christian Groves <[email-masked]>
Date: Thu, 04 Aug 2005 17:13:19 +0200

Hello Albrecht,

Your comment 2 is not entirely correct. H.248.4 Corrigenda 1 states:
"To provide interworking between MTP3B and SCTP, and to allow for flexible 
implementations of gateways and controllers in order to offer efficient use of 
SCTP associations, the M3UA layer may be added on top of SCTP."

Regards, Christian

---

From: [email-masked]
Date: Fri, 5 Aug 2005 11:07:08 +0200

Yes, that's correct, I forgot Corrigendum 1 for H.248.4.
Thanks for clarification,
Albrecht

                      Christian Groves                                                                                                   
                      <christian.groves@er         To:      Albrecht SCHWARZ/DE/ALCATEL@ALCATEL                                          
                      icsson.com>                  cc:      Atto Mu <[email-masked]>, [email-masked]                                
                      Sent by:                     Subject: Re: [Megaco] some questions on rfc3264 and ts29.232                          
                      megaco-bounces@ietf.                                                                                               
                      org                                                                                                                

                      04.08.2005 17:13                                                                                                   

Hello Albrecht,

Your comment 2 is not entirely correct. H.248.4 Corrigenda 1 states:
"To provide interworking between MTP3B and SCTP, and to allow for flexible
implementations of gateways and controllers in order to offer efficient use
of
SCTP associations, the M3UA layer may be added on top of SCTP."

Regards, Christian