Subject: [Megaco] FW: Signals played on a TDM termination in H.248

From: "Anant Kumar \(anant\)" <[email-masked]>
Date: Wed, 24 Aug 2005 17:16:26 -0700

Hi All,
 
There is a question internal to Cisco about what happens to a signal
being played on a TDM termination, in a non-NULL context, when the
termination is subtracted from the context. 
 
One school of thought believes that the signal should be stopped. There
is text in section 7.2.3 of H.248.1and rfc3525 

When a provisioned Termination is Subtracted from a Context, its
property values shall revert to: 

*            the default value, if specified for the property and not
overridden by provisioning;

*            otherwise, the provisioned value.

that is cited. 
 
The other school says that the signal should continue to play until it
times out or is explicitly stopped by the MGC (via a new Signals
Descriptor that does not contain this signal).
 
The second interpretation sounds right to me and would be consistent
with the xGCP world. In my opinion, the "property" referred to in the
cited text above does not refer to signals and events.
 
What would be the correct interpretation? 
 
Thanks.
-anant
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 25 Aug 2005 08:20:38 -0400

The signal halts.  This is reflected in the wording update in H.248.1
V3:
 
When a provisioned termination is Subtracted from a context, its
descriptor values shall revert to: 

*            the default value, if specified for the descriptor and not
overridden by provisioning;

Kevin
 
________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Anant Kumar (anant)
Sent: Wednesday, August 24, 2005 8:16 PM
To: [email-masked]
Subject: [Megaco] FW: Signals played on a TDM termination in H.248

	Hi All,
	 
	There is a question internal to Cisco about what happens to a
signal being played on a TDM termination, in a non-NULL context, when
the termination is subtracted from the context. 
	 
	One school of thought believes that the signal should be
stopped. There is text in section 7.2.3 of H.248.1and rfc3525 

	*            the default value, if specified for the property
and not overridden by provisioning;

	that is cited. 
	 
	The other school says that the signal should continue to play
until it times out or is explicitly stopped by the MGC (via a new
Signals Descriptor that does not contain this signal).
	 
	The second interpretation sounds right to me and would be
consistent with the xGCP world. In my opinion, the "property" referred
to in the cited text above does not refer to signals and events.

	Thanks.
	-anant

---

From: "Anant Kumar \(anant\)" <[email-masked]>
Date: Thu, 25 Aug 2005 21:23:00 -0700

Tom,

My intent was not to suggest that Megaco/H.248 is or should be xGCP! I
understand that it was a judgment call. I am trying to understand the
reasons why this decision was made. Does the Megaco community feel this
is a deficiency in the xGCP protocols? 

In any case, I set out to clarify what the expected behavior wrt signals
playing on a termination would be when the termination is Added,
Subtracted or Moved. I think that objective has definitely been met!

Thanks for your time.

Regards.
-anant 

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]] 
Sent: Thursday, August 25, 2005 6:58 PM
To: Anant Kumar (anant)
Cc: Kevin Boyle; [email-masked]
Subject: Re: [Megaco] Signals played on a TDM termination in H.248

Basically it was a judgement call, but there it is.  Megaco/H.248 is not
xGCP, even though it inherited a lot from it.

Anant Kumar (anant) wrote:
...
> 
> [ANANT] But you could play a signal on a termination without adding it

> to a context. So, not all terms in the NULL context are necessarily in

> the default state.
> 
> In the xGCP world, the MGC needs to explicitly clear signals and 
> events, if it so desires. They are not implicitly cleared upon DLCX.
> 
>