Subject: [Megaco] Digit map collection and new events

From: "Julio Martinez-Minguito (AL/EAB)" <[email-masked]>
Date: Thu, 18 Aug 2005 10:53:15 +0200

Hi: 

I have an hypotetic case, I don't know if there are call scenarios where this could happen:

1) The controller requests digit map detection for a termination.
2) The GW starts the digit map collection
3) before the digit map is completed, the controller wants to monitor for more events on the termination.
It sends a new events descriptor, including the old events and the new events

According to the H.248.1 section  7.1.14.6 when a new events descriptor is received, the GW shall start a new clear dial string. The digits collected so far are discarded.

is there any work around so a new event can be added to the termination without loosing the collected digits?

Regards, Julio

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Karthikeyan Sankaran" <[email-masked]>
Date: Thu, 18 Aug 2005 02:53:40 -0700

HI,
 
A work around could be to make use of buffering in completion event. For the first time while asking for digit collection the controller can ask for reporting of minimum digits [ex X]. After reporting of the first matched event sequence gateway goes into buffering state and buffers the remaining digits. Before the buffer control timer expiry a new completion event can be given so that these buffer digits can be applied on top of the new digit map. Note this can go on and on. This is a typical case of accepting international numbers from the gateway [if the gateway is not configured to accept one in the previous digit map], which can be a work around for you. 
 
Regards
Karthik

________________________________

From: [email-masked] on behalf of Julio Martinez-Minguito (AL/EAB)
Sent: Thu 8/18/2005 9:53 AM
To: [email-masked]
Subject: [Megaco] Digit map collection and new events

Hi:

Regards, Julio