Subject: RE: [Megaco] Query on Megaco - Disconnected Service change method

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 5 Aug 2005 10:59:07 -0400

1) This would depend upon the "stack".  However, the protocol indicates
that the former control association is reestablished, and it is then up
the the MGC to clean up any mess.
2) I don't understand this question. Either the MG has to restart cold
and tell the MGC about it with a ServiceChange, or it has to wait for
the MGC to clean everything up.
 
Kevin

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Irshad Ahmed
	Sent: Friday, August 05, 2005 8:26 AM
	To: [email-masked]
	Subject: [Megaco] Query on Megaco - Disconnected Service change
method

	Hi,
	 
	In our application, our MG sends a transaction and waits for
reply. Before the reply is reached to the MG, the MG got disconnected
and so the following message will be sent continuously (with increasing
transaction id ).
	 
	 Transaction=9{
	            Context=-{
	
ServiceChange=root{Services{Method=Disconnected, Reason="907
Transmission Failure"}}
	            }
	    } 

	Can anybody please clarify on the following doubts.
	1) How the stack handles Disconnected service change method?
	2) How do we make the MG to its normal state ?
	 
	Thanks in advance,
	 
	Regards,
	Irshad

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Irshad Ahmed" <[email-masked]>
Date: Tue, 9 Aug 2005 09:37:43 +0530

Hi kevin,

here i list the senario & what i want,

The problem is with the MGC, not with the MG. When the notify commands are sent from MG, they are not replied to. At this point, the MG assumes that the MGC is down and attempts to find a new one by sending service change commands. The MG sends a service change command to an MGC in its configured list. If this transaction times out, it will send a new transaction (with a new transaction ID) to the next MGC in the list. This continues until an MGC accepts the MG.
So here i don't know exactly how to reconnect the MGC with MG. Can you mail me , the megaco message (megaco text format) from MGC to MG for service change reply .

Thanks in advance,

Irshad

----- Original Message ----- 
  From: Kevin Boyle 
  To: Irshad Ahmed ; [email-masked] 
  Sent: Friday, August 05, 2005 8:29 PM
  Subject: RE: [Megaco] Query on Megaco - Disconnected Service change method

  1) This would depend upon the "stack".  However, the protocol indicates that the former control association is reestablished, and it is then up the the MGC to clean up any mess.
  2) I don't understand this question. Either the MG has to restart cold and tell the MGC about it with a ServiceChange, or it has to wait for the MGC to clean everything up.

  Kevin

----------------------------------------------------------------------------
    From: [email-masked] [mailto:[email-masked]] On Behalf Of Irshad Ahmed
    Sent: Friday, August 05, 2005 8:26 AM
    To: [email-masked]
    Subject: [Megaco] Query on Megaco - Disconnected Service change method

    Hi,

    In our application, our MG sends a transaction and waits for reply. Before the reply is reached to the MG, the MG got disconnected and so the following message will be sent continuously (with increasing transaction id ).

     Transaction=9{
                Context=-{
                        ServiceChange=root{Services{Method=Disconnected, Reason="907 Transmission Failure"}}
                }
        } 

    Thanks in advance,

    Regards,
    Irshad