Subject: [Megaco] How to decode H.248 messages

From: "Omer Faruk TUNA" <[email-masked]>
Date: Wed, 3 Aug 2005 09:46:18 +0300

> Hi all,
> 
> I am working on H - 248 Megaco messages for now. And I wonder if there
> is any tool which decodes H - 248 Megaco messages (text), that is
> which makes them understandable for all people with sufficient
> technical background. 
> 
> Do you have any knowledge on this?
> 
> Regards
> 
Omer

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Wed, 3 Aug 2005 10:09:28 +0300

There are some tools that can help you like Ethereal and Nethawk ...

Bülent Yılmaz

TO/Coordination Office

New Technologies&Project Development

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of Omer Faruk TUNA
Sent: Wednesday, August 03, 2005 9:46 AM
To: [email-masked]
Subject: [Megaco] How to decode H.248 messages

Hi all, 

I am working on H - 248 Megaco messages for now. And I wonder if there is any tool which decodes H - 248 Megaco messages (text), that is which makes them understandable for all people with sufficient technical background. 

Regards 

Omer 

************************************************************************
Bu elektronik posta ve onunla iletilen bütün dosyalar sadece göndericisi tarafyndan almasy amaçlanan yetkili gerçek ya da tüzel ki?inin kullanymy içindir.  E?er söz konusu yetkili alycy de?ilseniz bu elektronik postanyn içeri?ini açyklamanyz, kopyalamanyz, yönlendirmeniz ve kullanmanyz kesinlikle yasaktyr ve bu elektronik postayy derhal silmeniz gerekmektedir.
TURKCELL bu mesajyn içerdi?i bilgilerin do?rulu?u veya eksiksiz oldu?u konusunda herhangi bir garanti vermemektedir.  Bu nedenle bu bilgilerin ne ?ekilde olursa olsun içeri?inden, iletilmesinden, alynmasyndan ve saklanmasyndan sorumlu de?ildir. Bu mesajdaki görü?ler yalnyzca gönderen ki?iye aittir ve TURKCELLin görü?lerini yansytmayabilir
Bu e-posta bilinen bütün bilgisayar virüslerine kar?y taranmy?tyr.
************************************************************************
This e-mail and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you are not the intended recipient you are hereby notified that any dissemination, forwarding, copying or use of any of the information is strictly prohibited, and the e-mail should immediately be deleted.
TURKCELL makes no warranty as to the accuracy or completeness of any information contained in this message and hereby excludes any liability of any kind for the information contained therein or for the information transmission, reception, storage or use of such in any way whatsoever.  The opinions expressed in this message belong to sender alone and may not necessarily reflect the opinions of TURKCELL.
This e-mail has been scanned for all known computer viruses.
************************************************************************

---

From: "Omer Faruk TUNA" <[email-masked]>
Date: Wed, 3 Aug 2005 10:30:32 +0300

Hi,
 
I am taking the logs by using Ethereal or simply by connecting to Gateway Controller. For example I have taken the log of two way call. Its something like:
 
00:03:56:41.10[T:4]Received msg <-- GW IP[124.53.34.25] GW PORT[1984]

!/1 [124.53.34.25]:1984 T=20551{C=-{N=ROOT{OE=1519{it/ito}}}}

00:03:56:41.10[T:4]Sending msg --> GW IP[124.53.34.25] GW PORT[1984]

!/1 [124.53.34.25]:1984 P=20551{C=-{N=Root}}

...

What I meant by saying `how to decode H.248 messages` is that how to make those text messages more understandable (user friendly) for all users. 

I have asked that question to you because I know that there is such a tool for c7tu logs. It is a perl script which takes c7tu logs and some other parameters as input and returns a user friendly log as output.

Thanks...

Omer

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: 03 Ağustos 2005 Çarşamba 10:09
To: Omer Faruk TUNA; [email-masked]
Subject: RE: [Megaco] How to decode H.248 messages

 

Bülent Yılmaz

TO/Coordination Office

  _____  

 

Hi all, 

Regards 

Omer 

  _____  

  _____