Subject: RE: [Megaco] Signals played on a TDM termination in H.248

From: "Anant Kumar \(anant\)" <[email-masked]>
Date: Thu, 25 Aug 2005 15:45:43 -0700

Tom,

Thanks for your response.

Some clarification for my original question inline. 

Regards.
-anant

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]] 
Sent: Thursday, August 25, 2005 3:39 PM
To: Anant Kumar (anant)
Cc: Kevin Boyle; [email-masked]
Subject: Re: [Megaco] Signals played on a TDM termination in H.248

Answers below.

Anant Kumar (anant) wrote:
> Hello Kevin,
>  
> There are two related scenarios.
>  
> 1. You are playing a signal on a termination in the NULL context. Now 
> you ADD this termination to a non-NULL context. What happens with the 
> signal?
>  
[PTT] The signal is unaffected.

> 2. You are playing a signal on a termination in a non-NULL context. 
> This termination is now MOVEd to another non-NULL context.

[PTT] The signal is unaffected.  I distinctly remeber our putting
something to that effect in ther original text on MOVE.
>  
> The original case I described moves a termination from a non-NULL to 
> NULL context.

[PTT]  You cannot use MOVE to put a termination into the NULL context,
only SUBTRACT.  The reason MOVE exists as well as ADD and SUBTRACT is
because there was no way to use the latter to implement the semantics
described above: leaving the state of the termination otherwise
unchanged.  There were definitely some hard questions about redundant
commands when we were first defining the protocol, but the position is
quite clear in the description of MOVE.
[ANANT] I am not suggesting that this is accomplished using a MOVE. This
would be a SUBTRACT operation as you correctly point out. My contention
is that this is in effect a move from a non-NULL to a NULL context.
hence, the question below. 

It seems that when a termination moves from a non-NULL to NULL
termination (SUBTRACT) the signal is halted. However, when it moves from
a NULL - non-NULL context (ADD) or from a non-NULL to a non-NULL context
(MOVE), the signal is unaffected. Is that the intent? If so, I would
like to understand better the rationale behind this.

> Arguably, each of the three cases is moving a termination from one 
> context to another, NULL or non-NULL. Would the signal halt in each of

> the three cases. Where is the reference for that?
>  
> Regards.
> -anant
> 
> ________________________________
> 
> From: Kevin Boyle [mailto:[email-masked]]
> Sent: Thursday, August 25, 2005 5:21 AM
> To: Anant Kumar (anant); [email-masked]
> Subject: RE: [Megaco] FW: Signals played on a TDM termination in H.248
> 
> 
> The signal halts.  This is reflected in the wording update in H.248.1
> V3:
>  
> When a provisioned termination is Subtracted from a context, its 
> descriptor values shall revert to:
> 
> *            the default value, if specified for the descriptor and
not
> overridden by provisioning;
> 
> *            otherwise, the provisioned value.
> 
>  
> Kevin
>  
> ________________________________
> 
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Anant Kumar (anant)
> Sent: Wednesday, August 24, 2005 8:16 PM
> To: [email-masked]
> Subject: [Megaco] FW: Signals played on a TDM termination in H.248
> 
> 
> 
> 	Hi All,
> 	 
> 	There is a question internal to Cisco about what happens to a
signal 
> being played on a TDM termination, in a non-NULL context, when the 
> termination is subtracted from the context.
> 	 
> 	One school of thought believes that the signal should be
stopped. 
> There is text in section 7.2.3 of H.248.1and rfc3525
> 	
> 
> 	When a provisioned Termination is Subtracted from a Context, its

> property values shall revert to:
> 
> 	*            the default value, if specified for the property
> and not overridden by provisioning;
> 
> 	*            otherwise, the provisioned value.
> 
> 	 
> 	that is cited. 
> 	 
> 	The other school says that the signal should continue to play
until 
> it times out or is explicitly stopped by the MGC (via a new Signals 
> Descriptor that does not contain this signal).
> 	 
> 	The second interpretation sounds right to me and would be
consistent 
> with the xGCP world. In my opinion, the "property" referred to in the 
> cited text above does not refer to signals and events.
> 	 
> 	What would be the correct interpretation? 
> 	 
> 	Thanks.
> 	-anant
> 
> 
> 
> 
> ----------------------------------------------------------------------
> --
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 25 Aug 2005 19:15:32 -0400

> like to understand better the rationale behind this.
[PTT] The reason we made that decision was to provide predictable 
behaviour for terminations in NULL context.  We thought that if the MGC 
did a SUBTRACT and existing state persisted, this would be a mental 
hazard for designers.  They might forget to reset that state to 
something appropriate to the NULL context in their MGC code.

I should say that this was not a universally-welcomed decision, though I 
recall only Brian Rosen protesting it.

>>the three cases. Where is the reference for that?
...