Subject: [Megaco] about reserve group and reserve value

From: "Neal Zhu" <[email-masked]>
Date: Wed, 31 Aug 2005 13:47:51 +0000

in rfc 3525,there is a sample of call flow:

 MEGACO/1 [123.123.123.4]:55555 Transaction = 10003 {
       Context = $ {
          Add = A4444,
          Add = $ {
              Media {
                Stream = 1 {
                     LocalControl {
                         Mode = ReceiveOnly,

                         nt/jit=40 ; in ms
                     },
                     Local {
     v=0
     c=IN IP4 $ 
     m=audio $ RTP/AVP 4
     a=ptime:30 
     v=0 
     c=IN IP4 $ 
     m=audio $ RTP/AVP 0
                    }
                }
             }
          }
       } 
  }

 MG1 -> MGC:

   MEGACO/1 [124.124.124.222]:55555 Reply = 10003 {
      Context = 2000 {
         Add = A4444,
         Add=A4445{
            Media {
                Stream = 1 {
                    Local { v=0 o=- 2890844526 2890842807 IN IP4
   124.124.124.222 s=- t= 0 0 c=IN IP4 124.124.124.222 m=audio 2222
   RTP/AVP 4 a=ptime:30 a=recvonly
                    } ; RTP profile for G.723.1 is 4
                }

why here the reserve group is set as OFF for caller? So only G.723 is 
report by MG1. if MG2 can only support G.711.call will fail.but in fact 
both caller mg and callee mg support G.711.

I think that it is better to set reservegroup  as ON for caller and set 
reservegroup as OFF for callee .it is correct??

thanks,
Neal

_________________________________________________________________
与联机的朋友进行交流，请使用 MSN Messenger:  http://messenger.msn.com/cn  

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 31 Aug 2005 10:16:57 -0400

You're really talking about policy here rather than a protocol issue.
In real life, your policy is probably realistic.  On the other hand, the
example shows a case where the MG is given responsibility for managing
its resources.  The response is what might happen if the MG is short on
bandwidth but has enough memory and processing power.

Neal Zhu wrote:
>     c=IN IP4 $     m=audio $ RTP/AVP 4
>     a=ptime:30     v=0     c=IN IP4 $     m=audio $ RTP/AVP 0
>                    }
>                }
>             }
>          }
>       }  }
> 
> MG1 -> MGC:
>