Subject: [Megaco] Regarding Topology descriptor

From: "Nagar Prerna" <[email-masked]>
Date: Fri, 17 Nov 2006 16:24:50 -0800

Hi ,
Query : 
 
            Do we expect an explicit topology descriptor in response message
in following scenarios ( 1& 2 ) 
            Or the successful processing of topology descriptor is
acknowledged with the Add/Modify 's response as i can see in the response i
am getting.
            and in case the processing fails , we reply back with an error ?
            
1. Topology Descriptor with modify (P.S. RTP terminations are valid ones)

T 3 {
Context = 9 {
Topology {
tgwrtp/8073,
tgwrtp/8074,
oneway
},
Modify = tgwrtp/8073 {
Media {
LocalControl {
Mode = SendReceive
},
Remote {
v=0
o=- 0 0 IN IP4 -
s=-
c=IN IP4 10.103.6.1
t=0 0
m=audio 16396 RTP/AVP 0 101 100
a=ptime:10
a=rtpmap:101 telephone-event/8000/1
a=fmtp:101 0-15
a=rtpmap:100 X-NSE/8000/1
a=fmtp:100 192-194
}
}
}
}}} megamsg
 
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
Received from <cisco.com>:2944 at Thu Nov  2 16:00:35 PST 2006:
MegaConn0 P 10 { C = 9 {mf=TGWRTP/8073 }} megatx 
 
/** Topology descriptor absent in response ,when it was found to be
successfully processed at gateway **/

2. Topology descriptor with Add

T 3 {
Context = 1 {
Topology {
tgwrtp/8065,
tgwrtp/8066,
isolate
},
Add = $ {
Media {
LocalControl {
Mode = SendReceive
},
Local {
v=0
c=IN $ $
m=audio $ RTP/AVP 8
a=ptime:10
}
}
}
}} megatx}

<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
Received from [10.105.11.2]:2944:
!/2 [10.105.11.2]:2944 P = 3{ C = 1 {a=tgwrtp/8067  { m { l { ^M
v=0^M
o=- 0 0 IN IP4 -^M
s=-^M
c=IN IP4 10.105.12.2^M
t=0 0^M
m=audio 16388 RTP/AVP 8 101 100^M
a=ptime:10^M
a=rtpmap:101 telephone-event/8000/1^M
a=fmtp:101 0-15^M
a=rtpmap:100 X-NSE/8000/1^M
a=fmtp:100 192-194^M
 }  }  } }} at Fri Nov 17 13:25:15 PST 2006
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
/** Topology descriptor absent in response ,when it was found to be
successfully processed at gateway **/ 

Can anybody please describe what MGC expects in response when there is a
topology descriptor in request? 
 
Regards
Prerna

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Ashish Singh <[email-masked]>
Date: Sat, 18 Nov 2006 09:44:18 -0800

Descriptors are returned if they contain under-specified ($) or 
over-specified values. Since in this case, Topology descriptor is 
fully-specified, so it is NOT required to return it in response.

Tx
Ashish

Nagar Prerna wrote:
> Hi ,
> Query :
>  
>             Do we expect an explicit topology descriptor in response 
> message in following scenarios ( 1& 2 )
> acknowledged with the Add/Modify 's response as i can see in the 
> response i am getting.
>     *Topology {
>     /Modify/ *= tgwrtp/8073 {
>     Media {
>     LocalControl {
>     Mode = SendReceive
>     },
>     Remote {
>     v=0
>     o=- 0 0 IN IP4 -
>     s=-
>     c=IN IP4 10.103.6.1
>     t=0 0
>     /** Topology descriptor absent in response ,when it was found to
>     be successfully processed at gateway **/
>      
>
>     *Topology {
>     /Add /*= $ {
>     /** Topology descriptor absent in response ,when it was found to
>     be successfully processed at gateway **/ 
>
> *Can anybody please describe what MGC expects in response when there 
> is a topology descriptor in request?*
>  
> Regards
> Prerna
>
>      
>
>  
> ------------------------------------------------------------------------
>