Subject: [Megaco] A question about rtpmap

From: "Horace Zhang" <[email-masked]>
Date: Sun, 11 Mar 2007 22:11:12 -0800

Hi all,

According to RFC2327, a=rtpmap is used to specify dynamic payload type, not 
static dynamic payload type, is my understanding right?

But some equipments are sending SDP with a=rtpmap specifying static dynamic, 
for example:
v=0
o=- 285442017 285442017 IN IP4 10.0.21.1
s=-
c=IN IP4 10.0.21.1
t=0 0
m=audio 16480 RTP/AVP 18 0 2 4 8 96 97 98 100 101
a=rtpmap:18 G729a/8000
a=rtpmap:0 PCMU/8000
a=rtpmap:2 G726-32/8000
a=rtpmap:4 G723/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:96 G726-40/8000
a=rtpmap:97 G726-24/8000
a=rtpmap:98 G726-16/8000
a=rtpmap:100 NSE/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15
a=ptime:30
a=sendrecv

The equipment is trying to specify for each codec. On receiving this kind of 
SDP, should ignore the a=rtpmap lines for static payload type, or just 
reject the message?

_________________________________________________________________
Get a FREE Web site, company branded e-mail and more from Microsoft Office 
Live! http://clk.atdmt.com/MRT/go/mcrssaub0050001411mrt/direct/01/

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Raphael Tryster" <[email-masked]>
Date: Mon, 12 Mar 2007 08:57:56 +0200

You should not reject the message because RFC 3551 allows this
behaviour.

Raphael Tryster

P.S. I changed the SIP list because the list you used is for new SIP
development.

-----Original Message-----
From: Horace Zhang [mailto:[email-masked]] 
Sent: Monday, March 12, 2007 8:11 AM
To: [email-masked]; [email-masked]
Subject: [Megaco] A question about rtpmap

Hi all,

According to RFC2327, a=rtpmap is used to specify dynamic payload type,
not 
static dynamic payload type, is my understanding right?

But some equipments are sending SDP with a=rtpmap specifying static
dynamic, 
for example:
v=0
o=- 285442017 285442017 IN IP4 10.0.21.1
s=-
c=IN IP4 10.0.21.1
t=0 0
m=audio 16480 RTP/AVP 18 0 2 4 8 96 97 98 100 101
a=rtpmap:18 G729a/8000
a=rtpmap:0 PCMU/8000
a=rtpmap:2 G726-32/8000
a=rtpmap:4 G723/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:96 G726-40/8000
a=rtpmap:97 G726-24/8000
a=rtpmap:98 G726-16/8000
a=rtpmap:100 NSE/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15
a=ptime:30
a=sendrecv

The equipment is trying to specify for each codec. On receiving this
kind of 
SDP, should ignore the a=rtpmap lines for static payload type, or just 
reject the message?

_________________________________________________________________
Get a FREE Web site, company branded e-mail and more from Microsoft
Office 
Live! http://clk.atdmt.com/MRT/go/mcrssaub0050001411mrt/direct/01/

---

From: "Avasarala Ranjit-A20990" <[email-masked]>
Date: Mon, 12 Mar 2007 15:26:03 +0800

Hi

All media descriptions in a SDP message SHOULD contain "a=rtpmap"
mappings for the RTP payload types. The RTP payload types can be both
static and dynamic. So the message u enclosed is valid and should be
accepted.

Regards
Ranjit

-----Original Message-----
From: Horace Zhang [mailto:[email-masked]] 
Sent: Monday, March 12, 2007 11:41 AM
To: [email-masked]; [email-masked]
Subject: [Sip] A question about rtpmap

Hi all,

According to RFC2327, a=rtpmap is used to specify dynamic payload type,
not static dynamic payload type, is my understanding right?

dynamic, for example:

The equipment is trying to specify for each codec. On receiving this
kind of SDP, should ignore the a=rtpmap lines for static payload type,
or just reject the message?

_________________________________________________________________
Get a FREE Web site, company branded e-mail and more from Microsoft
Office Live!
http://clk.atdmt.com/MRT/go/mcrssaub0050001411mrt/direct/01/

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip