Subject: [Megaco] Future of RFC 3525

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 19 Mar 2007 10:50:52 -0400

RFC 3525 has now become a stumbling block to beginners, since it is way behind 
the state of H.248 standardization. We should do something about it. I see three 
possibilities:

  - change RFC 3525 status to Historic without doing anything else. This would 
warn people to look at the ITU-T documentation instead.

  - replace 3525 with a more up-to-date version. I'll comment that I personally 
am not willing to bring H.248.1v3 to the IETF because it has been diluted by 
optimizations. There is a standard axiom in the IETF that if there is more than 
way to do something you have an interoperability problem.

  - create an IETF-defined profile of the protocol, starting with H.248.1v3 and 
getting consensus on aspects that should be pruned out to leave a common core 
protocol.

Could I have an indication of interest in one option or another? The default 
action if no response will be to change RFC 3525 from Proposed Standard to Historic.

Tom Taylor

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tamar Nemet" <[email-masked]>
Date: Mon, 19 Mar 2007 18:27:02 +0200

The last possibility looks the best from my point of view

________________________________

מאת: Tom-PT Taylor [mailto:[email-masked]]
נשלח: ב 19/03/2007 16:50
אל: [email-masked]
נושא: [Megaco] Future of RFC 3525

Tom Taylor

---

From: [email-masked]
Date: Wed, 21 Mar 2007 14:22:58 +0100

My preference is the "historic" option.
-Albrecht

                      "Tom-PT Taylor"                                                                                                
                      <[email-masked]         To:      [email-masked]                                                              
                      om>                      cc:                                                                                   
                                               Subject: [Megaco] Future of RFC 3525                                                  
                      19.03.2007 15:50                                                                                               

RFC 3525 has now become a stumbling block to beginners, since it is way
behind
the state of H.248 standardization. We should do something about it. I see
three
possibilities:

  - change RFC 3525 status to Historic without doing anything else. This
would
warn people to look at the ITU-T documentation instead.

  - replace 3525 with a more up-to-date version. I'll comment that I
personally
am not willing to bring H.248.1v3 to the IETF because it has been diluted
by
optimizations. There is a standard axiom in the IETF that if there is more
than
way to do something you have an interoperability problem.

  - create an IETF-defined profile of the protocol, starting with H.248.1v3
and
getting consensus on aspects that should be pruned out to leave a common
core
protocol.

Could I have an indication of interest in one option or another? The
default
action if no response will be to change RFC 3525 from Proposed Standard to
Historic.

Tom Taylor

---

From: Christian Groves <[email-masked]>
Date: Thu, 22 Mar 2007 12:47:24 +1100

Hello Tom,

My preference IF we have to change something is to change the status to 
Historic.

I can understand not wanting to replace RFC3525 personally due to the 
amount of effort this would take.
However I'm surprised by your comment with regards to H.248.1v3 
"dilution". Yes there have been some optimisations, many of these have 
been based on implementation experience, something which I believe the 
IETF encourages. There have also been functionality added e.g. 
statistics handling that was not possible in pre-v3 versions. If we go 
down the profile approach many of the profiles today don't even support 
all the functionality from v1 and v2, so what would that mean for an 
IETF profile?

In reply to another email on this thread:
With regards to the free availability of ITU documents, this is for a 
trial period only. The decision will be revisited later this year. I 
would encourage people to get in contact with their country's 
communications administration dealing with ITU and ask this be continued 
on a permanent basis.

Regards, Christian

Tom-PT Taylor wrote:
> RFC 3525 has now become a stumbling block to beginners, since it is 
> way behind the state of H.248 standardization. We should do something 
> about it. I see three possibilities:
>
>  - change RFC 3525 status to Historic without doing anything else. 
> This would warn people to look at the ITU-T documentation instead.
>
> personally am not willing to bring H.248.1v3 to the IETF because it 
> has been diluted by optimizations. There is a standard axiom in the 
> IETF that if there is more than way to do something you have an 
> interoperability problem.
>
>  - create an IETF-defined profile of the protocol, starting with 
> H.248.1v3 and getting consensus on aspects that should be pruned out 
> to leave a common core protocol.
>
> default action if no response will be to change RFC 3525 from Proposed 
> Standard to Historic.
>
> Tom Taylor
>