Subject: [Megaco] Inconsistency between ABNF and ASN in version3

From: "Ganesh Kumar" <[email-masked]>
Date: Thu, 22 Mar 2007 14:24:41 +0530

Hi,

            I observed inconsistency between ABNF and ASN in case of
topologyDirection and auditReply.

TopologyDirection:

            In case of ABNF, it is choice of 5 possible directions, so
only one value is possible at one time.

            In case of ASN, it is two separate fields. Here two values
are allowed at one time.

ABNF:

topologyDirection = BothwayToken / IsolateToken / OnewayToken /

OnewayExternalToken / OnewayBothToken

ASN:

TopologyRequest ::= SEQUENCE

{

terminationFrom TerminationID,

terminationTo TerminationID,

topologyDirection ENUMERATED

{

bothway(0),

isolate(1),

oneway(2)

},

...,

streamID StreamID OPTIONAL,

topologyDirectionExtension ENUMERATED OPTIONAL

{

onewayexternal(0),

onewayboth(1),

...

}

-- if present, topologyDirectionExtension takes precedence over

-- topologyDirection

}

AuditReply:

            In case of ABNF, auditOther is termIDList. Here one or more
than one termination id is allowed.

            In case of ASN, auditResult (terminationID) and
auditResultTermList (terminationIDList) are separated, but second field
terminationAuditResult in both are same.

ABNF:

auditReply = (AuditValueToken / AuditCapToken)

(contextTerminationAudit / auditOther)

auditOther = EQUAL termIDList [LBRKT terminationAudit RBRKT]

ASN:

AuditReply ::= CHOICE

{

contextAuditResult TerminationIDList,

error ErrorDescriptor,

auditResult AuditResult,

...,

auditResultTermList TermListAuditResult

}

AuditResult ::= SEQUENCE

{

terminationID TerminationID,

terminationAuditResult TerminationAudit

}

TermListAuditResult ::= SEQUENCE

{

terminationIDList TerminationIDList,

terminationAuditResult TerminationAudit,

...

}

TerminationAudit ::= SEQUENCE OF AuditReturnParameter

Please clarify my queries about this inconsistency.

Thanks and Regards,

Ganesh

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Divij Agarwal <[email-masked]>
Date: Thu, 22 Mar 2007 16:37:22 +0530

Hi,
Please find the responses below:

Query 1: Inconsistency between ABNF and ASN in case of topologyDirection

        ?,
        ? 

The RFC grammar explicitly mentions that if topologyDirectionExtension is 
present than it should take precedence over topologyDirection. 
This ensures that at any given time only one of the two, topologyDirection 
or topologyDirectionExtension, can be present. 

Query 2: Inconsistency between ABNF and ASN in case of Auditreply
 
AuditReply ::= CHOICE
{
        ?,

AuditResult ::= SEQUENCE
{

?
}
 
In case of ASN, the Audit Reply is a CHOICE. Hence at any given instance 
either AuditResult  or TermListAuditResult  would be present.
In case of AuditResult a single term ID can be specifed while in case of 
TermListAuditResult a term id list can be specified.
In both the cases TerminationAudit would be present.

Earlier in the mailing list the document containing the differences 
between ASN and ABNF found in H.248.1 V3 (Sept 2005) was published dated 
10th July 2006 "ASN-ABNF differences H.248.1 V3".
Please find attached the same for reference.

With Regards,
Divij Agarwal
Software Engineer
Aricent, Inc

"Ganesh Kumar" <[email-masked]> 
03/22/2007 02:24 PM

To
<[email-masked]>
cc

Subject
[Megaco] Inconsistency between ABNF and ASN in version3

Hi,

TopologyDirection:
 
            In case of ABNF, it is choice of 5 possible directions, so 
only one value is possible at one time.
            In case of ASN, it is two separate fields. Here two values are 
allowed at one time.

ABNF:

ASN:
 
?,
?
 
AuditReply:

ABNF:
 
ASN:
 
AuditReply ::= CHOICE
{
?,
?

Thanks and Regards,
Ganesh_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

***********************  Aricent-Restricted   ***********************

***********************  Aricent-Unclassified   ***********************
"DISCLAIMER: This message is proprietary to Aricent  and is intended solely for the use of 
the individual to whom it is addressed. It may contain privileged or confidential information and should not be 
circulated or used for any purpose other than for what it is intended. If you have received this message in error, 
please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for 
loss or damage arising from the use of the information transmitted by this email including damage from virus."
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 22 Mar 2007 17:08:57 -0400

In response to point one, I believe you mean the ASN.1 grammar and not
the "RFC grammar".  I don't even know what an RFC grammar is...
 
Further, it does not ensure that only one of the two can be present.  In
fact, the topologyDirection is required. It merely ensures that if both
are present, that the extension takes precedence.  It was done this way
due to the way the ASN.1 was originally written (without the ellipsis).
 
Kevin

________________________________

From: Divij Agarwal [mailto:[email-masked]] 
Sent: Thursday, March 22, 2007 7:07 AM
To: [email-masked]
Cc: Divij Agarwal; [email-masked]
Subject: Re: [Megaco] Inconsistency between ABNF and ASN in version3

Hi, 

The RFC grammar explicitly mentions that if topologyDirectionExtension
is present than it should take precedence over topologyDirection. 
This ensures that at any given time only one of the two,
topologyDirection or topologyDirectionExtension, can be present. 

AuditReply ::= CHOICE 
{ 

AuditResult ::= SEQUENCE 
{ 

With Regards,
Divij Agarwal
Software Engineer
Aricent, Inc 

03/22/2007 02:24 PM 

To
<[email-masked]> 
cc
Subject

Hi, 

TopologyDirection: 

ABNF: 

ASN: 

AuditReply: 

ABNF: 
  
ASN: 
  
AuditReply ::= CHOICE 
{ 

Thanks and Regards, 

***********************  Aricent-Unclassified   *********************** 
"DISCLAIMER: This message is proprietary to Aricent  and is intended
solely for the use of 
the individual to whom it is addressed. It may contain privileged or
confidential information and should not be 
circulated or used for any purpose other than for what it is intended.
If you have received this message in error, 
please notify the originator immediately. If you are not the intended
recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of
this message. Aricent accepts no responsibility for 
loss or damage arising from the use of the information transmitted by
this email including damage from virus."