Subject: RE: [Megaco] Problem using FLASH (fl) event

From: "Seraya Miletzki" <[email-masked]>
Date: Sun, 25 Mar 2007 09:35:31 +0200

Hi
This is not H.248 issue but it is the MGW issue. Gdenerally there is a
definition of the On hook time - the time the MGW will wait before it
sends the Notify command. The Flash recognition is typically a shorter
period of On hook.
The MGW has to be aware of the Pulse dialing, otherwise it will report
al/fl once when 1 is dialed and it will report sveral al/fl signal if
higher digit is dialed.
 
BR
 
Seraya

________________________________

From: Mihai Dobre [mailto:[email-masked]] 
Sent: Monday, February 26, 2007 3:32 PM
To: [email-masked]
Subject: Re: [Megaco] Problem using FLASH (fl) event

Dear All,

First of all thanks for your quick answers at my problem.

Now the MGC inform and arm MGW with FLASH event as you can see in the
below message: 

MEGACO/1 [10.10.0.10]:2944
T=372884576{C=-{MF=al/1/2/27{E=370114304{dd/ce{DigitMap=dmap1},al/on{str
ict=exact},al/of{strict=exact},al/fl},SG{cg/dt},
DM=dmap1{([2-8]xxxxx|13xxxxxxxxx|0xxxxxxxx|9xxxx|1[0124-9]x|E|F|x.F|[0-9
].L)}}}

But another problem apear when a phone device with mechanical dial
rotary which normally use PULSE is connected at MGW. So, when a phone
like this (which use PULSE) try to dial a phone number that contain the
digit "1", MGW sends a NOTIFY command with observed event FLASH: 

MEGACO/1 [10.10.0.58]:2944
Transaction=20397{Context=-{Notify=al/1/2/27{ObservedEvents=370114304{20
070223T14360940:al/fl}}}}

I know that FLASH can be substitute with a short press on switch
on-hook/off-hook and also the digit "1" when PULSE is use it's similar
with a short on-hook/off-hook. In this way a subscriber can never dial a
number that contain the digit "1" from a PULSE phone.

My question is if is normal that MGW to observe the event FLASH when
waits for dialed digits or if is another way to avoid this odd
situation.

Best regards,

Mihai DOBRE

On 2/22/07, Kevin Boyle <[email-masked]> wrote: 

	Note that the MGC may be intentionally trying to prevent the
user from
	flashing.  This is also a possibility.  It is up to the call
processing
	code in the MGC to decide whether or not to arm and accept
events based
	upon the functionality it contains and wishes to provide to the
MG.
	
	Kevin
	
	-----Original Message-----
	From: Taylor, Tom-PT (CAR:AR00)
	Sent: Thursday, February 22, 2007 2:57 PM
	To: Mihai Dobre
	Cc: [email-masked]
	Subject: Re: [Megaco] Problem using FLASH (fl) event
	
	It is not an error for the MGC to fail to arm all possible
events. Some
	events are not relevant in a particular situation. Or the MGC 
	implementation does not handle some events. That may or may not
mean
	loss of functionality.
	
	As one example, the MGC is generally not going to be interested
in the
	g/sc (signal completion) event -- only in specific
circumstances. 
	
	If al/fl is not enabled, I assume the MGC is seeing al/on
followed very
	quickly by al/off, unless it happens that the latter is not
enabled.

	Mihai Dobre wrote:
	> Hello,
	>
	> Thank you for your quick answer. 
	>
	> Ok, the way that MGC deal with the FLASH event is incorrect
because
	does not armed the MGW to observe this specific event or all
events; but
	why MGW does not report error?
	>
	> Best regards, 
	> Mihai DOBRE
	>
	>
	> On 2/22/07, Tom-PT Taylor <[email-masked]> wrote:
	>
	>       The MGC has to request the events it wants reported. The
others 
	will not
	>       be reported. One thing the MGC can do, though, is
request al/*,
	that is,
	>       all events in the al package.
	>
	>       Mihai Dobre wrote:
	>       > Hello Everybody, 
	>       >
	>       > My name is Mihai Dobre and I work as telecom engineer.
During
	last months the company where I work implements a VoIP system
using one
	MGC and one large MGW (672 subscribers). I posses basic
knowledge of 
	MEGACO v1 protocol which help me to implement this VoIP system
but now I
	has a problem that is over my knowledge and I kindly request
your
	support.
	>       >
	>       > Problem description:
	>       > When a subscriber want to use one of the services:
Call 
	Waiting, Triparty or Conferece which use the FLASH key the MGW
sends to
	MGC the event al/on instead of al/fl. I've discuss with the
provider of
	MGW and after I send traces to them they claim that is the fault
because 
	MGC does not request on MGW this specific event - al/fl.
	>       > My question if is mandatory that MGC to send all the
supported
	events (example: {al/on, al/of, al/fl, al/ri.....and so on} ) to
MGW in
	order to provide full functionality of MGW.
	>       > My opinion is that the MGW should send in NOTIFY
command the
	new observed event and if is supported by MGC then proceed with
the
	second dial tone.
	>       > Thanks in advance.
	>       > Best regards
	>       > Mihai DOBRE
	
	_______________________________________________ 
	Megaco mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Seraya Miletzki" <[email-masked]>
Date: Sun, 25 Mar 2007 09:35:31 +0200

Hi
 
BR
 
Seraya

Dear All,

Best regards,

Mihai DOBRE

	
	Kevin
	
	-----Original Message-----
	From: Taylor, Tom-PT (CAR:AR00)
	Sent: Thursday, February 22, 2007 2:57 PM
	To: Mihai Dobre
	Cc: [email-masked]
	Subject: Re: [Megaco] Problem using FLASH (fl) event

	

because
others 
	will not
request al/*,
	that is,
During
Call 
supported
command the