Subject: [Megaco] Reg SO,RO RTP

From: "karthik prabhu Balakrishnan" <[email-masked]>
Date: Wed, 6 Jun 2007 17:01:23 +0200

Hello All,
I have a basic doubt to get clarrifed.
endpoint line/1 calls line/2 in a different gateway.
Shown below are the ADD requests from MGC.
T=41 showing ADD on originating Gateway.
T=42 showing ADD on terminating Gateway.

T=41{C=${A=line/1{M{ O{MO=SR}},SG{},E=63{al/on{strict=failWrong}}},A=${M{L{
v=0
o=bell 53655 53655 IN IP4 128.3.4.6
c=IN IP4 $
m=audio $ RTP/AVP 8
},O{MO=RC,RV=ON}}}}}

T=42{C=${A=line/2{M{O{MO=SR}},SG{al/ri},E=64{al/of{strict=failWrong}}},A=${M{L{
v=0
o=bell 53655 53655 IN IP4 128.3.4.6
c=IN IP4 $
m=audio $ RTP/AVP 8
},R{
v=0
o=bell 53655 53655 IN IP4 172.21.143.59
s=SDP from MEGACO LINE
c=IN IP4 xxxxxxxx
t=0 0
m=audio 8000 RTP/AVP 8
},O{MO=SO}}}}}

Clarrification:
i assume that, the Originating RTP termination is requestd to of type RO,
so that before answer phase,
for an unsuccesful call setup, an announcement could be played.
a personalised ringback tone be applied.

Question1.
Are my assumptions correct?
Are there any other reasons to have a receive only RTP.

Question2.
from T=42, the terminating RTP is requested to be of type SO.
Please let me understand the reason behind this.

Thanks and Regards,
karthik Prabhu
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Ashish Singh <[email-masked]>
Date: Wed, 06 Jun 2007 16:23:13 -0700

Hi Karthik,

mode=RC at originating gateway and mode=SO at terminating gateway will 
take care of early media, where terminating gateway can start sending 
media packets right away.

Thanks
Ashish.

karthik prabhu Balakrishnan wrote:
> T=41{C=${A=line/1{M{ 
> O{MO=SR}},SG{},E=63{al/on{strict=failWrong}}},A=${M{L{
> v=0
> o=bell 53655 53655 IN IP4 128.3.4.6 <http://128.3.4.6>
> c=IN IP4 $
> m=audio $ RTP/AVP 8
> },O{ MO=RC,RV=ON}}}}}
>  
> o=bell 53655 53655 IN IP4 128.3.4.6 <http://128.3.4.6>
> c=IN IP4 $
> m=audio $ RTP/AVP 8
> },R{
> v=0
> o=bell 53655 53655 IN IP4 172.21.143.59 <http://172.21.143.59>
> s=SDP from MEGACO LINE
> c=IN IP4 xxxxxxxx
> t=0 0
> m=audio 8000 RTP/AVP 8
> },O{MO=SO}}}}}
>  
>  
> Clarrification:
> ------------------------------------------------------------------------
>

---

From: "BEHAR ALDANA RONALD" <[email-masked]>
Date: Fri, 8 Jun 2007 14:40:31 +0200

Another reason is that if You are connected to a PSTN Network, some tones applied to the users can come from it so the port must be able to receive RTP's.

________________________________

De: karthik prabhu Balakrishnan [mailto:[email-masked]] 
Enviado el: miércoles, 06 de junio de 2007 17:01
Para: [email-masked]
CC: Schwarz Albrecht
Asunto: [Megaco] Reg SO,RO RTP

Hello All,

Clarrification:
 
Question1.
 
Question2.
 
Thanks and Regards,
karthik Prabhu

---

From: [email-masked]
Date: Sun, 10 Jun 2007 12:09:46 +0200

Seems to be a 2-party basic call (and not any supplementary service).
There is a call establishment direction and a bearer establishment
direction, and a bidirectional bearer has two unicast communication
channels.
The establishment of the unicast bearer from A to B MAY be done in
"parallel" as call establishment from A to B.
But typical services do already require at least the unicast bearer from B
to A direction, just for signaling of call progress information (e.g like
ringback tones etc).

Conclusion:
There are different requirements for "cut-through" of the two unicast
bearer channels (in case of a bidirectional communication service).

But, I guess there isn't any general principle.
There might be a difference between services of
a) PSTN emulation subsystem (PES) and
b) IP multimedia subsystem (IMS) and
other subsystems for other services.

                      "BEHAR ALDANA RONALD"                                                                                                         
                      <Ronald.Behar_Aldana@alcatel         To:      "karthik prabhu Balakrishnan" <[email-masked]>, <[email-masked]>     
                      -lucent.es>                          cc:      Schwarz Albrecht <[email-masked]>                           
                                                           Subject: RE: [Megaco] Reg SO,RO RTP                                                      
                      08.06.2007 14:40                                                                                                              

Another reason is that if You are connected to a PSTN Network, some tones
applied to the users can come from it so the port must be able to receive
RTP's.

Hello All,

T=42{C=${A=line/2{M{O{MO=SR}},SG{al/ri},E=64{al/of{strict=failWrong}}},A=${M{L
{
v=0
o=bell 53655 53655 IN IP4 128.3.4.6
c=IN IP4 $
m=audio $ RTP/AVP 8
},R{
v=0
o=bell 53655 53655 IN IP4 172.21.143.59
s=SDP from MEGACO LINE
c=IN IP4 xxxxxxxx
t=0 0
m=audio 8000 RTP/AVP 8
},O{MO=SO}}}}}

Clarrification:

Question1.

Question2.

Thanks and Regards,
karthik Prabhu