Subject: [Megaco] Observed events question

From: "Tamar Nemet" <[email-masked]>
Date: Tue, 2 Sep 2008 10:29:01 +0300

Hi,
 
Please look at the following megaco messages:

MGC -> MG:
T=22127{C=3983{S=e1/05/5{AT{}}},C=-{MF=e1/05/5{E=8591{bcas/sz,bcas/casf,
icas/casf},SG{icas/rlg},M{O{MO=IN}}}}}
 
MG -> MGC: T=22129{C=*{S=e1/05/5{AT{}}},C=-{MF=e1/05/5{SG,M{O{MO=IN}}}}}
 
MG -> MGC: T=233{C=-{N=E1/05/5{OE=8591{20080811T00550054:BCAS/SZ}}}}
MGC reply to MG: P=233{C=-{N=e1/05/5{ER=410{"Unknown Request ID"}}}} 
 
In the second message there is Subtract command that delete all the
signals (SG) but there is nothing regarding requested events, so the MG
still wait for the requested events from the first message.
 
When the MG send Notify with the observed event (in the third message) ,
the MGC answer with Unknown Request ID. 
 
We don't understand why this is an Unknown Request ID, this is the last
one that the MGC asked and nothing canceled this request ID.
 
Can you explain please ?
 
Thanks,
Tamar
_______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco

---

From: Deepak Bissa <[email-masked]>
Date: Wed, 3 Sep 2008 10:38:42 +0530

Hello,
There is minor correction in messages shown in red below.
I would like to know that what is MG's reply to the first two messages.

Ideally, MG shall reply back successfully to first message and for the second message it should send an error reply.
The reason being that termination has been already moved to NULL context by the effect of subtract command in first message.
Thus, for second message, MG will not be able to find the termination in any Non-Null context and should send error as 435, "Termination ID is not in specified Context".

But if MG replied successfully to subtract command in second message then MGC shall assume that all descriptors for the termination have been reset to default values (Refer H.248.1 (V3) section 7.2.3).
MGC will not be able to match the request ID as reported by MG in such a condition.

With regards,
Deepak Bissa
________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tamar Nemet
Sent: Tuesday, September 02, 2008 12:59 PM
To: [email-masked]
Cc: Michael Putter
Subject: [Megaco] Observed events question

Hi,

MGC -> MG: T=22127{C=3983{S=e1/05/5{AT{}}},C=-{MF=e1/05/5{E=8591{bcas/sz,bcas/casf,icas/casf},SG{icas/rlg},M{O{MO=IN}}}}}

MGC -> MG: T=22129{C=*{S=e1/05/5{AT{}}},C=-{MF=e1/05/5{SG,M{O{MO=IN}}}}}

In the second message there is Subtract command that delete all the signals (SG) but there is nothing regarding requested events, so the MG still wait for the requested events from the first message.

When the MG send Notify with the observed event (in the third message) , the MGC answer with Unknown Request ID.

We don't understand why this is an Unknown Request ID, this is the last one that the MGC asked and nothing canceled this request ID.

Can you explain please ?

Thanks,
Tamar

________________________________
"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error,please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility forloss or damage arising from the use of the information transmitted by this email including damage from virus."
_______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco