Subject: [Megaco] Error descriptors within stream descriptors

From: Michael Dell <[email-masked]>
Date: Thu, 30 Apr 2009 12:25:56 +0100

Hi there

I have a question concerning the validity of adding an error descriptor in a command response within a stream descriptor - could the list please let me know if this should be valid Megaco (v3)?

When adding or modifying a multi-stream termination, we may identify an error with some subset of the streams.  In this case, where should the error descriptor(s) be located?  Specifically, is it valid to include an error descriptor within a stream descriptor?

For example, a termination with id "ip/1" has three streams (1, 2 and 3).  A request to modify all three streams can be accommodated on stream 2, but fails for stream 1 and stream 3.  The response I would like to send is as follows:

!/2 [16.16.16.16]:1
P=11{
C=200{
MF=ip/1{
M{
ST=1{
ER=449{"Unsupported or Unknown Parameter or Property Value"}},
ST=3{
ER=449{"Unsupported or Unknown Parameter or Property Value"}}
}}}}

The relevant part of the ABNF seems to suggest that an error descriptor is not a valid streamParm.  I believe this makes the above invalid Megaco.

However, the "H.248 Sub-series Implementers' Guide" says, in section 7.1.20:

An Error Descriptor shall be specified at the "deepest level" that is semantically appropriate for the error being described ...
...
If the error being described can be determined to be at a descriptor level, the Error Descriptor may be returned at the descriptor level.

Does this indicate that stream-scope error descriptors are, in fact, allowed?

Thanks in advance for your input

Mike Dell
Data Connection Ltd.

---

From: Sudhanshu Garg <[email-masked]>
Date: Thu, 30 Apr 2009 17:48:51 +0530

Hi Mike,

Putting error descriptor inside another descriptor is not possible.

Regards,
Sudhanshu Garg
Engineering Project Manager
Ph: +91 124  4176218
Mob: +91 9999500798
A R I C E N T
________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael Dell
Sent: Thursday, April 30, 2009 4:56 PM
To: [email-masked]
Subject: [Megaco] Error descriptors within stream descriptors

Hi there

!/2 [16.16.16.16]:1
P=11{
C=200{
MF=ip/1{
M{
ST=1{

Mike Dell
Data Connection Ltd.

________________________________
"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error,please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus."