Subject: [Megaco] Inconsistency in Digit Map timers definition

From: Seraya Miletzki <[email-masked]>
Date: Wed, 26 Aug 2009 18:07:02 +0300

WARNING: contains banned part

Subject: Inconsistency in Digit Map timers definition
From: Seraya Miletzki <[email-masked]>
To: "[email-masked]" <[email-masked]>
Date: Wed, 26 Aug 2009 18:07:02 +0300

Hi

At H.248/1 V3  at       7.1.14.3        DigitMap syntax - "In addition to these event symbols, the string may contain "S" and "L" inter-event timing specifiers and the "Z" duration modifier."

At annex B Start timer (T) is also a valid symbol in the digitmap string.

digitMapLetter          = DIGIT               ;Basic event symbols

                          / %x41-4B / %x61-6B ; a-k, A-K

                          / "L" / "S" / "T"   ;Inter-event timers

                                               ; (long, short, start)

                          / "Z"               ;Long duration modifier

Need to specify the right pattern .

I think that the start timer is not a valid string here -Please comment.

Seraya

---

From: Christian Groves <[email-masked]>
Date: Tue, 01 Sep 2009 14:12:06 +1000

Hello Seraya,

As far as I know the start timer (T) is a valid part of the digit map 
syntax. The operation of the start timer is discussed elsewhere in 7.1.14

Regards, Christian

Seraya Miletzki wrote:
> ------------------------------------------------------------------------
>
> Subject:
> Inconsistency in Digit Map timers definition
> From:
> Seraya Miletzki <[email-masked]>
> Date:
> ------------------------------------------------------------------------
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/megaco
>