Subject: [Megaco] IP changeover Procedures

From: Akhil Jain <[email-masked]>
Date: Wed, 18 Nov 2009 16:00:22 +0530 (IST)

Hi All,
Per our Implementation, we need to provide Interface Redundancy at MGC end, the architecture we were going to implement is MGC-Active will have 2 IP interfaces and MGC-Standby will have 2 IP interfaces.Can someone help in answering following things:
1. If an Association has been established between MGC-Active (IP1) and peer MG, and now IP1 of MGC-Active has gone down and IP-2 of MGC-Active needs to takeover without breaking the current control association how can we achieve that? <<< Per "Updated
Draft ITU-T H.Sup7 “Gateway Control Protocol: Establishment Procedures for the
H.248 MGC-MG Control Association” (Ed. 0.14)" ServiceChangeAddress field can be used by MGC to tell new IP address for remaining association. But the document has suggested the use of Service Change Address field in the "Association Establishment Phase".Another thing if MGC sends ServiceChangeMethod as "Handoff" then It would mean that MGC wants a new association but that is not the case, MGC only wants to change the address for rest of the association. >>>
2. If we use MGCIDtotry field in the ServiceChange command then MGC will send this command through IP2 (as IP1 of MGC has been down) so, how will MG got to know that this request has been sent by MGC that has been registered on IP1. Shall it recognizes the MGC via MID ?
Kindly help!
ThanksAkhil Jain

      Try the new Yahoo! India Homepage. Click here. http://in.yahoo.com/trynew

---

From: Kevin Boyle <[email-masked]>
Date: Wed, 18 Nov 2009 10:19:50 -0500

Hi Akhil,
 
A change of address for the MGC implies a new control association.  That does not necessarily mean that any contexts will be altered; all it means is that the control association has undergone a change.  It is up to the MGC to clean up anything on the MG that is out-of-whack.  Given that this is really the same MGC (though the MG cannot possibly know that), the MGC can choose to take NO action and continue everything as it is.  I will note that the change of interface will take a non-zero amount of time, so there is the possibility that messages will be lost.  The spec is pretty clear that the MG has to send replies back to where the command came from, so there is no way that a change of IP address can not result in a change of association (see H.248.1, Clause 9).
 
There is no way the MG could know that the MGC is the same one after the change of interfaces.  Please see H.248.1 Annex F for normative details on the ServiceChange procedures that are then used in the overall procedures in Supplement 7.
 
Kevin

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of Akhil Jain
Sent: Wednesday, November 18, 2009 5:30 AM
To: [email-masked]
Subject: [Megaco] IP changeover Procedures

Hi All, 

1. If an Association has been established between MGC-Active (IP1) and peer MG, and now IP1 of MGC-Active has gone down and IP-2 of MGC-Active needs to takeover without breaking the current control association how can we achieve that? 
<<< Per "Updated Draft ITU-T H.Sup7 “Gateway Control Protocol: Establishment Procedures for the H.248 MGC-MG Control Association” (Ed. 0.14)" ServiceChangeAddress field can be used by MGC to tell new IP address for remaining association. But the document has suggested the use of Service Change Address field in the "Association Establishment Phase".
Another thing if MGC sends ServiceChangeMethod as "Handoff" then It would mean that MGC wants a new association but that is not the case, MGC only wants to change the address for rest of the association. >>>

Kindly help!

Thanks
Akhil Jain

  _____  

Now, send attachments up to 25MB with Yahoo! India Mail. Learn how <http://in.rd.yahoo.com/tagline_galaxy_2/*http://in.overview.mail.yahoo.com/photos> .

---

From: Akhil Jain <[email-masked]>
Date: Sat, 21 Nov 2009 21:33:31 +0530 (IST)

Hi Kevin,
Thanks for the reply. So if MGC-active sends a Service change from IP2 (as IP1 has been down) then shall it will fill Handoff as reason and new IP address as IP2 in MGCIDtotry field ? If that is the case then shall MG will reply on the new IP i.e. IP2 ? Kindly help.
ThanksAkhil Jain

--- On Wed, 18/11/09, Kevin Boyle <[email-masked]> wrote:

From: Kevin Boyle <[email-masked]>
Subject: RE: [Megaco] IP changeover Procedures
To: "'Akhil Jain'" <[email-masked]>, [email-masked]
Date: Wednesday, 18 November, 2009, 8:49 PM

Hi Akhil,
 
A change of address for the MGC implies a new control 
association.  That does not necessarily mean that any contexts will be 
altered; all it means is that the control association has undergone a 
change.  It is up to the MGC to clean up anything on the MG that is 
out-of-whack.  Given that this is really the same MGC (though the MG cannot 
possibly know that), the MGC can choose to take NO action and continue 
everything as it is.  I will note that the change of interface will take a 
non-zero amount of time, so there is the possibility that messages will be 
lost.  The spec is pretty clear that the MG has to send replies back to 
where the command came from, so there is no way that a change of IP address can 
not result in a change of association (see H.248.1, Clause 
9).
 
There is no way the MG could know that the MGC is the same one 
after the change of interfaces.  Please see H.248.1 Annex F for normative 
details on the ServiceChange procedures that are then used in the overall 
procedures in Supplement 7.
 
Kevin

  
  From: [email-masked] 
  [mailto:[email-masked]] On Behalf Of Akhil 
  Jain
Sent: Wednesday, November 18, 2009 5:30 AM
To: 
  [email-masked]
Subject: [Megaco] IP changeover 
  Procedures

    
      Hi All,

        Per our Implementation, we need to provide Interface Redundancy at 
        MGC end, the architecture we were going to implement is MGC-Active will 
        have 2 IP interfaces and MGC-Standby will have 2 IP interfaces.Can 
        someone help in answering following things:

        1. If an Association has been established between MGC-Active (IP1) 
        and peer MG, and now IP1 of MGC-Active has gone down and IP-2 of 
        MGC-Active needs to takeover without breaking the current control 
        association how can we achieve that? 
        <<< Per "Updated Draft ITU-T H.Sup7 “Gateway Control 
        Protocol: Establishment Procedures for the H.248 MGC-MG Control 
        Association” (Ed. 0.14)" ServiceChangeAddress field can be used by MGC 
        to tell new IP address for remaining association. But the document has 
        suggested the use of Service Change Address field in the "Association 
        Establishment Phase".
        Another thing if MGC 
        sends ServiceChangeMethod as "Handoff" then It would mean that MGC wants 
        a new association but that is not the case, MGC only wants to change the 
        address for rest of the association. >>>

        2. If we use MGCIDtotry 
        field in the ServiceChange command then MGC will send this command 
        through IP2 (as IP1 of MGC has been down) so, how will MG got to know 
        that this request has been sent by MGC that has been registered on IP1. 
        Shall it recognizes the MGC via MID ?

        Kindly 
        help!

        Thanks
        Akhil 
        Jain

  Now, send attachments up to 25MB with Yahoo! India Mail. Learn how. 

      The INTERNET now has a personality. YOURS! See your Yahoo! Homepage. http://in.yahoo.com/