Subject: [Megaco] Question on remote descriptor for IP IP terminations

From: "Yin Wang (yinwang)" <[email-masked]>
Date: Fri, 25 Dec 2009 14:09:51 +0800

Hi, all
 
I have one question on middle call codec change. For an example, the
call is first answered as G.711, so via H.248 interface, a context with
two IP terminations (ip/1/1/1 and ip/1/1/2), with both use G.711, let us
assume the h.248 modify message looks like
m=ip/1/1/1 { m { 
Local {
v=0
o=- 0 0 IN IP4 -
s=-
c=IN IP4 210.2.12.2
t=0 0
m=audio 16400 RTP/AVP 0
 } ,
Remote{
v=0
o=- 0 0 IN IP4 -
s=-
c=IN IP4 210.12.12.2
t=0 0
m=audio 16400 RTP/AVP 0
}}},
m=ip/1/1/2 { m { 
Local {
v=0
o=- 0 0 IN IP4 -
s=-
c=IN IP4 210.2.12.2
t=0 0
m=audio 16402 RTP/AVP 0
 } ,
Remote{
v=0
o=- 0 0 IN IP4 -
s=-
c=IN IP4 210.12.12.2
t=0 0
m=audio 16402 RTP/AVP 0
}}}
 
In case of middle-call codec change, assume will now use 19. The
question is whether it is necessary to include both remote descriptor in
trh modify transaction request? For the below example, remote descriptor
for ip/1/1/1 is unspecified, is it acceptable? How should MG
interoperate this for remote descriptor of ip/1/1/1, use old version?
  
m=ip/1/1/1 { m { 
Local {
v=0
o=- 0 0 IN IP4 -
s=-
c=IN IP4 210.2.12.2
t=0 0
m=audio 16400 RTP/AVP 19
 }}},
m=ip/1/1/2 { m { 
Local {
v=0
o=- 0 0 IN IP4 -
s=-
c=IN IP4 210.2.12.2
t=0 0
m=audio 16402 RTP/AVP 0
 } ,
Remote{
v=0
o=- 0 0 IN IP4 -
s=-
c=IN IP4 210.12.12.2
t=0 0
m=audio 16402 RTP/AVP 0
}}}
 
Thanks
 
wang yin

---

From: "Bhattacharjee, Arindam (Arindam)" <[email-masked]>
Date: Fri, 25 Dec 2009 08:30:10 -0600

Two scenarios apply in this condition:

 1.  ip/1/1/1 will send g711 & receive ptype 19 at near end, if DSP supports that asymmetric codec in two directions of the stream, else
 2.  ip/1/1/1 will stop sending any packets to the remote until remote is modified to ptype 19 & receive only ptype 19.

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Yin Wang (yinwang)
Sent: Friday, December 25, 2009 1:10 AM
To: [email-masked]
Subject: [Megaco] Question on remote descriptor for IP IP terminations

Hi, all

I have one question on middle call codec change. For an example, the call is first answered as G.711, so via H.248 interface, a context with two IP terminations (ip/1/1/1 and ip/1/1/2), with both use G.711, let us assume the h.248 modify message looks like
m=ip/1/1/1 { m {
Local {
v=0
o=- 0 0 IN IP4 -
s=-
c=IN IP4 210.2.12.2
t=0 0
m=audio 16400 RTP/AVP 0
 } ,
Remote{
v=0
o=- 0 0 IN IP4 -
s=-
c=IN IP4 210.12.12.2
t=0 0
m=audio 16400 RTP/AVP 0
}}},
m=ip/1/1/2 { m {
Local {
v=0
o=- 0 0 IN IP4 -
s=-
c=IN IP4 210.2.12.2
t=0 0
m=audio 16402 RTP/AVP 0
 } ,
Remote{
v=0
o=- 0 0 IN IP4 -
s=-
c=IN IP4 210.12.12.2
t=0 0
m=audio 16402 RTP/AVP 0
}}}

In case of middle-call codec change, assume will now use 19. The question is whether it is necessary to include both remote descriptor in trh modify transaction request? For the below example, remote descriptor for ip/1/1/1 is unspecified, is it acceptable? How should MG interoperate this for remote descriptor of ip/1/1/1, use old version?

m=ip/1/1/1 { m {
Local {
v=0
o=- 0 0 IN IP4 -
s=-
c=IN IP4 210.2.12.2
t=0 0
m=audio 16400 RTP/AVP 19
 }}},
m=ip/1/1/2 { m {
Local {
v=0
o=- 0 0 IN IP4 -
s=-
c=IN IP4 210.2.12.2
t=0 0
m=audio 16402 RTP/AVP 0
 } ,
Remote{
v=0
o=- 0 0 IN IP4 -
s=-
c=IN IP4 210.12.12.2
t=0 0
m=audio 16402 RTP/AVP 0
}}}

Thanks

wang yin