Subject: [Megaco] Specifying audio codec on fixed termination

From: François Plagnard <[email-masked]>
Date: Thu, 3 Dec 2009 17:20:29 +0100

Hello,

In a gateway between ISDN and IP, B channels on ISDN side are fixed terminations.

In some ISDN networks, the audio codec used line may vary per call (often between G.711 A law and mu law).

How this audio codec may be indicated by the MGC to the gateway?

Best regards,

François Plagnard

---

From: Tom Taylor <[email-masked]>
Date: Fri, 04 Dec 2009 11:23:28 -0500

It is legitimate to specify a Local Descriptor for the B channel termination, 
indicating which codec is being used.

François Plagnard wrote:
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/megaco

---

From: "Bhattacharjee, Arindam (Arindam)" <[email-masked]>
Date: Fri, 4 Dec 2009 10:24:13 -0600

Hi Farcois,
Audio codec is indicated by some other protocol ( Mostly SDP-session description protocol. RFC 4566)  in Local & Remote Descriptor in Megaco.
H248.1 specifies the details about those descriptor.

-Arindam
________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of François Plagnard
Sent: Thursday, December 03, 2009 11:20 AM
To: [email-masked]
Subject: [Megaco] Specifying audio codec on fixed termination

Hello,

Best regards,

François Plagnard

---

From: François Plagnard <[email-masked]>
Date: Fri, 4 Dec 2009 17:58:03 +0100

Thank you for your answer.
But, now my concern is how to specify an audio codec in a B channel in Local descriptor?
I have found no way to describe it in SDP format contained in Local descriptor (there is no RTP involved here or any other transport).

Best regards,
 
François Plagnard
 
-----Message d'origine-----
De : Tom Taylor [mailto:[email-masked]] 
Envoyé : vendredi 4 décembre 2009 17:23
À : François Plagnard
Cc : [email-masked]
Objet : Re: [Megaco] Specifying audio codec on fixed termination

---

From: "Bhattacharjee, Arindam (Arindam)" <[email-masked]>
Date: Fri, 4 Dec 2009 11:10:42 -0600

For ISDN-IP on ISDN side you will have physical terminator which the B-channel, for IP side you have to have a ephemeral terminator created by MG where you use RTP with local/remote descriptor.

If you are trying TDM only calls then the the T1 or E1 with ulaw or alaw should be preconfigured in MG. MGC does not need to know physical resource configuration of the MG.

May need more information on your implementation.

-Arindam

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of François Plagnard
Sent: Friday, December 04, 2009 11:58 AM
To: Tom Taylor
Cc: [email-masked]
Subject: Re: [Megaco] Specifying audio codec on fixed termination

Best regards,
 
François Plagnard

---

From: Tom Taylor <[email-masked]>
Date: Fri, 04 Dec 2009 14:03:35 -0500

Once upon a time (almost ten years ago) I created an SDP solution for ISDN, but 
eventually backed off before it was standardized. I forgot about the need to 
specify a transport for the media in the m= line when I answered you today. 
Either we would have to carry the necessary changes through as a new AVT profile 
or you'll have to use some sort of trick.

---

From: Christian Groves <[email-masked]>
Date: Sun, 06 Dec 2009 22:28:20 +1100

Hello Francois,

You can use the attributes from H.248.1 Annex C. i.e ACodec from C.1 or 
layer1prot from C.9. If you want to carry these in the text encoding use 
H.248.15 and a package ID of "anxc" (as defined in  Annex C).

Regards, Christian

Tom Taylor wrote:
> Once upon a time (almost ten years ago) I created an SDP solution for 
> ISDN, but eventually backed off before it was standardized. I forgot 
> about the need to specify a transport for the media in the m= line 
> when I answered you today. Either we would have to carry the necessary 
> changes through as a new AVT profile or you'll have to use some sort 
> of trick.
>
> François Plagnard wrote:
>> I have found no way to describe it in SDP format contained in Local 
>> descriptor (there is no RTP involved here or any other transport).
>>
>> Best regards,
>>  
>> François Plagnard
>>  
>> De : Tom Taylor [mailto:[email-masked]] Envoyé : vendredi 4 
>> décembre 2009 17:23
>> À : François Plagnard
>> Cc : [email-masked]
>> It is legitimate to specify a Local Descriptor for the B channel 
>> termination, indicating which codec is being used.
>>
>> François Plagnard wrote:
>>> Hello,
>>>
>>>  
>>>