Subject: [Megaco] MG answer DTMF Relay

From: "Kleinke, Thiago" <[email-masked]>
Date: Wed, 17 Mar 2010 15:35:56 +0100

Guys,

Is there any difference when MG sends the following answer:

a=rtpmap:101 telephone-event/8000/0

instead of:

a=rtpmap:101 telephone-event/8000

Will MGC drop this information because of /0?

Regards,

Thiago Willian Kleinke

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Thu, 18 Mar 2010 03:15:06 +0100

Your question got two parts, one related to SDP and the other one to H.248:
 
1) SDP
The SDP line is syntactically correct as you know, see RFC 4566.
The encoding parameter is optional, dependent on ...
Thus you should raise your question on:
https://www.ietf.org/mailman/listinfo/mmusic <https://www.ietf.org/mailman/listinfo/mmusic> 
https://www.ietf.org/mailman/listinfo/avt <https://www.ietf.org/mailman/listinfo/avt> 
 a=rtpmap:<payload type> <encoding name>/<clock rate> [/<encoding
         parameters>]

The particular SDP line is semantically questionable, see RFC 4733. Because there is not any semantic defined for the encoding parameter for telephone-events.
At least to my knowledge.
 
2) H.248
> Is there any difference when MG sends the following answer: ...
Your question is incomplete because your should first provide the MGC request command.
The MG reply is dependent on the request command, e.g. whether wildcarding is used in the SDP line. Or if the MGC did request a full specified "a=" line, which is supported by the MG, then the MG has to omit the SDP line in the reply.
Thus your example looks strange (at least requires more background).
 
-Albrecht

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Kleinke, Thiago
	Sent: Mittwoch, 17. März 2010 15:36
	To: [email-masked]
	Cc: Rezende, Daniel
	Subject: [Megaco] MG answer DTMF Relay

	Guys,

	instead of:

	Regards,

	Thiago Willian Kleinke