Subject: [Megaco] Unsupported embedded signal

From: François Plagnard <[email-masked]>
Date: Wed, 10 Mar 2010 11:45:46 +0100

Hello,

What must do a gateway when it receives a requested event with an embedded signal which is not supported by the gateway?

Must the gateway reject the command or must it accept the event even if it cannot play the signal?

Best regards,
 
--------------------------------------------
François Plagnard
 
ENEA Netbricks
---------------------------------------------

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Fri, 12 Mar 2010 04:16:51 +0100

In general, an H.248 Profile-less operated H.248 Control Association, the MG shall reply with an appropriate (H.248.8) error code. It's a master-slave relationship, thus the master got to known whether requested actions are executed or not.

The other scenario might be that the H.248 CA is operated in "profile mode", i.e. the MG did register with a ProfileID.
A profile specification allows to specify the details of package usage, e.g. whether a signal is mandatory or optional, and the particular MG behaviour.

Did you refer to a specific profile definition, François?

-Albrecht

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of François Plagnard
> Sent: Mittwoch, 10. März 2010 11:46
> To: [email-masked]
> Subject: [Megaco] Unsupported embedded signal
> 
> Hello,
> 
> What must do a gateway when it receives a requested event 
> with an embedded signal which is not supported by the gateway?
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/megaco
>