Subject: [Megaco] Megaco Service change reply without version

From: Ayush Jain <[email-masked]>
Date: Wed, 13 Oct 2010 18:16:41 +0530

Hi All,

If MGW sends a service change request to MGC & MGC has to reply without any descriptors(without version etc), then opening & closing bracket should be there on root or not. Currently for me, opening & closing brackets are coming from MGC, so MGW is returning Unsupported Descriptor & so Disconnect.

###########################Service Change coming from MGW

TRANSACTION = 17008 {

  CONTEXT = - {

    SERVICECHANGE = ROOT {

      SERVICES { METHOD = RESTART,

                 REASON = 901,

                 VERSION = 2 }

    }

  }

} msgLen = 206

MEGACO/2 [10.128.254.81]

REPLY = 17008 {

  CONTEXT = - {

    SERVICECHANGE = ROOT {

    }

  }

}

 msgLen = 103

So now, whether  {} is required after ROOT or not ? I could not get it clearly as per RFC.

Regards,
_Ayush

---

From: Tom Taylor <[email-masked]>
Date: Wed, 13 Oct 2010 21:59:59 -0400

You shouldn't be working from any RFC. The official reference for the 
protocol is H.248.1 as published by the ITU-T. You can find it at

http://www.itu.int/rec/T-REC-H/en

On 13/10/2010 8:46 AM, Ayush Jain wrote:
> Hi All,
>
> If MGW sends a service change request to MGC&  MGC has to reply without any descriptors(without version etc), then opening&  closing bracket should be there on root or not. Currently for me, opening&  closing brackets are coming from MGC, so MGW is returning Unsupported Descriptor&  so Disconnect.
>
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Thu, 14 Oct 2010 13:50:07 +1100

Hello Ayush,

The ABNF is:

serviceChangeReply = ServiceChangeToken EQUAL termIDList [LBRKT

(errorDescriptor / serviceChangeReplyDescriptor)

RBRKT]

The { } are within square brackets so if there's no descriptor 
information then they are not included.

Regards, Christian

On 14/10/2010 12:59 PM, Tom Taylor wrote:
>> If MGW sends a service change request to MGC&  MGC has to reply 
>> without any descriptors(without version etc), then opening&  closing 
>> bracket should be there on root or not. Currently for me, opening&  
>> closing brackets are coming from MGC, so MGW is returning Unsupported 
>> Descriptor&  so Disconnect.
>>
>>

---

From: Ayush Jain <[email-masked]>
Date: Thu, 14 Oct 2010 10:11:42 +0530

Hi Tom,
I got it. Actually I have checked in ITU - T H248.1 Draft.
But still am not clear whether for below: {} are required or not.
ABNF says: 

serviceChangeReply = ServiceChangeToken EQUAL termIDList [LBRKT
(errorDescriptor / serviceChangeReplyDescriptor)
RBRKT]
That means, if there is no error descriptor or service change reply descriptor, LBRKT & RBRKT are not required? Is it fine?

Regards,
_Ayush

---

From: Ayush Jain <[email-masked]>
Date: Thu, 14 Oct 2010 13:05:04 +0530

Thanks Ronald. I got it.

Regards,
_Ayush

-----Original Message-----
From: BEHAR ALDANA, RONALD (RONALD)** CTR ** [mailto:[email-masked]] 
Sent: Thursday, October 14, 2010 1:01 PM
To: Ayush Jain; Tom Taylor
Cc: [email-masked]
Subject: RE: [Megaco] Megaco Service change reply without version

Hi Ayush

According to ABNF "Square brackets enclose an optional element sequence", so since the LBRKT and RBRKT are inside the Square brackets "[]" they are optional also and should only be included when any of the parameters in the list is sent.

Regards

Ronald Behar Aldana 
QACC EMEA TSO 
Madrid (Spain) (0034 913305322)

-----Mensaje original-----
De: [email-masked] [mailto:[email-masked]] En nombre de Ayush Jain
Enviado el: jueves, 14 de octubre de 2010 6:42
Para: Tom Taylor
CC: [email-masked]
Asunto: Re: [Megaco] Megaco Service change reply without version

Hi Tom,

Regards,
_Ayush

---

From: "BEHAR ALDANA, RONALD (RONALD)** CTR **" <[email-masked]>
Date: Thu, 14 Oct 2010 09:31:05 +0200

Hi Ayush

Regards

Ronald Behar Aldana 
QACC EMEA TSO 

-----Mensaje original-----
De: [email-masked] [mailto:[email-masked]] En nombre de Ayush Jain
Enviado el: jueves, 14 de octubre de 2010 6:42
Para: Tom Taylor
CC: [email-masked]
Asunto: Re: [Megaco] Megaco Service change reply without version

Hi Tom,

Regards,
_Ayush