Subject: [Megaco] Megaco codec negotiation

From: Rudra Pratap Singh <[email-masked]>
Date: Mon, 7 Feb 2011 15:23:25 +0530

Hi All,

I'm a fresher in Megaco area.
I have some doubt regarding codec negotiation for audio and image in the following scenario-

Firstly there is negotiation of audio codec.
And after successful audio negotiation , there is a modify command to one of the termination from MGC
that contains image in local (L{image}) and an empty remote (R{})
can anyone please tell what should be the expected behaviour of MG?
following is the pdu--

!/1 [192.168.0.203]:2944 T=347{C=2{MF=eph3{M{O{MO=IN},L{v=0
c=IN IP4 $
a=ptime:10
m=image $ udptl t38
},R{}}}}}

and after this transaction ,if MGC send the folllwing

!/1 [192.168.0.203]:2944 T=347{C=2{MF=eph3{M{O{MO=IN},L{v=0
c=IN IP4 $
a=ptime:10
m=audio $ RTP/AVP 8
},R{}}}

then what should be the reply of MG?

Any information will be appreciated!

Thanks & Regards,
Rudra Pratap Singh

________________________________
"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error, please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus."

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Tue, 8 Feb 2011 15:10:12 +0100

Not sure whether this is meaningfull signalling at all:

 *
modification to StreamMode 'inactive' ... and later change again? to?
 *
the SDP for T.38 looks incorrect (what's the purpose of ptime?)

Further:

 *
Any H.248 Stream is bidirectional and the media format in each direction might be principally different ("asymmetric media"). If the MODIFY transaction would be successfull, then there would be different media formats in each direction.
 *
the notion of "codec negotiation" is OK on call control level, but not at H.248 due to master-slave relationship. There isn't any negotiation. Rather a resource reservation and committment concept.

If you look for correct SDP example signaling, see eg. T.38 (2010) and V.152 (2010).

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Rudra Pratap Singh
Sent: Montag, 7. Februar 2011 10:53
To: [email-masked]
Subject: [Megaco] Megaco codec negotiation

Hi All,

Thanks & Regards,
Rudra Pratap Singh