Subject: [Megaco] Query about LATCH Vs RELATCH

From: "Cool..AkaSh" <[email-masked]>
Date: Wed, 17 Aug 2011 19:05:15 +0530

Hi,

I have a query about the difference between Latch and Relatch. I am testing
BGF, and in my scenario when Latch is followed by Relatch then it is working
fine i.e. first it learn the packets from the source IP (except remote
descriptor IP) and when did RELATCH then learned the packets from new source
IP and drops the packets from the previous IP.

Now when I am doing a scenario Latch followed by Latch then also first it
learns the packets from the source IP and when did LATCH then it learn the
packet from new source IP and drops the packets from previous IP.

Here I am not able to figure out what is the difference between Latch and
Relatch because in the above scenario I can see LATCH is doing the same
thing which RELATCH does. Why RELATCH comes into the picture?

Please help me to figure out this, so that can proceed. Your help would be
appreciable.

---

Thanks & Regards,

Akash Gupta

---

From: "Makaraju, Maridi Raju (Raju)" <[email-masked]>
Date: Wed, 17 Aug 2011 14:35:29 -0500

Akash,

Latch completes when very next pkt arrives irrespective of the src is new or same as before.
Whereas relatch completes only when pkt from new src arrives.
In one scenario it may so happen that the next pkt arrives from new src. In such case eithet a latch or relatch can be completed with the same effect.

Thanks
Raju

 -----Original Message-----
From: 	Cool..AkaSh [mailto:[email-masked]]
Sent:	Wednesday, August 17, 2011 12:18 PM Central Standard Time
To:	[email-masked]
Subject:	[Megaco] Query about LATCH Vs RELATCH

Hi,

I have a query about the difference between Latch and Relatch. I am testing BGF, and in my scenario when Latch is followed by Relatch then it is working fine i.e. first it learn the packets from the source IP (except remote descriptor IP) and when did RELATCH then learned the packets from new source IP and drops the packets from the previous IP.

Now when I am doing a scenario Latch followed by Latch then also first it learns the packets from the source IP and when did LATCH then it learn the packet from new source IP and drops the packets from previous IP.

Here I am not able to figure out what is the difference between Latch and Relatch because in the above scenario I can see LATCH is doing the same thing which RELATCH does. Why RELATCH comes into the picture? 

Please help me to figure out this, so that can proceed. Your help would be appreciable.

---

Thanks & Regards,

Akash Gupta