Subject: [Mentoring-coordinators] Kicking off mentoring-coordinators

From: Alissa Cooper <[email-masked]>
Date: Mon, 13 May 2013 12:51:09 -0400

Hi all,

Welcome to the [email-masked] mailing list. These are the folks who have signed up as coordinators and who are on this list:

Ron Bonica
Ralph Droms
Lars Eggert
Leif Johansson
Murray Kucherawy
Robert Sparks

Brian Haberman and myself are also subscribed and will be helping to get the program going. Here is a sketch of how we envision the program working:

The secretariat will be building an IETF Mentoring page linked from the main IETF site. The site will contain FAQs about the program and web forms that allow people to sign up to be mentors or to be protégés. Our current thinking is to limit the protégé pool to anyone who has attended three or fewer IETF meetings, and to limit the mentor pool to anyone who is nomcom eligible. We could change the protégé limit in the future, but since this is an experiment we'd like to keep it somewhat limited for now and see how it works. Both the FAQs and the web form fields are attached for your review and comment.

IETF registration is already open. Our thinking was that we can start soliciting mentors any time by sending a message to IETF-Announce. Suggested text for that is included below. Once registration has been open for awhile, we can then start soliciting protégés by emailing the IETF 87 newcomers' mailing list, and sending the same mail to individuals who have attended fewer than 3 meetings (the secretariat can determine who is in this group for us).

It probably makes sense to set a deadline by which mentors and protégés need to sign up, after which you all can get to work doing the matchings. Suggestions for a deadline? The secretariat will be building a database to capture all of the info from the web forms. We're still working out how to make that a collaborative tool so that you all can work together on the matchings and see who has been matched already, etc. If you have thoughts about good tools for this, feel free to share.

Whether you want to stick to 1:1 matches or allow some 1:more-than-1 is up to you and might depend on who you get signed up in both groups.

Brian and I have also discussed opportunities to help mentors and protégés meet at the beginning of IETF week, perhaps in designated areas at the newcomers' meet-and-greet. We're still mulling that over but would appreciate your thoughts about that.

One last question is whether the fact that you all are coordinating the program should be made public. On one hand, it might be helpful for people to not know that you're doing the matching, so that no one tries to lobby you. Brian and I could certainly front all complaints/lobbying in that regard. On the other hand, you will be spending some time on this and so I can appreciate that you might want some recognition for it. Would be interested in your thoughts about that.

Let us know if you have questions.

Thanks,
Alissa

-----------

Subject: IETF Mentor Program

Hi all,
    Based on discussions during IETF 86, we are trialing an IETF mentoring program.  During this trial period, we would like to pair those who are new to the IETF (people who have attended 3 or fewer meetings) with existing IETF participants.  The goal is to provide a resource for the new people who can assist them with integrating into the IETF community.  Mentors and protégés (who express an interest in being mentored) will be paired prior to IETF 87. We cannot guarantee that every mentor or protégé will be matched, but we'll do our best. If the trial goes well, there may be a variety of ways to expand the program in the future.

    What we need is for people to volunteer to be mentors. As a mentor, we would ask that you be willing to assist your protégé before, during, and (hopefully) after IETF 87.  The actual level of interaction will be driven by an agreement between the mentor and the mentee. Additionally, we would need a brief description of your areas of expertise, technical interests, and conversational languages.

    People interested in acting as mentors can volunteer by filling at the form at ???.  An FAQ for this trial program is available here: ???.

Regards,
Alissa & Brian

---

From: Robert Sparks <[email-masked]>
Date: Mon, 13 May 2013 13:12:33 -0500

On 5/13/13 11:51 AM, Alissa Cooper wrote:
> It probably makes sense to set a deadline by which mentors and protégés need to sign up, after which you all can get to work doing the matchings. Suggestions for a deadline?
I'm not sure we would need the whole set before we started matching - 
maybe we have, and advertise, a date at which we would start
(to drive early signup), but do matching up to and at the IETF meeting? 
I would suggest that start date be 1 or two weeks before the -00 deadline.

> The secretariat will be building a database to capture all of the info from the web forms. We're still working out how to make that a collaborative tool so that you all can work together on the matchings and see who has been matched already, etc. If you have thoughts about good tools for this, feel free to share.
It's dangerous to build too much tool when you're still trying to figure 
out what you really want to be doing - it can cause you to accidentally 
get stuck with a behavior you don't really need. I would strongly 
suggest just starting with a wiki and more manual effort than you want 
in the long run until we know what a tool really needs to help with.
> One last question is whether the fact that you all are coordinating the program should be made public. On one hand, it might be helpful for people to not know that you're doing the matching, so tha…
When in doubt, fail open.

> Let us know if you have questions.

On the signup forms - consider asking both mentors and protoges (I'm 
worried how the community will react to the term btw) are active in any 
other SDOs, and if they have any non-IETF activities they are passionate 
about.

RjS
>
>
>
> _______________________________________________
> mentoring-coordinators mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mentoring-coordinators

---

From: Leif Johansson <[email-masked]>
Date: Tue, 14 May 2013 14:37:15 +0200

On 05/13/2013 08:12 PM, Robert Sparks wrote:
> (to drive early signup), but do matching up to and at the IETF
> meeting? I would suggest that start date be 1 or two weeks before the
> -00 deadline.

sounds reasonable, how many mentorees are we expecting?

> It's dangerous to build too much tool when you're still trying to
> figure out what you really want to be doing - it can cause you to
> accidentally get stuck with a behavior you don't really need. I would
> strongly suggest just starting with a wiki and more manual effort than
> you want in the long run until we know what a tool really needs to
> help with.

agree fully.

> When in doubt, fail open.

+1
> worried how the community will react to the term btw) are active in
> any other SDOs, and if they have any non-IETF activities they are
> passionate about.
>
> RjS
>>
>>

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 15 May 2013 11:38:36 +0000

Hi,

>> The secretariat will be building an IETF Mentoring page linked from the main IETF site. The site will contain FAQs about the program and web forms that allow people to sign up to be mentors or to…

during the IAB retreat, the point was brought up that it would be helpful that mentors could recall their first exposure to the IETF clearly, i.e., maybe not the folks who have been coming for 20 years. But we don't need to have a hard rule here, we can just take this into account when we do the matching.

>> IETF registration is already open. Our thinking was that we can start soliciting mentors any time by sending a message to IETF-Announce. Suggested text for that is included below. Once registratio…

As I said during the retreat, I think a personalized message from the IETF chair to each individual potential protege would probably look better than (just) an email to the attendee list (which not all are on anyway). Being offered a mentor needs to be seen as something of value, which is more strongly conveyed in a message sent in Jari's name IMO.

> I'm not sure we would need the whole set before we started matching - maybe we have, and advertise, a date at which we would start
> (to drive early signup), but do matching up to and at the IETF meeting? I would suggest that start date be 1 or two weeks before the -00 deadline.

Sounds reasonable.

> It's dangerous to build too much tool when you're still trying to figure out what you really want to be doing - it can cause you to accidentally get stuck with a behavior you don't really need. I would strongly suggest just starting with a wiki and more manual effort than you want in the long run until we know what a tool really needs to help with.

+1 on this, a (private) wiki is fine

>> Whether you want to stick to 1:1 matches or allow some 1:more-than-1 is up to you and might depend on who you get signed up in both groups.

IMO 1:1 makes the most sense, except for corner cases (two new attendees from the same company interested in the same topic, etc.)

>> Brian and I have also discussed opportunities to help mentors and protégés meet at the beginning of IETF week, perhaps in designated areas at the newcomers' meet-and-greet. We're still mulling tha…

Definitely at the newcomer's beer. Maybe they can open 30 min early for mentors and proteges?

> When in doubt, fail open.

No problem with that.

>>     Based on discussions during IETF 86, we are trialing an IETF mentoring program.  During this trial period, we would like to pair those who are new to the IETF (people who have attended 3 or fewer meetings) with existing IETF participants.  The goal is to provide a resource for the new people who can assist them with integrating into the

s/a resource/a contact person/

>> IETF community.  Mentors and protégés (who express an interest in being mentored) will be paired prior to IETF 87. We cannot guarantee that every mentor or protégé will be matched, but we'll do our best. If the trial goes well, there may be a variety of ways to expand the program in the future.
>> 

I think we want to say a bit more than just "the actual level of interaction will be driven by an agreement between the mentor and the mentee". We can say that examples of mentoring include accompanying the mentee during the week, introducing them to folks they want to meet, explaining what's going on both in session and elsewhere, taking them to dinners, etc.

> On the signup forms - consider asking both mentors and protoges (I'm worried how the community will react to the term btw) are active in any other SDOs, and if they have any non-IETF activities they are passionate about.

+1 on the term protege, but mentee is also bad. We need a good term here that sounds selective. (I want proteges to be able to say to their bosses "I got picked for this special thing, so you should send me again")

Lars

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 15 May 2013 11:39:36 -0400

> sounds reasonable, how many mentorees are we expecting?

No idea. We'll know better after this trial!

So, let's say July 1 for start date?

>> It's dangerous to build too much tool when you're still trying to figure out what you really want to be doing - it can cause you to accidentally get stuck with a behavior you don't really need. I…

Alright, will let the secretariat know.

>> When in doubt, fail open.

Sounds good. In that case I think it would make sense to include your names in the mentor solicitation below.

Alissa

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 15 May 2013 11:41:05 -0400

>> On the signup forms - consider asking both mentors and protoges (I'm worried how the community will react to the term btw) are active in any other SDOs, and if they have any non-IETF activities th…

We have gone around a few times on the term for people being mentored -- "mentees," "proteges," "newcomers." None of them seem quite right. Send suggestions if you have them.

Agree on asking about other SDOs and non-IETF activities.

Alissa

---

From: Robert Sparks <[email-masked]>
Date: Wed, 15 May 2013 12:43:40 -0500

> We have gone around a few times on the term for people being mentored -- "mentees," "proteges," "newcomers." None of them seem quite right. Send suggestions if you have them.
Brainstorming (assisted by a random walk through a few thesaurus sites):

rookie, tenderfoot, enthusiast, scholar, learner

(fwiw - several sites went out of their way to show different gender 
forms for protégé)

---

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 16 May 2013 07:01:59 +0000

> rookie, tenderfoot, enthusiast, scholar, learner

talent
newbie
hopeful
fellow
trainee

Another thought: For new hires at NetApp, we assign a buddy. Both the mentor and the protege are simply called buddies. It's kinda nice, because it implies some sort of equivalence between the two rather than a hierarchy.

Lars

---

From: Leif Johansson <[email-masked]>
Date: Thu, 16 May 2013 10:19:47 +0200

> Another thought: For new hires at NetApp, we assign a buddy. Both the mentor and the protege are simply called buddies. It's kinda nice, because it implies some sort of equivalence between the two…
The social context of an employee is quite different from that of an IETF
"greenhorn". I think we want to avoid terms that could have (even the
slightest) perojative connotation.

        MVH leifj

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 16 May 2013 09:28:13 -0400

What if we just call them participants? We could have mentors and mentoring participants.

---

From: Leif Johansson <[email-masked]>
Date: Thu, 16 May 2013 15:37:45 +0200

> What if we just call them participants? We could have mentors and mentoring participants.

good & simple

---

From: Ralph Droms <[email-masked]>
Date: Thu, 16 May 2013 09:45:59 -0400

>> What if we just call them participants? We could have mentors and mentoring participants.

I agree ... I haven't been able to come up with a better alternative.  

- Ralph

---

From: Ralph Droms <[email-masked]>
Date: Thu, 16 May 2013 09:48:33 -0400

> So, let's say July 1 for start date?

Sounds fine.  

>>> It's dangerous to build too much tool when you're still trying to figure out what you really want to be doing - it can cause you to accidentally get stuck with a behavior you don't really need. I…

Me, too...

>>> When in doubt, fail open.

I agree.

- Ralph

---

From: Ronald Bonica <[email-masked]>
Date: Thu, 16 May 2013 13:51:37 +0000

+1

Teachers and students are people who learn together!

                        Ron

> -----Original Message-----
> From: [email-masked] [mailto:mentoring-
> [email-masked]] On Behalf Of Eggert, Lars
> Sent: Thursday, May 16, 2013 3:02 AM
> To: Robert Sparks
> Cc: <[email-masked]>; Alissa Cooper
> Subject: Re: [Mentoring-coordinators] Kicking off mentoring-
> coordinators
> 
> Another thought: For new hires at NetApp, we assign a buddy. Both the
> mentor and the protege are simply called buddies. It's kinda nice,
> because it implies some sort of equivalence between the two rather than
> a hierarchy.
> 
> Lars

---

From: Ralph Droms <[email-masked]>
Date: Thu, 16 May 2013 09:55:48 -0400

> during the IAB retreat, the point was brought up that it would be helpful that mentors could recall their first exposure to the IETF clearly, i.e., maybe not the folks who have been coming for 20 y…

Interesting point.  I can clearly remember my first exposure to the IETF (which was more than 20 years ago), and it's either clearly irrelevant and OBE, or gives us a model for 1x1 introductions in the future...

At the time I first started in the IETF (1989), Phill Gross was IETF Chair.  He had been a grad student TA for me a decade earlier, and we stayed in touch.  When the DHCP problem came along, he suggested I might find it interesting, and we formed the dhc WG.

On the one hand, it's not likely anyone coming to the IETF now will have been a grad student with a current IETF chair.  On the other hand, it was that 1x1 relationship and introduction that drove my engagement at the WG chair level.

- Ralph

>>> [...]