Subject: [MEXT] reduce mobility header size

From: "Hampel, K Georg (K Georg)" <[email-masked]>
Date: Thu, 20 Jan 2011 19:27:36 -0600

All,

Is there currently any effort to reduce the mobility header size in route optimization? Thanks.

Georg Hampel

---

From: [email-masked] (Arnaud Ebalard)
Date: Fri, 21 Jan 2011 09:04:02 +0100

Hi,

> route optimization? Thanks.

Do you mean the presence of RH2 and HAO in DestOpt in the packets?

If you intend *to use IPsec/IKE between the peers*, I proposed a
solution to remove RH2 and HAO in DestOpt from packets and also the
need for HoTI/HoT in the following draft: 

  http://tools.ietf.org/html/draft-ebalard-mext-ipsec-ro-02

For a simple introduction (description, advantages, drawbacks), 

  http://natisbad.org/IRO/

Cheers,

a+

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 21 Jan 2011 15:58:02 +0100

HEllo,

Generally speaking it is a very good intention to reduce the mobility
header size as much as possible.

For IPv6 the problem is all the more important knowing the addresses are
4 times longer than IPv4.

But also in IPv4 there are intentions to reduce the headers during
Mobile IPv4 handovers (e.g. handover from NAT to non-NAT should use the
smaller header).

When you say "reduce MH size in RO" do you mean the headers of the
Return Routability tests?  Or the headers of data direct path
communication after RR was performed?

Alex

Le 21/01/2011 02:27, Hampel, K Georg (K Georg) a écrit :
> _______________________________________________ MEXT mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/mext

---

From: "Hampel, K Georg (K Georg)" <[email-masked]>
Date: Fri, 21 Jan 2011 10:16:18 -0600

Hi,

To clarify my prior question: I'm referring to the size of RH2 and HOA headers that are carried on traffic packets during route optimization when MN does not reside in its home network.

I agree with Arnaud's comment that RH2 and HOA can be dropped when peers sustain an IPsec-protected traffic connection.

May concern are traffic connections WITHOUT IPsec protection. This applies to the vast majority of mobile internet traffic. The additional 24B (or 48B if both peers are mobile) for RH2 and/or HOA represent a burden on wireless connections. In principle, the IP addresses carried in these headers could be replaced by a hash or a session identifier. This, of course, creates middle-box traversal issues.

Has this issue been worked somewhere? 

Thanks.

Georg Hampel

-----Original Message-----
From: Arnaud Ebalard [mailto:[email-masked]] 
Sent: Friday, January 21, 2011 3:04 AM
To: Hampel, K Georg (K Georg)
Cc: [email-masked]; Klein, Thierry E (Thierry)
Subject: Re: [MEXT] reduce mobility header size

Hi,

  http://natisbad.org/IRO/

Cheers,

a+

---

From: "Laganier, Julien" <[email-masked]>
Date: Fri, 21 Jan 2011 18:03:23 +0000

There was a draft:

http://tools.ietf.org/html/draft-haddad-mip6-tunneling-optimization-01

--julien

From: [email-masked] [mailto:[email-masked]] On Behalf Of Hampel, K Georg (K Georg)
Sent: Thursday, January 20, 2011 5:28 PM
To: [email-masked]
Cc: Klein, Thierry E (Thierry)
Subject: [MEXT] reduce mobility header size

All,

Georg Hampel

---

From: "Hampel, K Georg (K Georg)" <[email-masked]>
Date: Thu, 27 Jan 2011 13:21:52 -0600

All,

RFC 3775 makes RH2 and HAO headers on payload packets only a SHOULD requirement! It doesn't provide any regulation on how MN/CN should proceed when such headers are missing.

When omitting these headers, the packet looks like an ordinary transport packet on the wire, but it carries an INCORRECT transport header checksum. This means that certain middle boxes may discard the packet which is undesirable.

I therefore propose the following:

1) In RO, a sending host MAY omit HAO and RH2 headers on payload packets.

2) When omitting these headers, the checksum of the lowest transport header MUST be matched to the actual IP header of the packet, i.e. the pseudo header must be based on CoA rather than HoA.

3) In case the transport protocol is ESP or AH, the host MUST proceed according to: http://tools.ietf.org/html/draft-ebalard-mext-ipsec-ro-02.

This means that the sending host must recompute the transport-header checksum of packets it receives from the transport layer. The receiving host searches the binding entries based on the packet's on-the-wire IP addresses (i.e. CoA instead of HoA). If such an entry exists, the host recomputes the checksum using the HoA from this entry before passing the packet up to the transport layer.
In this manner, the higher protocol layers don't feel disturbed and middle-box collisions are avoided!

Regards,
-Georg

-----Original Message-----
From: Arnaud Ebalard [mailto:[email-masked]] 
Sent: Friday, January 21, 2011 3:04 AM
To: Hampel, K Georg (K Georg)
Cc: [email-masked]; Klein, Thierry E (Thierry)
Subject: Re: [MEXT] reduce mobility header size

Hi,

  http://natisbad.org/IRO/

Cheers,

a+