Subject: RE: [MIB-DOCTORS] RE: SNMP MIBs and IETF standards track work

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Tue, 7 Nov 2006 21:13:57 +0200

I apologize for the confusion. 

The problem with the message in the quote under the new and accurate
interpretation is that it does not apply to all protocols developped in
the IETF. Some WGs consider that SNMP does not fit their requirements,
especially for configuration operations. Mandating a MIB module and
support for SNMP is not applicable in some cases and in other prevents a
real discussion about manageability requirements. 

Dan

> -----Original Message-----
> From: David B Harrington [mailto:[email-masked]] 
> Sent: Tuesday, November 07, 2006 9:00 PM
> To: Romascanu, Dan (Dan); 'Natale, Bob'
> Cc: 'MIB Doctors'; [email-masked]
> Subject: RE: [MIB-DOCTORS] RE: SNMP MIBs and IETF standards track work
> 
> Hi Dan,
> 
> The comment you quote was from me, not Randy. 
> "as a condition of standards-track advancement" was meant to 
> include advancement to Proposed Standard, not just 
> advancement to Draft and Full Standard status.
> 
> dbh
> 
> > -----Original Message-----
> > From: Romascanu, Dan (Dan) [mailto:[email-masked]]
> > Sent: Tuesday, November 07, 2006 10:51 AM
> > To: Natale, Bob
> > Cc: MIB Doctors; [email-masked]
> > Subject: [MIB-DOCTORS] RE: SNMP MIBs and IETF standards track work
> > 
> > Obviously my statement needs clarification. I was responding to the 
> > following text by Randy
> > 
> > > > However, I believe that MIB modules and support for SNMP should 
> > > > continue to be required as a condition of IETF standards-track 
> > > > advancement until suitable alternative solutions are
> > completed and
> > > > available.
> > > ...
> > 
> > And referring to the fact that the MIB documents themselves seldom
> if
> > never get beyond Proposed Standard stage ('advance on the
> > standards-track') nowadays. 
> > 
> > But maybe I was the one who mis-understood Randy's intention? 
> > 
> > Dan
> > 
> > 
> >  
> >  
> > 
> > > -----Original Message-----
> > > From: Natale, Bob [mailto:[email-masked]]
> > > Sent: Tuesday, November 07, 2006 8:33 PM
> > > To: Romascanu, Dan (Dan)
> > > Cc: MIB Doctors; [email-masked]
> > > Subject: SNMP MIBs and IETF standards track work
> > > 
> > > Hi Dan,
> > > 
> > > > -----Original Message-----
> > > > From: Romascanu, Dan (Dan) [mailto:[email-masked]]
> > > > Sent: Monday, November 06, 2006 9:18 PM ...
> > > > I believe that there is no real problem here, as the
> > number of MIB
> > > > documents that I saw advancing on the standards-track lately is
> as
> > > low
> > > > as zero. 
> > > 
> > > Hmmm.  Perhaps I am mis-interpreting your statement above, but a 
> > > quick scan of the I-D database for anything with "mib"
> > > in the title returns
> > > 71 active entries.  A fair number of those appear to be 
> intended for 
> > > the standards track.  A large percentage of the remainder, IMHO, 
> > > probably should be.  A number of these MIBs seem to address 
> > > current/important/exciting capabilities.
> > > 
> > > Perhaps we in the O&M Area have not been as enthusiastic and 
> > > energetic about promoting standard MIBs in the recent past as we 
> > > were at one time...?
> > > 
> > > [FWIW: It has been my view for a long time -- clearly 
> unsupported by 
> > > community consensus -- that "richer" MIBs are the missing 
> ingredient 
> > > to continuing and expanding the success of SNMP.  Richer 
> MIBs would 
> > > leverage the cumulative effects of Moore's Law, control plane 
> > > evolution, and community experience via more capable SNMP agents 
> > > that would focus on "higher-order" management constructs (such as 
> > > templates, profiles, policies, services, operations, and so
> > > forth) exposed via those MIBs.]
> > > 
> > > I recognize (and contribute to, in non-IETF venues) the 
> > > multi-protocol world we live and work in today...it is a 
> promising 
> > > but clearly unsettled environment.  In the meantime (and as Randy 
> > > suggested), critical networks need solid interoperable 
> management.  
> > > That SNMP is still a contender for that role is more a 
> testament to 
> > > its early strengths and vast deployment than to any recent 
> > > shepherding on our part.
> > > 
> > > True, both of those pluses are fast diminishing in the
> marketplace.
> > > Whether we should just let that happen without a viable 
> successor in 
> > > place is, IMHO, an important matter for the community to decide.
> > > Perhaps we have already decided (in the affirmative) by
> default...?
> > > 
> > > Cheers,
> > > BobN
> > > 
> > 
> > _______________________________________________
> > MIB-DOCTORS mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/mib-doctors
> > 
> 
> 

_______________________________________________
MIB-DOCTORS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mib-doctors

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 7 Nov 2006 21:01:42 -0800

Hi -

> From: "Romascanu, Dan (Dan)" <[email-masked]>
> To: "David B Harrington" <[email-masked]>; "Natale, Bob" <[email-masked]>
> Cc: "MIB Doctors" <[email-masked]>; <[email-masked]>
> Sent: Tuesday, November 07, 2006 11:13 AM
> Subject: [OPS-NM] RE: [MIB-DOCTORS] RE: SNMP MIBs and IETF standards trackwork
...
>  Some WGs consider that SNMP does not fit their requirements,
...

What protocol(s) and management information model(s) are these
WGs using?  Or are they just arguing that since SNMP and MIBs
aren't perfect, it's better to do nothing?

Randy