Subject: [MIB-DOCTORS] Connectivity Fault Management MIB

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Wed, 15 Nov 2006 00:09:38 +0200

The IEEE 802.1 P802.1ag/D7.1 - Connectivity Fault Management is running
a recirculation ballot. 

The full standard draft is available at: 

http://www.ieee802.org/1/files/private/ag-drafts/d7/802-1ag-d7-1.pdf

The MIB module in txt format is available at: 

http://www.ieee802.org/1/files/private/ag-drafts/d7/8021ag71.mib

Please review and provide comments until 11/23 to me, Bert, or the IEEE
802.1 WG e-mail list. 

Folks who need the IEEE Web site username and password for the purpose
of reviewing these documents are invited to approach me or Bert. 

Dan

_______________________________________________
MIB-DOCTORS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mib-doctors

---

From: "Alex Rozin" <[email-masked]>
Date: Wed, 15 Nov 2006 08:34:57 +0200

Please provide clarifications for the IEEE8021-CFM-MIB in .1ag:

1. If dot1agCfmStackMepId==0 (a MEP is not configured on an interface),  what
value does index dot1agCfmMdIndex have in dot1agCfmStackTable?

2. Why the index, for example, in dot1agCfmMdTable is an single integer
one (dot1agCfmMdIndex) and not a pair {dot1agCfmMdFormat, dot1agCfmMdName}?
In this case we will not need the object dot1agCfmMdTableNextIndex, etc.

3. The same concerns dot1agCfmMaIndex vs. {dot1agCfmMaFormat, dot1agCfmMaName}. In another words, why cannot we index 
dot1agCfmMaTable by index {dot1agCfmMdFormat, dot1agCfmMdName, dot1agCfmMaFormat, dot1agCfmMaName}?

4. Why do we have both the field dot1agCfmMaMoreThanOneVid and a special interval for dot1agCfmMaIndex to reflect a association with VLAN? IMHO simpler method is to have in this table number of VLANs, that may be 0.

5. In the Table 17-1 object dot1agCfmMdIndex is referred to 12.14.2.1.2:b, but 12.14.2.1.2:b describes "An MD Level". Could you use integer index dot1agCfmStackLevel instead? 

Thanks, Alex

-----Original Message-----
From: Romascanu, Dan (Dan) [mailto:[email-masked]]
Sent: Wednesday, November 15, 2006 12:10 AM
To: MIB Doctors; Bridge-Mib (E-mail)
Subject: [Bridge-mib] Connectivity Fault Management MIB 

Dan

_______________________________________________
Bridge-mib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bridge-mib

**********************************************************************************************************************

The information contained in this e-mail message and its attachments is privileged and confidential, and is protected from unauthorized use or dissemination or by intellectual property rights. The information is intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify MRV immediately by telephone, or by e-mail and delete the message from your computer.

Thank you!

************************************************************************************************************

************************************************************************************
This footnote confirms that this email message has been scanned by
PineApp Mail-SeCure for the presence of malicious code, vandals & computer viruses.
************************************************************************************

---

From: "Alex Rozin" <[email-masked]>
Date: Sun, 19 Nov 2006 12:41:26 +0200

1. Norman Finn wrote:
> 4. The Stack Table will be revised to have the interface number, MD
> Level, VLAN ID or zero, and direction as inputs, and  produce
> Maintenance Domain index, MA index, MEPID (or 0 for MIPs) as outputs.

To my understanding, there cannot be more that one Maintenance Domains
with the same MD Level on a single Bridge. Am I right? 

2. Providing a single Bridge cannot have more than one Maintenance Domain 
with the same MD Level, then can you index the table dot1agCfmMdTable by
dot1agCfmMdLevel? In this case you don't need additional arbitrary integer
index dot1agCfmMdIndex neither dot1agCfmMdTableNextIndex. I offer 
to replace dot1agCfmMdIndex by dot1agCfmMdLevel in all relevant tables, for
example in dot1agCfmMaTable.

3. Now let's consider dot1agCfmMaTable. If the first index of this table is
dot1agCfmMdLevel, then you could use the pair {dot1agCfmMaFormat, dot1agCfmMaName}
as a second and third indexes: maximum length of index would be 1+1+1+45=48, not so
VERY long OIDs. Note that, for example, in 
DISMAN-PING-MIB (http://www.simpleweb.org/ietf/mibs/modules/IETF/txt/DISMAN-PING-MIB)
maximum index in pingCtlTable is 1+32+1+32=66.

So, the MIB would not need complex, unnatural objects dot1agCfmMdTableNextIndex
and dot1agCfmMaTableNextIndex neither type Dot1afCfmIndexIntegerNextFree; referential
integrity of tables would be provided automatically, issues of the index reusage,  increasing
and wrapping around.

4. The natural demands should be formulated:
a) When an entry in the dot1agCfmMdTable is deleted, all relevant entries in
dot1agCfmMaTable must be deleted as well, and
b)  When an entry in the dot1agCfmMaTable is deleted, all relevant entries
in dot1agCfmMepTable (etc.) must be deleted.

5. If the WG continue to use the arbitrary integer index dot1agCfmMdIndex with different
ranges for associated and not-associated, then instead of a single object dot1agCfmMaTableNextIndex
two objects must be defined, one per a such range, let us say:
dot1agCfmMaTableVlanedNextIndex (0, 1..4094) and 
dot1agCfmMaTableNonVlanedNextIndex (0, 16777217..4294967295).

And what is more, why second indexes in dot1agCfmMaEntry cannot be repeated inside
different domains? In other words object dot1agCfmMaTableNextIndex should be per MD.

Thanks, Alex