Subject: [MIB-DOCTORS] FW: Documents on IESG Telechat Agenda for March 8, 2007

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Fri, 2 Mar 2007 10:56:21 +0200

Please see below the documents on the agenda for next IESG telechat.
Please note that there are several MIB documents on the agenda this
time. I would appreciate if you can send me your reviews and comments by
Wednesday, March 7, 2007 COB. 

Thanks and Regards,

Dan

2. Protocol Actions
	Reviews should focus on these questions: "Is this document a
	reasonable basis on which to build the salient part of the
Internet
	infrastructure? If not, what changes would make it so?"

2.1 WG Submissions
2.1.1 New Item
  o draft-ietf-ccamp-crankback-06.txt
    Crankback Signaling Extensions for MPLS and GMPLS RSVP-TE (Proposed 
    Standard) - 1 of 12 
    Token: Ross Callon
  o draft-ietf-hubmib-efm-mib-06.txt
    Definitions and Managed Objects for OAM Functions on Ethernet Like 
    Interfaces (Proposed Standard) - 2 of 12 
    Note: Bert Wijnen is the PROTO shepherd 
    Token: Dan Romascanu
  o draft-ietf-idr-avoid-transition-04.txt
    Avoid BGP Best Path Transitions from One External to Another
(Proposed 
    Standard) - 3 of 12 
    Note: Last Call ends 2007-03-12 
    Token: Bill Fenner
  o draft-ietf-pim-sm-bsr-10.txt
    Bootstrap Router (BSR) Mechanism for PIM (Proposed Standard) - 4 of
12 
    Note: Last Call ends 2007-03-12 
    Token: Bill Fenner
  o draft-ietf-avt-hc-over-mpls-protocol-08.txt
    Protocol Extensions for Header Compression over MPLS (Proposed
Standard) - 
    5 of 12 
    Note: PROTO Shepherd is Colin Perkins. 
    Token: Cullen Jennings
  o draft-ietf-rohc-tcp-16.txt
    RObust Header Compression (ROHC): A Profile for TCP/IP (ROHC-TCP)
(Proposed 
    Standard) - 6 of 12 
    Token: Magnus Westerlund
  o draft-ietf-webdav-rfc2518bis-18.txt
    HTTP Extensions for Distributed Authoring - WebDAV (Proposed
Standard) - 7 
    of 12 
    Token: Ted Hardie
  o draft-ietf-sip-connected-identity-05.txt
    Connected Identity in the Session Initiation Protocol (SIP)
(Proposed 
    Standard) - 8 of 12 
    Note: Keith Drage is the document PROTO shepherd 
    Token: Cullen Jennings
  o draft-ietf-imss-fc-zs-mib-03.txt
    Fibre-Channel Zone Server MIB (Proposed Standard) - 9 of 12 
    Token: Dan Romascanu
  o draft-ietf-imss-fc-rscn-mib-02.txt
    Fibre Channel Registered State Change Notification (RSCN) MIB
(Proposed 
    Standard) - 10 of 12 
    Token: Dan Romascanu
  o draft-ietf-imss-fc-fcs-mib-02.txt
    Fibre-Channel Fabric Configuration Server MIB (Proposed Standard) -
11 of 
    12 
    Token: Dan Romascanu
  o draft-ietf-eap-keying-18.txt
    Extensible Authentication Protocol (EAP) Key Management Framework
(Proposed 
    Standard) - 12 of 12 
    Token: Jari Arkko

2.1.2 Returning Item
  o draft-ietf-mpls-ecmp-bcp-03.txt
    Avoiding Equal Cost Multipath Treatment in MPLS Networks (BCP) - 1
of 1 
    Token: Ross Callon

2.2 Individual Submissions
2.2.1 New Item
  o draft-bellovin-useipsec-06.txt
    Guidelines for Mandating the Use of IPsec (BCP) - 1 of 5 
    Token: Russ Housley
  o draft-siemborski-rfc2554bis-08.txt
    SMTP Service Extension for Authentication (Proposed Standard) - 2 of
5 
    Token: Lisa Dusseault
  o Five-document ballot:  - 3 of 5
     - draft-legg-xed-rxer-07.txt
       Robust XML Encoding Rules (RXER) for Abstract Syntax Notation One

       (ASN.1) (Proposed Standard) 
     - draft-legg-xed-rxer-ei-04.txt
       Encoding Instructions for the Robust XML Encoding Rules (RXER)
(Proposed 
       Standard) 
     - draft-legg-xed-asd-07.txt
       Abstract Syntax Notation X (ASN.X) (Proposed Standard) 
     - draft-legg-xed-asd-gserei-03.txt
       Abstract Syntax Notation X (ASN.X) Representation of Encoding 
       Instructions for the Generic String Encoding Rules (GSER)
(Proposed 
       Standard) 
     - draft-legg-xed-asd-xerei-03.txt
       Abstract Syntax Notation X (ASN.X) Representation of Encoding 
       Instructions for the XML Encoding Rules (XER) (Proposed Standard)

    Token: Ted Hardie
  o draft-mcwalter-langtag-mib-02.txt
    Language Tag MIB (Proposed Standard) - 4 of 5 
    Token: Bill Fenner
  o draft-mcwalter-uri-mib-03.txt
    Uniform Resource Identifier (URI) MIB (Proposed Standard) - 5 of 5 
    Token: Bill Fenner

2.2.2 Returning Item
NONE

3. Document Actions

3.1 WG Submissions
	Reviews should focus on these questions: "Is this document a
reasonable
	contribution to the area of Internet engineering which it
covers? If
	not, what changes would make it so?"

3.1.1 New Item
  o draft-ietf-opes-smtp-security-03.txt
    Integrity, privacy and security in OPES for SMTP (Informational) - 1
of 5 
    Token: Ted Hardie
  o draft-ietf-pce-pcecp-interarea-reqs-05.txt
    PCE Communication Protocol (PCECP) Specific Requirements for
Inter-Area 
    Multi Protocol Label Switching (MPLS) and Generalized MPLS (GMPLS)
Traffic 
    Engineering (Informational) - 2 of 5 
    Token: Ross Callon
  o draft-iesg-sponsoring-guidelines-01.txt
    Guidance on Area Director Sponsoring of Documents (Informational) -
3 of 5 
    Note: Decided on 2007-01-25 to make this an RFC not an ION, but Last
Call 
    comments have reopened that question. 
    Token: Brian Carpenter
  o draft-ietf-dnsop-serverid-08.txt
    Requirements for a Mechanism Identifying a Name Server Instance 
    (Informational) - 4 of 5 
    Note: Peter Koch &lt;[email-masked]&gt; is the document shepherd 
    Token: David Kessens
  o draft-ietf-v6ops-natpt-to-historic-00.txt
    Reasons to Move NAT-PT to Historic Status (Informational) - 5 of 5 
    Token: David Kessens

3.1.2 Returning Item
NONE

3.2 Individual Submissions Via AD
	Reviews should focus on these questions: "Is this document a
reasonable
	contribution to the area of Internet engineering which it
covers? If
	not, what changes would make it so?"

3.2.1 New Item
NONE
3.2.2 Returning Item
NONE
3.3 Independent Submissions Via RFC Editor
	The IESG will use RFC 3932 responses: 1) The IESG has not
	found any conflict between this document and IETF work; 2) The
	IESG thinks that this work is related to IETF work done in WG
	<X>, but this does not prevent publishing; 3) The IESG thinks
	that publication is harmful to work in WG <X> and recommends
	not publishing at this time; 4) The IESG thinks that this
	document violates the IETF procedures for <X> and should
	therefore not be published without IETF review and IESG
	approval; 5) The IESG thinks that this document extends an
	IETF protocol in a way that requires IETF review and should
	therefore not be published without IETF review and IESG
approval.

	Other matters may be recorded in comments to be passed on
	to the RFC Editor as community review of the document.

3.3.1 New Item
  o draft-blanchet-v6ops-tunnelbroker-tsp-03.txt
    IPv6 Tunnel Broker with the Tunnel Setup Protocol (TSP)
(Experimental) - 1 
    of 1 
    Note: See 'IESG Note' section for proposed RFC 3932 response. 
    Token: David Kessens

3.3.2 Returning Item
NONE
3.3.3 For Action
  o draft-ooms-xcast-basic-spec-11.txt
    Explicit Multicast (Xcast) Concepts and Options (Experimental) - 1
of 1 
    Token: Brian Carpenter

_______________________________________________
MIB-DOCTORS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mib-doctors

---

From: "Wijnen, Bert \(Bert\)" <[email-masked]>
Date: Fri, 2 Mar 2007 17:57:31 +0100

I have looked at 

   draft-mcwalter-langtag-mib-02.txt

and that one seems fine.

I also looked at 

  draft-mcwalter-uri-mib-03.txt

and I worry a bit: 
All 3 TCs speak about use of these TCs as an index 
(or indexes; I though the plural is indices; but who is me).

Anyway, if they are (often) used as an index, it may be wise to 
add some text that explains that
- there is an absolute limit of 128 subids for an OID
- even if the length is such that an OID is within 128 subids, 
  it is not very efficient to have (very) long OIDs, so it is not
  very efficient to have an index of a URI that is up to say 120
  octets. 

Maybe we need a URIforIndexing TC that does LIMIT the size to
at most 128, probably better to limit it to 120 or 100 or so).
And in the DESCRIPTION clause of that one make it very clear why the
SIZE restrictions are as they are what the impact is of very long OIDs
(or indices).

Bert

> -----Original Message-----
> From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
> Sent: vrijdag 2 maart 2007 9:56
> To: MIB Doctors (E-mail); [email-masked]; [email-masked]
> Subject: [MIB-DOCTORS]FW: Documents on IESG Telechat Agenda 
> for March 8, 2007
> 
> 
> 
> Please note that there are several MIB documents on the 
> agenda this time. I would appreciate if you can send me your 
> reviews and comments by Wednesday, March 7, 2007 COB. 
> 
> Thanks and Regards,
> 
> Dan
> 
> 
> 
> 
> 2. Protocol Actions
> 	reasonable basis on which to build the salient part of 
> the Internet
>     Avoid BGP Best Path Transitions from One External to 
> Another (Proposed 
>     Standard) - 3 of 12 
>     RObust Header Compression (ROHC): A Profile for TCP/IP 
> (ROHC-TCP) (Proposed 
>     Standard) - 6 of 12 
>     Token: Magnus Westerlund
>     Connected Identity in the Session Initiation Protocol 
> (SIP) (Proposed 
>     Standard) - 8 of 12 
>     Fibre Channel Registered State Change Notification (RSCN) 
> MIB (Proposed 
>     Standard) - 10 of 12 
>     Token: Dan Romascanu
>     Extensible Authentication Protocol (EAP) Key Management 
> Framework (Proposed 
>     Standard) - 12 of 12 
>     Token: Jari Arkko
> 
> 2.1.2 Returning Item
>     Avoiding Equal Cost Multipath Treatment in MPLS Networks 
> (BCP) - 1 of 1 
>     Token: Ross Callon
> 
> 
>        Encoding Instructions for the Robust XML Encoding 
> Rules (RXER) (Proposed 
>        Standard) 
>        Instructions for the Generic String Encoding Rules 
> (GSER) (Proposed 
>        Standard) 
> 	Reviews should focus on these questions: "Is this 
> document a reasonable
> 	contribution to the area of Internet engineering which 
> it covers? If
>     Integrity, privacy and security in OPES for SMTP 
> (Informational) - 1 of 5 
>     Token: Ted Hardie
>     PCE Communication Protocol (PCECP) Specific Requirements 
> for Inter-Area 
>     Multi Protocol Label Switching (MPLS) and Generalized 
> MPLS (GMPLS) Traffic 
>     Note: Decided on 2007-01-25 to make this an RFC not an 
> ION, but Last Call 
> 	Reviews should focus on these questions: "Is this 
> document a reasonable
> 	contribution to the area of Internet engineering which 
> it covers? If
>     Explicit Multicast (Xcast) Concepts and Options 
> (Experimental) - 1 of 1 
>     Token: Brian Carpenter
> 
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 2 Mar 2007 18:44:54 +0100

> SIZE restrictions are as they are what the impact is of very long OIDs

I suggest to define TCs once we know at least one use case. You
can always limited the size so it is unclear that we need a common
size limit or what that should be (we will simply introduce an
arbitrary limit). And as a matter of fact, I see many URL these
days that are actually longer than 100 octets so I believe this
really has to be dealt with by designing MIBs so that they avoid
using URIs as indexes.

/js

-- 
Juergen Schoenwaelder		 Jacobs University Bremen
<http://www.eecs.iu-bremen.de/>	 P.O. Box 750 561, 28725 Bremen, Germany