Subject: [MIB-DOCTORS] Call for volunteers for MIB DR review for PWE MIB documents

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 10 Jun 2007 07:44:09 +0200

This is the second call for a volunteer to perform MIB Doctor reviews on
the PW ATM and TDM MIB modules in PWE3. The documents seem to be in good
shape, they passed WGLC and are authored by Orly, but certainly having
them looked at by an independent MIB doctor pair of eyes would help. 

http://ietf.org/internet-drafts/draft-ietf-pwe3-pw-atm-mib-03.txt

http://ietf.org/internet-drafts/draft-ietf-pwe3-tdm-mib-08.txt

Thanks and Regards,

Dan

_______________________________________________
MIB-DOCTORS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mib-doctors

---

From: "Wijnen, Bert \(Bert\)" <[email-masked]>
Date: Mon, 11 Jun 2007 15:27:10 +0200

Dan, I am not sure I will find time to do a proper review before my
vacation, 
and when I get back from vacation I have only a few days before I start
traveling
to IEEE 802.1 meeting and IETF. SO I won't be able to dig into details.
 
But probably a good review is needed.
 
I see that these MIB modules import from various other pwe3 WG MIB
documents,
for which I believe there is no IETF LC yet?
 
One thing I see in draft-ietf-pwe3-pw-atm-mib-03.txt is:

    pwAtmOutboundNto1Vpi OBJECT-TYPE
       SYNTAX        AtmVpIdentifier
       MAX-ACCESS    not-accessible
       STATUS        current
       DESCRIPTION
           "VPAtmVpIdentifier
I value of this ATM PW. In atmTransparent(3),
            Vpi will be the equivalent of 0xFFFFFFFF"
      ::= { pwAtmOutboundNto1Entry 2 }

   pwAtmOutboundNto1Vci OBJECT-TYPE
       SYNTAX        AtmVcIdentifier
       MAX-ACCESS    not-accessible
       STATUS        current
       DESCRIPTION
           "VCI value of this ATM PW. In atmTransparent(3), or
            VP case, the value will be the equivalent of
            0xFFFFFFFF"
       ::= { pwAtmOutboundNto1Entry 3 }
 
Both TCs do NOT allow for a value of 0xFFFFFFFF
 
same for pwAtmInboundNto1MappedVpi and pwAtmInboundNto1MappedVci
 
for
  pwAtmPerfIntervalNumber OBJECT-TYPE
    SYNTAX        Unsigned32
    MAX-ACCESS    not-accessible
    STATUS        current
    DESCRIPTION
        "A number (normally between 1 and 96 to cover a 24 hour
         period) which identifies the interval for which the set
         of statistics is available. The interval identified by 1
         is the most recently completed 15 minute interval, and
         the interval identified by N is the interval immediately
         preceding the one identified by N-1. The minimum range of
         N is 1 through 4. The default range is 1 through 32. The
         maximum value of N is 1 through 96."
    ::= { pwAtmPerfIntervalEntry 1 }
 
It seems to me that the SYNTAX should be  UNSIGNED32 (1..96)
 
For
  pwAtmPerfIntervalDuration OBJECT-TYPE
     SYNTAX      Unsigned32
     MAX-ACCESS  read-only
     STATUS      current
     DESCRIPTION
       "The duration of a particular interval in seconds,
        Adjustments in the system's time-of-day clock, may
        cause the interval to be greater or less than, the
        normal value. Therefore this actual interval value
        is provided."
     ::= { pwAtmPerfIntervalEntry 3 }
 
It seems that I would add a UNITS "seconds" clause
 
>From the following DESCRIPTION clause
  pwAtmPerf1DayIntervalNumber OBJECT-TYPE
    SYNTAX        Unsigned32
    MAX-ACCESS    not-accessible
    STATUS        current
    DESCRIPTION
        "The number of interval, where 1 indicates current day
         measured period and 2 and above indicate previous days
         respectively"
    ::= { pwAtmPerf1DayIntervalEntry 1 }

I get the impression that zero is not a valid value and so a range to
exclude zero would
then make sense.
 
I think there is much more... but it needs time to review.

Bert Wijnen 

________________________________

	From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
	Sent: Sunday, June 10, 2007 7:44 AM
	To: MIB Doctors (E-mail)
	Subject: [MIB-DOCTORS] Call for volunteers for MIB DR review for
PWE MIBdocuments

	This is the second call for a volunteer to perform MIB Doctor
reviews on the PW ATM and TDM MIB modules in PWE3. The documents seem to
be in good shape, they passed WGLC and are authored by Orly, but
certainly having them looked at by an independent MIB doctor pair of
eyes would help. 

	 

	 

	Thanks and Regards,

	Dan

---

From: "Orly Nicklass" <[email-masked]>
Date: Sat, 16 Jun 2007 01:07:00 +0300

Bert,

Tnx for the brief review as a starting point.

In lines

  _____  

From: Wijnen, Bert (Bert) [mailto:[email-masked]] 
Sent: Monday, June 11, 2007 16:27
To: Romascanu, Dan (Dan); MIB Doctors (E-mail)
Subject: RE: [MIB-DOCTORS] Call for volunteers for MIB DR review for
PWEMIBdocuments

[[Orly Nicklass]] PW and TC had WG LC. By mistake they were put for
additional LC till 19 and 22 of June.

 

same for pwAtmInboundNto1MappedVpi and pwAtmInboundNto1MappedVci[[Orly
Nicklass]] ---good point. I suppose changing the type or alternate solution
will be needed for such case to reflect unused. Any good suggestion?

for

For

then make sense.

Bert Wijnen 

  _____  

From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
Sent: Sunday, June 10, 2007 7:44 AM
To: MIB Doctors (E-mail)
Subject: [MIB-DOCTORS] Call for volunteers for MIB DR review for PWE
MIBdocuments

This is the second call for a volunteer to perform MIB Doctor reviews on the
PW ATM and TDM MIB modules in PWE3. The documents seem to be in good shape,
they passed WGLC and are authored by Orly, but certainly having them looked
at by an independent MIB doctor pair of eyes would help. 

 

 

Thanks and Regards,

Dan