Subject: Re: [MIB-DOCTORS] Copyright notice in "code"

From: Russ Housley <[email-masked]>
Date: Sun, 05 Apr 2009 16:08:19 -0400

Dan:

I do not see PIB modules as code in the Trustee list.

http://trustee.ietf.org/docs/Code-Components-List-11-10-08.txt

Russ

At 09:09 AM 3/25/2009, Romascanu, Dan (Dan) wrote:

Russ,

I thought that we already knew this from the previous conversations. The
clarification that I thought that we were expecting from Jorge was
whether we are allowed to replace 'the code' in the first paragraph by
'the MIB module' for MIB modules and 'the PIB module' for PIB modules. Or
we must use exactly the copyright text below?

Dan

-----Original Message-----

From: [email-masked] on behalf of Russ Housley

Sent: Wed 3/25/2009 7:54 AM

To: [email-masked]

Cc: [email-masked]; [email-masked]

Subject: Copyright notice in "code"

I spoke with Jorge today, and he confirmed that the entire legend below
needs to appear in comments in any code, such as MIB, PIB, ASN.1, XML
Schema, and so on.  This is needed to comply with the BSD open
source license.

Russ

Copyright (c) <insert year> IETF Trust and the persons identified
as

authors of the code. All rights reserved.

Redistribution and use in source and binary forms, with or without

modification, are permitted provided that the following conditions

are
met:

-
Redistributions of source code must retain the above copyright

notice, this list of conditions and the following disclaimer.

-
Redistributions in binary form must reproduce the above copyright

notice, this list of conditions and the following disclaimer in the

documentation and/or other materials provided with the distribution.

-
Neither the name of Internet Society, IETF or IETF Trust, nor the

names of specific contributors, may be used to endorse or promote

products derived from this software without specific prior written

permission.

THIS
SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS

"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT
NOT

LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR

A
PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT

OWNER
OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,

SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT

LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
USE,

DATA,
OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY

THEORY
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT

(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
USE

OF
THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 6 Apr 2009 18:06:29 +0200

Neither are YANG modules which result from the NETMOD WG. 
 
What is the process of adding new items to this list? 
 
Dan

________________________________

	From: Russ Housley [mailto:[email-masked]] 
	Sent: Sunday, April 05, 2009 11:08 PM
	To: Romascanu, Dan (Dan); [email-masked]
	Cc: [email-masked]; [email-masked];
[email-masked]
	Subject: RE: Copyright notice in "code"

	Dan:

	Russ

		Russ,
		
		I thought that we already knew this from the previous
conversations. The clarification that I thought that we were expecting
from Jorge was whether we are allowed to replace 'the code' in the first
paragraph by 'the MIB module' for MIB modules and 'the PIB module' for
PIB modules. Or we must use exactly the copyright text below?
		
		Dan

		-----Original Message-----
		From: [email-masked] on behalf of Russ Housley
		Sent: Wed 3/25/2009 7:54 AM
		To: [email-masked]
		Cc: [email-masked]; [email-masked]
		Subject: Copyright notice in "code"
		
		I spoke with Jorge today, and he confirmed that the
entire legend below needs to appear in comments in any code, such as
MIB, PIB, ASN.1, XML Schema, and so on.  This is needed to comply with
the BSD open source license.
		
		Russ

		
		            Copyright (c) <insert year> IETF Trust and
the persons identified as
		            authors of the code. All rights reserved.
		       
		            Redistribution and use in source and binary
forms, with or without
		            modification, are permitted provided that
the following conditions
		            are met:
		       
		            - Redistributions of source code must retain
the above copyright
		              notice, this list of conditions and the
following disclaimer.
		       
		            - Redistributions in binary form must
reproduce the above copyright
		              notice, this list of conditions and the
following disclaimer in the
		              documentation and/or other materials
provided with the distribution.
		       
		            - Neither the name of Internet Society, IETF
or IETF Trust, nor the
		              names of specific contributors, may be
used to endorse or promote
		              products derived from this software
without specific prior written
		              permission.
		       
		            THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT
HOLDERS AND CONTRIBUTORS
		            "AS IS" AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT
		            LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR
		            A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
EVENT SHALL THE COPYRIGHT
		            OWNER OR CONTRIBUTORS BE LIABLE FOR ANY
DIRECT, INDIRECT, INCIDENTAL,
		            SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT
		            LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
OR SERVICES; LOSS OF USE,
		            DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND ON ANY
		            THEORY OF LIABILITY, WHETHER IN CONTRACT,
STRICT LIABILITY, OR TORT
		            (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
IN ANY WAY OUT OF THE USE
		            OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

---

From: Russ Housley <[email-masked]>
Date: Mon, 06 Apr 2009 14:08:04 -0400

Send email to [email-masked] and ask.

Russ

At 12:06 PM 4/6/2009, Romascanu, Dan (Dan) wrote:

What is the process of adding new
items to this list?

Dan

From: Russ Housley
[
mailto:[email-masked]]

Dan:

Russ

Russ,

I thought that we already knew this from the previous conversations.
The clarification that I thought that we were expecting from Jorge was
whether we are allowed to replace 'the code' in the first paragraph by
'the MIB module' for MIB modules and 'the PIB module' for PIB modules. Or
we must use exactly the copyright text below?

Dan

-----Original Message-----

To: [email-masked]

I spoke with Jorge today, and he confirmed that the entire legend
below needs to appear in comments in any code, such as MIB, PIB, ASN.1,
XML Schema, and so on.  This is needed to comply with the BSD open
source license.

Russ

are met:

-

-

-

permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS

A

OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL,

DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
ANY

THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT

OF
THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

---

From: Henk Uijterwaal <[email-masked]>
Date: Tue, 07 Apr 2009 10:07:48 +0200

> Send email to [email-masked] and ask.

I like the process but is the process known?

If somebody puts something into a RFC tomorrow that can reasonably be
seen as "code" but isn't included in the list, does anybody in the
publication process know that the list should be extended and the
copyright statement be put in the file?

Henk

>> * /Neither are YANG modules which result from the NETMOD WG.
>> /* 
>> */What is the process of adding new items to this list?
>> /* 
>> */Dan
>> /* 
>>
>> ------------------------------------------------------------------------
>>     From: Russ Housley [ mailto:[email-masked]]
>>     Cc: [email-masked]; [email-masked]; [email-masked]
>>>         conversations. The clarification that I thought that we were
>>>         expecting from Jorge was whether we are allowed to replace
>>>         'the code' in the first paragraph by 'the MIB module' for MIB
>>>         modules and 'the PIB module' for PIB modules. Or we must use
>>>         exactly the copyright text below?
>>>
>>>         Dan
>>>
>>>
>>>
>>>         I spoke with Jorge today, and he confirmed that the entire
>>>         legend below needs to appear in comments in any code, such as
>>>         MIB, PIB, ASN.1, XML Schema, and so on.  This is needed to
>>>         comply with the BSD open source license.
>>>
>>>         Russ
>>>
>>>
>>>
>>>
>>>                     Copyright (c) <insert year> IETF Trust and the
>>>         persons identified as
>>>                     - Redistributions of source code must retain the
>>>         above copyright
>>>                     - Redistributions in binary form must reproduce
>>>         the above copyright
>>>                     - Neither the name of Internet Society, IETF or
>>>         IETF Trust, nor the
>>>                     "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
>>>         INCLUDING, BUT NOT
>>>                     A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
>>>         SHALL THE COPYRIGHT
>>>                     OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
>>>         INDIRECT, INCIDENTAL,
>>>                     LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
>>>         SERVICES; LOSS OF USE,
>>>                     (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
>>>         ANY WAY OUT OF THE USE
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Trustees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trustees

-- 
------------------------------------------------------------------------------
Henk Uijterwaal                           Email: henk.uijterwaal(at)ripe.net
RIPE Network Coordination Centre          http://www.amsterdamned.org/~henk
P.O.Box 10096          Singel 258         Phone: +31.20.5354414
1001 EB Amsterdam      1016 AB Amsterdam  Fax: +31.20.5354445
The Netherlands        The Netherlands    Mobile: +31.6.55861746
------------------------------------------------------------------------------

Belgium: an unsolvable problem, discussed in endless meetings, with no
          hope for a solution, where everybody still lives happily.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 7 Apr 2009 11:05:37 +0200

Trustees are copied to the mails, so the question is asked. 
 
What is the process of adding new types of 'code' to the list? 
 
Thanks, 
 
Dan

	From: Russ Housley [mailto:[email-masked]] 
	Sent: Monday, April 06, 2009 9:08 PM
	To: Romascanu, Dan (Dan); [email-masked]
	Cc: [email-masked]; [email-masked];
[email-masked]; David Kessens; David Partain
	Subject: RE: Copyright notice in "code"

	Russ

		Neither are YANG modules which result from the NETMOD
WG. 

		Dan

			From: Russ Housley [ mailto:[email-masked]
<mailto:[email-masked]> ] 

			
			Cc: [email-masked];
[email-masked]; [email-masked]

			Dan:

			I do not see PIB modules as code in the Trustee
list.

			Russ

			At 09:09 AM 3/25/2009, Romascanu, Dan (Dan)
wrote:

				Russ,

				I thought that we already knew this from
the previous conversations. The clarification that I thought that we
were expecting from Jorge was whether we are allowed to replace 'the
code' in the first paragraph by 'the MIB module' for MIB modules and
'the PIB module' for PIB modules. Or we must use exactly the copyright
text below?

				Dan

				
				-----Original Message-----
				
				From: [email-masked] on behalf of
Russ Housley

				To: [email-masked]
				
				Cc: [email-masked];
[email-masked]

				I spoke with Jorge today, and he
confirmed that the entire legend below needs to appear in comments in
any code, such as MIB, PIB, ASN.1, XML Schema, and so on.  This is
needed to comply with the BSD open source license.

				Russ

				            Copyright (c) <insert year>
IETF Trust and the persons identified as
				
				            authors of the code. All
rights reserved.

				            Redistribution and use in
source and binary forms, with or without
				
				            modification, are permitted
provided that the following conditions
				
				            are met:

				            - Redistributions of source
code must retain the above copyright
				
				              notice, this list of
conditions and the following disclaimer.

				            - Redistributions in binary
form must reproduce the above copyright
				
				              notice, this list of
conditions and the following disclaimer in the
				
				              documentation and/or other
materials provided with the distribution.

				            - Neither the name of
Internet Society, IETF or IETF Trust, nor the
				
				              names of specific
contributors, may be used to endorse or promote
				
				              products derived from this
software without specific prior written
				
				              permission.

				            THIS SOFTWARE IS PROVIDED BY
THE COPYRIGHT HOLDERS AND CONTRIBUTORS
				
				            "AS IS" AND ANY EXPRESS OR
IMPLIED WARRANTIES, INCLUDING, BUT NOT
				
				            LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
				
				            A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
				
				            OWNER OR CONTRIBUTORS BE
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
				
				            SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
				
				            LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
				
				            DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
				
				            THEORY OF LIABILITY, WHETHER
IN CONTRACT, STRICT LIABILITY, OR TORT
				
				            (INCLUDING NEGLIGENCE OR
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
				
				            OF THIS SOFTWARE, EVEN IF
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

---

From: Ray Pelletier <[email-masked]>
Date: Tue, 7 Apr 2009 09:32:42 -0400

Dan,

Your request to have PIB modules considered 'code' and placed on the  
Code Components list at
http://trustee.ietf.org/docs/Code-Components-List-11-10-08.txt  is  
accepted for Trustee consideration.

I anticipate the Trust will review the matter in April.

Ray

On Apr 7, 2009, at 5:05 AM, Romascanu, Dan (Dan) wrote:

> Cc: [email-masked]; [email-masked]; mib- 
> [email-masked]; David Kessens; David Partain
>>> expecting from Jorge was whether we are allowed to replace 'the  
>>> code' in the first paragraph by 'the MIB module' for MIB modules  
>>> and 'the PIB module' for PIB modules. Or we must use exactly the  
>>> copyright text below?
>>>
>>> Dan
>>>
>>>
>>>
>>> below needs to appear in comments in any code, such as MIB, PIB,  
>>> ASN.1, XML Schema, and so on.  This is needed to comply with the  
>>> BSD open source license.
>>>
>>> Russ
>>>
>>>
>>>
>>>
>>>             Copyright (c) <insert year> IETF Trust and the persons  
>>> identified as
>>>             - Redistributions of source code must retain the above  
>>> copyright
>>>             - Redistributions in binary form must reproduce the  
>>> above copyright
>>>             - Neither the name of Internet Society, IETF or IETF  
>>> Trust, nor the
>>>             LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY  
>>> AND FITNESS FOR
>>>             A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL  
>>> THE COPYRIGHT
>>>             DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER  
>>> CAUSED AND ON ANY
>>>             (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY  
>>> OUT OF THE USE
>>>             OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY  
>>> OF SUCH DAMAGE.
>