Subject: [MIB-DOCTORS] GROUP versus MANDATORY-GROUPS in errata 3292

From: Benoit Claise <[email-masked]>
Date: Tue, 08 Jan 2013 13:03:51 +0100

MIB doctors,

http://www.rfc-editor.org/errata_search.php?eid=3292
I would like to double-check that this errata should be verified.

Regards, Benoit

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 8 Jan 2013 13:56:38 +0100

> I would like to double-check that this errata should be verified.

Looks reasonable. 

It seems smilint does not detect this problem. I have to dig into the
libsmi source code to see whether I can get it changed such that
smilint flags this kind of error in the future.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Benoit Claise <[email-masked]>
Date: Tue, 08 Jan 2013 14:10:50 +0100

Thanks Juergen.

Regards, Benoit

---

From: "Bert Wijnen" <[email-masked]>
Date: Tue, 8 Jan 2013 14:11:27 +0100

SMICng strict checking DOES flag it as an error (beside many other
warnings). For the error reported as an errata, see the bottom of this list.
I am somehwat surprised. RFC-Editor (back in my days at least, which
is before the december date of this RFC) is supposed to check MIB
modules with SMICng checker.

Bert

C:\bw\smicng\rfcs>smicng rfc4750a.inc
Successful parsing

C:\bw\smicng\rfcs>smicng rfc4750b.inc
W: f(rfc4750b.mi2), (162,14) Variable "ospfVirtIfAreaId" in notification 
"ospfVirtIfStateCh
ange" is an index for a table
W: f(rfc4750b.mi2), (163,14) Variable "ospfVirtIfNeighbor" in notification 
"ospfVirtIfState
Change" is an index for a table
W: f(rfc4750b.mi2), (180,14) Variable "ospfNbrIpAddr" in notification 
"ospfNbrStateChange"
is an index for a table
W: f(rfc4750b.mi2), (181,14) Variable "ospfNbrAddressLessIndex" in notification 
"ospfNbrSta
teChange" is an index for a table
W: f(rfc4750b.mi2), (204,14) Variable "ospfVirtNbrArea" in notification 
"ospfVirtNbrStateCh
ange" is an index for a table
W: f(rfc4750b.mi2), (205,14) Variable "ospfVirtNbrRtrId" in notification 
"ospfVirtNbrStateC
hange" is an index for a table
W: f(rfc4750b.mi2), (220,14) Variable "ospfIfIpAddress" in notification 
"ospfIfConfigError"
 is an index for a table
W: f(rfc4750b.mi2), (221,14) Variable "ospfAddressLessIf" in notification 
"ospfIfConfigErro
r" is an index for a table
W: f(rfc4750b.mi2), (239,14) Variable "ospfVirtIfAreaId" in notification 
"ospfVirtIfConfigE
rror" is an index for a table
W: f(rfc4750b.mi2), (240,14) Variable "ospfVirtIfNeighbor" in notification 
"ospfVirtIfConfi
gError" is an index for a table
W: f(rfc4750b.mi2), (258,14) Variable "ospfIfIpAddress" in notification 
"ospfIfAuthFailure"
 is an index for a table
W: f(rfc4750b.mi2), (259,14) Variable "ospfAddressLessIf" in notification 
"ospfIfAuthFailur
e" is an index for a table
W: f(rfc4750b.mi2), (277,14) Variable "ospfVirtIfAreaId" in notification 
"ospfVirtIfAuthFai
lure" is an index for a table
W: f(rfc4750b.mi2), (278,14) Variable "ospfVirtIfNeighbor" in notification 
"ospfVirtIfAuthF
ailure" is an index for a table
W: f(rfc4750b.mi2), (295,14) Variable "ospfIfIpAddress" in notification 
"ospfIfRxBadPacket"
 is an index for a table
W: f(rfc4750b.mi2), (296,14) Variable "ospfAddressLessIf" in notification 
"ospfIfRxBadPacke
t" is an index for a table
W: f(rfc4750b.mi2), (309,13) Variable "ospfVirtIfAreaId" in notification 
"ospfVirtIfRxBadPa
cket" is an index for a table
W: f(rfc4750b.mi2), (310,13) Variable "ospfVirtIfNeighbor" in notification 
"ospfVirtIfRxBad
Packet" is an index for a table
W: f(rfc4750b.mi2), (322,14) Variable "ospfIfIpAddress" in notification 
"ospfTxRetransmit"
is an index for a table
W: f(rfc4750b.mi2), (323,14) Variable "ospfAddressLessIf" in notification 
"ospfTxRetransmit
" is an index for a table
W: f(rfc4750b.mi2), (326,14) Variable "ospfLsdbType" in notification 
"ospfTxRetransmit" is
an index for a table
W: f(rfc4750b.mi2), (327,14) Variable "ospfLsdbLsid" in notification 
"ospfTxRetransmit" is
an index for a table
W: f(rfc4750b.mi2), (328,14) Variable "ospfLsdbRouterId" in notification 
"ospfTxRetransmit"
 is an index for a table
W: f(rfc4750b.mi2), (342,14) Variable "ospfVirtIfAreaId" in notification 
"ospfVirtIfTxRetra
nsmit" is an index for a table
W: f(rfc4750b.mi2), (343,14) Variable "ospfVirtIfNeighbor" in notification 
"ospfVirtIfTxRet
ransmit" is an index for a table
W: f(rfc4750b.mi2), (345,14) Variable "ospfLsdbType" in notification 
"ospfVirtIfTxRetransmi
t" is an index for a table
W: f(rfc4750b.mi2), (346,14) Variable "ospfLsdbLsid" in notification 
"ospfVirtIfTxRetransmi
t" is an index for a table
W: f(rfc4750b.mi2), (347,14) Variable "ospfLsdbRouterId" in notification 
"ospfVirtIfTxRetra
nsmit" is an index for a table
W: f(rfc4750b.mi2), (361,14) Variable "ospfLsdbAreaId" in notification 
"ospfOriginateLsa" i
s an index for a table
W: f(rfc4750b.mi2), (362,14) Variable "ospfLsdbType" in notification 
"ospfOriginateLsa" is
an index for a table
W: f(rfc4750b.mi2), (363,14) Variable "ospfLsdbLsid" in notification 
"ospfOriginateLsa" is
an index for a table
W: f(rfc4750b.mi2), (364,14) Variable "ospfLsdbRouterId" in notification 
"ospfOriginateLsa"
 is an index for a table
W: f(rfc4750b.mi2), (381,14) Variable "ospfLsdbAreaId" in notification 
"ospfMaxAgeLsa" is a
n index for a table
W: f(rfc4750b.mi2), (382,14) Variable "ospfLsdbType" in notification 
"ospfMaxAgeLsa" is an
index for a table
W: f(rfc4750b.mi2), (383,14) Variable "ospfLsdbLsid" in notification 
"ospfMaxAgeLsa" is an
index for a table
W: f(rfc4750b.mi2), (384,14) Variable "ospfLsdbRouterId" in notification 
"ospfMaxAgeLsa" is
 an index for a table
W: f(rfc4750b.mi2), (420,14) Variable "ospfIfIpAddress" in notification 
"ospfIfStateChange"
 is an index for a table
W: f(rfc4750b.mi2), (421,14) Variable "ospfAddressLessIf" in notification 
"ospfIfStateChang
e" is an index for a table
W: f(rfc4750b.mi2), (438,14) Variable "ospfAreaId" in notification 
"ospfNssaTranslatorStatu
sChange" is an index for a table
W: f(rfc4750b.mi2), (469,21) Variable "ospfNbrIpAddr" in notification 
"ospfNbrRestartHelper
StatusChange" is an index for a table
W: f(rfc4750b.mi2), (470,21) Variable "ospfNbrAddressLessIndex" in notification 
"ospfNbrRes
tartHelperStatusChange" is an index for a table
W: f(rfc4750b.mi2), (488,21) Variable "ospfVirtNbrArea" in notification 
"ospfVirtNbrRestart
HelperStatusChange" is an index for a table
W: f(rfc4750b.mi2), (489,21) Variable "ospfVirtNbrRtrId" in notification 
"ospfVirtNbrRestar
tHelperStatusChange" is an index for a table
E: f(rfc4750b.mi2), (518,21) Group "ospfTrapControlGroup" is both a MANDATORY 
and condition
al group for module "OSPF-TRAP-MIB"

*** 1 error and 43 warnings in parsing

Bert
----- Original Message ----- 
From: "Juergen Schoenwaelder" <[email-masked]>
To: "Benoit Claise" <[email-masked]>
Cc: "MIB Doctors (E-mail)" <[email-masked]>; "Stewart Bryant" 
<[email-masked]>
Sent: Tuesday, January 08, 2013 1:56 PM
Subject: Re: [MIB-DOCTORS] GROUP versus MANDATORY-GROUPS in errata 3292

> _______________________________________________
> MIB-DOCTORS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mib-doctors

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 8 Jan 2013 19:12:26 +0100

> smilint flags this kind of error in the future.

I managed to convince smilint to catch this:

OSPF-TRAP-MIB:539: group 'ospfTrapControlGroup' is both mandatory and optional in `ospfTrapCompliance'

We have similar issues in the RDBMS-MIB [RFC 1697] and the RIPv2-MIB
[RFC1724]. I am not sure it is worth doing something about this. All
the other IETF MIB modules seem to be fine.

/js