Subject: Re: [MIB-DOCTORS] Request for MIB review of draft-ietf-storm-iscsimib

From: Benoit Claise <[email-masked]>
Date: Mon, 14 Jan 2013 12:25:17 +0100

Hi Mike,

Can you please have a look to see if this latest version addresses your
points at http://www.macfaden.com/ietf/iscsi-mib-1-reviewed.txt

Regards, Benoit
> Benoit, MIB Doctors,
>
> Did anybody have time to check the updated iSCSI MIB?
>
> I would like to progress the draft to the IESG soon.
>
> Thank you in advance,
>
>   Martin
>
> On 10/10/2012 06:09 PM, Benoit Claise wrote:
>> Hi Mike,
>>
>> As far as I know, you did the review of draft-ietf-storm-iscsimib
>> Can you please have a look to see if this latest version addresses your
>> points at http://www.macfaden.com/ietf/iscsi-mib-1-reviewed.txt
>>
>> Regards, Benoit
>>> Hi Ron and Benoit,
>>>
>>> The MIB doctors did a review of draft-ietf-storm-iscsimib a while back
>>> and did comment on the text, but also on the MIB module itself.
>>> (https://datatracker.ietf.org/doc/draft-ietf-storm-iscsimib)
>>>
>>> The STORM working group has gone through the review and updated the
>>> draft to address these.
>>>
>>> Can you please ask the MIB doctors to review the ISCSI MIB module 
>>> again?
>>>
>>> Thanks in advance,
>>>
>>>   Martin
>>>
>>
>

---

From: Michael MacFaden <[email-masked]>
Date: Sun, 27 Jan 2013 22:53:50 -0800

Hi Benoit,

I reviewed the current #3 draft at
https://datatracker.ietf.org/doc/draft-ietf-storm-iscsimib/
the nits checker had a few items to review:
http://tools.ietf.org/idnits?url=http://tools.ietf.org/id/draft-ietf-storm-iscsimib-03.tx

There exist editorial comments to clean up, some noted below

- -- <a
href="./draft-ietf-storm-iscsi-cons-03">draft-ietf-storm-iscsi-cons-03</a>
&amp; remove this note.

but otherwise looks good to me.

Tests performed:
prunus% smistrip draft-ietf-storm-iscsimib-03
smistrip draft-ietf-storm-iscsimib-03
ISCSI-MIB: 3761 lines.
prunus% smilint -l9 ISCSI-MIB
smilint -l9 ISCSI-MIB
prunus% smidump -f tree ISCSI-MIB

Compared output of smidump -f identifiers from 01 draft to 03, no changes.
Verified all nonscalars begin with iscsiInstIndex index as described per
section 4 (Relationship to SNMP Contexts)
Verified marker objects were deprecated as stated in section 5.
Verified all three new objects added
  iscsiInstXNodeArchitecture
 iscsiSsnTaskReporting
  iscsiSsnProtocolLevel

items resolved from last review.
- - 4. IANA Considerations - check
- - 8. Intellectual property section -check
Rest of issues I reported in prior review were resolved previously on the
list.

s/
Mike MacFaden

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 28 Jan 2013 08:02:45 +0000

Hi Mike,

Did you also comment concerning the Security Considerations section?

It seems that it is not updated according to the last template version on the wiki as per https://svn.tools.ietf.org/area/ops/trac/wiki/mib-security# (the last but final paragraph and the corresponding references).

I noticed this while performing the Gen-ART review of the document.

Regards,

Dan

From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael MacFaden
Sent: Monday, January 28, 2013 8:54 AM
To: Benoit Claise
Cc: MIB Doctors (E-mail)
Subject: Re: [MIB-DOCTORS] Fwd: Re: Request for MIB review of draft-ietf-storm-iscsimib

Hi Benoit,

I reviewed the current #3 draft at https://datatracker.ietf.org/doc/draft-ietf-storm-iscsimib/
the nits checker had a few items to review:
http://tools.ietf.org/idnits?url=http://tools.ietf.org/id/draft-ietf-storm-iscsimib-03.tx

- -- <a href="./draft-ietf-storm-iscsi-cons-03">draft-ietf-storm-iscsi-cons-03</a> &amp; remove this note.

Tests performed:

Verified all nonscalars begin with iscsiInstIndex index as described per section 4 (Relationship to SNMP Contexts)

items resolved from last review.
- - 4. IANA Considerations - check
- - 8. Intellectual property section -check
Rest of issues I reported in prior review were resolved previously on the list.

s/
Mike MacFaden