Subject: Re: [MIB-DOCTORS] Benoit Claise's Discuss on draft-ietf-mpls-tp-oam-id-mib-09: (with DISCUSS and COMMENT)

From: "Joan Cucchiara" <[email-masked]>
Date: Fri, 18 Sep 2015 12:34:08 -0400

Hi Venkat,

WRT draft-ietf-tp-oam-id-mib-11.txt:   MIB Module compiles cleanly with smicng and smiLint.

Thanks,

-Joan

From: Venkatesan Mahalingam [mailto:[email-masked]] 
Sent: Monday, September 14, 2015 7:12 PM
To: Joan Cucchiara
Cc: Joan Cucchiara; MIB Doctors (E-mail); Mach Chen; Sam Aldrin; [email-masked]; BRUNGARD, DEBORAH A
Subject: Benoit Claise's Discuss on draft-ietf-mpls-tp-oam-id-mib-09: (with DISCUSS and COMMENT)

Joan,

I've fixed the compilation warnings and published the new version 11, can you please compile again and update us the status?

-Venkat

On Tuesday, September 8, 2015, Joan Cucchiara <[email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');> > wrote:

Hi Venkat,

Still NOT done.  Same issue.

W: f(MPLS-OAM-ID-STD-MIB.my), (881,22) MIN-ACCESS value identical to access specified for "mplsOamIdMegOperStatus"

W: f(MPLS-OAM-ID-STD-MIB.my), (886,22) MIN-ACCESS value identical to access specified for "mplsOamIdMegSubOperStatus"

All that is needed is removal of the following  9 lines which start at line 881 of the stripped MIB .   Let me know if you have any questions.

         OBJECT      mplsOamIdMegOperStatus

         MIN-ACCESS  read-only

         DESCRIPTION

               "Write access is not required."

         OBJECT      mplsOamIdMegSubOperStatus

         MIN-ACCESS  read-only

         DESCRIPTION

               "Write access is not required."

Thanks,

-Joan

From: Venkatesan Mahalingam [mailto:[email-masked]] 
Sent: Tuesday, September 08, 2015 2:00 AM
To: Joan Cucchiara; Joan Cucchiara; MIB Doctors (E-mail)
Cc: Mach Chen; Sam Aldrin; [email-masked]; BRUNGARD, DEBORAH A
Subject: Re: Fwd: Benoit Claise's Discuss on draft-ietf-mpls-tp-oam-id-mib-09: (with DISCUSS and COMMENT)

Joan,

Can you please do the MIB compilation on the latest version 09 an confirm?

-Venkat.

On Fri, Sep 4, 2015 at 9:19 AM, Benoit Claise <[email-masked]> wrote:

On 04/09/2015 17:47, Venkatesan Mahalingam wrote:

Benoit, 

Are you okay with the suggested changes?

Yes, as they comply with the latest boilerplate.

Regards, B.

Joan,

Can you please respond to the compilation warnings?

-Venkat

---------- Forwarded message ----------
From: Venkatesan Mahalingam <[email-masked]>
Date: Thursday, September 3, 2015
Subject: Benoit Claise's Discuss on draft-ietf-mpls-tp-oam-id-mib-09: (with DISCUSS and COMMENT)
To: Benoit Claise <[email-masked]>
Cc: The IESG <[email-masked]>, Joan Cucchiara <[email-masked]>, [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], "[email-masked]" <[email-masked]>

Hi Benoit and Joan, 

We will publish the next version with the below changes in the security section, hope this is fine.

OLD

Section-8
   There are number of management objects defined in this MIB module
   with a MAX-ACCESS clause of read-create. Such objects may be
   considered sensitive or vulnerable in some network environments.
   The support for SET operations in a non-secure environment
   without proper protection can have negative effect on network
   operations.

NEW

Section-8 

There are number of management objects defined in this MIB module
   with a MAX-ACCESS clause of read-create. Such objects may be
   considered sensitive or vulnerable in some network environments.
   The support for SET operations in a non-secure environment without proper protection opens devices to attack.

Regd, Joan's comments, I dont see any reported warnings on version 09,

Joan: If you could quickly verify the compilation on version 09 and confirm, if would be of great help as IESG approval is pending for this draft. 

timeout 10 smilint -s -e -l 6 mibs/MPLS-OAM-ID-STD-MIB 2>report.txt

While processing your request the following errors and/or warnings have been found:

mibs/MPLS-OAM-ID-STD-MIB:83: [2] {object-identifier-not-prefix} Object identifier element `xxx' name only allowed as first element
mibs/MPLS-OAM-ID-STD-MIB:23: [2] {module-identity-registration} illegal module identity registration

-Venkat.

On Wed, Sep 2, 2015 at 11:59 PM, Benoit Claise <[email-masked]> wrote:

Benoit Claise has entered the following ballot position for
draft-ietf-mpls-tp-oam-id-mib-09: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-mpls-tp-oam-id-mib/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Based on the feedback of the security AD, the security guidelines for the
IETF MIB modules
(http://trac.tools.ietf.org/area/ops/trac/wiki/mib-security) have been
changed 9 months ago.
The exact change at
http://trac.tools.ietf.org/area/ops/trac/wiki/mib-security?action=diff <http://trac.tools.ietf.org/area/ops/trac/wiki/mib-security?action=diff&version=7&old_version=6> &version=7&old_version=6

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

The MIB doctor latest review from Joan Cucchiara:

My comments (which I made to the authors also about Feb 28, 2015) was
about these warnings:
Warning with SMICNG compiler:

W: f(MPLS-TP-OAM-MIB.my), (883,22) MIN-ACCESS value identical to access
specified for "mplsOamIdMegOperStatus"
W: f(MPLS-TP-OAM-MIB.my), (888,22) MIN-ACCESS value identical to access
specified for "mplsOamIdMegSubOperStatus"

Yes, these are just warnings, but they are easily fixable and I believe
the authors agreed to fix these warnings during the AD review process
(that would be you

Other than these warnings, the MIB is fine with me to go forward.

 

No virus found in this message.
Checked by AVG - www.avg.com
Version: 2014.0.4830 / Virus Database: 4365/10594 - Release Date: 09/07/15

No virus found in this message.
Checked by AVG - www.avg.com
Version: 2014.0.4830 / Virus Database: 4365/10641 - Release Date: 09/14/15

---

From: Venkatesan Mahalingam <[email-masked]>
Date: Fri, 18 Sep 2015 15:29:10 -0700

Thanks Joan.

Deborah,

Yes, we are ready to go.

-Venkat

On Friday, September 18, 2015, BRUNGARD, DEBORAH A <[email-masked]> wrote:

> Much thanks Joan-
>
> Venkat – we are ready to go then?
>
>
>
> Thanks everyone-
> Deborah
>
>
>
>
>
> *From:* Joan Cucchiara [mailto:[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>]
> *Sent:* Friday, September 18, 2015 12:34 PM
> *To:* 'Venkatesan Mahalingam'
> *Cc:* 'Joan Cucchiara'; 'MIB Doctors (E-mail)'; 'Mach Chen'; 'Sam
> Aldrin'; [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>; BRUNGARD,
> DEBORAH A
> *Subject:* RE: Benoit Claise's Discuss on
> draft-ietf-mpls-tp-oam-id-mib-09: (with DISCUSS and COMMENT)
>
>
>
> Hi Venkat,
>
>
>
> *From:* Venkatesan Mahalingam [mailto:[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>]
> *Sent:* Monday, September 14, 2015 7:12 PM
> *To:* Joan Cucchiara
> *Cc:* Joan Cucchiara; MIB Doctors (E-mail); Mach Chen; Sam Aldrin;
> [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>; BRUNGARD,
> DEBORAH A
> *Subject:* Benoit Claise's Discuss on draft-ietf-mpls-tp-oam-id-mib-09:
> (with DISCUSS and COMMENT)
>
>
>
> Joan,
>
>
>
> I've fixed the compilation warnings and published the new version 11, can
> you please compile again and update us the status?
>
>
>
>
>
> -Venkat
>
>
>
>
>
> On Tuesday, September 8, 2015, Joan Cucchiara <[email-masked]>
> wrote:
>
> Hi Venkat,
>
>
>
> W: f(MPLS-OAM-ID-STD-MIB.my), (881,22) MIN-ACCESS value identical to
> access specified for "mplsOamIdMegOperStatus"
>
> W: f(MPLS-OAM-ID-STD-MIB.my), (886,22) MIN-ACCESS value identical to
> access specified for "mplsOamIdMegSubOperStatus"
>
>
>
> All that is needed is removal of the following  9 lines which start at
> line 881 of the stripped MIB .   Let me know if you have any questions.
>
>
>
>
>
> *From:* Venkatesan Mahalingam [mailto:[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>]
> *Sent:* Tuesday, September 08, 2015 2:00 AM
> *To:* Joan Cucchiara; Joan Cucchiara; MIB Doctors (E-mail)
> *Cc:* Mach Chen; Sam Aldrin; [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>; BRUNGARD,
> DEBORAH A
> *Subject:* Re: Fwd: Benoit Claise's Discuss on
> draft-ietf-mpls-tp-oam-id-mib-09: (with DISCUSS and COMMENT)
>
>
>
> Joan,
>
>
>
> On Fri, Sep 4, 2015 at 9:19 AM, Benoit Claise <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>
> From: *Venkatesan Mahalingam* <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>
> To: Benoit Claise <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>
> Cc: The IESG <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>, Joan Cucchiara <
> [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>,
> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>,
> [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>,
> [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>,
> [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>,
> [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>,
> "[email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>" <
> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>>
>
> Hi Benoit and Joan,
>
>
>
>    *without proper protection can have negative effect on network*
>
> *   operations.*
>
> NEW
>
>
>
> Section-8
>
> Joan: If you could quickly verify the compilation on version 09 and
> confirm, if would be of great help as IESG approval is pending for this
> draft.
>
>
>
> On Wed, Sep 2, 2015 at 11:59 PM, Benoit Claise <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>
> http://trac.tools.ietf.org/area/ops/trac/wiki/mib-security?action=diff&version=7&old_version=6
>
>

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Fri, 18 Sep 2015 21:14:19 +0000

Much thanks Joan-

Thanks everyone-
Deborah

From: Joan Cucchiara [mailto:[email-masked]]
Sent: Friday, September 18, 2015 12:34 PM
To: 'Venkatesan Mahalingam'
Cc: 'Joan Cucchiara'; 'MIB Doctors (E-mail)'; 'Mach Chen'; 'Sam Aldrin'; [email-masked]; BRUNGARD, DEBORAH A
Subject: RE: Benoit Claise's Discuss on draft-ietf-mpls-tp-oam-id-mib-09: (with DISCUSS and COMMENT)

Hi Venkat,

Thanks,
-Joan

From: Venkatesan Mahalingam [mailto:[email-masked]]
Sent: Monday, September 14, 2015 7:12 PM
To: Joan Cucchiara
Cc: Joan Cucchiara; MIB Doctors (E-mail); Mach Chen; Sam Aldrin; [email-masked]<mailto:[email-masked]>; BRUNGARD, DEBORAH A
Subject: Benoit Claise's Discuss on draft-ietf-mpls-tp-oam-id-mib-09: (with DISCUSS and COMMENT)

Joan,

-Venkat

On Tuesday, September 8, 2015, Joan Cucchiara <[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
Hi Venkat,

Thanks,
-Joan

Cc: Mach Chen; Sam Aldrin; [email-masked]<mailto:[email-masked]>; BRUNGARD, DEBORAH A

Joan,

-Venkat.

On Fri, Sep 4, 2015 at 9:19 AM, Benoit Claise <[email-masked]<mailto:[email-masked]>> wrote:
On 04/09/2015 17:47, Venkatesan Mahalingam wrote:
Benoit,

Regards, B.

Joan,

-Venkat

---------- Forwarded message ----------
From: Venkatesan Mahalingam <[email-masked]<mailto:[email-masked]>>
Date: Thursday, September 3, 2015
Subject: Benoit Claise's Discuss on draft-ietf-mpls-tp-oam-id-mib-09: (with DISCUSS and COMMENT)
To: Benoit Claise <[email-masked]<mailto:[email-masked]>>
Cc: The IESG <[email-masked]<mailto:[email-masked]>>, Joan Cucchiara <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Hi Benoit and Joan,

OLD

Section-8

   operations.
NEW

Section-8

On Wed, Sep 2, 2015 at 11:59 PM, Benoit Claise <[email-masked]<mailto:[email-masked]>> wrote:
Benoit Claise has entered the following ballot position for
draft-ietf-mpls-tp-oam-id-mib-09: Discuss

No virus found in this message.
Checked by AVG - www.avg.com<http://www.avg.com>
Version: 2014.0.4830 / Virus Database: 4365/10594 - Release Date: 09/07/15
No virus found in this message.
Checked by AVG - www.avg.com<http://www.avg.com>
Version: 2014.0.4830 / Virus Database: 4365/10641 - Release Date: 09/14/15