Subject: [middisc] currently used TCP option numbers

From: Lars Eggert <[email-masked]>
Date: Mon, 24 May 2010 10:03:35 -0400

Hi,

in order to avoid clashes between options that the IETF assigns in the near future and ones that are currently being used without proper registration, would you let me know which option numbers your products use and - if you are aware of it - which numbers may be used by other vendors? I will then instruct IANA to mark them as "user without proper registration" (or something like this) in the IANA table at http://www.iana.org/assignments/tcp-parameters/tcp-parameters.xml 

My main motivation is that we've just assigned option #29, and I have heard that some vendors are using numbers in the low 30s. Because IANA typically assigns numbers incrementally, there may be a clash in the not too far future. I'd really like to avoid those clashes from happening. IANA can skip those numbers that are used without proper registration, if they know about them.

Thanks,
Lars

---

From: Mark Day <[email-masked]>
Date: Wed, 26 May 2010 20:13:53 -0700

Riverbed currently uses options 76,77, and 78. Our products are configurable to allow changing the option number(s) used, but in practice almost no-one changes from the default option numbers.

--Mark

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lars Eggert
Sent: Monday, May 24, 2010 10:04 AM
To: [email-masked]
Subject: [middisc] currently used TCP option numbers

Hi,

Thanks,
Lars