Subject: Re: [mif] New I-D: draft-savolainen-mif-dns-server-selection-00

From: "shshrosh" <[email-masked]>
Date: Tue, 24 Feb 2009 10:28:45 +0800

Hi,

After reading your new draft, I am puzzled by a question.
In the previous discussion, the main idea is to select interfaces of a node by policies generated by the node and/or the netwrok(I am not sure whether this still needs discussion in your draft). But in the new draft the interface can be decided just by the DNS suffix. There may be some conflicts between these two methods. Am i made some misunderstanding?

Wenjie Hu

Best Regards！

2009-02-24 

shshrosh 

发件人： [email-masked] 
发送时间： 2009-02-19  21:58:13 
收件人： [email-masked] 
抄送： 
主题： [mif] New I-D: draft-savolainen-mif-dns-server-selection-00 
 
Hi,
I have now created a new I-D http://tools.ietf.org/internet-drafts/draft-savolainen-mif-dns-server-selection-00.txt based on the comments I recall receiving in IETF#73 for the previous version (draft-savolainen-6man-fqdn-based-if-selection).
Most notably this new I-D is now focusing purely on DNS server selection in multi-homed environments facing split DNS problems. I.e. the network interface and address selection for actual IP flows (i.e. usage of DNS suffixes for routing & source address selection) is now totally dropped out (except that the draft mentions those really are needed..).
Comments are welcome,
        Teemu
>-----Original Message-----
>From: ext IETF I-D Submission Tool [mailto:[email-masked]]
>Sent: 19 February, 2009 15:45
>To: Savolainen Teemu (Nokia-D-MSW/Tampere)
>Subject: New Version Notification for
>draft-savolainen-mif-dns-server-selection-00
>
>
>A new version of I-D,
>draft-savolainen-mif-dns-server-selection-00.txt has been
>successfuly submitted by Teemu Savolainen and posted to the
>IETF repository.
>
>Filename:        draft-savolainen-mif-dns-server-selection
>Revision:        00
>Title:           DNS Server Selection on Multi-Homed Hosts
>Creation_date:   2009-02-19
>WG ID:           Independent Submission
>Number_of_pages: 12
>
>Abstract:
>A multi-homed host may receive DNS server configuration
>information from multiple physical and/or virtual network
>interfaces.  In split DNS scenarios not all DNS servers are
>able to provide the same information.  When the multi-homed
>host needs to utilize DNS, it has to select which of the
>servers to contact to.  This document describes problems of
>split DNS for multi-homed hosts and also a method for
>selecting the DNS server with help of DNS suffix information
>received dynamically for each network interface.  The method
>is useful in split DNS scenarios where private names are used
>and where correct DNS server selection is mandatory for
>successful DNS resolution.
>
>
>
>The IETF Secretariat.
>
>
>
_______________________________________________
mif mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mif

---

From: Kevin Chin <[email-masked]>
Date: Mon, 23 Feb 2009 19:02:37 -0800

Hi-

Yes please clarify. I also wanted to confirm the use case:
" The procedure described in chapter 3 applies when applications are
   allowed to utilize multiple interfaces in parallel."

This definitely narrows scope but also applicability.
Does using DNS for interface selection imply "on startup of application
(initial DNS query?)" not failover or mobility cases?

thanks-

On Mon, Feb 23, 2009 at 6:28 PM, shshrosh <[email-masked]> wrote:

> In the previous discussion, the main idea is to select interfaces of a node
> by policies generated by the node and/or the netwrok(I am not sure
> whether this still needs discussion in your draft). But in the new draft the
> interface can be decided just by the DNS suffix. There may be some conflicts
> between these two methods. Am i made some misunderstanding?
>
> Wenjie Hu
>
> Best Regards！
>
>
> 2009-02-24
> ------------------------------
>  shshrosh
> ------------------------------
>  *发件人：* [email-masked]
> *发送时间：* 2009-02-19  21:58:13
> *收件人：* [email-masked]
> *抄送：*
> *主题：* [mif] New I-D: draft-savolainen-mif-dns-server-selection-00
>    Hi,
>  I have now created a new I-D
> http://tools.ietf.org/internet-drafts/draft-savolainen-mif-dns-server-selection-00.txt
>  based on the comments I recall receiving in IETF#73 for the previous version (draft-savolainen-6man-fqdn-based-if-selection).
>

---

From: <[email-masked]>
Date: Tue, 24 Feb 2009 11:50:22 +0100

Hi,

The main negative feedback I received at IETF#73 was that DNS information should NOT be used for selecting interface over which actual IP flows are to be created, but that should be done instead by routing functions (e.g. source & destination address selection algorithms and/or with help of possible routing information delivered to host by some means). Thus describing that functionality is no longer in the scope of the draft.

As the routing cannot help to choose the right DNS server (the DNS server selection is not based on IP-addresses), this draft focuses now solely on that problem.

So indeed the scope of this draft is narrower now. The idea is that the functionality dropped/not included in this document is covered by other documents (like what the proposed charter item "Routing of multiple interfaces" would provide).

"Does using DNS for interface selection imply "on startup of application (initial DNS query?)" not failover or mobility cases?"

The intent of this draft is to describe DNS _server_selection_ per DNS query, in an environment where multiple interfaces are simultaneously available for application's use (currently applications are often forced/bound/directed to use a single network interface at a time, thus DNS server selection is trivial -> always use the DNS server address obtained from the interface application is bound to). The actual interface selection for application's IP flows shall happen, after the DNS resolution has completed, by routing functions (which may or may not select same interface that was used for DNS query).

This draft does not cover how and when the physical/virtual interfaces are brough up or down (but I think logic for that could perhaps include DNS suffix information).

If an application does just one DNS query, then the DNS server selection is done just once, and after DNS has provided an IP address, it is up-to other functions to choose what network interfaces are used and when. If the application does another DNS query later on (e.g. for different name, or after TTL of the name has expired), the DNS server selection algorithm will check what interfaces are up at that point and prioritize DNS servers according to available network interfaces.

"the main idea is to select interfaces of a node by policies generated by the node and/or the netwrok"

This draft now focuses solely on DNS server selection, but the selection is affected by DNS suffix information obtained from the network interfaces. Networks can influence this host based policy by providing suffixes. In addition to utilizing existing DHCP options, I could envision introduction of some new protocols that could provide more and/or fine grained information, but would of course require more standardization etc.

"But in the new draft the interface can be decided just by the DNS suffix"

The interface for actual IP flows is not decided by DNS suffix in this draft, but the DNS suffix is just used as hint for higher likelyhood of successful DNS query if done with DNS servers of interfaces having matching DNS suffix.

Does this answer your questions? I can update the draft text (especially on introduction) to more precisely describe that it is focusing solely on DNS server selection.

Best regards,

    Teemu

________________________________
From: ext Kevin Chin [mailto:[email-masked]]
Sent: 24 February, 2009 05:03
To: shshrosh
Cc: Savolainen Teemu (Nokia-D-MSW/Tampere); [email-masked]
Subject: Re: [mif] New I-D: draft-savolainen-mif-dns-server-selection-00

Hi-

This definitely narrows scope but also applicability.
Does using DNS for interface selection imply "on startup of application (initial DNS query?)" not failover or mobility cases?

thanks-

On Mon, Feb 23, 2009 at 6:28 PM, shshrosh <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Wenjie Hu

Best Regards！

2009-02-24
________________________________
shshrosh
________________________________
发件人： [email-masked]<mailto:[email-masked]>
发送时间： 2009-02-19  21:58:13
收件人： [email-masked]<mailto:[email-masked]>
抄送：
主题： [mif] New I-D: draft-savolainen-mif-dns-server-selection-00
Hi,
I have now created a new I-D http://tools.ietf.org/internet-drafts/draft-savolainen-mif-dns-server-selection-00.txt based on the comments I recall receiving in IETF#73 for the previous version (draft-savolainen-6man-fqdn-based-if-selection).
Most notably this new I-D is now focusing purely on DNS server selection in multi-homed environments facing split DNS problems. I.e. the network interface and address selection for actual IP flows (i.e. usage of DNS suffixes for routing & source address selection) is now totally dropped out (except that the draft mentions those really are needed..).
Comments are welcome,
        Teemu
>From: ext IETF I-D Submission Tool [mailto:[email-masked]<mailto:[email-masked]>]
_______________________________________________
mif mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mif

_______________________________________________
mif mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mif