Subject: Re: [mif] IP model for multiple mode mobile terminal

From: Qin Wu <[email-masked]>
Date: Mon, 09 Feb 2009 14:14:02 +0800

Hi,Peny:
I lost these thread discussion for a while. Thank for your clarification. I fully agree with your most point.As regarding no-mip case for generic IP model,even without user experience for service continuity,i.e., nomadicity, the teminal with multiple interface also can work.The more detailed mechanism is for further study.
as regarding whether generic MIP solution can make the seamless handover, you are right. Some mobility enhanced work have already been done in mipshop working group,e.g.,RFC5270.
Best regards!~
-Qin 
----- Original Message ----- 
From: "Peny Yang" <[email-masked]>
To: "Qin Wu" [email-masked]
Cc: "mif" <[email-masked]>
Hi, Qin:

It's a interesting point. Check the lines below:

On Sat, Jan 17, 2009 at 7:03 PM, w53375 <sunseawq at huawei.com> wrote:
> Thanks for your reply, Please see the follow up comments below.
> -Qin
>
> ----- Original Message -----
> From: Hui Deng
> To: Qin Wu
> Cc: mif at ietf.org
> Sent: Wednesday, January 14, 2009 6:35 AM
> Subject: IP model for multiple mode mobile terminal
> Hi, Qin,
>
> Thanks for your comments. see below inline reply.
> 2009/1/8 Qin Wu <sunseawq at huawei.com>
>>
>> Interesting topic, As we discussed before, you thought Internet IP
>> model was invented by 1 PC, 1 Default Gateway, 1 default route. But today it
>> is a little different, mobile terminal has multiple modes, it would like to
>> use all of them simulatenously which orginal IP model doesn't work any more
>> on it.
>
> [Qin]What I understand in order to achieve seamless handover during the
> inter-technology handover, the UE is required to support dual
> mode,e.g.,WiMAX mode and CDMA mode.Before UE moves from WiMAX access network
> to the CDMA access network, the UE can attach to WIMAX and CDMA link
> simuteneusly,in this situation, the traffic can be bicasted to the UE
> through two links, the packet loss can be avoided wholly, however, the
> difficulty is when the UE frequently moves between hetergeneous network at
> high speed, there are great chanllenge for the UE to maintain the WiMAX link
> and CDMA link simuteneously.
[Peny] Are you talking about MIP case or non-MIP case?
In case of MIP, I agree with you.
In case of non-MIP, it seems in IETF there is no way to bi-cast the
streams to two different interfaces with two addresses of MN.
I just review the discussion in this list. Personally, I think MIF is
to solve the issue of GENERIC  IP model. As hui said previously, IP
model should no longer have the original assumption of "one link" as
many terminals have multiple links so far.
MIP has the way to support the multiple links in MN. I once did some
work on this as well. Basically, Generic MIP solution is not adequate
to make the seamless handover. It needs some low layer modifications
(such as one address for multiple link, prevent the high layers to
detecting the link transfer event, etc). All the problems originated
from the "one default link" design of current OS. Maybe it's the time
to do something to improve the generic IP model for multiple link
support in MN.

> it seems that dynamical provision and routing, coordination and
> synchronization will become more complicated, simple way make deployment
> easy, it is the way of Internet exist
> [Qin} I agree more optimized approach can be used to faciliate utilizing the
> network resource and better user experience.
> thanks
[Peny] I agree with you two as well.

BRG
Peny
_______________________________________________
mif mailing list
mif at ietf.org
https://www.ietf.org/mailman/listinfo/mif

*******************************************************************************************
This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!
*******************************************************************************************

---

From: Peny Yang <[email-masked]>
Date: Tue, 10 Feb 2009 11:44:47 +0800

Hey, Qin:

On Mon, Feb 9, 2009 at 2:14 PM, Qin Wu <[email-masked]> wrote:
> Hi,Peny:
> I lost these thread discussion for a while. Thank for your clarification. I
> fully agree with your most point.As regarding no-mip case for generic IP
> model,even without user experience for service continuity,i.e., nomadicity,
> the teminal with multiple interface also can work.The more detailed
> mechanism is for further study.
[Peny] I don't get your point here. Could you add more lines to show
the relationship between Nomadic and MIF?

> as regarding whether generic MIP solution can make the seamless
> handover, you are right. Some mobility enhanced work have already been done
> in mipshop working group,e.g.,RFC5270.
[Peny] Well. MIP case is out of the scope of MIF. I am afraid that
it's not a good idea to discuss it in this list.

Peny

> This email and its attachments contain confidential information from HUAWEI,
> which is intended only for the person or entity whose address is listed
> above. Any use of the information contained herein in any way (including,
> but not limited to, total or partial disclosure, reproduction, or
> dissemination) by persons other than the intended recipient(s) is
> prohibited. If you receive this e-mail in error, please notify the sender by
> phone or email immediately and delete it!

---

From: Qin Wu <[email-masked]>
Date: Tue, 10 Feb 2009 13:52:02 +0800

Hi,Peny:
Thank for your reply. Please see the answers in line.
-Qin
----- Original Message ----- 
From: "Peny Yang" <[email-masked]>
To: "Qin Wu" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, February 10, 2009 11:44 AM
Subject: Re: [mif] IP model for multiple mode mobile terminal

> the relationship between Nomadic and MIF?
[Qin]What I understand MIF here is MIF can be viewed as Simple IP issue at this step, compared with mobile IP issue.
As regarding the relationship between nomadic and MIF, MIF can be applicable into nomdical scenarios. Just as Hui said, 
the case in which the service needs not be kept ongoing, the service can be stopped and restarted again, am I right?
> it's not a good idea to discuss it in this list.
[Qin] I have not any objection about this.