Subject: Re: [mif] AMSS/Brew Multi-interface handling

From: Hui Deng <[email-masked]>
Date: Fri, 9 Apr 2010 23:31:25 +0800

Hi, George,

just two clarifications AMSS/Brew DNS configuration is
interface based other than host based?

secondly, network profile could identify only APN other than PDP context?

thanks

-Hui

2009/8/16 George Tsirtsis <[email-masked]>:
> Hi all,
>
> I sent this to Margaret during the IETF meeting but I did not hear
> back from her. Maybe it got lost in the IETF noise so I thought I
> might as well forward this to the list.
>
> I hope it helps.
>
> George
>
> ---------- Forwarded message ----------
> From: George Tsirtsis <[email-masked]>
> Date: Wed, Jul 29, 2009 at 9:58 AM
> Subject: AMSS/Brew Multi-interface handling
> To: [email-masked]
>
>
> Hi Margaret,
>
> Here is a description of how multi-interface support is handled by
> Advanced Mobile Station Software (AMSS) that comes with Brew OS for
> all Qualcomm chipsets (e.g., MSM, Snapdragon etc). I hope this is
> helpful information for draft-mrw-mif-current-practices.
>
> Let me know if you have any questions.
>
> Regards
> George Tsirtsis (wearing a Qualcomm hat)
>
> -----------------------------------------------------------------------------------------------------
>
>
> Multiple Interface Handling - Qualcomm AMSS/Brew Mobile Platform
>
> AMSS supports a concept of “netpolicy” which allows each application
> to specify the type of network connectivity desired.  The netpolicy
> contains parameters such as access technology, IP version type and
> network profile.  Access technology could be a specific technology
> type such as CDMA or WiFi or could be a group of technologies, such as
> ANY_Cellular or ANY_Wireless.  IP version could be one of Ipv4, Ipv6
> or Default.  The network profile identifies a type of network domain
> or service within a certain network technology, such as 3GPP APN or
> Mobile IP Home Agent.  It also specifies all the mandatory parameters
> required to connect to the domain such authentication credentials and
> other optional parameters such as QoS attributes.  Network Profile is
> technology specific and set of parameters contained in the profile
> could vary for different technologies.
>
> Two models of network usage are supported.
>
> Applications requiring network connectivity specify an appropriate
> netpolicy in order to select the desired network.  The netpolicy may
> match one or more network interfaces.  AMSS system selection module
> selects the best interface out of the ones that match the netpolicy
> based on various criteria such as cost, speed or other provisioned
> rules.  Application explicitly starts the selected network interface
> and, as a result, the application also gets bound to the corresponding
> network interface.  All outbound packets from this application are
> always routed over this bound interface using the source address of
> the interface.
> Alternately, applications may rely on a separate connection manager to
> control (start/stop) the network interface.    In this method,
> applications are not necessarily bound to any one interface.  All
> outbound packets from such applications are routed on one of the
> interfaces that match its netpolicy.  The routing decision is made
> individually for each packet and  selects the best interface based on
> the criteria described above and the destination address.   Source
> address is always that assigned to the interface used to transmit the
> packet.
>
> Note that all of the routing/interface selection decisions are based
> on the netpolicy and not just destination address to avoid overlapping
> private Ipv4 address issue.  This also allows multiple (logical)
> interfaces to be configured with the same IP address, for example, to
> handle certain tunnelling scenarios.   Applications that do not
> specify a netpolicy are routed by AMSS to the best possible interface
> using the default netpolicy.  Default netpolicy could be pre-defined
> or provisioned by the administrator or operator.  Hence default
> interface could vary from device to device and also depends upon the
> available networks at any given time.
> AMSS allows each interface to be configured with its own set of DNS
> configuration parameters – a list of DNS servers, domain names etc.
> Interface selected to make a DNS resolution is the one to which
> application making the DNS query is bound.  Applications can also
> specify a different netpolicy as part of DNS request to select another
> interface for DNS resolution.  Regardless, all the DNS queries are
> sent only over this selected interface using the DNS configuration
> from the interface.   DNS resolution is first attempted with the
> primary server configured in the interface.  If a response is not
> received, the queries are sent to all the other servers configured in
> the interface in a sequential manner using a backoff mechanism.
> _______________________________________________
> mif mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mif
>

---

From: "Laganier, Julien" <[email-masked]>
Date: Fri, 9 Apr 2010 10:12:19 -0700

Hi Margaret - 

I notice this text is not included in the current rev. of the current practice draft. Are you going to include it?

Thanks.

--julien

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Margaret Wasserman
> Sent: Sunday, August 16, 2009 7:04 AM
> To: George Tsirtsis
> Cc: mif
> Subject: Re: [mif] AMSS/Brew Multi-interface handling
> 
> 
> Hi George,
> 
> Thanks for sending this!
> 
> I'll add it to the next version of the draft.
> 
> Margaret
> 
> On Aug 16, 2009, at 5:41 AM, George Tsirtsis wrote:
> 
> > Hi all,
> >
> > AMSS supports a concept of "netpolicy" which allows each application
> > configuration parameters - a list of DNS servers, domain names etc.

---

From: Hui Deng <[email-masked]>
Date: Sat, 10 Apr 2010 20:57:56 +0800

Hi Julien

As I asked the question yesterday,
it is expected that Qualcomm has more detail clarification about the text,

Regards,

-Hui

---

From: "Laganier, Julien" <[email-masked]>
Date: Mon, 12 Apr 2010 14:20:00 -0700

Hi Hui,

I do not understand what is meant here. Can you clarify?

Thanks.

--julien

Hui Deng wrote:
> > I notice this text is not included in the current rev. of the current
> practice draft. Are you going to include it?
> >
> > Thanks.
> >
> > --julien
> >
> >> > ------------------------------------------------------------------
> ---
> >> --------------------------------
> >> >
> >> >
> >> > type such as CDMA or WiFi or could be a group of technologies,
> such
> >> as
> >> > Alternately, applications may rely on a separate connection
> manager
> >> to

---

From: Hui Deng <[email-masked]>
Date: Tue, 13 Apr 2010 08:57:58 +0800

Hi Julien

What I mean is I sent one email to clarify the AMSS/Brew several days ago
http://www.ietf.org/mail-archive/web/mif/current/msg00714.html
would like to clarify more detail before adding into the current practice draft,

thanks

-Hui

---

From: "Laganier, Julien" <[email-masked]>
Date: Tue, 13 Apr 2010 13:25:39 -0700

> interface based other than host based?

Quoting the text George sent:

> secondly, network profile could identify only APN other than PDP

Quoting the text George sent: 

   The network profile identifies a type of network domain 

--julien

---

From: "Laganier, Julien" <[email-masked]>
Date: Tue, 13 Apr 2010 13:27:59 -0700

I have replied to your other email; it's not clear to me what needs to be clarified.

--julien

Hui Deng wrote:
> >> >> From: [email-masked] [mailto:[email-masked]] On
> Behalf
> >> Of
> >> >> Margaret Wasserman
> >> >> > or service within a certain network technology, such as 3GPP
> APN
> >> or
> >> >> > required to connect to the domain such authentication
> credentials
> >> and
> >> >> > other optional parameters such as QoS attributes.  Network
> Profile
> >> is
> >> >> > netpolicy in order to select the desired network.  The
> netpolicy
> >> may
> >> >> > always routed over this bound interface using the source
> address
> >> of
> >> >> > the interface.
> >> >> > individually for each packet and  selects the best interface
> based
> >> on
> >> >> > address is always that assigned to the interface used to
> transmit
> >> the
> >> >> > packet.
> >> >> >
> >> >> > interfaces to be configured with the same IP address, for
> example,
> >> to
> >> >> > interface could vary from device to device and also depends
> upon
> >> the
> >> >> > received, the queries are sent to all the other servers
> configured
> >> in

---

From: Hui Deng <[email-masked]>
Date: Wed, 14 Apr 2010 09:58:17 +0800

inline please,

>   configuration parameters - a list of DNS servers, domain names etc.
As you can see from the MIF discussion, even configuration could be
interface based,
but final DNS server selection could be host based, does AMSS/Brew
works similar?

>   could vary for different technologies.
wifi has two type connections:connected through APN, or directed
connected with Internet
assume you have 3G+Wifi Connections,
in your profile, it would be the same APN for 3G and Wfi, then you
have to rely on access type?
but access type will differentiate 3g and wifi.
So who will be high priority? access type or APN(profile).

thanks for your clarification.

-Hui

---

From: Hui Deng <[email-masked]>
Date: Wed, 14 Apr 2010 09:59:04 +0800

I have explained as well, hope it clarify the question.

-Hui

---

From: "Laganier, Julien" <[email-masked]>
Date: Fri, 16 Apr 2010 17:42:53 -0700

Hello Hui,

Pls. see inline:

Hui Deng wrote:
> interface based, but final DNS server selection could be host based, 
> does AMSS/Brew works similar?

Quoting the text George sent:

> from the interface.

This seems to answer your question, doesn't it?
 
> >   required to connect to the domain such authentication credentials
> >   and other optional parameters such as QoS attributes.  Network Profile
> >   is technology specific and set of parameters contained in the profile

I am not sure I follow you. Let me try to sketch what happens:

An application specifying an APN in its network profile means that it desire to connect to the PDN named by this APN. 

As a result, only interfaces connecting to that APN will be selected, which rules out WiFi by itself and keeps in 3G, and any of the 3GPP accesses over WiFi (such as 3GPP I-WLAN or either of the various non-3GPP accesses over S2a/b/c interfaces.)

If the application has specified a preference for an ANY_Cellular access technology (or say HSDPA) then 3G will be selected, if the application has specified a preference for an ANY_Wireless access technology (or say IEEE 802.11) the 3GPP I-WLAN application will be selected. If the application hasn't specified anything, the default access will be selected.

Does the above clarify the situation?

--julien

---

From: Hui Deng <[email-masked]>
Date: Tue, 20 Apr 2010 23:49:21 +0800

Hello Julien,

inline please

> This seems to answer your question, doesn't it?
It still not clear to me, like the last sentence, it doesn't say application
like web browser which could use multiple interfaces, which interface
will this application be bound to?

> Does the above clarify the situation?
Could I understand that access type is more high priority than APN,
if that is what it is designed, please kind help to clarify the text,

thanks

-hui