Subject: Re: [mif] WG LC for MIF PS

From: <[email-masked]>
Date: Thu, 1 Apr 2010 10:27:57 +0200

> -----Message d'origine-----
> De : Laganier, Julien [mailto:[email-masked]]
> Envoyé : mercredi 31 mars 2010 17:27
> À : SEITE Pierrick RD-RESA-REN; [email-masked];
> [email-masked]
> Cc : [email-masked]
> Objet : RE: [mif] WG LC for MIF PS
> 
> Hello,
> 
> [email-masked] wrote:
> >
> > Hi Zhen,
> >
> > >
> > > >> 3.4 Address selection
> > > >> It is good to mention that some OS like OSX does not implement
> > > >> 3484-like policy table.
> > > > This belongs to the current-practices doc.
> > > >> Default behavior of the 3484 policy table is
> > > >> to prefer IPv6 over IPv4, but this behavior in some situations are
> > not
> > > >> optimal and need to be changed.
> > > >
> > > > How much this comment related to MIF? Can you describe a specific
> > > scenario?
> > >
> > > If the host has two interfaces, one connects to the IPv6-only and one
> > > connection to IPv4, and a dual stack application may be restricted by
> > > the address selection policy.
> >
> > Ok, the PS text can be updated to state that default selection, as per
> > RFC3484, is not always optimal.
> 
> RFC 3484 address selection not being optimal seems like an orthogonal
> problem to a host being attached to multiple network domains since the
> issue can also occurs when a host is attached to a single domain. So I
> don't think we should list this in the PS.
> 

It makes sense to focus on issues specific to MIF.

Thanks,
Pierrick

> --julien

---

From: Zhen Cao <[email-masked]>
Date: Mon, 5 Apr 2010 20:42:01 +0800

On Wed, Mar 31, 2010 at 11:27 PM, Laganier, Julien <[email-masked]> wrote:
>
> RFC 3484 address selection not being optimal seems like an orthogonal problem to a host being attached to multiple network domains since the issue can also occurs when a host is attached to a single domain. So I don't think we should list this in the PS.
>

If one interface is IPv6 and another interface is IPv4, which one to
choose is directly related to the mif. That's not covered by RFC3484.
And i am thinking of if the "domain selection" can cover this problem.

-Zhen

---

From: "Laganier, Julien" <[email-masked]>
Date: Mon, 5 Apr 2010 08:07:13 -0700

> And i am thinking of if the "domain selection" can cover this problem.

The generic problem of how to best choose between IPv4 and IPv6 to reach a given destination exists already with a single interface and a single administrative domain and is thus not specific to MIF. A solution to this problem would work in MIF too and thus I do not think we should list this in the problem statement.

--julien

---

From: Scott Brim <[email-masked]>
Date: Mon, 05 Apr 2010 11:26:01 -0400

Laganier, Julien allegedly wrote on 04/05/2010 11:07 EDT:
>>> RFC 3484 address selection not being optimal seems like an
>>> orthogonal problem to a host being attached to multiple network
>>> domains since the issue can also occurs when a host is attached
>>> to a single domain. So I don't think we should list this in the
>>> PS.
>> 
>> If one interface is IPv6 and another interface is IPv4, which one
>> to choose is directly related to the mif. That's not covered by
>> RFC3484. And i am thinking of if the "domain selection" can cover
>> this problem.
> 
> The generic problem of how to best choose between IPv4 and IPv6 to
> reach a given destination exists already with a single interface and
> a single administrative domain and is thus not specific to MIF. A
> solution to this problem would work in MIF too and thus I do not
> think we should list this in the problem statement.
> 
> --julien

IMHO: The MIF scope is that once you get your answers back from those
other mechanisms for determining what works (v6 vs v4 .. and TCP vs SCTP
and so on), those answers may be spread across multiple interfaces, and
you have to use the right one in the right way.

Scott

---

From: Zhen Cao <[email-masked]>
Date: Tue, 6 Apr 2010 10:52:19 +0800

> The generic problem of how to best choose between IPv4 and IPv6 to reach a given destination exists already with a single interface and a single administrative domain and is thus not specific to MI…

Yes, I agree this problem flows into the address selection bullet.
Considering Scott's comments, we will have to take care of the result
delivered from the solution to a single domain when applied to
multiple domains. Thanks for the discussion.