Subject: [mif] 答复: Fwd: I-D Action: draft-baker-6man-multi-homed-host-00.txt

From: Liang Geng <[email-masked]>
Date: Mon, 21 Sep 2015 00:14:53 +0800

Hi Fred,

I have just read through this draft (the most recent 03 version).

The draft is very pleasant to read and I believe it focuses on the same
multi-homed issue MIF WG is working on. It very well described how IPV6
hosts/network are expected to behave in multi-homed scenario.

In mif, Provisioning Domain (PvD) is introduced to associate and identify
network configurations for a particular interface. I think it is a good idea
to see if there is any conflict between the mechanism in PvD solution and
the host/network behavior described in your draft. However, I don't see
obvious ones at present. 

Best wishes,
Liang

> -----邮件原件-----
> 发件人: mif [mailto:[email-masked]] 代表 Fred Baker (fred)
> 发送时间: 2015年8月10日 22:04
> 收件人: [email-masked]
> 主题: [mif] Fwd: I-D Action: draft-baker-6man-multi-homed-host-00.txt
> 
> This is actually being discussed in 6man, as the chairs requested it
there, but
> MIF might have comments to pass along.
> 
> > Begin forwarded message:
> >
> > From: <[email-masked]>
> > Subject: I-D Action: draft-baker-6man-multi-homed-host-00.txt
> > Date: August 7, 2015 at 7:40:43 AM PDT
> > To: <[email-masked]>
> > Reply-To: <[email-masked]>
> >
> >
> > A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> >
> >
> >        Title           : Host routing in a multi-prefix network
> >        Authors         : Fred Baker
> >                          Brian Carpenter
> > 	Filename        : draft-baker-6man-multi-homed-host-00.txt
> > 	Pages           : 6
> > 	Date            : 2015-08-07
> >
> > Abstract:
> >   This note describes expected host behavior in a network that has more
> >   than one prefix, each allocated by an upstream network that
> >   implements BCP 38 filtering.
> >
> >
> > The IETF datatracker status page for this draft is:
> > https://datatracker.ietf.org/doc/draft-baker-6man-multi-homed-host/
> >
> > There's also a htmlized version available at:
> > https://tools.ietf.org/html/draft-baker-6man-multi-homed-host-00
> >
> >
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at
tools.ietf.org.
> >
> > Internet-Drafts are also available by anonymous FTP at:
> > ftp://ftp.ietf.org/internet-drafts/
> >
> > _______________________________________________
> > I-D-Announce mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/i-d-announce
> > Internet-Draft directories: http://www.ietf.org/shadow.html or
> > ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Fri, 25 Sep 2015 11:22:15 +0000

Thanks. I'm not just sure why you copied me and not my co-author, but whatever. Yes, I think they are related problems. I'm glad you see no conflict; if you see an issue, please let us know.

> On Sep 20, 2015, at 9:14 AM, Liang Geng <[email-masked]> wrote:
> 
> Hi Fred,
>

---

From: Liang Geng <[email-masked]>
Date: Sat, 26 Sep 2015 23:05:29 +0800

Dear Fred,

Thank you for your email.

I received your request for comments in MIF mail list and my previous email was a response of that.

I believe that this draft describes the behavior of a host very similar to the host which behaves as a MPVD-aware node in MIF. I might get this wrong but I suspect that the related MIF RFCs (i.e. RFC 7556) may have covered the same issues.

Therefore, I think It is very important for us to understand whether and how much of this work is in MIF or 6MAN's scope and how it should fit in to avoid any duplication. Currently without seeing much conflict on how multi-homed host/network behavior is described in both your draft and MIF architecture, I am a bit worried that there might be some extent of overlaps. Hence, I would also like to see more comments both from your side and mif folks.

Best wishes,
Liang 
> -----Original Message-----
> From: Fred Baker (fred) [mailto:[email-masked]]
> Sent: Friday, September 25, 2015 7:22 PM
> To: Liang Geng
> Cc: [email-masked]; Brian E Carpenter
> Subject: Re: [mif] I-D Action: draft-baker-6man-multi-homed-host-00.txt
> 
> Thanks. I'm not just sure why you copied me and not my co-author, but
> whatever. Yes, I think they are related problems. I'm glad you see no conflict; if
> you see an issue, please let us know.
> 
> > The draft is very pleasant to read and I believe it focuses on the
> > same multi-homed issue MIF WG is working on. It very well described
> > how IPV6 hosts/network are expected to behave in multi-homed scenario.
> >
> > In mif, Provisioning Domain (PvD) is introduced to associate and
> > identify network configurations for a particular interface. I think it
> > is a good idea to see if there is any conflict between the mechanism
> > in PvD solution and the host/network behavior described in your draft.
> > However, I don't see obvious ones at present.
> >
> > Best wishes,
> > Liang
> >
> >> -----邮件原件-----
> >>> This note describes expected host behavior in a network that has
> >>> more than one prefix, each allocated by an upstream network that

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 27 Sep 2015 08:08:25 +1300

> Therefore, I think It is very important for us to understand whether and how much of this work is in MIF or 6MAN's scope and how it should fit in to avoid any duplication. Currently without seeing…

Put simply, this draft is intended to mitigate the underlying problem whether or
not the host is using MPVD mechanisms, so it belongs in 6man.

If you can identify any way in which it damages MPVD mechanisms, that would
be good input.

   Brian

---

From: Liang Geng <[email-masked]>
Date: Tue, 29 Sep 2015 22:36:59 +0800

Dear Brian,

> not the host is using MPVD mechanisms, so it belongs in 6man.

PvD is naturally there. My understanding is that no matter a certain group of associated network configurations are called a "MPVD", it is an MIF problem if that are used for multi-homed purposes. As seen in MIF charter:

" The purpose of the MIF working group is to describe the architecture detailing how devices attach to and operate in multiple networks ......"
And
(one of the chartered goal)" An incrementally deployable architecture, defining a consistent approach and recommended practices for handling sets of network configuration objects by hosts, attached to multiple networks, which enable hosts to improve network connectivity for the host's applications and users. Each of these sets of network configuration objects is referred to collectively as a provisioning domain (PVD) "

> If you can identify any way in which it damages MPVD mechanisms, that would

Personally I think the draft should not only be not-damaging MPVD mechanisms, but also somehow imply the concept of PvDs since it's naturally there for all multi-homed hosts and the problem has been investigated in MIF with a deployable approach. I don't think I have a strong opinion on where this work belongs to but I feel that mif work should also be involved if it is in 6man. I would love to contribute to this draft to address any MIF-specific issues.

Best wishes
Liang
________________________________
Liang GENG | 耿亮
网络技术研究所 | Department of Network Technology
中国移动通信有限公司研究院 | China Mobile Research Institute
手机 | Mobile：+86 13910103207
电话 | Landline：+86 15801696688-36334
传真 | Fax：+86 10 63135198
电子邮箱 | Email：[email-masked]
北京西城区宣武门西大街32号 | 32 Xuanwumen West Street, Xicheng District, Beijing, China
邮编 | Postcode：100053

> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: Sunday, September 27, 2015 3:08 AM
> To: Liang Geng; 'Fred Baker (fred)'
> Cc: [email-masked]
> > I believe that this draft describes the behavior of a host very similar to the host
> which behaves as a MPVD-aware node in MIF. I might get this wrong but I
> suspect that the related MIF RFCs (i.e. RFC 7556) may have covered the same
> issues.
> >
> > Therefore, I think It is very important for us to understand whether and how
> much of this work is in MIF or 6MAN's scope and how it should fit in to avoid any
> duplication. Currently without seeing much conflict on how multi-homed
> host/network behavior is described in both your draft and MIF architecture, I am
> a bit worried that there might be some extent of overlaps. Hence, I would also
> like to see more comments both from your side and mif folks.
> 

> >> whatever. Yes, I think they are related problems. I'm glad you see no
> >> conflict; if you see an issue, please let us know.
> >>
> >>> identify network configurations for a particular interface. I think
> >>> it is a good idea to see if there is any conflict between the
> >>> mechanism in PvD solution and the host/network behavior described in your
> draft.