Subject: [mile] Documents for consideration as MILE WG items

From: Brian Trammell <[email-masked]>
Date: Wed, 26 Oct 2011 09:23:18 +0200

Greetings, all, and welcome to the MILE working group!

As a contributor, I'd like to put forward three documents for consideration as working group items under the initial charter; these are all relatively lightweight, and I believe should be easy to come to agreement on.

1. For * An informational template for extensions to IODEF:

"Guidelines for Extensions to IODEF for Managed Incident Lightweight Exchange"
       http://tools.ietf.org/html/draft-trammell-mile-template 

This is an informational document primarily intended to speed the work of the MILE WG itself. It contains an Internet-Draft template for IODEF extensions.

2. For * A Standards Track document for IODEF Extensions in IANA XML Registry:

"Expert Review for IODEF Extensions in IANA XML Registry"
http://tools.ietf.org/html/draft-trammell-mile-iodef-xmlreg

This is a housekeeping and process document, which specifies a change to IODEF-related XML schema registrations in order to ensure an expert review of those schemas. It's really short; indeed, I'll quote the important part of the document here:

   Changes to the XML Schema registry for schema names beginning with
   "urn:ietf:params:xml:schema:iodef" are subject to an additional IODEF
   Expert Review [RFC5226].

   The IODEF expert(s) for these reviews will be designated by the IETF
   Security Area Directors.

3. For * A Standards Track document specifying the transport for RID:

"Transport of Real-time Inter-network Defense (RID) Messages"
http://tools.ietf.org/html/draft-trammell-mile-rfc6046-bis

This document is a straight update of RFC6046, making minor editorial changes and updating its status to Standards Track; there are no substantive technical changes from the HTTP-based protocol specified in RFC6046.

As a contributor, I'd appreciate comments to the list on these documents by 2 November, stating whether you support the documents for adoption as WG items, and whether you would be willing to review them. (Okay, if you've read this message this far, you've essentially already reviewed mile-iodef-xmlreg, but the other two could use a critical eye.)

After 2 November, Kathleen will hold a consensus call on these documents.

Many thanks, and best regards,

Brian

---

From: <[email-masked]>
Date: Sat, 29 Oct 2011 22:03:53 -0400

Brian,

To state the obvious, the 6046bis draft (RID transport) should clearly be adopted by
the WG, as it will need to be normatively referenced by Kathleen's 6045bis draft (RID),
and both should be published as RFCs together.

I wonder whether it would be possible to combine the other two drafts into one,
as the iodef-xmlreg draft is effectively the actual IANA considerations for the use of
the IODEF template.  If the drafts are combined, it's still possible to have those IANA
considerations apply to all IODEF extensions, not just those that use the template.

The different tracks (informational vs. standard) that are currently intended for the two
drafts are a potential problem, on which I'll defer to Sean (AD), noting that Brian's
message below reproduces all of the normative text in the iodef-xmlreg draft (2 sentences).

Thanks,
--David
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Brian Trammell [[email-masked]]
Sent: Wednesday, October 26, 2011 3:23 AM
To: [email-masked]
Subject: [mile] Documents for consideration as MILE WG items

Brian
_______________________________________________
mile mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mile

---

From: Brian Trammell <[email-masked]>
Date: Sun, 30 Oct 2011 09:35:46 +0100

Hi, David,

Thanks for the comments! An excellent point on the template and iodef-xmlreg... Indeed, the primary reason that these _are_ two drafts is to address the situation that a document template is clearly Informational: a Standards Track document with what is essentially a convenience template for other documents might be incorrectly read as process to further standardize the form of MILE documents, which is 1. not the intention and 2. IMO a bad idea for its inflexibility.

I had assumed after discussion with IANA that changes to the IANA XML Registry itself, or the process for handling it, would require a Standards Track document. Practically speaking, the change would be implemented with a note added to the top of the Registry noting that any registration of an IODEF-relevant schema would require additional Expert Review. However, looking at 3688, the BCP that defines the registry, it is probably sufficient to update it with a BCP, and a BCP status for the template is not at all inappropriate IMO. Will also wait for Sean's guidance on this point, but it would be possible to get such an -02 of mile-template out before the Taipei cutoff, especially given that the new text in the template would be half the length of this message. :)

Thanks again, and best regards,

Brian

---

From: <[email-masked]>
Date: Sun, 30 Oct 2011 15:17:17 -0400

Hi Brian,

> Thanks for the comments! An excellent point on the template and iodef-xmlreg... Indeed, the primary
> reason that these _are_ two drafts is to address the situation that a document template is clearly
> Informational: a Standards Track document with what is essentially a convenience template for other
> documents might be incorrectly read as process to further standardize the form of MILE documents,
> which is 1. not the intention and 2. IMO a bad idea for its inflexibility.

Hmm - the following sentence in section 4 may need some tweaking to align with that intention:

   Documents describing an IODEF extension should follow the document
   template given in this section.

> I had assumed after discussion with IANA that changes to the IANA XML Registry itself, or the process
> for handling it, would require a Standards Track document. Practically speaking, the change would be
> implemented with a note added to the top of the Registry noting that any registration of an IODEF-
> relevant schema would require additional Expert Review. However, looking at 3688, the BCP that defines
> the registry, it is probably sufficient to update it with a BCP, and a BCP status for the template is
> not at all inappropriate IMO.

That sounds promising - a BCP is a standards-track document, and I agree that sections 2 and 3 of the mile-template draft look like BCP material. There should be no problem putting the template itself into an informative appendix of a BCP, and doing so may improve the document structure (e.g., reduces the opportunity to confuse the template's IANA Considerations section with the enclosing draft's IANA Considerations section).  It may also make sense to add a section to the draft with strong recommendations (SHOULD) on what to include as part of specifying an IODEF extension, independent of whether the template is used or not.

That said, I would *definitely* wait for Sean's guidance.  With mile not meeting until late Wednesday in Taipei, a -02 version could be submitted when submissions reopen on Monday.

Thanks,
--David

> -----Original Message-----
> From: Brian Trammell [mailto:[email-masked]]
> Sent: Sunday, October 30, 2011 4:36 AM
> To: Black, David; Sean Turner
> Cc: [email-masked]
> Subject: Re: [mile] Documents for consideration as MILE WG items
> 
> Hi, David,
> 
> Thanks for the comments! An excellent point on the template and iodef-xmlreg... Indeed, the primary
> reason that these _are_ two drafts is to address the situation that a document template is clearly
> Informational: a Standards Track document with what is essentially a convenience template for other
> documents might be incorrectly read as process to further standardize the form of MILE documents,
> which is 1. not the intention and 2. IMO a bad idea for its inflexibility.
> 
> I had assumed after discussion with IANA that changes to the IANA XML Registry itself, or the process
> for handling it, would require a Standards Track document. Practically speaking, the change would be
> implemented with a note added to the top of the Registry noting that any registration of an IODEF-
> relevant schema would require additional Expert Review. However, looking at 3688, the BCP that defines
> the registry, it is probably sufficient to update it with a BCP, and a BCP status for the template is
> not at all inappropriate IMO. Will also wait for Sean's guidance on this point, but it would be
> possible to get such an -02 of mile-template out before the Taipei cutoff, especially given that the
> new text in the template would be half the length of this message. :)
> 
> > As a contributor, I'd like to put forward three documents for consideration as working group items
> under the initial charter; these are all relatively lightweight, and I believe should be easy to come
> to agreement on.
> >
> >
> > This is an informational document primarily intended to speed the work of the MILE WG itself. It
> contains an Internet-Draft template for IODEF extensions.
> >
> >
> > This is a housekeeping and process document, which specifies a change to IODEF-related XML schema
> registrations in order to ensure an expert review of those schemas. It's really short; indeed, I'll
> quote the important part of the document here:
> >
> > This document is a straight update of RFC6046, making minor editorial changes and updating its
> status to Standards Track; there are no substantive technical changes from the HTTP-based protocol
> specified in RFC6046.
> >
> >
> > As a contributor, I'd appreciate comments to the list on these documents by 2 November, stating
> whether you support the documents for adoption as WG items, and whether you would be willing to review
> them. (Okay, if you've read this message this far, you've essentially already reviewed mile-iodef-
> xmlreg, but the other two could use a critical eye.)
> >