Subject: Re: [mile] RFC6546 possible editorial errata

From: "C. Henry Adams & BIE" <[email-masked]>
Date: Fri, 23 Nov 2012 07:37:18 -0800 (PST)

After further review, I agree that the statement appears to be in 
error.   There are a number of variables (Types of Errors) that could be
 applied when it comes to HTTP Error Codes. Thus, the results of sending
 a request to a RID System from a client should not relate to the 
failure or malfunction of the RID System itself.

The statement 
should not relate HTTP Error Codes to a failing RID System with internal
 issues. Perhaps the statement should identify External and Internal 
Errors related a RID System to some capacity.

C. Henry Adams

[email-masked] (Direct Email)

[email-masked]

---

From: "C. Henry Adams & BIE" <[email-masked]>
Date: Fri, 23 Nov 2012 08:04:34 -0800 (PST)

Wait-a-minute.   The only time one observes HTTP 400-404 Error Codes is when the Client is sending a request to say a " web site ".   So, replacing the "web site" with RID System, the error will likely be observed from the Client's Side not the Server's Side.

Furthermore, this would likely apply to HTTP 500-510 Error Codes as well.

The RID System will not see the HTTP Error Codes period.  The Client will see and experience them.

C. Henry Adams

---

From: "C. Henry Adams & BIE" <[email-masked]>
Date: Fri, 23 Nov 2012 08:39:39 -0800 (PST)

Clarification:

Here's the way I would write the statement below:

On the condition that a Client of a RID System sends a HTTP Request to a Server RID System and experience a HTTP 400-404 Error, that Client is likely in error.

On the condition that a Client of a RID System sends a HTTP Request to a Server RID System and experience a HTTP 500-510 Error, the receiving Server is likely in error.

-----------------------------------------------------------------------------------------------------------------------------------

"If a RID system receives an improper RID message in an HTTP Request,
   it MUST return an appropriate 4xx Client Error result code to the
   requesting RID system.  If a RID system cannot process a RID message
   received in an HTTP Request due to an error on its own side, it MUST
   return an appropriate 5xx Server Error result code to the requesting
   RID system."

C. Henry Adams