Subject: [mile] Updated IODEF Enumeration Reference Format Draft

From: Adam Montville <[email-masked]>
Date: Wed, 7 Nov 2012 17:32:28 +0000

All:

I'm pleased to submit draft-montville-mile-enum-reference-format-01 available at

http://www.ietf.org/id/draft-montville-mile-enum-reference-format-01.txt

Changes:

  *   IANA Table Request Changes
     *   Removed "Name"
     *   Added "Full Name
     *   Added "Abbreviation"
  *   Specified id_type to be <Abbreviation>_<Version>
  *   Reviewed text for scope statements and limited scope to IODEF, while alluding to the method's potential usefulness elsewhere.
  *   Ensured that the Reference class diagram is explicitly referenced as [IODEF].
  *   Updated IANA Considerations to request creation of the table
  *   Updated IANA table format fields with simple descriptions

I look forward to your comments.

Regards,

Adam W. Montville | Security and Compliance Architect
CISA, CISSP

Direct: 503 276-7661
Mobile: 360 471-7815

TRIPWIRE | Take CONTROL
http://www.tripwire.com

---

From: "Black, David" <[email-masked]>
Date: Sat, 17 Nov 2012 10:42:45 -0500

Adam,

Thanks for working on this draft.

I see that the version is included in the id_type string prefix.
I'm assuming that this version is the version number of the registered
specification.  That makes sense if the version doesn't change often
and especially if a version change results in a change to the identifier
format.

How often does the version change for the specs that are the sources of
the enumerations of interest?

If the spec version changes often, and especially if enumeration
identifiers from previous versions usually remain valid in new versions,
an alternative approach would be to tie the version to the identifier
format rather than the spec version - this could avoid having several
dozen id_type strings for versions of a single spec.

Please also take a look at these two emails that I sent to the list earlier:

identifier formats: http://www.ietf.org/mail-archive/web/mile/current/msg00853.html
more on versions: http://www.ietf.org/mail-archive/web/mile/current/msg00854.html

I have some additional editorial concerns that I'll send to you directly.

Thanks,
--David

From: [email-masked] [mailto:[email-masked]] On Behalf Of Adam Montville
Sent: Wednesday, November 07, 2012 12:32 PM
To: <[email-masked]>
Subject: [mile] Updated IODEF Enumeration Reference Format Draft

All:

Changes:

    *   Removed "Name"
    *   Added "Full Name
    *   Added "Abbreviation"

Regards,

Direct: 503 276-7661
Mobile: 360 471-7815

TRIPWIRE | Take CONTROL
http://www.tripwire.com

---

From: Adam Montville <[email-masked]>
Date: Thu, 29 Nov 2012 20:29:24 +0000

Hi David,

Thank you for your diligence!  I do appreciate it.

Please see comments inline.

Regards,

Adam

On Nov 17, 2012, at 7:42 AM, "Black, David" <[email-masked]<mailto:[email-masked]>> wrote:

Adam,

I see that the version is included in the id_type string prefix.
I’m assuming that this version is the version number of the registered
specification.  That makes sense if the version doesn’t change often
and especially if a version change results in a change to the identifier
format.

>From what I've seen, rarely.  However, emerging enumerations could be used and they might change more frequently.

So, what you're proposing is that the versioning information be attached to id rather than id_type.  That seems reasonable to me.

With respect to this message, which is about id and id_type formatting, I'm happy to make adjustments to the draft where necessary.  In that message you mention guidance being provided to the Designated Expert.  Where would that guidance be provided in the draft (or is it provided elsewhere)?

Additionally, I'm interested to know what others think about these approaches.  Again, I'm here to create a draft based on what the community wants to see implemented, so chime in if you have an opinion in these matters.

Take and I had an opportunity to speak in Atlanta, and I understand the concern represented in the message above.  This will be addressed in a forthcoming revision.

I have some additional editorial concerns that I’ll send to you directly.

Thanks,
--David

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Adam Montville
Sent: Wednesday, November 07, 2012 12:32 PM
To: <[email-masked]<mailto:[email-masked]>>
Subject: [mile] Updated IODEF Enumeration Reference Format Draft

All:

Changes:

     *   Removed "Name"
     *   Added "Full Name
     *   Added "Abbreviation"

Regards,

Direct: 503 276-7661
Mobile: 360 471-7815

TRIPWIRE | Take CONTROL
http://www.tripwire.com