Subject: [mile] Fw: GRC Report Exchange draft-ietf-mile-grc-exchange-01.txt

From: "C. Henry Adams & BIE" <[email-masked]>
Date: Wed, 14 Nov 2012 17:39:00 -0800 (PST)

It is stated, "The GRCPolicy class has six attributes:" located in section 4.1.  GRCPolicy Class Could the following attributes be identified by a letter or number?

1. restriction
2. ext-restriction
3. MsgType
4. ext-MsgType
5. MsgDestination
6. ext-MsgDestination

C. Henry Adams

[email-masked] (Direct Email)

--- On Wed, 11/14/12, C. Henry Adams & BIE <[email-masked]> wrote:

From: C. Henry Adams & BIE <[email-masked]>
Subject: GRC Report Exchange  draft-ietf-mile-grc-exchange-01.txt
To: [email-masked]
Cc: "C. Henry Adams" <[email-masked]>
Date: Wednesday, November 14, 2012, 8:17 PM

Reviewing the GRC Exchange Document, I identified with what appears to be a description of XML strings in Section 3.   Should the term "String or Strings" follow the words in subsections 3.4.7   Example (3.4.7.  Postal Address String) , 3.4.8 Example (3.4.8.  Telephone and Fax Numbers String) (OR)  should defining specific "strings" be a subsection in itself of  the Language Type "Strings" which represent a sequence of elements utilized by XML?
 
C. Henry Adams

[email-masked] (Direct Email)

---

From: "Moriarty, Kathleen" <[email-masked]>
Date: Thu, 15 Nov 2012 16:25:53 -0500

Hello C. Henry,

Each of the referenced attributes contains a selection of values that are valid for that attribute.  While a number could be used for a machine readable implementation, it is common to use the full name from the data model in an XML schema.  The thinking is that XML is already a bit bloated, so you can read and understand the XML formatted document.  In the case of this list of attributes, it is possible, but then you would have to go back and look at the data model to figure out what the attribute is about when you look at the value.

Thanks,
Kathleen

From: [email-masked] [mailto:[email-masked]] On Behalf Of C. Henry Adams & BIE
Sent: Wednesday, November 14, 2012 8:39 PM
To: [email-masked]
Cc: C. Henry Adams
Subject: [mile] Fw: GRC Report Exchange draft-ietf-mile-grc-exchange-01.txt

It is stated, "The GRCPolicy class has six attributes:" located in section

4.1.  GRCPolicy Class
Could the following attributes be identified by a letter or number?

1. restriction
2. ext-restriction
3. MsgType
4. ext-MsgType
5. MsgDestination
6. ext-MsgDestination

C. Henry Adams
[email-masked]<mailto:[email-masked]> (Direct Email)

--- On Wed, 11/14/12, C. Henry Adams & BIE <[email-masked]<mailto:[email-masked]>> wrote:

From: C. Henry Adams & BIE <[email-masked]<mailto:[email-masked]>>
Subject: GRC Report Exchange draft-ietf-mile-grc-exchange-01.txt
To: [email-masked]<mailto:[email-masked]>
Cc: "C. Henry Adams" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, November 14, 2012, 8:17 PM
Reviewing the GRC Exchange Document, I identified with what appears to be a description of XML strings in Section 3.   Should the term "String or Strings" follow the words in subsections 3.4.7   Example (3.4.7. Postal Address String) , 3.4.8 Example (3.4.8. Telephone and Fax Numbers String) (OR)  should defining specific "strings" be a subsection in itself of  the Language Type "Strings" which represent a sequence of elements utilized by XML?

C. Henry Adams
[email-masked]<mailto:[email-masked]> (Direct Email)

---

From: "C. Henry Adams & BIE" <[email-masked]>
Date: Thu, 15 Nov 2012 16:46:25 -0800 (PST)

My apologies; for clarification purposes, when reading the document - I attempt to identify with a layperson reviewing statements while trying to read and comprehend the words or "Attributes" written on a single separate line of a Draft Document. Perhaps, it could be unclear to distinguish their significance.

It was not my intent to associate an alphanumerical value to an Attribute.  I was trying to view the document from a written standpoint and not from a programming standpoint.

By doing so, I gather a better understanding of how to take an analytical vision and place it in the realm of a visual one.

Furthermore, I agree with your explanation regarding not complicating XML Schema any more than it already is at this point.  

C. Henry Adams

--- On Thu, 11/15/12, Moriarty, Kathleen <[email-masked]> wrote:

From: Moriarty, Kathleen <[email-masked]>
Subject: RE: [mile] Fw: GRC Report Exchange draft-ietf-mile-grc-exchange-01.txt
To: "C. Henry Adams & BIE" <[email-masked]>, "[email-masked]" <[email-masked]>
Date: Thursday, November 15, 2012, 4:25 PM

Hello C. Henry,  Each of the referenced attributes contains a selection of values that are valid for that attribute.  While a number could be used for a machine readable implementation, it is common to use the full name from the data model in an XML schema.  The thinking is that XML is already a bit bloated, so you can read and understand the XML formatted document.  In the case of this list of attributes, it is possible, but then you would have to go back and look at the data model to figure out what the attribute is about when you look at the value.  Thanks,Kathleen  From: [email-masked] [mailto:[email-masked]] On Behalf Of C. Henry Adams & BIE
Sent: Wednesday, November 14, 2012 8:39 PM
To: [email-masked]
Cc: C. Henry Adams
Subject: [mile] Fw: GRC Report Exchange draft-ietf-mile-grc-exchange-01.txt  It is stated, "The GRCPolicy class has six attributes:" located in section 4.1.  GRCPolicy ClassCould the following attributes be identified by a letter or number?

1. restriction
2. ext-restriction
3. MsgType
4. ext-MsgType
5. MsgDestination
6. ext-MsgDestination

C. Henry Adams

Date: Wednesday, November 14, 2012, 8:17 PMReviewing the GRC Exchange Document, I identified with what appears to be a description of XML strings in Section 3.   Should the term "String or Strings" follow the words in subsections 3.4.7   Example (3.4.7. Postal Address String) , 3.4.8 Example (3.4.8. Telephone and Fax Numbers String) (OR)  should defining specific "strings" be a subsection in itself of  the Language Type "Strings" which represent a sequence of elements utilized by XML?
 
C. Henry Adams