Subject: [mile] Enumeration Reference Format Change Proposal

From: "Adam W. Montville" <[email-masked]>
Date: Mon, 20 May 2013 09:17:21 -0700

For those of you interested in the Enumeration Reference Format (http://datatracker.ietf.org/doc/draft-montville-mile-enum-reference-format/), I'd like to propose a change to the way things are laid out - these changes are (belatedly) based on some comments received during the Orlando meeting.

At present, the IODEF Reference class would look like this:

      <Reference>
         <ReferenceName>CXI:1.0:CXI-1234-XYZ</ReferenceName>
         <URL>http://cxi.example.com</URL>
         <Description>Foo</Description>
      </Reference>

I would like to update this as follows (or something similar):

      <Reference>
         <ReferenceName>
            <Abbreviation>CXI</Abbreviation>
            <Version>1.0</Version>
            <ID>CXI-1234-XYZ</ID>
         </ReferenceName>
         <URL>http://cxi.example.com</URL>
         <Description>Foo</Description>
      </Reference>

An alternative using attributes instead of elements:

      <Reference>
         <ReferenceName abbreviation="CXI" version="1.0">CXI-1234-XYZ</ReferenceName>
         <URL>http://cxi.example.com</URL>
         <Description>Foo</Description>
      </Reference>

Further, the IANA Considerations section would be updated to provide better guidance for an expert to register a new type with respect to the fields recorded in the registry.

         Full Name: The full name of the enumeration as a string from the ASCII character set.

         Abbreviation: The abbreviation of the enumeration as a string from the ASCII character set.  An abbreviation may be an initialism or acronym, is free-form, but is limited to between two and five upper-case characters meeting the regular expression: ^[A-Z]{2,5}$

         Version: The version of the enumeration as a string using major and minor dotted notation meeting the regular expression as follows: ^[1-9]+\.[0-9]+$

         Specification URI: A list of one or more URIs [RFC3986] from
         which the registered specification can be obtained.  The
         registered specification MUST be readily and publicly available
         from that URI.

The two changes that have been made here are regular expressions used to limit valid values for Abbreviation and Version, and the limitation overall to the ASCII character set.  

These are proposals intended to encourage discussion.  Hopefully, these changes make this draft more succinct and easier to work with.  

Regards,

Adam

---

From: Eric Burger <[email-masked]>
Date: Mon, 20 May 2013 21:21:17 -0400

I much prefer saying what you mean.  This is a much better way to go.  Since we are already paying the heavy penalty for using XML, we might as well *use* XML.

On May 20, 2013, at 12:17 PM, Adam W. Montville <[email-masked]> wrote:

> _______________________________________________
> mile mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mile