Subject: [mile] FW: New Version Notification for draft-ietf-mile-enum-reference-format-02.txt

From: Adam Montville <[email-masked]>
Date: Mon, 4 Nov 2013 14:08:06 +0000

Please take some time to review and comment on this draft.  

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, November 04, 2013 6:06 AM
> To: Adam Montville; David Black; David L.Black
> Subject: New Version Notification for draft-ietf-mile-enum-reference-
> format-02.txt
> 
> 
> A new version of I-D, draft-ietf-mile-enum-reference-format-02.txt
> has been successfully submitted by Adam W. Montville and posted to the
> IETF repository.
> 
> Filename:	 draft-ietf-mile-enum-reference-format
> Revision:	 02
> Title:		 IODEF Enumeration Reference Format
> Creation date:	 2013-11-04
> Group:		 mile
> Number of pages: 7
> URL:             http://www.ietf.org/internet-drafts/draft-ietf-mile-enum-
> reference-format-02.txt
> Status:          http://datatracker.ietf.org/doc/draft-ietf-mile-enum-reference-
> format
> Htmlized:        http://tools.ietf.org/html/draft-ietf-mile-enum-reference-
> format-02
> Diff:            http://www.ietf.org/rfcdiff?url2=draft-ietf-mile-enum-reference-
> format-02
> 
> Abstract:
>    The Incident Object Description Exchange Format [IODEF] provides a
>    Reference class used to reference external entities (such as
>    enumeration identifiers).  However, the method of external entity
>    identification has been left unstructured.  This document describes a
>    method to provide structure for referencing external entities for the
>    [IODEF] Reference class.
> 
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
> ...

. . .

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Tue, 5 Nov 2013 15:09:21 +0000

Hi Adam,

In the draft I see 

      <?xml version="1.0" encoding="UTF-8"?>
      <xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema"
        elementFormDefault="qualified">
        <xs:element name="EnumRef">
          <xs:complexType>
            <xs:sequence>
              <xs:element ref="Abbreviation"/>
              <xs:element ref="Index"/>
              <xs:element ref="ID"/>
            </xs:sequence>
          </xs:complexType>
        </xs:element>
        <xs:element name="Abbreviation" type="xs:NCName"/>
        <xs:element name="Version" type="xs:integer"/>
        <xs:element name="ID" type="xs:NCName"/>
      </xs:schema>

Should the Version be Index? Or should there be an Index element in the schema and a Version in the EnumRef complex type?

Panos

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adam Montville
Sent: Monday, November 04, 2013 9:08 AM
To: [email-masked]
Subject: [mile] FW: New Version Notification for draft-ietf-mile-enum-reference-format-02.txt

> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
> ...

. . .
_______________________________________________
mile mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mile

---

From: Adam Montville <[email-masked]>
Date: Tue, 5 Nov 2013 23:51:49 +0000

Hi Panos,

Good catch, thank you.  I believe that "Version" should instead be "Index".

Any further comments?

Adam

________________________________________
From: Panos Kampanakis (pkampana) [[email-masked]]
Sent: Tuesday, November 05, 2013 9:08 AM
To: Adam Montville; [email-masked]
Subject: RE: [mile] FW: New Version Notification        for     draft-ietf-mile-enum-reference-format-02.txt

Hi Adam,

In the draft I see

Panos

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adam Montville
Sent: Monday, November 04, 2013 9:08 AM
To: [email-masked]
Subject: [mile] FW: New Version Notification for draft-ietf-mile-enum-reference-format-02.txt

. . .

...

. . .

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Wed, 6 Nov 2013 03:27:21 +0000

Makes sense. From our discussion in a previous thread, I think the Version will need to be removed from the XML and Section 4. 
Nothing new I had to add.

Panos

-----Original Message-----
From: Adam Montville [mailto:[email-masked]] 
Sent: Tuesday, November 05, 2013 6:52 PM
To: Panos Kampanakis (pkampana); [email-masked]
Subject: RE: [mile] FW: New Version Notification for draft-ietf-mile-enum-reference-format-02.txt

Hi Panos,

Any further comments?

Adam

Hi Adam,

In the draft I see

Panos

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adam Montville
Sent: Monday, November 04, 2013 9:08 AM
To: [email-masked]
Subject: [mile] FW: New Version Notification for draft-ietf-mile-enum-reference-format-02.txt

. . .

...
This message and attachments may contain confidential information. If it appears that this message was sent to you by mistake, any retention, dissemination, distribution or copying of this message and attachments is strictly prohibited. Please notify the sender immediately and permanently delete the message and any attachments.

. . .