Subject: [mile] How are email and file hashes computed?

From: "Roman D. Danyliw" <[email-masked]>
Date: Wed, 26 Feb 2014 21:37:58 +0000

Hello!

Setting HashData@type="email-hash" conveys that the combination of ds:Signature, ds:KeyInfo, or ds:Reference classes of the same HashData will describe "[a]n email hash" of some form.  Over which part of the email is this hash computed?  We currently fail to specify this detail.

The same question applies to when HashData@type="file-hash".  In this case, I would propose we state that the "hash is computed over the entire contents of the file".

Roman

---

From: Brian Trammell <[email-masked]>
Date: Thu, 27 Feb 2014 06:47:02 +0100

hi Roman,

the key question here is what's done in practice?

> Setting HashData@type="email-hash" conveys that the combination of ds:Signature, ds:KeyInfo, or ds:Reference classes of the same HashData will describe "[a]n email hash" of some form.  Over which p…

What's commonly done here? I can see a case for body-only, headers-only, originator headers, or any combination of the three. 

> The same question applies to when HashData@type="file-hash".  In this case, I would propose we state that the "hash is computed over the entire contents of the file".

Is it ever (generally) useful to express something other than a hash over the whole file?

> Roman
> 
> _______________________________________________
> mile mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mile