Subject: [mile] ROLIE Property Element

From: "Banghart, Stephen A. (Fed)" <[email-masked]>
Date: Mon, 12 Dec 2016 15:58:47 +0000

All,

During the IETF 97 MILE meeting we discussed the possibility of adding a means for standardizing a property element in ROLIE to provide for the easy inclusion of name/value pair metadata extensions. At the MILE meeting, the group decided that we want to support both the definition of property element extension and newly defined elements. Here is the issue that was presented at the meeting:

Often there are identifying or characterizing properties of the content that doesn't belong in a atom:category element (e.g. IODEF ID). A decision needs to be made regarding these "properties".
These options prevent a requesting client from needing to download the content to find these vital properties:
■        Option 1: Create an extensible rolie:property element with strict constraints that allows for arbitrary exposure of data model specific properties. The scheme and name attributes are registered.

For example: <rolie:property name="iodef-id" value="1234"/>

■        Option 2: Require any arbitrary property exposure to be done through a newly defined element.

For example: <iodef:id>1234</iodef:id>

The group settled on a new Option 3: Establish the extension capability to register property elements for use, but also the use of locally defined elements. This option combines the best of both options, allowing for properties to be defined by extension specifications without limiting the use of custom elements.

As long as there are no objections, we will update the specification to reflect Option 3. We will register an IANA table in the ROLIE Core document that extensions may register their properties to, and specify that new elements may be used for extension as well.

Thanks,
Stephen Banghart

---

From: Adam Montville <[email-masked]>
Date: Tue, 20 Dec 2016 15:05:36 +0000

At this point I have no objection, but I seem to remember Henk had a
perspective on this one.  Perhaps he can articulate his perspective in
writing here?

On Mon, Dec 12, 2016 at 10:00 AM Banghart, Stephen A. (Fed) <
[email-masked]> wrote:

> All,
>
>
>
> During the IETF 97 MILE meeting we discussed the possibility of adding a
> means for standardizing a property element in ROLIE to provide for the easy
> inclusion of name/value pair metadata extensions. At the MILE meeting, the
> group decided that we want to support both the definition of property
> element extension and newly defined elements. Here is the issue that was
> presented at the meeting:
>
>
>
> Often there are identifying or characterizing properties of the content
> that doesn’t belong in a atom:category element (e.g. IODEF ID). A decision
> needs to be made regarding these “properties”.
>
> ■        Option 1: Create an extensible rolie:property element with
> strict constraints that allows for arbitrary exposure of data model
> specific properties. The scheme and name attributes are registered.
>
>
>
> For example: <rolie:property name=”iodef-id” value=”1234”/>
>
>
>
> The group settled on a new *Option 3*: Establish the extension capability
> to register property elements for use, but also the use of locally defined
> elements. This option combines the best of both options, allowing for
> properties to be defined by extension specifications without limiting the
> use of custom elements.
>
>
>
> As long as there are no objections, we will update the specification to
> reflect *Option 3*. We will register an IANA table in the ROLIE Core
> document that extensions may register their properties to, and specify that
> new elements may be used for extension as well.
>
>
>
> Thanks,
>
> Stephen Banghart
> _______________________________________________
> mile mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mile
>