Subject: [mile] Hackathon for SACM/MILE at IETF 101

From: Adam Montville <[email-masked]>
Date: Fri, 02 Feb 2018 21:42:42 +0000

I have added SACM/XMPP to the hackathon page at:
https://trac.ietf.org/trac/ietf/meeting/wiki/101hackathon

Our goal is to use this hackathon to discover, and bind to XMPP-grid,
interfaces between specific components in an endpoint assessment workflow.
If possible, we will attempt to extend an existing XMPP server
implementation to provide some XMPP-grid Controller functionality.

Here's what is written on the hackathon page:

*SACM/XMPP Interface Discovery*

   - Champion(s)
      - Adam Montville
      - Bill Munyan
   - Project(s)
      - Configuring XMPP services extended with as much of an XMPP-grid
      Controller as possible (​
      https://datatracker.ietf.org/doc/draft-ietf-mile-xmpp-grid/)
      - Implementation of an XMPP-Grid connector for SCAP assessment engine
      - Implementation of an XMPP-Grid connector for SCAP results
      repository/dashboard

Kind regards,

Adam

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Sun, 4 Feb 2018 13:28:53 +0000

Hi Adam,

Thanks for championing this project and adding it to the wiki.
Do you anticipate any special networking requirements beyond those typically provided by the IETF network? Will you be setting up your own network for XMPP-grid enabled devices?

Cheers,
Charles

From: mile <[email-masked]> on behalf of Adam Montville <[email-masked]>
Date: Friday, February 2, 2018 at 10:43 PM
To: "[email-masked]" <[email-masked]>, "<[email-masked]>" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [mile] Hackathon for SACM/MILE at IETF 101

I have added SACM/XMPP to the hackathon page at: https://trac.ietf.org/trac/ietf/meeting/wiki/101hackathon

Our goal is to use this hackathon to discover, and bind to XMPP-grid, interfaces between specific components in an endpoint assessment workflow. If possible, we will attempt to extend an existing XMPP server implementation to provide some XMPP-grid Controller functionality.

SACM/XMPP Interface Discovery
·         Champion(s)
o    Adam Montville
o    Bill Munyan
·         Project(s)
o    Configuring XMPP services extended with as much of an XMPP-grid Controller as possible (​https://datatracker.ietf.org/doc/draft-ietf-mile-xmpp-grid/<https://datatracker.ietf.org/doc/draft-ietf-mile-xmpp-grid/>)
o    Implementation of an XMPP-Grid connector for SCAP assessment engine
o    Implementation of an XMPP-Grid connector for SCAP results repository/dashboard

Kind regards,

Adam

---

From: Adam Montville <[email-masked]>
Date: Mon, 05 Feb 2018 12:29:51 +0000

Hi Charles,

We don't anticipate any special networking requirements at this point -
whatever the IETF provides should be sufficient for our needs.

Kind regards,

Adam

On Sun, Feb 4, 2018 at 7:29 AM Charles Eckel (eckelcu) <[email-masked]>
wrote:

> Do you anticipate any special networking requirements beyond those
> typically provided by the IETF network? Will you be setting up your own
> network for XMPP-grid enabled devices?
>
>
>
> Cheers,
>
> Charles
>
>
>
> *From: *mile <[email-masked]> on behalf of Adam Montville <
> [email-masked]>
> *Date: *Friday, February 2, 2018 at 10:43 PM
> *To: *"[email-masked]" <[email-masked]>, "<[email-masked]>" <[email-masked]>,
> "[email-masked]" <[email-masked]>
> *Subject: *[mile] Hackathon for SACM/MILE at IETF 101
>
>
>
> o    Configuring XMPP services extended with as much of an XMPP-grid

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 6 Feb 2018 17:57:08 -0700

As I told Adam offlist, I'll commit to submitting an updated XMPP-Grid
I-D by the end of this week, primarily to include more examples and text
about publishing to different Topic namespaces (IODEF etc.).

Peter

On 2/2/18 2:42 PM, Adam Montville wrote:
> I have added SACM/XMPP to the hackathon page
> at: https://trac.ietf.org/trac/ietf/meeting/wiki/101hackathon
> 
> interfaces between specific components in an endpoint assessment
> workflow. If possible, we will attempt to extend an existing XMPP server
>   * Champion(s)
>   * Project(s)
> _______________________________________________
> mile mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mile
>