Subject: Re: [Mip4] HoA=0.0.0.0 question

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 16 Jun 2005 10:30:34 -0700

Hello Kuntal,

Based on your example, I do not believe that the distinction
would case any change to the base Mobile IPv4 specification.
Would this be a new document within the aaa working group?

Regards,
Charlie P.

Chowdhury, Kuntal wrote:

>Hi Charlie,
>
>Based on local policy the HA may have to process a new RRQ differently than a re-registration. For example, the local policy may not require the HA to perform AAA auth (i.e. process MN-AAA) every time the MN performs re-registration (i.e. when it has a valid binding) but the local policy requires AAA auth when there is no active binding (new RRQ).
>
>This is an example scenario. Is there any RFC/ID that explains the HoA=0.0.0.0 behavior for MIPv4?
>
>Regards,
>Kuntal
>
>
>
>  
>
>>-----Original Message-----
>>From: Charles E. Perkins [mailto:[email-masked]]
>>Sent: Thursday, June 16, 2005 12:14 PM
>>To: Chowdhury, Kuntal
>>Cc: [email-masked]
>>Subject: Re: [Mip4] HoA=0.0.0.0 question
>>
>>
>>
>>Hello Kuntal,
>>
>>Can you explain what difference it would make
>>one way or the other?
>>
>>Regards,
>>Charlie P.
>>
>>
>>Chowdhury, Kuntal wrote:
>>
>>    
>>
>>>Hi all,
>>>
>>>I have a question on MIP RRQ with HoA=0.0.0.0. It is a 
>>>      
>>>
>>common practice in the industry today to use HoA=0.0.0.0 in 
>>the RRQ to request for a dynamic HoA assignment. The question 
>>I have is: when the HA receives a RRQ with HoA=0.0.0.0 does 
>>it always treat that as a NEW registration request even if 
>>there is an unexpired mobility binding for the same NAI in the HA?
>>    
>>
>>>Thanks,
>>>Kuntal
>>>
>>> 
>>>
>>>      
>>>
>>
>>    
>>

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Thu, 16 Jun 2005 13:20:44 -0400

Hi Charlie,

Regards,
Kuntal

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 16 Jun 2005 21:55:36 +0200

Hi Kuntal,

On 2005-06-16 19:20 Chowdhury, Kuntal said the following:
> Hi Charlie,
> 
> Based on local policy the HA may have to process a new RRQ
> differently than a re-registration. For example, the local policy may
> not require the HA to perform AAA auth (i.e. process MN-AAA) every
> time the MN performs re-registration (i.e. when it has a valid
> binding) but the local policy requires AAA auth when there is no
> active binding (new RRQ).

Personal opinion: You have the answer there.  If there is an active
binding, you don't perform AAA auth, in this case.  Never mind whether
the RRQ requests a new dynamic address assignment or not.

On the other hand, if the policy specifies AAA re-auth before
address assignment, never mind any active sessions, the answer
should be pretty clear too - do it :-)

(Of course, a decent implementation should return the same HoA as
the currently active binding has, also in the event of a new RRQ
with 0.0.0.0 when there is an active binding.  This is not an 
anomalous case, as the HA has to be prepared for a client which
has re-booted or been turned off and on by the user.  But I don't
know if this really has any bearing on your original question.)

> HoA=0.0.0.0 behavior for MIPv4?

RFC 3344.

	Henrik

> Regards, Kuntal
> 
> 
> 
>> -----Original Message----- From: Charles E. Perkins
>> [mailto:[email-masked]] Sent: Thursday, June 16, 2005
>> 12:14 PM To: Chowdhury, Kuntal Cc: [email-masked] Subject: Re:
>> [Mip4] HoA=0.0.0.0 question
>> 
>> 
>> 
>> Hello Kuntal,
>> 
>> Can you explain what difference it would make one way or the other?
>> 
>> 
>> Regards, Charlie P.