Subject: RE: [Mip4] HoA=0.0.0.0 question

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Thu, 16 Jun 2005 18:15:59 -0400

Hi Henrik and Charlie,

What I understand from your responses is that HoA=0 should be treated by the HA as a new registration request (since an HoA assignment is involved here). Is this a correct understanding?

Regards,
Kuntal

> -----Original Message-----
> From: Henrik Levkowetz [mailto:[email-masked]]
> Sent: Thursday, June 16, 2005 2:56 PM
> To: Chowdhury, Kuntal
> Cc: Charles E. Perkins; [email-masked]
> Subject: Re: [Mip4] HoA=0.0.0.0 question
> 
> 
> Hi Kuntal,
> 
> On 2005-06-16 19:20 Chowdhury, Kuntal said the following:
> > Hi Charlie,
> > 
> > Based on local policy the HA may have to process a new RRQ
> > differently than a re-registration. For example, the local 
> policy may
> > not require the HA to perform AAA auth (i.e. process MN-AAA) every
> > time the MN performs re-registration (i.e. when it has a valid
> > binding) but the local policy requires AAA auth when there is no
> > active binding (new RRQ).
> 
> Personal opinion: You have the answer there.  If there is an active
> binding, you don't perform AAA auth, in this case.  Never mind whether
> the RRQ requests a new dynamic address assignment or not.
> 
> On the other hand, if the policy specifies AAA re-auth before
> address assignment, never mind any active sessions, the answer
> should be pretty clear too - do it :-)
> 
> (Of course, a decent implementation should return the same HoA as
> the currently active binding has, also in the event of a new RRQ
> with 0.0.0.0 when there is an active binding.  This is not an 
> anomalous case, as the HA has to be prepared for a client which
> has re-booted or been turned off and on by the user.  But I don't
> know if this really has any bearing on your original question.)
> 
> > This is an example scenario. Is there any RFC/ID that explains the
> > HoA=0.0.0.0 behavior for MIPv4?
> 
> RFC 3344.
> 
> 
> 	Henrik
> 
> 
> > Regards, Kuntal
> > 
> > 
> > 
> >> -----Original Message----- From: Charles E. Perkins
> >> [mailto:[email-masked]] Sent: Thursday, June 16, 2005
> >> 12:14 PM To: Chowdhury, Kuntal Cc: [email-masked] Subject: Re:
> >> [Mip4] HoA=0.0.0.0 question
> >> 
> >> 
> >> 
> >> Hello Kuntal,
> >> 
> >> Can you explain what difference it would make one way or the other?
> >> 
> >> 
> >> Regards, Charlie P.
> 
> 

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 17 Jun 2005 00:33:20 +0200

Hi Kuntal,

On 2005-06-17 00:15 Chowdhury, Kuntal said the following:
> Hi Henrik and Charlie,
> 
> What I understand from your responses is that HoA=0 should be treated
> by the HA as a new registration request (since an HoA assignment is
> involved here). Is this a correct understanding?

No, there really doesn't exist a distinction between "re-registration"
and "new registration", so your question doesn't have a "Yes" or "No"
answer.  Please see my reply to Avi's mail for more about this.

	Henrik

> 
> Regards, Kuntal
> 
> 
>> -----Original Message----- From: Henrik Levkowetz
>> [mailto:[email-masked]] Sent: Thursday, June 16, 2005 2:56 PM
>>  To: Chowdhury, Kuntal Cc: Charles E. Perkins; [email-masked] 
>>> not require the HA to perform AAA auth (i.e. process MN-AAA)
>>> every time the MN performs re-registration (i.e. when it has a
>>> valid binding) but the local policy requires AAA auth when there
>>> is no active binding (new RRQ).
>> 
>>  binding, you don't perform AAA auth, in this case.  Never mind
>> whether the RRQ requests a new dynamic address assignment or not.
>> 
>> anomalous case, as the HA has to be prepared for a client which has
>> re-booted or been turned off and on by the user.  But I don't know
>> if this really has any bearing on your original question.)
>> 
>>> This is an example scenario. Is there any RFC/ID that explains
>>> the HoA=0.0.0.0 behavior for MIPv4?
>> 
>> RFC 3344.
>> 
>> 
>> Henrik
>> 
>> 
>>> Regards, Kuntal
>>> 
>>> 
>>>

---

From: "Charles E.Perkins" <[email-masked]>
Date: Thu, 16 Jun 2005 15:42:53 -0700

Hello Kuntal,

"Chowdhury, Kuntal" wrote:

> What I understand from your responses is that HoA=0 should be
> treated by the HA as a new registration request (since an HoA
> assignment is involved here). Is this a correct understanding?

I'd rather not modify the specification about how the
home agent might distinguish this as a new Request.
Just from memory, without perusing the document,
I believe that the concept of "new registration"
in the base specification is tied closely to the
use of the same "Identification" field within the
Registration Request, and I would not want to disturb
the meaning of that term.

Moreover, I don't yet fully understand the need, even
in the context of AAA protocols.

Regards,
Charlie P.