Subject: [Mip4] lifetime in Registration Request

From: [email-masked]
Date: Mon, 25 Jul 2005 22:55:04 -0300 (ADT)

Hi All,

I hope that this is a right question for this list.

Just about the value of the lifetime field in Registration Request
message. What is the value if the MN uses the CoA? And.. the more
important, what will happen if it expires? What if the MN is doing
intra-domain movements when the lifetime expires, should the MN register
with the home network anyway? I meant while still using micro-mobility
protocols which are supposed to surpress the registrations..

any answer or pointer will be appreciated

sincerely

Z.

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: "Tsirtsis, George" <[email-masked]>
Date: Tue, 26 Jul 2005 10:54:39 -0400

You need to separate in you mind any micromobility mechanism or other
considerations from the need to renew a binding at the HA. 

The HoA to CoA binding MUST be renewed before its lifetime expires and
every time the CoA changes if the mobile wants its traffic to be
redirected to its current location. The Lifetime of such a binding is
configurable and it could be 30sec or 30hours....it all depends on the
type of deployment you are talking about.

I hope this helps
Regards
George

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Ji Zhang
> Sent: Tuesday, July 26, 2005 10:18 AM
> To: zhen
> Cc: Mobile IP v4
> Subject: Re: [Mip4] lifetime in Registration Request
> 
> 
> Hi Zhen,
> 
> A mobility binding need to be renewed by the MN if the MN 
> thinks it is still useful. It is not necessary that the MN 
> updates the mobility binding at its HA on every intra-domain 
> handover. The MN needs to do this only when the mobility 
> binding at the HA is about to expire. However, it does need 
> to update the mobility binding at its GFA on every 
> intra-domain IP layer handover.
> 
> Ji
> 
> > Hi Vasanth,
> >
> > Thank you for the kind reply. About the micro-mobility part, what I 
> > meant is that if the MN is still using the  same CoA (which is the 
> > address of the gateway foreign agent in case of Regional 
> Registration) 
> > according to the spirit of micro-mobility protocols the MN doesn't 
> > need to register to the home. But if the lifetime expires 
> in the home 
> > agent, the tunneling will be stopped and probably more 
> seriously the 
> > binding will be deleted. So the MN has to anyway send out 
> > registrations even though it's just doing intra-domain 
> movements. Is 
> > this true?
> >
> > Zhen
> >
> > On Tuesday, July 26, 2005, at 01:12 AM, vasanth kumar wrote:
> >
> > > HI zhen,
> > >          Lifetime value usually they use a value of 30 sec in coa 
> > > scenario. After the lifetime times out, the tunneling 
> home network 
> > > packets by agents will be stopped i.e there should not be 
> any packet 
> > > flow between MN and agents . I don't abt intra-domain 
> movements. But 
> > > if there is IP change in MN it should re-register with the new 
> > > IP-address and remove binding of the old-ip address using 
> > > deregistratoin request.
> > >
> > > vasanth
> > >
> > > On 7/26/05, [email-masked] <[email-masked]> wrote:
> > >> Hi All,
> > >>
> > >> intra-domain movements when the lifetime expires, should the MN 
> > >> register with the home network anyway? I meant while still using 
> > >> micro-mobility protocols which are supposed to surpress the 
> > >> registrations..
> > >>
> > >>     Charter page: 
> > >> http://www.ietf.org/html.charters/mip4-charter.html
> >      Charter page: 
> http://www.ietf.org/html.charters/mip4-charter.html

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================