Subject: [Mip4] Call origination

From: "Arunkumar Sivaraman" <[email-masked]>
Date: Tue, 18 Jul 2006 14:50:15 +0530

Hi,

  I have a doubt on the following call origination scenario:

Network System: CDMA 2000

Scenario 1: MN in home network, powers on. 

Doubts:

1.	Does the MN get an ip address through normal IPCP procedures or
through MIP RRQ with NAi extension to the HA.
2.	What parameter sent by the MN makes the PDSN/HA send an agent
advertisement with 'H' bit set.
3.	Does (2) happen,at all, when MN is in home network?
4.	Protocol call flow in this scenario.

Scenario 2: MN, having active call, hands off to a foreign network, for
the first time.

Doubts:

1.	Can the mobile in this scenario move into the foreign network
with a ZERO HA address value?
2.	If (1) ain't possible, other than static provisioning is there
any other way for the mobile to acquire a HA address, while it is active
in its home n/w?
3.	Is the MN-FA authentication values provisioned in MN, or can
they be constructed on the fly? 

regards,

Arunkumar Sivaraman,

Airvana India Pvt. Ltd.,

Ph: +91-80-41348788.

"Work is something I do between weekends."

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Pete McCann <[email-masked]>
Date: Tue, 18 Jul 2006 09:43:56 -0500

Hi, Arunkumar,

Arunkumar Sivaraman wrote:
>       advertisement with ‘H’ bit set.

Call setup for cdma2000 links is described in 3GPP2 publication
X.S0011, which is TIA-835.  You can find a copy here:

http://www.3gpp2.org/Public_html/specs/X.S0011-002-D_v1.0_060301.pdf

To use Mobile IP, the MN does not negotiate an address with
IPCP and instead leaves out the IP address configuration option
entirely.  The MN subsequently gets an agent advertisement
and registers via the PDSN.  The MN sets the home agent and
home address fields to zero, and includes the NAI extension
along with a Challenge-response extension.

>    1. Can the mobile in this scenario move into the foreign network with
>       a ZERO HA address value?
>    2. If (1) ain’t possible, other than static provisioning is there any
>       other way for the mobile to acquire a HA address, while it is
>       active in its home n/w?
>    3. Is the MN-FA authentication values provisioned in MN, or can they
>       be constructed on the fly?

In a cdma2000 network the MN is never "at home" so the above
scenario doesn't happen.

-Pete

> regards,
> 
>  
> 
> Arunkumar Sivaraman,
> 
> Airvana India Pvt. Ltd.,
> 
> Ph: +91-80-41348788.
> 
>  
> 
> //"Work is something I do between weekends."//
> 
>  
>