Subject: RE: [Mip4] Minor issue with MN advertisement sequence number handling

From: "Arun SG" <[email-masked]>
Date: Fri, 23 Mar 2007 16:21:49 +0530

Maybe I'm missing something here.
At step 5, when FA restarts, why is the advertisement sent with sequence
number 6? Wouldn't it be 1?
The window when this error can happen is that FA sends advertisement
with seq num 1, restarts and again sends aa with seq num =1. Then the
two are AAs have equal seq num and MN will not register. I think in any
other case, restart would not cause a problem.  

Regards,
Arun

-----Original Message-----
From: Ahmad Muhanna [mailto:[email-masked]] 
Sent: Friday, March 23, 2007 3:46 PM
To: Bjorn Andersson
Cc: [email-masked]
Subject: RE: [Mip4] Minor issue with MN advertisement sequence number
handling

Now I understand what you meant by "If the FA is restarted before it has
sent a second advertisement"
I also agree that this case is very unlikely.

Regards,
Ahmad

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf 
> Of Bjorn Andersson
> Sent: Friday, March 23, 2007 8:27 AM
> To: Muhanna, Ahmad (RICH1:2H10)
> Cc: [email-masked]
> Subject: Re: [Mip4] Minor issue with MN advertisement sequence number 
> handling
> 
> On 3/23/07, Ahmad Muhanna <[email-masked]> wrote:
> > Bjorn Andersson [mailto:[email-masked]]:
> > > If the FA is restarted before it has sent a second
> advertisement the
> > > MN will not reregister.
> >
> > Why? Can you please explain.
> 
> 1. FA starts
> 2. FA sends advertisement with sequence number 0 3. MN registers via 
> FA 4. FA restarts 5. FA sends advertisement with sequence number 0 6. 
> Sequence number is equal to, not less than, previous sequence number. 
> MN does not register.
> 7. MN sends packet to FA for tunneling, but MN is not registered to FA

> (since the FA restarted after the registration), so the FA does not 
> tunnel the packet to the HA. This will be the case until the 
> registration expires.
> 
> But as I said, it is minor issues since it quite unlikely to occur, 
> but it could still be improved and fixed in the RFC.
> Or am I missing something?
> 
>   Bjorn
> 

--
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: "Bjorn Andersson" <[email-masked]>
Date: Fri, 23 Mar 2007 13:17:09 +0200

> number 6? Wouldn't it be 1?

Your, or someone's mail reader has lost the new line after the zero.
The number six you see if from step 6. Step 5 says it will be sent
with sequence number zero, the first sequence number (it could be 1 if
it always starts with 1).

> other case, restart would not cause a problem.

Yes, this is exactly what I am saying. The time period between the two
first advertisements. If the FA advertises once per 30s then the FA
should not be restarted for 30s or MNs may lose their connection.

It's a minor issue, but has already caused confusion in a real life
setup (that's how I noticed it). So can't we just change the text to
"less or equal to" ? Or are there protocolwise any negative
implications of changing the text?

  Bjorn

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 24 Mar 2007 09:19:32 +0100

on 2007-03-23 12:17 Bjorn Andersson said the following:
...
> implications of changing the text?

The change looks good to me.  Good catch.

	Henrik