Subject: [Mip4] Minor issue with MN advertisement sequence number handling

From: "Bjorn Andersson" <[email-masked]>
Date: Thu, 22 Mar 2007 16:11:32 +0200

Section "2.4.4. Sequence Numbers and Rollover Handling" of RFC3344
(and bis) says:

"If a mobile node detects two successive values of the sequence number
in the Agent Advertisements from the foreign agent with which it is
registered, the second of which is less than the first and inside the
range 0 to 255, the mobile node SHOULD register again."

If the FA is restarted before it has sent a second advertisement the
MN will not reregister. The text should either say "... the second is
less than or equal to the first ..." or alternatively "... the second
is 0 or less than the first ...".

Regards,
Björn Andersson

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Thu, 22 Mar 2007 19:49:29 -0500

Hi Bjorn,
I do not see any problem in the text. May be I am missing something. More inline.

Regards,
Ahmad

> -----Original Message-----
> From: Bjorn Andersson [mailto:[email-masked]] 
> Sent: Thursday, March 22, 2007 3:12 PM
> To: [email-masked]
> Subject: [Mip4] Minor issue with MN advertisement sequence 
> number handling
> 
> Section "2.4.4. Sequence Numbers and Rollover Handling" of 
> RFC3344 (and bis) says:
> 
> "If a mobile node detects two successive values of the 
> sequence number in the Agent Advertisements from the foreign 
> agent with which it is registered, the second of which is 
> less than the first and inside the range 0 to 255, the mobile 
> node SHOULD register again."
> 
> If the FA is restarted before it has sent a second 
> advertisement the MN will not reregister. 

[Ahmad]
Why? Can you please explain.

> The text should 
> either say "... the second is less than or equal to the first 
> ..." or alternatively "... the second is 0 or less than the 
> first ...".
> 
> Regards,
> Björn Andersson
> 
> --

---

From: "Bjorn Andersson" <[email-masked]>
Date: Fri, 23 Mar 2007 09:26:53 +0200

On 3/23/07, Ahmad Muhanna <[email-masked]> wrote:
> Bjorn Andersson [mailto:[email-masked]]:

1. FA starts
2. FA sends advertisement with sequence number 0
3. MN registers via FA
4. FA restarts
5. FA sends advertisement with sequence number 0
6. Sequence number is equal to, not less than, previous sequence
number. MN does not register.
7. MN sends packet to FA for tunneling, but MN is not registered to FA
(since the FA restarted after the registration), so the FA does not
tunnel the packet to the HA. This will be the case until the
registration expires.

But as I said, it is minor issues since it quite unlikely to occur,
but it could still be improved and fixed in the RFC. Or am I missing
something?

  Bjorn

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Fri, 23 Mar 2007 05:15:54 -0500

Now I understand what you meant by "If the FA is restarted before it has
sent a second advertisement"
I also agree that this case is very unlikely.

Regards,
Ahmad

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Bjorn Andersson
> Sent: Friday, March 23, 2007 8:27 AM
> To: Muhanna, Ahmad (RICH1:2H10)
> Cc: [email-masked]
> Subject: Re: [Mip4] Minor issue with MN advertisement 
> sequence number handling
> 
> 2. FA sends advertisement with sequence number 0 3. MN 
> registers via FA 4. FA restarts 5. FA sends advertisement 
> with sequence number 0 6. Sequence number is equal to, not 
> less than, previous sequence number. MN does not register.
> 7. MN sends packet to FA for tunneling, but MN is not 
> registered to FA (since the FA restarted after the 
> registration), so the FA does not tunnel the packet to the 
> HA. This will be the case until the registration expires.
> 
> But as I said, it is minor issues since it quite unlikely to 
> occur, but it could still be improved and fixed in the RFC. 
> Or am I missing something?
> 
>   Bjorn
>