Subject: Re: [Mip4] I-D ACTION:draft-ietf-mip4-nemo-v4-base-00.txt

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 2 Mar 2007 11:36:57 -0800 (PST)

Hi Kent,
  
  Shouldn't it be the other way around, i.e. interoperability is tested based on the standard spec?

It seems something went wrong but I don't know what.

Regards,

--behcet

----- Original Message ----
From: Kent Leung (kleung) <[email-masked]>
To: Behcet Sarikaya <[email-masked]>
Cc: [email-masked]
Sent: Friday, March 2, 2007 12:00:39 PM
Subject: RE: [Mip4] I-D ACTION:draft-ietf-mip4-nemo-v4-base-00.txt

Hi Behcet.  NEMOv4 is needed for interoperability.
 
MIP4 WG charter:
 
11. MIPv4 Moving Network Support

The Network Mobility (nemo) working group deals with the problem of
mobility of a whole network, such as might exist inside a vehicle,
train, or airplane. The nemo working group has developed draft
specifications for both IPv6 and IPv4 mobile networks. However, it has
been recognized that the IPv4 version of the protocol can be viewed as
an extension of the basic Mobile IPv4 protocol, and there is good 
reason
to do this extension in the mip4 working group. The working group will
take on the MIPv4 network mobility internet draft and progress it along
the standards track. In addition, the working group will take up
extensions to the basic MIPv4 moving network support in the areas of
dynamic prefix assignment and foreign agent support.

Kent

From: Behcet Sarikaya [mailto:[email-masked]] 
Sent: Friday, March 02, 2007 9:41 AM
To: Kent Leung (kleung)
Cc: [email-masked]
Subject: Re: [Mip4] I-D ACTION:draft-ietf-mip4-nemo-v4-base-00.txt

Hi Kent,
  Just out of curiousity, hasn't this protocol been productized already? Such a thing was mentioned when NEMO WG was being formed and that was why NEMO WG concentrated on IPv6 based solution?
 
Regards,
 
--behcet

----- Original Message ----
From: "[email-masked]" <[email-masked]>
To: [email-masked]
Cc: [email-masked]
Sent: Thursday, March 1, 2007 2:50:03 PM
Subject: [Mip4] I-D ACTION:draft-ietf-mip4-nemo-v4-base-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.
This draft is a work item of the Mobility for IPv4 Working Group of the IETF.

    Title        : IPv4 Network Mobility (NEMO) Protocol
    Author(s)    : K. Leung, et al.
    Filename    : draft-ietf-mip4-nemo-v4-base-00.txt
    Pages        : 1
    Date        : 2007-3-1

   This document describes a protocol for supporting Mobile Networks
   between a Mobile Router and a Home Agent by extending the Mobile IPv4
   protocol.  A Mobile Router is responsible for the mobility of one or
   more network segments or subnets moving together.  The Mobile Router
   hides its mobility from the nodes on the mobile network.  The nodes
   on the Mobile Network may be fixed in relationship to the Mobile
   Router and may not have any mobility function.

   Extensions to Mobile IPv4 are introduced to support Mobile Networks.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-mip4-nemo-v4-base-00.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of 
the message. 
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the 
username "anonymous" and a password of your e-mail address. After 
logging in, type "cd internet-drafts" and then 
"get draft-ietf-mip4-nemo-v4-base-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
    [email-masked].
In the body type:
    "FILE /internet-drafts/draft-ietf-mip4-nemo-v4-base-00.txt".
    
NOTE:    The mail server at ietf.org can return the document in
    MIME-encoded form by using the "mpack" utility.  To use this
    feature, insert the command "ENCODING mime" before the "FILE"
    command.  To decode the response(s), you will need "munpack" or
    a MIME-compliant mail reader.  Different MIME-compliant mail readers
    exhibit different behavior, especially when dealing with
    "multipart" MIME messages (i.e. documents which have been split
    up into multiple messages), so check your local documentation on
    how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: "Kent Leung \(kleung\)" <[email-masked]>
Date: Fri, 2 Mar 2007 12:41:34 -0800

Hi Behcet.  That's why the draft is published for standardization.  So
vendors/implementors can interoperate in accordance to the spec.
 
Kent

________________________________

From: Behcet Sarikaya [mailto:[email-masked]] 
Sent: Friday, March 02, 2007 11:37 AM
To: Kent Leung (kleung)
Cc: [email-masked]
Subject: Re: [Mip4] I-D ACTION:draft-ietf-mip4-nemo-v4-base-00.txt

Hi Kent,

  Shouldn't it be the other way around, i.e. interoperability is tested
based on the standard spec?

Regards,
 
--behcet
 
----- Original Message ----
From: Kent Leung (kleung) <[email-masked]>
To: Behcet Sarikaya <[email-masked]>
Cc: [email-masked]
Sent: Friday, March 2, 2007 12:00:39 PM
Subject: RE: [Mip4] I-D ACTION:draft-ietf-mip4-nemo-v4-base-00.txt

MIP4 WG charter:

Kent

________________________________

Hi Kent,
  Just out of curiousity, hasn't this protocol been productized already?
Such a thing was mentioned when NEMO WG was being formed and that was
why NEMO WG concentrated on IPv6 based solution?
 
Regards,
 
--behcet

----- Original Message ----
From: "[email-masked]" <[email-masked]>
To: [email-masked]
Cc: [email-masked]
Sent: Thursday, March 1, 2007 2:50:03 PM
Subject: [Mip4] I-D ACTION:draft-ietf-mip4-nemo-v4-base-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.
This draft is a work item of the Mobility for IPv4 Working Group of the
IETF.

Send a message to:
    [email-masked].
In the body type:

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 05 Mar 2007 09:51:47 +0100

>  based on the standard spec?

Currently the NEMOv4 base protocol is the only stds track document for
NEMOv4.  Is this what you mean?

> It seems something went wrong but I don't know what.

I'm trying to identify what you think went wrong, can you explain.

The only alternative to NEMOv4 Base spec (this draft) is text in rfc3344
Mobile IPv4 where it is said that mobile networks and Mobile Routers
_can_ work with Mobile IPv4.  Which is very much true to a certain
extent, and it was the starting point for NEMOv4 implementations; but
lacking explicit message formats for prefix exchanges it led obviously
to interoperability issues, hence this draft.

What do you think went wrong, sorry?

Alex

> 
> Regards,
> 
> --behcet
> 
> ----- Original Message ---- From: Kent Leung (kleung) 
> <[email-masked]> To: Behcet Sarikaya <[email-masked]> Cc: 
> [email-masked] Sent: Friday, March 2, 2007 12:00:39 PM Subject: RE: 
> [Mip4] I-D ACTION:draft-ietf-mip4-nemo-v4-base-00.txt
> 
> specifications for both IPv6 and IPv4 mobile networks. However, it 
> has been recognized that the IPv4 version of the protocol can be 
> viewed as an extension of the basic Mobile IPv4 protocol, and there 
> is good reason to do this extension in the mip4 working group. The 
> working group will take on the MIPv4 network mobility internet draft 
> and progress it along the standards track. In addition, the working 
> group will take up extensions to the basic MIPv4 moving network 
> support in the areas of dynamic prefix assignment and foreign agent 
> support.
> 
> Kent
> 
> ------------------------------------------------------------------------
>  *From:* Behcet Sarikaya [mailto:[email-masked]] *Sent:* 
> Friday, March 02, 2007 9:41 AM *To:* Kent Leung (kleung) *Cc:* 
> [email-masked] *Subject:* Re: [Mip4] I-D 
> ACTION:draft-ietf-mip4-nemo-v4-base-00.txt
> 
> Hi Kent, Just out of curiousity, hasn't this protocol been 
> productized already? Such a thing was mentioned when NEMO WG was 
> being formed and that was why NEMO WG concentrated on IPv6 based 
> solution?
> 
> Regards,
> 
> --behcet
> 
> ----- Original Message ---- From: "[email-masked]" 
> <[email-masked]> To: [email-masked] Cc: 
> [email-masked] Sent: Thursday, March 1, 2007 2:50:03 PM Subject: 
> [Mip4] I-D ACTION:draft-ietf-mip4-nemo-v4-base-00.txt
> 
> directories. This draft is a work item of the Mobility for IPv4 
> Working Group of the IETF.
> 
> Title        : IPv4 Network Mobility (NEMO) Protocol Author(s)    : 
> K. Leung, et al. Filename    : draft-ietf-mip4-nemo-v4-base-00.txt 
> Pages        : 1 Date        : 2007-3-1
> 
> 
> [email-masked] with the word unsubscribe in the body 
> of the message. You can also visit 
> https://www1.ietf.org/mailman/listinfo/I-D-announce to change your 
> subscription settings.
> 
> logging in, type "cd internet-drafts" and then "get 
> draft-ietf-mip4-nemo-v4-base-00.txt".
> 
> http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> Send a message to: [email-masked]. In the body type: "FILE 
> /internet-drafts/draft-ietf-mip4-nemo-v4-base-00.txt".
> 
> MIME-encoded form by using the "mpack" utility.  To use this feature,
>  insert the command "ENCODING mime" before the "FILE" command.  To 
> decode the response(s), you will need "munpack" or a MIME-compliant 
> mail reader.  Different MIME-compliant mail readers exhibit different
>  behavior, especially when dealing with "multipart" MIME messages 
> (i.e. documents which have been split up into multiple messages), so 
> check your local documentation on how to manipulate these messages.
> 
> Internet-Draft. -- Mip4 mailing list: [email-masked] Web interface: 
> https://www1.ietf.org/mailman/listinfo/mip4 Charter page: 
> http://www.ietf.org/html.charters/mip4-charter.html Supplemental 
> site: http://www.mip4.org/
> 
> 

______________________________________________________________________
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email 
______________________________________________________________________