Subject: Re: [Mip4] I-D ACTION:draft-ietf-mip4-gen-ext-01.txt

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 23 Apr 2007 23:39:30 -0700

Hello,

I went through the revised document. Most of my comments
during the WG last call have been addressed. Thanks.

A couple of minor comments.

We need to add some text in the Introduction section to say
that this document describes a mechanism to configure a mobile
node with information from both the home link and foreign link.
It also needs to say that this document just defines a new
MIPv4 configuration options exchange extensions and this
extension is used to carry the DHCP and BOOTP options defined
in RFC 2132. With the current text in the Introduction section,
it is not clear what the document is about until you get to
section 3. :)

In the Security Considerations section, perhaps rephrase

>    There is no confidentiality provided by the extension.  The extension
>    is transferred unencrypted, and if sensitive information is sent for
>    host configuration purposes, it may need to be protected by other
>    means.

as

   There is no confidentiality provided for this extension.  The
   information carried in the extension is from the home network and
   is transferred unencrypted.  If sensitive information is sent for
   host configuration purposes, it may need to be protected by other
   means outside the scope of this document.

Vijay

[email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories.
> This draft is a work item of the Mobility for IPv4 Working Group of the IETF.
> 
> 	Title		: Mobile IPv4 Extension for Configuration Options Exchange
> 	Author(s)	: J. Bharatia, et al.
> 	Filename	: draft-ietf-mip4-gen-ext-01.txt
> 	Pages		: 13
> 	Date		: 2007-2-26
> 	
> This document describes the mechanism for providing the host
>    configuration information during Mobile IP registration.  One or more
>    Configuration Options Exchange Extensions may be included in the
>    registration message to provide the Mobile Node the configuration
>    parameters needed for network service (e.g.  DNS).
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-mip4-gen-ext-01.txt
> 
> To remove yourself from the I-D Announcement list, send a message to 
> [email-masked] with the word unsubscribe in the body of 
> the message. 
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
> to change your subscription settings.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the 
> username "anonymous" and a password of your e-mail address. After 
> logging in, type "cd internet-drafts" and then 
> "get draft-ietf-mip4-gen-ext-01.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-mip4-gen-ext-01.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: "McCann Peter-A001034" <[email-masked]>
Date: Tue, 24 Apr 2007 13:05:52 -0400

Hi, Vijay,

Thanks for checking the doc one last time.

Kent, Kuntal, Jayshree, how quickly can you turn around an
edit?  I am ready to submit this document as soon as the
comments below are addressed.

-Pete

Vijay Devarapalli wrote:
> Hello,
> 
> I went through the revised document. Most of my comments during the
> WG last call have been addressed. Thanks. 
> 
> We need to add some text in the Introduction section to say that this
> document describes a mechanism to configure a mobile node with
> information from both the home link and foreign link.  
> MIPv4 configuration options exchange extensions and this extension is
> used to carry the DHCP and BOOTP options defined in RFC 2132. With
> the current text in the Introduction section, it is not clear what
> the document is about until you get to section 3. :)   
> 
>>    There is no confidentiality provided by the extension.  The
>>    extension is transferred unencrypted, and if sensitive
>>    information is sent for host configuration purposes, it may need
>>    to be protected by other means.
> 
> as
> 
>> directories. This draft is a work item of the Mobility for IPv4
>> Working Group of the IETF. 
>> 
>>    configuration information during Mobile IP registration.  One or
>>    more Configuration Options Exchange Extensions may be included in
>>    the registration message to provide the Mobile Node the
>>    configuration parameters needed for network service (e.g.  DNS).
>> 
>> You can also visit
>> https://www1.ietf.org/mailman/listinfo/I-D-announce 
>> logging in, type "cd internet-drafts" and then "get
>> draft-ietf-mip4-gen-ext-01.txt".
>> 
>> http://www.ietf.org/shadow.html or
>> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>>

---

From: "Jayshree Bharatia" <[email-masked]>
Date: Fri, 27 Apr 2007 17:26:51 -0500

Vijay,

I have made the following changes per your comments:

Section 1 (Introduction)
From
This document defines a new extension that can be used to carry
configuration
parameters during Mobile IPv4 registration.

To
This document defines a new extension that can be used to carry
configuration
parameters from the Foreign Agent and/or Home Agent during Mobile IPv4
registration. This configuration parameters include DHCP option
(Parameter
Request List) defined in RFC2132.

Section 5 (Security Considerations)
From 
There is no confidentiality provided by the extension. The extension is
transferred unencrypted, and if sensitive information is sent for host
configuration purposes, it may need to be protected by other means.

To
There is no confidentiality provided for this extension. The information
carried
in the Configuration Options Exchange Extension is from the Home Network
and/or
Foreign Network and is transferred unencrypted. If sensitive information
is sent
for host configuration purposes, it may need to be protected by other
means
outside the scope of this document.

Let me know if this is acceptable.

Thanks,
Jayshree

-----Original Message-----
From: Vijay Devarapalli [mailto:[email-masked]] 
Sent: Tuesday, April 24, 2007 1:40 AM
To: [email-masked]; McCann Peter-A001034
Cc: Kent Leung (kleung); Chowdhury, Kuntal; Bharatia, Jayshree
(RICH1:2H10)
Subject: Re: [Mip4] I-D ACTION:draft-ietf-mip4-gen-ext-01.txt

Hello,

We need to add some text in the Introduction section to say that this
document describes a mechanism to configure a mobile node with
information from both the home link and foreign link. It also needs to
say that this document just defines a new MIPv4 configuration options
exchange extensions and this extension is used to carry the DHCP and
BOOTP options defined in RFC 2132. With the current text in the
Introduction section, it is not clear what the document is about until
you get to section 3. :)

>    There is no confidentiality provided by the extension.  The
extension

as

Vijay

>    configuration information during Mobile IP registration.  One or
more

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Mon, 30 Apr 2007 11:12:02 -0700

Looks good to me.

Thanks
Vijay 

> From: Jayshree Bharatia [mailto:[email-masked]] 
> Sent: Friday, April 27, 2007 3:27 PM
> To: Vijay Devarapalli
> Cc: Kent Leung (kleung); Chowdhury, Kuntal; [email-masked]; 
> McCann Peter-A001034
> Subject: RE: [Mip4] I-D ACTION:draft-ietf-mip4-gen-ext-01.txt
> 
> Vijay,
> 
> extension is
> information