Subject: RE: [Mip6] Draft Agenda for WG meeting at IETF58

From: Soliman Hesham <[email-masked]>
Date: Sat, 25 Oct 2003 00:57:08 -0400

> Thierry,
 > 
 > I wish you had bought this up a month ago when the MIP6
 > charter was being discussed. we could have added multi-
 > homed (or more explicitly multi-interface) mobile nodes
 > to the charter.

=> FWIW, he did bring it up and so did I (In Minneapolis
meeting 2001 and it got delayed because of the MIPv6 debacle)
and a few other people. 

Hesham

 > 
 > now the charter is finalised, there are work items and
 > the schedule to complete the work items on the charter
 > is very aggresive. see
 > http://www.ietf.org/html.charters/mip6-charter.html.
 > 
 > there is nothing wrong when Raj said he didnt see any
 > interest for multi-homed mobile nodes. nobody bought
 > them up when the charter was being discussed.
 > 
 > Vijay
 > 
 > ps: I am not against including multi-homed mobile nodes
 > in the charter. infact I think we should work on them.
 > 
 > Thierry Ernst wrote:
 > > Hi Basavaraj,
 > > 
 > > I find your answer amazing...
 > > 
 > > Given the fact the MIP6 WG is a new group, I find it very 
 > appropriate to
 > > discuss the missions of the WG right now. Also, I would find very
 > > appropriate to raise the issue at the meeting to see how 
 > many people
 > > have interest in this. If only a minority has, so, very 
 > fine, it means
 > > it's not considered important. Demonstration done.
 > > 
 > > 
 > >>>In the second place, there are a few drafts turning 
 > around this issues,
 > >>>and drafts have been submitted regularly for a few years. 
 > So, given the
 > >>>number of drafts and period of effect, I find it rather 
 > important. On a
 > >>>personal side, I would like to see something coming up from this
 > >>>activity so that we can implement a common solution, no 
 > doing our own
 > >>>cooking in our lab.
 > >>
 > >>I am aware of the various drafts addressing this. But I do 
 > not see why
 > >>this is a critical need for the WG to take on at this 
 > time. I do not
 > >>for example see a large number of people in the WG 
 > demanding that this
 > > 
 > > 
 > > Please specify: how many people is considered "large" ?
 > > 
 > > 
 > >>be a work item because it is absolutely a MUST for mobile 
 > IPv6 to be
 > >>deployed. What you are cooking in your lab may be 
 > interesting but is
 > >>not necessarily needed by the industry at this time. 
 > > 
 > > 
 > > Huh ? The industry your are refering too is not the same 
 > as the one I'm
 > > involved in. The fact that I work for a University doesn't 
 > necessarily
 > > make me unaware of business realities.
 > > 
 > > 
 > >>So if you believe
 > >>that there is interest in this work, the I-D can always be
 > >>standardized as Experimental (without WG intervention) 
 > which would let
 > >>the people with common interests implement it and interop.
 > > 
 > > 
 > > Don't take me wrong: I don't have any solution, so I cannot expect
 > > anything to be experimental ... But THERE ARE solutions, 
 > and all of them
 > > address distinct and complementary issues. The purpose of this
 > > discussion and draft-montavont is to come to an agreement 
 > on what is
 > > needed so that all the parties involved can work on a 
 > single solution.
 > > The need WG directive to achieve this. Designing a single 
 > specification
 > > is clearly a WG task.
 > > 
 > > 
 > >>>Anyway, let's see why the other people are thinking. If 
 > it happens that
 > >>>there is no room in this WG to deal with issue, I will most likely
 > >>>propose a BOF at Seoul Meeting (and, well, this might not 
 > be a bad idea,
 > >>>because the benefit of having several interfaces [either 
 > actual, or
 > >>>virtual] could be shared by both Fixed Nodes and Mobile 
 > Nodes (I'm not
 > >>>exclusively thinking about NEMO, although the idea comes 
 > from there]).
 > >>>The reason I have not yet pushed toward a new WG is 
 > because there are
 > >>>already many WGs. 
 > >>
 > >>Well, please do intiate a discussion on this topic to determine 
 > >> - the interest
 > >> - how vital is this for IPv6 mobility
 > > 
 > > 
 > >>>In conclusion, may I request a short slot to deal the 
 > issue (not the
 > >>>solutions) during the meeting, please, so that we come to 
 > a WG consensus
 > >>>and act upon it ?
 > >>
 > >>Sure, but first you have to demonstrate via the ML that 
 > there is some
 > >>interest in this topic. If you can do that in the next 
 > week or so, we
 > >>can include it on the agenda.
 > > 
 > > 
 > > This discussion is already initiated, and several people 
 > have already
 > > answered. I don't think it's necessary to demonstrate how 
 > vital it is
 > > for IPv6 mobility (could you by the way demonstrate how 
 > vital Mobile
 > > IPv6 is ? What about RO ? Just kidding); simply demonstrating the
 > > interest of people to work on this is enough. So, I will 
 > let the other
 > > intereted ML members with some space to pop up on the ML.
 > > 
 > > Thierry.
 > > 
 > > 
 > > 
 > > 
 > > 
 > > 
 > > _______________________________________________
 > > Mip6 mailing list
 > > [email-masked]
 > > https://www.ietf.org/mailman/listinfo/mip6
 > 
 > 
 > 
 > _______________________________________________
 > Mip6 mailing list
 > [email-masked]
 > https://www.ietf.org/mailman/listinfo/mip6
 > 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Vijay Devarapalli <[email-masked]>
Date: Sat, 25 Oct 2003 15:30:47 -0700

Soliman Hesham wrote:
> => FWIW, he did bring it up 

you missed the point. there is a big difference between
bringing it up and generating interest in the WG.

> and so did I (In Minneapolis

so? without MIPv6 being standardized first, there was no
point talking about multiple interfaces and multiple flows.

Vijay

ps: FWIW, I support adding multi-homed mobile nodes to the
charter.