Subject: RE: [Mip6] Draft Agenda for WG meeting at IETF58

From: [email-masked]
Date: Wed, 22 Oct 2003 22:23:08 -0500

> 
> Hi,
> 
> I do have a concern about the agenda. 

Glad to see that we are having the agenda bashing on the ML now rather
than at the WG meeting ;)

> 
> First thing first: I may have missed something during the MIP6 charter
> discussion: I don't see anything related to multihomed mobile node.
> (multihoming covers MNs with several interfaces, MNs with several HAs,
> and MNs with several HoAs/CoAs). Is this something to be excluded or
> included in this WG ?

This is not within the scope of the current charter. I (chair hat off)
do not believe there is any urgency to deal with this problem. Hence
can be considered in a future revision of the charter if deemed necessary.

> 
> About the agenda, draft
> draft-montavont-mobileip-multihoming-pb-statement-00.txt
> (http://www.ietf.org/mail-archive/ietf-announce/Current/msg26474.html)
> has been submitted in an effort to investigate issues in supporting
> multihomed mobile nodes under Mobile IPv6.
> 
> Thus, I'm wondering if it won't be better to discuss the 
> issues and the
> potential items that will have to be taken under consideration by the
> new MIP6 WG, rather than discussing specific solutions (I guess that 4
> and 5 somewhat fall into the same discussions [Ryuji, please 
> correct me about 4]). 
> 
> In any case, draft-montavont-mobileip-multihoming-pb-statement-00.txt
> attemps to state what the problem is so that we are all on the wave in
> order to be able to design a single WG solution that would address all
> the issues. Probably it would be useful to include this draft in the
> agenda.

I agree that it is a good idea to discuss the problem statement. But given
the current scope of the charter and the priorities of the WG, I would rather
have that this discussion be carried out on the Mailing list first. I would
like to see the opinions of the WG members w.r.t this problem.

> Comments ?
> Thierry

-Basavaraj

> 
> 
> 
> 
> > MIP6 (Mobility for IPv6 WG) Draft Agenda
> > ----------------------------------------
> > 
> > MONDAY, November 10, 2003 
> > 1530-1730 Afternoon Sessions II
> > 
> > CHAIRS: Basavaraj Patil <[email-masked]>
> >         Gopal Dommety	<[email-masked]>
> > 
> > Agenda:
> > 
> > 1. Preliminaries	10 Mins			Chairs
> >    - Minutes
> >    - Document status
> >    - Agenda bashing
> > 		
> > 
> > 2. MIPv6 MIB		15 Mins			Glenn Keeni
> >    I-D: draft-ietf-mip6-mipv6-mib-00.txt
> > 
> > 3. MIPv6 Remote interop testing	 15 Mins	T.J 
> Kniveton/Samita C.
> >    I-D: draft-kniveton-mipv6-remote-testing-00.txt
> > 
> > 4. Inter Home Agents Protocol (HAHA)  10 Mins	Ryuji Wakikawa
> >    I-D: draft-wakikawa-mip6-nemo-haha-00.txt
> > 
> > 5. Filters for Mobile IPv6 Bindings (NOMADv6) 10 Mins  K. 
> Kuladinithi 
> >    I-D: draft-nomadv6-mobileip-filters-00.txt
> > 
> > 6. Roadmap for the WG	15 Mins			Chairs and ADs
> > 
> > 
> > _______________________________________________
> > Mip6 mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/mip6
> > 
> 
> 
> -- 
> 
> Thierry Ernst, PhD
> WIDE at Keio University, Japan
> E-mail: [email-masked]
> Web: http://www.sfc.wide.ad.jp/~ernst/
> --
> Jun Murai Lab
> Keio University K-square Town Campus
> 1488-8 Ogura, Saiwai-ku, Kawasaki
> Kanagawa, 212-0054 Japan
> Phone : +81-44-580-1600
> Fax   : +81-44-580-1437
> Mobile: 090-9815-8023
> 
> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mip6
> 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Thierry Ernst <[email-masked]>
Date: Thu, 23 Oct 2003 16:31:07 +0900

Hi Basavaraj,

> can be considered in a future revision of the charter if deemed necessary.

Well, I cannot really agree. 

In the first place, why did you list the Nomad draft if it's not within
the scope ?

In the second place, there are a few drafts turning around this issues,
and drafts have been submitted regularly for a few years. So, given the
number of drafts and period of effect, I find it rather important. On a
personal side, I would like to see something coming up from this
activity so that we can implement a common solution, no doing our own
cooking in our lab.

Anyway, let's see why the other people are thinking. If it happens that
there is no room in this WG to deal with issue, I will most likely
propose a BOF at Seoul Meeting (and, well, this might not be a bad idea,
because the benefit of having several interfaces [either actual, or
virtual] could be shared by both Fixed Nodes and Mobile Nodes (I'm not
exclusively thinking about NEMO, although the idea comes from there]).
The reason I have not yet pushed toward a new WG is because there are
already many WGs. 

In conclusion, may I request a short slot to deal the issue (not the
solutions) during the meeting, please, so that we come to a WG consensus
and act upon it ?

Thierry.

---

From: montavont <[email-masked]>
Date: Thu, 23 Oct 2003 09:57:24 +0200

Hi Basavaraj, Thierry,

I don't understand neither why you give a slot to nomadv6, while other 
solutions which are very close where also submitted as I-D.

Anyway, I think that before considering any solutions, it is important 
to first see what are the issues of a multihomed host / MN.
The draft "draft-montavont-mobileip-multihoming-pb-statement-00.txt" 
could initiate discussion around multihoming and make people work 
together on a unique solution if needed.

Nicolas

---

From: Conny Larsson <[email-masked]>
Date: Thu, 23 Oct 2003 10:52:06 +0200

Thierry,

I agree with you. I believe the multihoming scenarios, as discussed in 
draft-montavont-mobileip-multihoming-pb-statement-00.txt, are of 
interest. I also believe that we have to look into how a mobile node may 
redirect flows from one interface to another, as mentioned in Chapter 5.

It seems to me that the multihoming problem could be covered by the mip6 
wg (i.e. if the charter is changed). I would like it to cover flow 
mobility as well since this will be interesting when you are multihomed. 
However, one could also argue that flows are something above the IP 
layer and should be handled somewhere else and I believe this is the 
current position of the wg.

Regards
Conny Larsson