Subject: RE: [Mip6] Draft Agenda for WG meeting at IETF58

From: Soliman Hesham <[email-masked]>
Date: Wed, 22 Oct 2003 22:04:15 -0400

Hi Raj, 

One comment below.

 > 5. Filters for Mobile IPv6 Bindings (NOMADv6) 10 Mins  K. 
 > Kuladinithi 
 >    I-D: draft-nomadv6-mobileip-filters-00.txt
 > 

=> What is the intention of discussing the above draft?
I'm not against this, in fact I think that the WG should 
start working in the area of flow movement (called filters
in this draft). But the impression I got was that this 
is not going to be part of the charter for now, right?
So I'm wondering if this is an informational presentation
or if there is a change about the direction of the WG. 

Hesham

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: [email-masked]
Date: Wed, 22 Oct 2003 22:17:59 -0500

> or if there is a change about the direction of the WG. 

Good question. Note that the current agenda is only draft.
This agenda item will be dropped as you currently note that
the charter scope does not cover this. 
I added this to the agenda as a result of a request from the
authors. However I have indicated to the authors that the
criteria for allocating time at a WG meeting is:
1. The work is within the scope of the charter 
2. There is a significant interest (as seen on ML) and hence
   worth discussing

> Hesham

-Basavaraj

---

From: "KASSI-LAHLOU Mohammed FTRD/DMI/CAE" <[email-masked]>
Date: Thu, 23 Oct 2003 16:43:45 +0200

Hi,

I agree too. The multihoming (multi-interfaces, multi-HAs...) are important topics. Situations with access networks and hosts of various technologies or with different suppliers will increase. Therefore, the behavior of mobileIP in these cases has to be specified.

Kassi

-----Message d'origine-----
De : Conny Larsson [mailto:[email-masked]] 
Envoyé : jeudi 23 octobre 2003 10:52
À : Thierry Ernst
Cc : [email-masked]; [email-masked]
Objet : Re: [Mip6] Draft Agenda for WG meeting at IETF58

Thierry,

I agree with you. I believe the multihoming scenarios, as discussed in 
draft-montavont-mobileip-multihoming-pb-statement-00.txt, are of 
interest. I also believe that we have to look into how a mobile node may 
redirect flows from one interface to another, as mentioned in Chapter 5.

It seems to me that the multihoming problem could be covered by the mip6 
wg (i.e. if the charter is changed). I would like it to cover flow 
mobility as well since this will be interesting when you are multihomed. 
However, one could also argue that flows are something above the IP 
layer and should be handled somewhere else and I believe this is the 
current position of the wg.

Regards
Conny Larsson

Thierry Ernst wrote:

>Hi Basavaraj,
>
>Thanks to your answer. Comments to your answer, and request below:
>
>
>  
>
>>>First thing first: I may have missed something during the MIP6 
>>>charter
>>>discussion: I don't see anything related to multihomed mobile node.
>>>(multihoming covers MNs with several interfaces, MNs with several HAs,
>>>and MNs with several HoAs/CoAs). Is this something to be excluded or
>>>included in this WG ?
>>>      
>>>
>>This is not within the scope of the current charter. I (chair hat off) 
>>do not believe there is any urgency to deal with this problem. Hence 
>>can be considered in a future revision of the charter if deemed 
>>necessary.
>>    
>>
>
>Well, I cannot really agree.
>
>In the first place, why did you list the Nomad draft if it's not within 
>the scope ?
>
>In the second place, there are a few drafts turning around this issues, 
>and drafts have been submitted regularly for a few years. So, given the 
>number of drafts and period of effect, I find it rather important. On a 
>personal side, I would like to see something coming up from this 
>activity so that we can implement a common solution, no doing our own 
>cooking in our lab.
>
>Anyway, let's see why the other people are thinking. If it happens that 
>there is no room in this WG to deal with issue, I will most likely 
>propose a BOF at Seoul Meeting (and, well, this might not be a bad 
>idea, because the benefit of having several interfaces [either actual, 
>or virtual] could be shared by both Fixed Nodes and Mobile Nodes (I'm 
>not exclusively thinking about NEMO, although the idea comes from 
>there]). The reason I have not yet pushed toward a new WG is because 
>there are already many WGs.
>
>In conclusion, may I request a short slot to deal the issue (not the
>solutions) during the meeting, please, so that we come to a WG 
>consensus and act upon it ?
>
>Thierry.
>
>
>  
>
>>>About the agenda, draft 
>>>draft-montavont-mobileip-multihoming-pb-statement-00.txt
>>>(http://www.ietf.org/mail-archive/ietf-announce/Current/msg26474.html
>>>)
>>>has been submitted in an effort to investigate issues in supporting
>>>multihomed mobile nodes under Mobile IPv6.
>>>
>>>Thus, I'm wondering if it won't be better to discuss the
>>>issues and the
>>>potential items that will have to be taken under consideration by the
>>>new MIP6 WG, rather than discussing specific solutions (I guess that 4
>>>and 5 somewhat fall into the same discussions [Ryuji, please 
>>>correct me about 4]). 
>>>
>>>In any case, draft-montavont-mobileip-multihoming-pb-statement-00.txt
>>>attemps to state what the problem is so that we are all on the wave 
>>>in order to be able to design a single WG solution that would address 
>>>all the issues. Probably it would be useful to include this draft in 
>>>the agenda.
>>>      
>>>
>>I agree that it is a good idea to discuss the problem statement. But 
>>given the current scope of the charter and the priorities of the WG, I 
>>would rather have that this discussion be carried out on the Mailing 
>>list first. I would like to see the opinions of the WG members w.r.t 
>>this problem.
>>    
>>
>

---

From: Soliman Hesham <[email-masked]>
Date: Sat, 25 Oct 2003 23:50:48 -0400

> > => FWIW, he did bring it up 
 > 
 > you missed the point. there is a big difference between
 > bringing it up and generating interest in the WG.

=> I think you missed a few emails! There is clear interest
in the WG. In fact, I haven't seen one email objecting
to this topic being added (except Raj's last email). 

 > 
 > > and so did I (In Minneapolis
 > > meeting 2001 and it got delayed because of the MIPv6 debacle)
 > > and a few other people. 
 > 
 > so? without MIPv6 being standardized first, there was no
 > point talking about multiple interfaces and multiple flows.

=> Now it's done. So let's talk.

 > ps: FWIW, I support adding multi-homed mobile nodes to the
 > charter.

=> Great.

Hesham

---

From: [email-masked]
Date: Fri, 31 Oct 2003 07:19:05 -0600

Hi Keiichi,
> 
> Hi all,
> 
> Since it seems no one is intersted in this topic, I stop requesting a
> slot for this.  I'll raise the same topic again before next next IETF
> probablly with implementation and some operational experience.

I think this proposal is actually quite relevant to the MIP6 WG. I am
definitely interested in this work. I think it makes sense to include
this on the agenda for the upcoming meeting. RO is a part of the
base spec. However the base spec does not have any guidance on
when RO should be used. And this I-D is the only one so far that is
making any recommendations at all.

So, I will add this to the agenda item.

-Basavaraj

> 
> # Comments or contacts about this topic are of course welcome 
> at any time
> 
> ---
> Keiichi SHIMA
> IIJ Research Laboratory <[email-masked]>
> KAME Project <[email-masked]>
> 
> From: Keiichi SHIMA / 島慶一 <[email-masked]>
> Subject: Re: [Mip6] Draft Agenda for WG meeting at IETF58
> Date: Thu, 23 Oct 2003 16:13:41 +0900 (JST)
> 
> > Hi,
> > 
> > I wonder if we can have a time to discuss mechanisms for RO 
> procedure
> > initiation judgement.  The basic draft mentions that a
> > mobile/correpondent node should be administratively enabled/disabled
> > to allow RO.  However, I think we need more flexible mechanism for
> > managed networks.
> > 
> > Please take a look into
> > http://www.ietf.org/internet-drafts/draft-shima-mip6-rohints-00.txt,
> > which describes one such proposal.
> > 
> > Regards,
> > ---
> > Keiichi SHIMA
> > IIJ Research Laboratory <[email-masked]>
> > KAME Project <[email-masked]>
>