Subject: [Mip6] Mobile IPv6 Interop Testing Draft

From: Samita Chakrabarti <[email-masked]>
Date: Mon, 20 Oct 2003 10:53:43 -0700 (PDT)

As per Basavaraj Patil's recommendation, a mip6-interop
design team has been formed and the team has worked on producing
the first draft on the Mobile IPv6 remote interop testing
requirements, scenarios and procedures.

The draft has been submitted as an individual draft for
now, but it is targeting to be a working group draft in
the next revision. It is available through T.J Kniveton's
webpage until the draft becomes available at the IETF directory.

http://www.mipv6.org/specs/draft-kniveton-mipv6-remote-testing-00.txt

Thanks.

The mip6-interop design team.
T.J Kniveton,
Basavaraj Patil,
Hesham Soliman,
Henrik Petander,
Samita Chakrabarti

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Keiichi SHIMA / 島慶一 <[email-masked]>
Date: Fri, 24 Oct 2003 21:32:44 +0900 (JST)

Hello Samita and T.J.,

It is very interesting and good idea to establish a remote test
environment. (and we are interested in participating the test, of
course :-)

By the way, I have a question (or concern) about the virtual home link
described in Section 8 in the draft.

Section 8 proposes the method for mobile node implementers to test
'returning to home' with other home agent vendor's implementation,
even when the mobile node cannot access the real home link of the home
agent.

My question is, how is a home agent (and a home link) configured?

I imagined the following network, for example.

      ----+----------  home link P::/64
  	  |
          |P::1 (home agent address)
       IF1|200.0.0.1
       +--+-+
       | HA |    IF3(200.0.0.1 - 100.0.0.1)
       +--+-+
       IF2| 
	  |
     ((Internet))
	  |
	  |
       ---+---------+------------ visited link of MN tester Q::/64
	      	    |
	      	    |Q::100 (care-of address)
	      	 IF1|100.0.0.1
	      	 +--+-+
       	       	 | MN |   IF2(100.0.0.1-200.0.0.1)
		 +----+

HA has physically two interfaces, IF1 and IF2.  In this case, IF2 has
nothing to do with this scenario, I ignore it.  HA also has one tunnel
interface IF3 between 200.0.0.1 and 100.0.0.1.

MN has physically one interface IF1, and one tunnel interface IF2
between 100.0.0.1 and 200.0.0.1.

The draft says, MN receives a router advertisement for home link from
HA via the tunnel interface IF2.  However I think it is difficult,
since HA must have two different interfaces and those interfaces must
be assigned the same prefix (in this case, P::/64).  This means HA is
required to support a kind of multi-link subnet technology.  (Or did I
misread?)

If there is no physical home link, I think it is possible to configure.
For example,

       +--+-+  IF1(200.0.0.1 - 100.0.0.1)
       | HA |       P::1/64 (home address)
       +--+-+
       IF2|200.0.0.1 
	  |
     ((Internet))
	  |
	  |
       ---+---------+------------ visited link of MN tester Q::/64
	      	    |
	      	    |Q::100 (care-of address)
	      	 IF1|100.0.0.1
	      	 +--+-+
       	       	 | MN |   IF2(100.0.0.1-200.0.0.1)
		 +----+

In this case, I see no problem.  However, this scenario requires as
many home subnets as the number of mobile nodes, since HA must arrange
different tunnel interface and home prefix for each mobile node.

I don't think the former scenario is not appropriate.  It is of course
more efficient than the latter, if HA can do that.  But I just think
not so many home agent can do it.  I may be wrong...

Best Regards,
---
Keiichi SHIMA
IIJ Research Laboratory <[email-masked]>
KAME Project <[email-masked]>