Subject: [Mip6] I-D ACTION:draft-mkhalil-mipv6-nai-00.txt

From: [email-masked]
Date: Fri, 17 Oct 2003 15:34:39 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title		: Mobile IP Network Access Identifier Extension for IPv6
	Author(s)	: M. Khalil, et. al.
	Filename	: draft-mkhalil-mipv6-nai-00.txt
	Pages		: 0
	Date		: 2003-10-17
	
This document defines a way for the mobile node to identify itself,
by including the NAI with the MIPv6 Binding Update messages.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-mkhalil-mipv6-nai-00.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-mkhalil-mipv6-nai-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-mkhalil-mipv6-nai-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "T.J. Kniveton" <[email-masked]>
Date: Fri, 17 Oct 2003 15:08:45 -0700

> by including the NAI with the MIPv6 Binding Update messages.

I have some comments and questions on the draft, if you're ready for them.

Is there supposed to be any way to authenticate a user as owning a particular
NAI? Are you planning on integrating the use of AAAv6, PANA, or some other
method?

   Upon receiving the Binding Update, the HA will first verify 
   the authenticity of the Binding Update. It will then attempt
   to allocate a unique IP address to the MN.

This is a catch-22, right? How can the HA verify the authenticity of the BU
without having a pre-established security association with the MN at a certain
address? There is no way listed to establish some sort of authenticity of the
NAI, unless I am totally missing something..

  Upon receiving a Binding Update, the HA MUST verify the 
  authenticity of the Binding Update message. The authentication
  process is out side the scope of this draft.

I disagree.

  If and when the HA receives a valid Binding Update with the
  Home IP address field set to zero and the NAI option included,
  it will attemnpt to allocate a unique IP address and 
  proceed with registration procedure as stated in [MIPV6].

So this means you are turning off all security?

I think I am not understanding the gist of the draft. Please explain how
security works in this scheme..

thanks,

TJ

-- 
        T.J. Kniveton 
   Communication Systems Lab
     Nokia Research Center

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6