Subject: [Mip6] issue 327 part 1 status -- BAD calculation clarification

From: Jari Arkko <[email-masked]>
Date: Wed, 12 May 2004 19:51:25 +0300

I think we had agreement on this part, except that you Mike
commented:

>   (a) Computation of authentication data when MN deregisters from a foreign link.
> 
>    You proposed:
> 
>       Mobility Data = care-of address | correspondent | MH Data
>       Authenticator = First (96, HMAC_SHA1 (Kbm, Mobility Data))
> 
>    Where | denotes concatenation. "Care-of address" is the
>    care-of address which will be registered for the mobile node
>    if the Binding Update succeeds. Note that this address
>    might be different from the source address of the Binding Update
>    message, if the Alternative Care-of Address mobility option is
>    used, or when the lifetime of the binding is set to zero.
> 
>       This still isn't very clear. I take it that "Care-of address"
>       is meant to be the home address (not the CoA) when the lifetime
>       of the binding is zero?

Yes. Maybe:

    Where | denotes concatenation. "Care-of address" is the
    care-of address which will be registered for the mobile node
    if the Binding Update succeeds, or the home address of the
    mobile node if this option is used in de-registration. Note also that
    this address might be different from the source address of the Binding Update
    message, if the Alternative Care-of Address mobility option is
    used, or when the lifetime of the binding is set to zero.

I think this falls into the category of a clarification
rather than a technical change. If people can agree to this,
I can notify the RFC editor.

--Jari

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: "Ed Remmell" <[email-masked]>
Date: Wed, 12 May 2004 10:18:05 -0700

Looks good to me.

Thanks.
- Ed

> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]] 
> Sent: Wednesday, May 12, 2004 9:51 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; Vijay Devarapalli; Brian Haley; 
> [email-masked]; [email-masked]
> Subject: issue 327 part 1 status -- BAD calculation clarification
> 
> ---
> Incoming mail is certified Virus Free.
> Checked by AVG anti-virus system (http://www.grisoft.com).
> Version: 6.0.676 / Virus Database: 438 - Release Date: 5/3/2004
>  
> 

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.676 / Virus Database: 438 - Release Date: 5/3/2004