Subject: [Mip6] RE: issue 327 #4

From: [email-masked]
Date: Tue, 11 May 2004 19:20:21 -0700

> -----Original Message-----
> From: ext Yukiyo Akisada [mailto:[email-masked]]
> Sent: Tuesday, May 11, 2004 7:08 PM
> To: [email-masked]; Devarapalli Vijay (Nokia-NRC/MtView)
> Cc: [email-masked]
> Subject: issue 327 #4
> 
> 
> Hi, Jari and Vijay.
> 
> On Mon, 10 May 2004 16:55:38 +0300
> Jari Arkko <[email-masked]> wrote:
> 
> > >>>4 - this just needs a clarification. if the MN is not  
> > >>>    including a Home Address Option in a de-registration
> > >>>    BU from the home link, it MUST set the lifetime to 0.
> > >>>    if the lifetime is 0, it is always a de-registration BU.
> 
> (snip)
> 
> > I think all the above is actually pretty clear. You need to know
> > if you are doing a reg or a de-reg. Then we have the 
> following cases:
> > 
> > REG    - SENDER: HAO is mandatory, coa!=hoa, and lifetime!=0
> >           RECEIVER: HAO is mandatory, coa!=hoa, and lifetime!=0
> > 
> > DE-REG - SENDER: HAO is optional, coa=hoa, and lifetime=0
> >           RECEIVER: HAO is optional, coa=hoa or lifetime=0
> 
> In the result,
> BU (lifetime!=0) w/o HaO means DE-REG for receiver, right?
> 
> In my memory, 
> at the last Connectathon,
> Vijay said that the receiver also requires 'coa=hoa and 
> lifetime=0' for de-registraion.
> # In this case, the receiver was HA.

I think I said if the Home Address option is present and home
address is equal to care-of, then it means de-registration to
the receiver irrespective of what the lifetime field is.

if the lifetime is 0, it always means de-registration.

> 
> If the receiver disallows to receive BU (lifetime!=0) w/o HaO 
> for de-registraion,
> we need text change.

this should be disallowed. 

Vijay

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Samita Chakrabarti <[email-masked]>
Date: Fri, 14 May 2004 16:11:28 -0700 (PDT)

> > For simplicity, why can't we always mandate lifetime = 0 for 
> > de-registration ?
> 
> Well, if a home agent or CN receives a binding update request that specifies
> a non-zero lifetime but HoA = CoA, does it make sense to create such a
> mobility binding where HoA = CoA? No, it does not. So, it is important to

I agree that we should check hoA != COA for non-zero lifetime.

> also check that HoA != CoA before accepting a new binding update request
> with a non-zero lifetime. Along the same lines, in general, any BU that has
> HoA = CoA would be handled as a deregistration BU, regardless of the setting
> of the lifetime field.
> 
>

I guess it was discussed earlier and if it is already in the draft that
HoA=COA would be considered as de-reg request irrespective of lifetime
value - then it's not worth discussing now. 
Perhaps we can re-visit its usefulness later.

Thanks,
-Samita