Subject: [Mip6] [Fwd: Re: Question on Binding Refresh Advice option]

From: Alpesh <[email-masked]>
Date: Wed, 12 May 2004 10:15:44 -0700

Wondering if we can incorporate some text clarifying the 
behavior/interpretation of the binding
refresh advice option? The current version of the draft lacks 
clarification regarding its usage.

Rgds
Alpesh

-------- Original Message --------
Subject: Re: Question on Binding Refresh Advice option
Date: Thu, 08 Apr 2004 08:55:08 -0700
From: Kent Leung <[email-masked]>
To: Alpesh Patel <[email-masked]>
CC: Jari Arkko <[email-masked]>, Jari Arkko 
<[email-masked]>, [email-masked]
References: <[email-masked]> <[email-masked]>

I think Jari said that HA is not restricting but only recommending MN to 
refresh
the binding.

How about this?

"... how long after receiving the Binding Ack that the mobile node SHOULD send
a new home registration to the home agent."

Kent

At 07:14 AM 4/8/2004 -0700, Alpesh Patel wrote:
>Jari -
>
>So, does that mean that the HA is "restricting" the binding lifetime than 
>requested in the BU?
>
>Don't sound like that from the 2nd comment?
>
>-a
>
>Jari Arkko wrote:
>>Alpesh Patel wrote:
>>
>>>Jari -
>>>
>>>Seeking clarification on the Binding Refresh Advice option - quoting 6.2.4,
>>>
>>>    The Binding Refresh Advice option is only valid in the Binding
>>>    Acknowledgement, and only on Binding Acknowledgements sent from the
>>>    mobile node's home agent in reply to a home registration.  The
>>>    Refresh Interval is measured in units of four seconds, and indicates
>>>    how long before the mobile node SHOULD send a new home registration
>>>    to the home agent.  The Refresh Interval MUST be set to indicate a
>>>    smaller time interval than the Lifetime value of the Binding
>>>    Acknowledgement.
>>>
>>>Guess the text should have said "how long before <>>registration>> the mobile node SHOULD send a new home reg..."
>>>
>>>wondering if the text << >> should have been added (or something similar?)
>>
>>I think it means difference from CURRENT TIME, not difference
>>from EXPIRY TIME. I agree that text might have been clearer.
>>How about "... indicates remaining time until the mobile node ..."?
>>
>>>What if the Mobile does not register within this time? What should the 
>>>HA do?
>>
>>Nothing. Its advice.
>>--Jari
>>
>

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Jari Arkko <[email-masked]>
Date: Wed, 12 May 2004 23:17:26 +0300

Hi Alpesh,

I believe this issue is already being tracked. See
   http://www.arkko.com/publications/mipv6/issues/issue324.txt

Is the suggested text below acceptable to you:

OLD:
NEW:
    remaining time until the mobile node SHOULD send a new home registration

--Jari

Alpesh wrote:
>> So, does that mean that the HA is "restricting" the binding lifetime 
>> than requested in the BU?
>>
>>>> Guess the text should have said "how long before <>>registration>> 
>>>> the mobile node SHOULD send a new home reg..."
>>>>
>>>> What if the Mobile does not register within this time? What should 
>>>> the HA do?
>>>
>>>
>>> Nothing. Its advice.
>>> --Jari
>>>
>>
> 
> 
> 
>

---

From: Alpesh <[email-masked]>
Date: Wed, 12 May 2004 17:58:36 -0700

Jari -

This is fine. I would suggest that we add a sentence reflecting the fact 
that if the mobile node does not
send BU to refresh the Binding cache, HA would not do anything. The text 
says "SHOULD",
but the first time I read this I was pondering the applicability.

-a

Jari Arkko wrote:

>> I think Jari said that HA is not restricting but only recommending MN 
>> to refresh
>> the binding.
>>
>> How about this?
>>

---

From: Jari Arkko <[email-masked]>
Date: Fri, 14 May 2004 18:40:25 +0300

> but the first time I read this I was pondering the applicability.

I see your point, but I'm reluctant to add
anything more at this stage. Sorry! The
name of the option is "Advice", so I think it
can be interpreted this way. If there's future
confusion about it, we can always fix it
in the updated RFC at a later date.

--Jari