Subject: RE: [Mip6] use of IPsec

From: "Soliman Hesham" <[email-masked]>
Date: Wed, 5 May 2004 14:39:17 -0400

> > => That's true, but at the same time it's easy to fix that.
 > >    A new header can be defined, as we did eventually.
 > 
 > It's easy in hindsight, especially if one disregards the
 > other features that were deleted as collateral damage.

=> That's right, for me it was easy back then because
I didn't see a big benefit for piggybacking, but I
guess we don't have concensus on that.

 > 
 > Well, I'm easy on this.  Please exhibit the threat by way of
 > some rational application (e.g., VoIP).  As I understand it,
 > the application running on the correspondent node has to have
 > certain characteristics:
 > 1) no feedback from the mobile node

=> Not really, I remember having a discussion (I think
on the list) where we thought it was possible for the bombing
node to continue to provide feedback by guessing the 
TCP sequence no. For instance in the case where a streaming
server is being used to bomb the victim.

 > 2) agrees to accept bazillions of incoming packets
 >    regardless of (1)

=> The victim will not accept anything, but its
link will be floodded nevertheless.

 > 
 > Or we can try to justify by way of the distributed
 > denial of service attack, whereby bazillions of
 > devices in the Internet attempt to use a sophisticated
 > Mobile IPv6 mechanism instead of just bombing the heck
 > out of the victim with pings...  (?)

=> The difference here is that the attacker is not traceable.

 > 
 > >                            In my mind, the major reason
 > > is the lack of global PKI. After all we use IPsec with the HA
 > > and it works fine.
 > 
 > Yow.  Global PKI.  It sounded a lot better before
 > we had John Ashcroft.

=> :) Yes, it seems to me like there are harder problems
in the world than MIPv6 security :( 

Hesham

 > Regards,
 > Charlie P.

========================================================
This email may contain confidential and privileged material for the sole
use of the intended recipient.  Any review or distribution by others is 
strictly prohibited.  If you are not the intended recipient please contact
the sender and delete all copies.
========================================================

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: "Charles E.Perkins" <[email-masked]>
Date: Wed, 05 May 2004 12:19:21 -0700

Hello Hesham,

I guess you wrote this before receiving my "Correction:"
e-mail.  And anyway I'm not sure about whether it's
relevant to the original topic of the thread, so maybe
I shouldn't even send this...

> server is being used to bomb the victim.

That would require some pretty clever synchronization
and guesstimation of round trip times between victim
and correspondent node.  "Possible" (p <= .00...1),
I'll agree with, sort-of ...  Did anyone ever _show_ this??

> link will be floodded nevertheless.

Yes, oops, please see my correction.

> => The difference here is that the attacker is not traceable.

1) The correspondent node certainly knows the responsible
   home address ==> traceability
2) With zombies, nobody ever cares about traceability anyway.

So, we're all the way up to p=0.00...1 threats now.

Regards,
Charlie P.