Subject: Re: [Mip6] issue 327 part 1 status -- BAD calculation clarification

From: Samita Chakrabarti <[email-masked]>
Date: Fri, 14 May 2004 14:01:59 -0700 (PDT)

Hi Jari,

Hope it's not too late to comment on this.

> >   (a) Computation of authentication data when MN deregisters from a foreign 
link.
> > 
> >    You proposed:
> > 
> >       Mobility Data = care-of address | correspondent | MH Data
> >       Authenticator = First (96, HMAC_SHA1 (Kbm, Mobility Data))
> > 
> >    Where | denotes concatenation. "Care-of address" is the
> >    care-of address which will be registered for the mobile node
> >    if the Binding Update succeeds. Note that this address
> >    might be different from the source address of the Binding Update
> >    message, if the Alternative Care-of Address mobility option is
> >    used, or when the lifetime of the binding is set to zero.
> > 
> >       This still isn't very clear. I take it that "Care-of address"
> >       is meant to be the home address (not the CoA) when the lifetime
> >       of the binding is zero?
> 
> Yes. Maybe:
> 
>     Where | denotes concatenation. "Care-of address" is the
>     care-of address which will be registered for the mobile node
>     if the Binding Update succeeds, or the home address of the
>     mobile node if this option is used in de-registration. Note also that
>     this address might be different from the source address of the Binding 
Update
>     message, if the Alternative Care-of Address mobility option is
>     used, or when the lifetime of the binding is set to zero.
> 
> I think this falls into the category of a clarification
> rather than a technical change. If people can agree to this,
> I can notify the RFC editor.

Yes this is just clarification. I have experienced interop problem
at Connectathon this time because of ambiguity.

I'd prefer the text to be clearer; note that the word
"different" in the following line is not clear.

>Note also that
>     this address might be different from the source address of the Binding 
Update
>     message, if the Alternative Care-of Address mobility option is
>     used, or when the lifetime of the binding is set to zero.
>  

We need to clarify further, for example:

1) If BU lifetime =0, with or without home-address option.
   COA = homeaddr
   
2) If Alt-COA is present and this is not a de-registration request,
   then COA = address in alternate COA option

  Thanks,
  -Samita 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Jari Arkko <[email-masked]>
Date: Sat, 15 May 2004 08:17:09 +0300

> Hope it's not too late to comment on this.

It may be. I sent the edits to the RFC editor
yesterday.

But I'll take a look at this anyway, and
if there's a serious problem we can do something.

--Jari