Subject: [Mip6] Issue 330

From: Vijay Devarapalli <[email-masked]>
Date: Sat, 08 May 2004 23:18:03 -0700

hi Jari,

I think the first two suggestions should be adopted. I am not sure
about the 3rd one.

> 1.  Section 5.1, page 21:
> 
>    When IKE version 1 is used with preshared secret authentication
>    between the mobile node and the home agent, aggressive mode MUST be
>    used.  Similarly, the ID_IPV6_ADDR Identity Payload MUST NOT be used
>    in IKEv1 phase 1.
> 
> might be revised to separate the sentences, as follows:
> 
>    When IKE version 1 is used with preshared secret authentication
>    between the mobile node and the home agent, aggressive mode MUST be
>    used.
> 
>    The ID_IPV6_ADDR Identity Payload MUST NOT be used in IKEv1 phase 1.  [a reference to the ipsec
>    i-d would be useful here if appropriate]
> 
> 2.  Section 11.3.2, page 113:
> 
>    o  In addition, for all security associations bound to the mobile
>       node's home address established by IKE, the mobile node MUST
>       include an ISAKMP Identification Payload [8] in the IKE exchange,
>       giving the mobile node's home address as the initiator of the
>       Security Association [7].
> 
> It is not critical, but I would suggest that "the IKE exchange" read "the IKE phase 2 exchange".

Vijay

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Jari Arkko <[email-masked]>
Date: Mon, 10 May 2004 00:32:54 +0300

Vijay Devarapalli wrote:
>>    The ID_IPV6_ADDR Identity Payload MUST NOT be used in IKEv1 phase 

Breaking the paragraph in two is fine.

>> 1.  [a reference to the ipsec

Maybe not, if there's no additional explanation in the
other draft either.

>> "the IKE phase 2 exchange".

Right.

Seems like the third issue, the rationale behind not
using IPV6_ADDR in phase 1, has already been dealt with
in e.g. issue 305. I don't think we should add the
rationale to the RFC at this stage.

This leaves us with the first two modifications.

--Jari