Subject: RE: [Mip6] Consensus Call: Standardizing the auth protocol [I-D:draft-ietf-mip6-auth-protocol-00.txt]

From: "Hirschman, Brent B [NTK]" <[email-masked]>
Date: Thu, 7 Oct 2004 12:39:58 -0500

I support standardization of this draft!!

The question to the WG is:

1. Should we standardize the authentication protocol specified in I-D
   draft-ietf-mip6-auth-protocol-00.txt as an alternative (to the
   IPSec mechanism specified in RFC3775/6) means to securing the BUs
   and BAcks between the MN and HA. Note that this solution is an
   additional mechanism for doing registration with an HA and does not
   deprecate the currently specified solution. 

   Yes	     [XXX ]
   No	     [ ]

Brent Hirschman
Principal Member of Technical Staff
Industry Standards
KSOPHD0504-5D178
6220 Sprint Parkway, Overland Park, KS 66251
Voice 913-794-4271  FAX 913-794-0420
PCS 913-593-6221
[email-masked]

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Lipford, Mark A [NTK]" <[email-masked]>
Date: Thu, 7 Oct 2004 13:00:54 -0500

I agree, a YES for me too.

Mark A. Lipford 
Manager, Sprint Industry Standards 
6220 Sprint Parkway (Eisenhower C) 
Mailstop:  KSOPHD0504-5D128 
Overland Park, KS  66251-6118 

(913) 794-3764 (office) 
(913) 794-0420 (fax) 
(913) 579-2319 (mobile) 
[email-masked] 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Alpesh
Sent: Thursday, October 07, 2004 11:45 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Mip6] Consensus Call: Standardizing the auth protocol
[I-D:draft-ietf-mip6-auth-protocol-00.txt]

My vote is YES for the draft.

-a

[email-masked] wrote:

>This is a consensus call to the WG on the issue of standardizing the
>authentication-data-suboption mechanism for performing a binding
between the
>MN and HA. The issue has been discussed on the WG mailing list over
>the last few weeks. The I-D
>(draft-patil-mip6-whyauthdataoption-00.txt) has captured some of the
>arguments, but there are several others that have been made on the
>list as well. A summary of the discussion was sent out earlier and is
>captured in :
>http://www1.ietf.org/mail-archive/web/mip6/current/msg01690.html
>
>The proposal here (in brief) is to standardize a mechanism specified
>in I-D draft-ietf-mip6-auth-protocol-00.txt for performing MIP6
>registration with a home agent. RFC3775 specifies the use of IPsec to
>secure the binding update/ACK messages between the MN and HA. The
>auth-protocol mechanism relies on the use of an
>authentication-data-suboption and does not require the MN-HA to
>establish an IPsec SA.  
>(For the discussion that has ensued so far, please refer to the MIP6
>ML archives)
>
>   Yes	     [ ]
>The consensus call will close on October 12th, 2004.
>
>-Chairs
>

---

From: "Soliman, Hesham" <[email-masked]>
Date: Fri, 8 Oct 2004 01:19:34 -0400

I haven't seen an argument that changes my stand on this issue
yet, so I'll have to go with NO.

Hesham

 > From: [email-masked] [mailto:[email-masked]]On 
 > Behalf Of
 > [email-masked]
 > Sent: Wednesday, October 06, 2004 6:03 PM
 > To: [email-masked]
 > Subject: [Mip6] Consensus Call: Standardizing the auth protocol
 > authentication-data-suboption mechanism for performing a 
 > binding between the

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

---

From: [email-masked]
Date: Fri, 8 Oct 2004 09:52:16 +0300

Hi,

My vote is:

   Yes	     [X]
   No	     [ ]

BR,
	Juha Wiljakka
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
ext [email-masked]

authentication-data-suboption mechanism for performing a binding between the

   Yes	     [ ]
   No	     [ ]

-Chairs

---

From: [email-masked]
Date: Mon, 11 Oct 2004 07:39:10 +0300

Yes	[X]
   No	     	[ ]

Mika

> Sent: 07 October, 2004 01:03
> To: [email-masked]

---

From: [email-masked]
Date: Mon, 11 Oct 2004 10:18:21 -0500

I vote YES,

Franck

----- Original Message ----- 
From: <[email-masked]> 
To: <[email-masked]> 
Sent: Wednesday, October 06, 2004 3:02 PM 
Subject: [Mip6] Consensus Call: Standardizing the auth protocol [I-D:draft-ietf-mip6-auth-protocol-00.txt] 
This is a consensus call to the WG on the issue of standardizing the authentication-data-suboption mechanism for performing a binding between the MN and HA. The issue has been discussed on the WG mailing list over the last few weeks. The I-D
(draft-patil-mip6-whyauthdataoption-00.txt) has captured some of the arguments, but there are several others that have been made on the list as well. A summary of the discussion was sent out earlier and is captured in : http://www1.ietf.org/mail-archive/web/mip6/current/msg01690.html
The proposal here (in brief) is to standardize a mechanism specified in I-D draft-ietf-mip6-auth-protocol-00.txt for performing MIP6 registration with a home agent. RFC3775 specifies the use of IPsec to secure the binding update/ACK messages between the MN and HA. The auth-protocol mechanism relies on the use of an authentication-data-suboption and does not require the MN-HA to establish an IPsec SA. (For the discussion that has ensued so far, please refer to the MIP6 ML archives)
The question to the WG is: 
1. Should we standardize the authentication protocol specified in I-D 
   draft-ietf-mip6-auth-protocol-00.txt as an alternative (to the 
   IPSec mechanism specified in RFC3775/6) means to securing the BUs 
   and BAcks between the MN and HA. Note that this solution is an 
   additional mechanism for doing registration with an HA and does not 
   deprecate the currently specified solution. 
   Yes      [ ] 
   No      [ ]

---

From: [email-masked]
Date: Tue, 12 Oct 2004 07:46:18 +0300

I vote YES.

BR,
Markku Ala-Vannesluoma
Nokia

---

From: "Manning, Serge M [NTK]" <[email-masked]>
Date: Mon, 11 Oct 2004 14:50:13 -0500

>From: [email-masked] [mailto:[email-masked]] On 
>Subject: [Mip6] Consensus Call: Standardizing the auth 
>protocol [I-D:draft-ietf-mip6-auth-protocol-00.txt]

   Yes	     [X]
   No	     [ ]

[Serge] I vote Yes.

---

From: [email-masked]
Date: Tue, 12 Oct 2004 08:34:34 -0500

Forwarding this email from Mark (by request) since his original email
does not seem to have made it to the list.

-BPa

> From: ext Lipford, Mark A [NTK] 
> [mailto:[email-masked]]
> Sent: Thursday, October 07, 2004 1:01 PM
> To: Alpesh; Patil Basavaraj (Nokia-NET/Dallas)
> Cc: [email-masked]
> Subject: RE: [Mip6] Consensus Call: Standardizing the auth protocol

---

From: Samita Chakrabarti <[email-masked]>
Date: Tue, 12 Oct 2004 10:04:52 -0700 (PDT)

> >The consensus call will close on October 12th, 2004.

My vote is :

No	     [X]

to the above question.

I have read *whyauthdataoption* draft and I understand that 
draft-ietf-mip6-auth-protocol-00.txt [ similar to MIPv4 authentication ]
is easily deployable in 3GPP2 network rather than IPSec/IKE as specified
in the base MIPv6 RFCs. I am not convinced that the auth-protocol draft
is the solution for the issues and hence standardization. 
I am OK with an informational RFC or experimental one for the 3GPP2 usage. 

Regards,
-Samita