Subject: [Mip6] New draft revision for preconfigured keys for authenticating Binding Updates

From: "Charles E.Perkins" <[email-masked]>
Date: Thu, 21 Oct 2004 13:50:36 -0700

Hello folks,

I am expecting to finish today a new revision for

"Preconfigured Binding Management Key Data for Mobile IPv6"

namely,
	draft-ietf-mip6-precfgKbm-01.txt

During the last IETF, there was discussion about
whether or not to include a Care-of Address test
in this draft, so that a correspondent node could
use the basic idea of the draft while still having
equal confidence that the mobile node is legitimately
addressable as it claims.  The consensus as I recall
is that this "preconfigured" draft should NOT take
on the additional specification for the Care-of
Test that would have been needed.

That's good in a way, because it keeps this draft
simpler.  On the other hand, I would very much
like to see that there is as much commonality as
possible between the various approaches, mainly
so that the code can be kept as simple as possible
and to reduce the number of hiding places for bugs.
One way to promote this code simplicity is by
re-using the material in the base draft as much
as possible.

With that in mind, I am proposing in the new draft
that the computation for Kbm be made in the same
way as in the base Mobile IPv6 specification, but
with preconfigured data used in the formula.
This is a real improvement as well as, in some
ways, a simplification.  This means that, instead
of preconfiguring the key itself (Kbm), one would
instead preconfigure the Home Keygen Token (Hkt)
and the Care-of Keygen Token (Ckt), as well as
the nonce values used in the computation.  This
allows for quite a few bits of randomness for the
data used in the computation.

Then, Kbm is computed exactly as specfied in the
base draft, using the preconfigured Keygen Tokens.

This has another great advantage, which is that
the Kbm used changes at every new care-of address.
This makes the replay protection much improved
than if the care-of address does not affect the
value of Kbm.  The replay protection is, as
computed in the draft, already sufficient for
many cases.  But having the replay also depend
on specific care-of addresses in use will just
be that much better.  Also, I expect this will
make it just a little more difficult to gather
enough data to crack the preconfigured secret
data.  I believe this formulation maintains
the ability to create a stronger security
association than afforded by return routability,
albeit only applicable in a restricted set of
scenarios as documented in the draft.

Comments on this will be welcome; please excuse
the short amount of time before the submission
deadline.  If need be, I will be happy to revise
the draft just after the blackout period ends
again after the IETF.

Regards,
Charlie P.

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Francis Dupont <[email-masked]>
Date: Sat, 23 Oct 2004 11:03:31 +0200

In your previous mail you wrote:

=> I designed a care-of test for the MN-CN IPsec draft: at the last
meeting I proposed to make it a separate document which can be used
for any RO protection mechanism without a built-in care-of address
test. Obviously the pre-configured key document is one of them...

Regards

[email-masked]