Subject: RE: [Mip6] Next steps for I-D: draft-ietf-mip6-auth-protocol

From: "Lipford, Mark A [NTK]" <[email-masked]>
Date: Fri, 22 Oct 2004 08:40:25 -0500

Charlie,

I sent a brief reply yesterday, but it may be lost somewhere.

3GPP2 is currently in their R&F piece of completing their release D.
This is the review and freeze process where the document is baselined
and comments submitted against it.  The goal is to try and complete that
this month so that the document can be forward to the 3GPP2 SDO's for
balloting and to have the ballot comments liaised back to 3GPP2 in time
to start addressing them at the December meeting.  The general rule is
that 3GP2 and TIA will not publish a document with references to IETF
Internet-drafts, so we would need to have an RFC number before we
complete ballot resolution, which Sprint is pushing to have done in
January.

You probably recall the FA Challenge I-D and how it held up our initial
release, but it is also a critical piece to the successful mobile IP
deployments we have.  This I-D is similar in importance from our
[Sprint's] perspective.

Hope this helps.

Mark A. Lipford 
Manager, Sprint Industry Standards 
6220 Sprint Parkway (Eisenhower C) 
Mailstop:  KSOPHD0504-5D128 
Overland Park, KS  66251-6118 

(913) 794-3764 (office) 
(913) 794-0420 (fax) 
(913) 579-2319 (mobile) 
[email-masked] 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Charles E.Perkins
Sent: Thursday, October 21, 2004 2:51 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Mip6] Next steps for I-D: draft-ietf-mip6-auth-protocol

Hello Basvaraj,

[email-masked] wrote:

> Well, one of the key driving factors for expediting the work on this
> I-D is because of the fact that 3GPP2 would like to incorporate MIP6
> into the TIA-835 specification (Rev D). This would be a major step
> forward in terms of MIP6 deployment. The charter of the WG is to take
> on tasks that aid in deployment. This is one of those tasks.

No problem with that.  What is their timeline?

>> For instance, I strongly disagree that authentication
>> should mandate including the NAI.
> 
> If you are going to use the AAA infra as a means for authenticating a
> MIP6 user, and the identity used/configured in the AAA-Home for the
> user is an NAI, it makes sense to include the NAI as part of the
> auth-protocol.

Of course, it is not insane to include the NAI.  It is
useful in many circumstances.  That means "MAY", not "SHOULD".
It is equally sensible to run the protocol without NAI, just
not with pre-existing equipment that expects otherwise.

>> I also wonder
>> why there is any mandate to agree with anything
>> in rfc3012bis, since that is a protocol specification
>> concerned with IPv4.

> ???? I dont understand your concern here Charlie.

The draft says:

   The MN MUST use either CHAP_SPI or HMAC_CHAP_SPI as defined in
   [3012bis] to indicate CHAP style authentication.

I don't think it is a good idea to make the specification
this way, unless it is already agreed that the numbering
space would be kept identical forever.  Otherwise, there
will have to be two numbering spaces for the SPI field,
and in that case the above quoted specification would not
be a good idea it seems to me.

But this is a relatively minor point, and the original
request was to delay the scheduled WG last call in order
that I might have time to fully understand the draft.

I don't mind adding issues to the issue tracker, but
my point is that it's premature for WG last call.

Regards,
Charlie P.

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Charles E.Perkins" <[email-masked]>
Date: Fri, 22 Oct 2004 07:00:35 -0700

Hello Mark,

I could imagine getting through WG last call
by January.

I can't imagine getting through the RFC editor's
queue by January.

Would that be O.K.?

Regards,
Charlie P.