Subject: RE: [Mip6] Next steps for I-D: draft-ietf-mip6-auth-protocol

From: [email-masked]
Date: Thu, 21 Oct 2004 14:30:53 -0500

Hi Charlie,

>Hello Basvaraj,
>
>I am in favor of getting things done as quickly as possible,
>but I hope that we do not have to rush to completion so
>soon on this.  What are the driving factors for expediting
>the standardization of the protocol?

Well, one of the key driving factors for expediting the work on this
I-D is because of the fact that 3GPP2 would like to incorporate MIP6
into the TIA-835 specification (Rev D). This would be a major step
forward in terms of MIP6 deployment. The charter of the WG is to take
on tasks that aid in deployment. This is one of those tasks.

>For instance, I strongly disagree that authentication
>should mandate including the NAI.  

If you are going to use the AAA infra as a means for authenticating a
MIP6 user, and the identity used/configured in the AAA-Home for the
user is an NAI, it makes sense to include the NAI as part of the
auth-protocol. 

>I also wonder
>why there is any mandate to agree with anything
>in rfc3012bis, since that is a protocol specification
>concerned with IPv4.

???? I dont understand your concern here Charlie.

>I think there could be a number of other issues
>about which discussion is needed.

Sure. Please feel free to raise the issues with the I-D. The I-D is a
WG document and we will specify the mechanism based on WG consensus.

>Regards,
>Charlie P.

-Basavaraj

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Charles E.Perkins" <[email-masked]>
Date: Thu, 21 Oct 2004 12:50:53 -0700

Hello Basvaraj,

> on tasks that aid in deployment. This is one of those tasks.

No problem with that.  What is their timeline?

> user is an NAI, it makes sense to include the NAI as part of the

Of course, it is not insane to include the NAI.  It is
useful in many circumstances.  That means "MAY", not "SHOULD".
It is equally sensible to run the protocol without NAI, just
not with pre-existing equipment that expects otherwise.

> ???? I dont understand your concern here Charlie.

The draft says:

   The MN MUST use either CHAP_SPI or HMAC_CHAP_SPI as defined in
   [3012bis] to indicate CHAP style authentication.

I don't think it is a good idea to make the specification
this way, unless it is already agreed that the numbering
space would be kept identical forever.  Otherwise, there
will have to be two numbering spaces for the SPI field,
and in that case the above quoted specification would not
be a good idea it seems to me.

But this is a relatively minor point, and the original
request was to delay the scheduled WG last call in order
that I might have time to fully understand the draft.

I don't mind adding issues to the issue tracker, but
my point is that it's premature for WG last call.

Regards,
Charlie P.