Subject: [Mip6] Next steps for I-D: draft-ietf-mip6-auth-protocol

From: [email-masked]
Date: Thu, 21 Oct 2004 12:48:31 -0500

Next steps for I-D: draft-ietf-mip6-auth-protocol

1. Merge the NAI Option for MIP6 (specified in I-D:
   draft-ietf-mip6-nai-option) with the Auth protocol draft. 
   
2. There were several people who suggested during the consensus call
   that they would like to see some changes to the current
   proposal. Please send the changes that you would like to see to the
   I-D by raising an issue. The issue list for MIP6 is at:
   http://www.mip4.org/issues/tracker/mip6/

3. We will issue a Working group last call as soon as the next
   revision of the I-D is published.

-Basavaraj

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Charlie P <[email-masked]>
Date: Thu, 21 Oct 2004 12:14:44 -0700

Hello Basvaraj,

I am in favor of getting things done as quickly as possible,
but I hope that we do not have to rush to completion so
soon on this.  What are the driving factors for expediting
the standardization of the protocol?

For instance, I strongly disagree that authentication
should mandate including the NAI.  I also wonder
why there is any mandate to agree with anything
in rfc3012bis, since that is a protocol specification
concerned with IPv4.

I think there could be a number of other issues
about which discussion is needed.

Regards,
Charlie P.

---

From: Alpesh <[email-masked]>
Date: Thu, 21 Oct 2004 12:37:56 -0700

Charlie -

I just did a grep on doc and we don't have a MUST that NAI and 
MHAE/MN-AAA AE
must go together. NAI "should" be used with the auth. option (not must).

Beyond that, can you list the issues? I can add them up on the issue 
tracker
(or maybe you can too) and we can track it there?

-a

Charlie P wrote:

>>   draft-ietf-mip6-nai-option) with the Auth protocol draft.   2. 
>> There were several people who suggested during the consensus call

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 21 Oct 2004 14:19:00 -0700

> must go together. NAI "should" be used with the auth. option (not must).

"should" is not defined in RFC 2119. :) when used in an RFC,
the lowercase should is generally considered the equivalent
of MUST. alteast thats my understanding.

I guess you wanted to say NAI option SHOULD be used with auth
option (?).

Vijay

---

From: Alpesh <[email-masked]>
Date: Thu, 21 Oct 2004 15:08:05 -0700

cut and paste :)

    <t>
    The MN SHOULD use NAI option <xref target= "NAI_opt"/> to
    enable the Home Agent to make use of available AAA
    infrastructure which requires NAI.
    </t>

This is what I have :)
-a