Subject: RE: [Mip6] Next steps for I-D: draft-ietf-mip6-auth-protocol

From: "Soliman, Hesham" <[email-masked]>
Date: Thu, 21 Oct 2004 21:35:23 -0400

> > Charlie -
 > > 
 > > I just did a grep on doc and we don't have a MUST that NAI and 
 > > MHAE/MN-AAA AE
 > > must go together. NAI "should" be used with the auth. 
 > option (not must).
 > 
 > "should" is not defined in RFC 2119. :) when used in an RFC,
 > the lowercase should is generally considered the equivalent
 > of MUST. alteast thats my understanding.

=> Correct. See 2461, there are no upper case keywords.

 > 
 > I guess you wanted to say NAI option SHOULD be used with auth
 > option (?).

=> I agree with Charlie, SHOULD is too strong. There SHOULD
be alternatives like IMSI ...etc

Hesham

 > 
 > Vijay
 > 
 > > 
 > > Beyond that, can you list the issues? I can add them up on 
 > the issue 
 > > tracker
 > > (or maybe you can too) and we can track it there?
 > > 
 > > -a
 > > 
 > > Charlie P wrote:
 > > 
 > >>
 > >> Hello Basvaraj,
 > >>
 > >> I am in favor of getting things done as quickly as possible,
 > >> but I hope that we do not have to rush to completion so
 > >> soon on this.  What are the driving factors for expediting
 > >> the standardization of the protocol?
 > >>
 > >> For instance, I strongly disagree that authentication
 > >> should mandate including the NAI.  I also wonder
 > >> why there is any mandate to agree with anything
 > >> in rfc3012bis, since that is a protocol specification
 > >> concerned with IPv4.
 > >>
 > >> I think there could be a number of other issues
 > >> about which discussion is needed.
 > >>
 > >> Regards,
 > >> Charlie P.
 > >>
 > >>
 > >>
 > >> [email-masked] wrote:
 > >>
 > >>> Next steps for I-D: draft-ietf-mip6-auth-protocol
 > >>>
 > >>> 1. Merge the NAI Option for MIP6 (specified in I-D:
 > >>>   draft-ietf-mip6-nai-option) with the Auth protocol draft.   2. 
 > >>> There were several people who suggested during the consensus call
 > >>>   that they would like to see some changes to the current
 > >>>   proposal. Please send the changes that you would like 
 > to see to the
 > >>>   I-D by raising an issue. The issue list for MIP6 is at:
 > >>>   http://www.mip4.org/issues/tracker/mip6/
 > >>>
 > >>> 3. We will issue a Working group last call as soon as the next
 > >>>   revision of the I-D is published.
 > >>>
 > >>> -Basavaraj
 > >>>   _______________________________________________
 > >>> Mip6 mailing list
 > >>> [email-masked]
 > >>> https://www1.ietf.org/mailman/listinfo/mip6
 > >>>  
 > >>>
 > >>
 > >>
 > > 
 > > 
 > > 
 > > _______________________________________________
 > > Mip6 mailing list
 > > [email-masked]
 > > https://www1.ietf.org/mailman/listinfo/mip6
 > 
 > 
 > _______________________________________________
 > Mip6 mailing list
 > [email-masked]
 > https://www1.ietf.org/mailman/listinfo/mip6
 > 

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Francis Dupont <[email-masked]>
Date: Sat, 23 Oct 2004 11:17:31 +0200

In your previous mail you wrote:

=> I believe you mean the GSM IMSI (the thing which should never be sent
in clear over the network :-), don't you?

Regards

[email-masked]

PS: BTW I agree and I have a real concern about RFC 2119 keyword misused
in some documents of this WG, for instance the IKEv2 one...
Here an ID is RECOMMENDED or even REQUIRED, but not a particular ID.