Subject: RE: [Mip6] review of draft-ietf-mip6-bootstrapping-split-00.txt

From: "Kilian Weniger" <[email-masked]>
Date: Wed, 28 Sep 2005 10:10:39 +0200

please see comments inline.

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]] 
> Sent: Dienstag, 27. September 2005 19:23
> To: Kilian Weniger
> Cc: [email-masked]
> Subject: Re: [Mip6] review of 
> draft-ietf-mip6-bootstrapping-split-00.txt
> 
> Kilian Weniger wrote:
> > Hi all,
> > 
> > draft-ietf-mip6-bootstrap-ps-03 says that local HA 
> assignment has been
> > mentioned as one approach to provide efficient routing and location
> > privacy, but unfortunately there is no reference. Did the 
> authors refer
> > to draft-koodli-mip6-location-privacy-solutions-00.txt, 
> which proposes
> > reverse tunneling as one solution to prevent the disclosure 
> of MN's CoA
> > and, thus, location to CN?
> > 
> > My question is if and how local HA assignment as described in
> > draft-ietf-mip6-bootstrapping-split-00.txt can provide 
> location privacy.
> > If a MN gets assigned a local HA, it changes its HoA and 
> updates DNS. It
> > is true that the CoA is not disclosed to CN if MN uses 
> reverse tunneling
> > to the local HA. But IMO location privacy support might be 
> broken, since
> > the new HoA now contains location information and is 
> publicly available
> > in DNS, i.e., other nodes (including CN) can derive the 
> (approximate)
> > location of MN by requesting MN's HoA from DNS. By 
> periodically querying
> > DNS, others can even track MN's movement. I agree that the 
> accuracy of
> > the location might be relatively low, depending on "how 
> local" the local
> > HAs are and how quick the MN changes to new (i.e., closer) 
> local HAs.
> > But if the accuracy is low because the MN has not switched to the
> > closest local HA, it is likely that the routing efficiency 
> is not good,
> > too.
> 
> the MN could refrain from asking the HA to do the DNS update.
> as described in draft-ietf-mip6-bootstrapping-split-00.txt,
> the HA does not update the DNS entry for the MN unless the
> MN requests it.

yes, but if the MN does not request DNS updates after bootstrapping with
a local HA, it is not reachable for other nodes - at least not at the
HoA belonging to the local HA. Consequently, if location privacy is
required, efficient routing is not possible for communication sessions
not initiated by MN or for mobile-to-mobile communication (e.g., VoIP
sessions). 

If my understanding is correct, I think it might be good to have some
text about that in draft-ietf-mip6-bootstrapping-split-00.txt,
especially because location privacy and routing efficiency is mentioned
in draft-ietf-mip6-bootstrap-ps-03.txt as a motiviation for the
bootstrapping solution. 

Kilian

> 
> > An alternative solution to this problem is to reverse 
> tunnel to local
> > HAs, but keep the HoA of MN unchanged. This approach is, 
> e.g., proposed
> > in draft-weniger-rota-00.txt.
> > 
> > BTW, shouldn't the QNAME be set to "_mip6_ipv6.example.com" 
> instead of
> > "mip6.example.com" in the DNS lookup by service name 
> example in section
> > 5.1.2 of draft-ietf-mip6-bootstrapping-split-00.txt? 
> 
> yes.
> 
> Vijay
> 
> 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "James Kempf" <[email-masked]>
Date: Wed, 28 Sep 2005 08:50:13 -0700

jak>> We can look at putting some text in the Security Considerations 
section. There's a real tension between reachability and location privacy 
here, I think.

                  jak

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 28 Sep 2005 12:03:53 -0700

> in draft-ietf-mip6-bootstrap-ps-03.txt as a motiviation for the

I think I understand your point now. if the MN acquires a local
HA and HoA and the MN's DNS entry is updated with the local HoA,
then this reveals where the MN is located. there isn't much we
can do here. maybe just point this out, as Jim recommended, in
the Security Considerations section. (somebody a while ago
suggested adding location privacy considerations section to
every draft :)

Vijay