Subject: [Mip6] [issue64] No tunnel before accepting the first IPv4-IPv6 tunneled BA

From: Ryuji Wakikawa <[email-masked]>
Date: Thu, 23 Feb 2006 19:08:38 +0000

New submission from Ryuji Wakikawa <[email-masked]>:

When a MN roams to global v4 network and sends BU with UDP header,
the HA will sends back BA without UDP header (since there is no NAT).

However, the MN can not receive the BA which is IPv4-IPv6
tunneled...  The bi-directional tunnel is established after the
completion of BU and BA exchanges.  This is somehow chicken-egg
problem, isn't this?

Note if IPsec tunnel is used, it should be alright. IPsec tunnel is
established after IKE exchanges.

So my proposal is that HA always reply BA with UDP header.
This is simple. I like simplicity.

Comment from  Hesham
=> Agreed. Reply with a UDP tunnel; if no NAT were detected then the                                                                 
following BUs can be IP in IP. So this rule applies to the first
BU only.

----------
category: Technical
draft: draft-ietf-mip6-nemo-v4traversal
messages: 203
nosy: ryuji
priority: Must fix
status: Text proposed
title: No tunnel before accepting the first IPv4-IPv6 tunneled BA

_________________________________________________
Mip6 issue tracker <[email-masked]>
<http://www.mip4.org/issues/tracker/mip6/issue64>
_________________________________________________

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Ryuji Wakikawa <[email-masked]>
Date: Tue, 28 Feb 2006 11:51:27 +0900

Hi

#I Cc MIP6 ML.

The first version of the draft is not fully completed one due to time  
constrain.

See the section 4.1.
We introduce a new NAT detection mechanism by using BU.

The new draft should be submitted before the next IETF.

ryuji

On 2006/02/28, at 11:44, Mohan Parthasarathy wrote:

>   At least this what i read in 2.3.2.2
>
>
>    In this scenario the mobile node will need to tunnel IPv6 packets
>    containing the binding update to the home agent's IPv4 address. The
>    mobile node uses the IPv4 address it gets from the foreign  
> network as
>    a source address in the outer header.So, what do you mean by UDP ?
>
> -mohan
>
>
>
> ----- Original Message -----
> From: "Ryuji Wakikawa" <[email-masked]>
> To: "Mohan Parthasarathy" <[email-masked]>
> Sent: Monday, February 27, 2006 6:35 PM
> Subject: Re: [Mip6] [issue64] No tunnel before accepting the first  
> IPv4-IPv6tunneled BA
>
>
>> BU is sent with UDP header.
>>
>> ryuji
>>
>> On 2006/02/28, at 11:28, Mohan Parthasarathy wrote:
>>
>>> Sounds odd..how does the HA receive the BU in the first place when
>>> there is no tunnel ?
>>> If there is no issue there, there is no issue here, right ? Of
>>> course i am talking for the
>>> non-ipsec tunnel case. The real issue is how did the HA receive the
>>> IPv6-in-IPv4 BU
>>> without a IPv6-in-IPv4 tunnel ?
>>>
>>> -mohan
>>>
>>> ----- Original Message -----
>>> From: "Ryuji Wakikawa" <[email-masked]>
>>> To: <[email-masked]>
>>> Sent: Thursday, February 23, 2006 11:08 AM
>>> Subject: [Mip6] [issue64] No tunnel before accepting the first IPv4-
>>> IPv6tunneled BA
>>>
>>>
>>>

---

From: Ryuji Wakikawa <[email-masked]>
Date: Tue, 28 Feb 2006 12:00:02 +0900

Hi

#Please include MIP6 ML

The BU is not processed in the IP forwarding engine.
BU is stored in UDP packet and the UDP port receiver must process the  
packets (IPheader etc).
In addition, there is mapped address in the IPv6 header.
It is impossible to process this packet with the ip forwarding engine.
The node does not configure the mapped address to the interface and  
does not have route for the mapped address.
#I personally don't like the use of mapped address, but this is what  
we agreed in DT at this point.

Even HA does not have tunnel state, all the BU must be protected by  
IPsec.
Thus, HA process only authenticated BU.

ryuji

On 2006/02/28, at 11:50, Mohan Parthasarathy wrote:

> UDP is to solve the NAT traversal problem. But the BU itself IPv6- 
> inIPv4 encapsulated packet.
>
> -mohan
>

---

From: Mohan Parthasarathy <[email-masked]>
Date: Mon, 27 Feb 2006 19:48:34 -0800 (PST)

Hi,

But it would still be a IPv6-in-UDP-IPv4 packet ? 

-mohan

--- Ryuji Wakikawa <[email-masked]> wrote:

> >>> the HA will sends back BA without UDP header
> (since there is no  
> >>> NAT).
> >>>