Subject: RE: [Mip6] Draft agenda for WG meeting at IETF65

From: "Giaretta Gerardo" <[email-masked]>
Date: Wed, 8 Mar 2006 09:55:39 +0100

Hi Kuntal, Vidya, all,

I tend to think that the draft applies to NETLMM or at least it would be useful to have a presentation in NETLMM and not in MIP6. It seems to me that the draft applies also to LMM and NETLMM is currently the only WG in IETF that is developing network-based mobility solution. Concerning the fact that it leverages MIP6 protocol, I guess this is a technical choice that could be taken into consideration also in NETLMM design if there are real advantages.

--Gerardo

> -----Original Message-----
> From: Narayanan, Vidya [mailto:[email-masked]] 
> Sent: mercoledì 8 marzo 2006 9.27
> To: Junghoon Jee; Chowdhury, Kuntal; Vijay Devarapallli
> Cc: [email-masked]; Basavaraj Patil
> Subject: RE: [Mip6] Draft agenda for WG meeting at IETF65
> 
> While the draft doesn't specifically apply to "LMM", we have to ask
> ourselves about how many different ways we are going to do 
> network-based
> mobility in the IETF? 
> 
> Also, is the intent of this draft to use network-based mobility for
> global mobility? If so, it would be good to see an explanation of why
> that is needed. 
> 
> Thanks,
> Vidya
> 
> > -----Original Message-----
> > From: Junghoon Jee [mailto:[email-masked]] 
> > Sent: Tuesday, March 07, 2006 10:46 PM
> > To: 'Chowdhury, Kuntal'; 'Vijay Devarapallli'
> > Cc: [email-masked]; 'Basavaraj Patil'
> > Subject: RE: [Mip6] Draft agenda for WG meeting at IETF65
> > 
> >  
> > > > >
> > http://www.ietf.org/internet-drafts/draft-chowdhury-netmip6-00.txt
> > > > >
> > > > > It shows a way to provide mobility service for IPv6 
> using a MIP6
> > > Client
> > > > > in the network. Note that the proposal re-uses MIP6 protocol
> > with
> > > some
> > > > > inters access router signals. The proposed method will be
> > > useful to
> > > > > provide IPv6 mobility service in operator's networks
> > > where majority
> > > of
> > > > > the handsets are not MIP6 capable.
> > > > 
> > > > doesnt this belong in NETLMM?
> > > [KC>] I don't think it applies to NETLMM directly. The 
> > reason is that 
> > > "NET" part perhaps is applicable, but the "LMM" part is 
> not. Another
> > > difference: this I-D leverages MIP6 protocol as is.  
> > 
> > Yes, I agree that this I-D is not tightly related with 
> "Localized" MM.
> > 
> > I would like to have a chance to see the off-line 
> > presentation about this I-D through the upcoming MIP6 WG 
> > 
> > Thanks,
> > Junghoon
> > 
> > 
> > _______________________________________________
> > Mip6 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/mip6
> > 
> 
> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mip6
> 
--------------------------------------------------------------------

CONFIDENTIALITY NOTICE

This message and its attachments are addressed solely to the persons above and may contain confidential information. If you have received the message in error, be informed that any use of the content hereof is prohibited. Please return it immediately to the sender and delete the message. Should you have any questions, please contact us by replying to [email-masked].

        Thank you

                                        www.telecomitalia.it

--------------------------------------------------------------------

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Wed, 8 Mar 2006 08:40:08 -0500

> Sent: Wednesday, March 08, 2006 2:27 AM
network-based
> mobility in the IETF?

[KC>] Ideally one way...but the world is neither perfect nor one
solution fits the bill for every problem space. 

> global mobility? If so, it would be good to see an explanation of why

[KC>] Yes, the solution is for macro mobility management. I hope you are
not questioning the need for macro mobility management in a network. The
network based mobility management is used in the world today in
disparate (often proprietary) ways. We are trying to define one way
(that reuses MIP6 protocol as much as possible).

> > > > > It shows a way to provide mobility service for IPv6 using a
MIP6
> > > "NET" part perhaps is applicable, but the "LMM" part is not.
Another
> > Yes, I agree that this I-D is not tightly related with "Localized"
MM.

---

From: "Giaretta Gerardo" <[email-masked]>
Date: Wed, 8 Mar 2006 15:08:09 +0100

Hi Kuntal,
 
I'd like to have a clear definition of what you mean by macro mobility management. This is because the scope of NETLMM is to  define a network-based solution for the mobility within an operator's network: this is what for example is done by GTP in 3GPP networks. This is a local mobility because it does not involve the whole Internet, but only a domain that can span the whole operator's network. I guess this is what you are proposing, too. Or are you proposing a network-based mobility management protocol to handle ubiquitous mobility across any and all access types?
 
Concerning leveraging MIP6 protocol, if there are technical reasons to use MIP6 protocol as NETLMM solution I think NETLMM may be based on MIP6 signaling. Personally, I don't see these reasons, but I may be wrong.
 
--Gerardo

________________________________

	From: Chowdhury, Kuntal [mailto:[email-masked]] 
	Sent: mercoledì 8 marzo 2006 14.51
	To: Giaretta Gerardo; Narayanan, Vidya
	Cc: [email-masked]; Basavaraj Patil; Junghoon Jee; Vijay Devarapallli
	Subject: RE: [Mip6] Draft agenda for WG meeting at IETF65

	Gerardo,

	I am OK to make a presentation in netlmm since at least the "net" part is common. However, the I-D is not specifically trying to address localized mobility which is a big part of netlmm wg's agenda. 

	I think at this stage, we want to get feedback from both mip6 and netlmm wg members for progress of the work. If netlmm wg decides to leverage mip6 protocol for LMM aspects, that would be alright. We can decide the future home for this work at that time.

	Regards,

	Kuntal

________________________________

	From: Giaretta Gerardo [mailto:[email-masked]] 
	Sent: Wednesday, March 08, 2006 2:56 AM
	To: Narayanan, Vidya; Chowdhury, Kuntal
	Cc: [email-masked]; Basavaraj Patil; Junghoon Jee; Vijay Devarapallli
	Subject: RE: [Mip6] Draft agenda for WG meeting at IETF65

	Hi Kuntal, Vidya, all,

	--Gerardo

	--------------------------------------------------------------------
	CONFIDENTIALITY NOTICE
	This message and its attachments are addressed solely to the persons
	above and may contain confidential information. If you have received
	the message in error, be informed that any use of the content hereof
	is prohibited. Please return it immediately to the sender and delete
	the message. Should you have any questions, please contact us by
	replying to [email-masked] <mailto:[email-masked]> .
	        Thank you
	                                        www.telecomitalia.it <http://www.telecomitalia.it> 
	--------------------------------------------------------------------

	"This email message and any attachments are confidential information of Starent Networks, Corp. The information transmitted may not be used to create or change any contractual obligations of Starent Networks, Corp. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this e-mail and its attachments by persons or entities other than the intended recipient is prohibited. If you are not the intended recipient, please notify the sender immediately -- by replying to this message or by sending an email to [email-masked] -- and destroy all copies of this message and any attachments without reading or disclosing their contents. Thank you." 

CONFIDENTIALITY NOTICE

        Thank you

                                        www.telecomitalia.it

---

From: "Soliman, Hesham" <[email-masked]>
Date: Wed, 8 Mar 2006 07:20:28 -0800

It's not Raj's fault, I gave him the wrong name. 
Don't worry, the content is clearly inclusive of nemo :) which is what
really matters. 

Hesham 

 > From: Thierry Ernst [mailto:[email-masked]] 
 > Sent: Tuesday, March 07, 2006 6:57 PM
 > To: [email-masked]
 > Subject: Re: [Mip6] Draft agenda for WG meeting at IETF65
 > 
 > 
 > Hi Basavaraj,
 > 
 > On Tue, 07 Mar 2006 09:47:49 -0600
 > Basavaraj Patil <[email-masked]> wrote:
 > > Below is the agenda for the MIP6 WG meeting. If you had 
 > sent a request 
 > > for a slot and do not see it, please contact me.
 > 
 > > Agenda of MIP6 WG meeting @ IETF65
 > > Monday, March 20 2006, 1300-1500 Afternoon Session I
 > > 
 > > ------------------------------------------------------
 > 
 > > 3. I-D: draft-ietf-mip6-v4traversal-01.txt        15 Mins
 > >   Presenter: Hesham Soliman
 > 
 > Is this on purpose that you always forget about 'NEMO' ? ;-) 
 > The right name should be:
 > http://www.ietf.org/internet-drafts/draft-ietf-mip6-nemo-v4tr
aversal-00.txt
 > Thierry.

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Wed, 8 Mar 2006 07:26:26 -0800

Kuntal, 
Clearly, this does not translate to the terminology used by NETLMM for its definitions of "global" and "local" - so, if you are referring to macro-mobility in light of the definition you've stated below, I believe your draft does fall within the scope of NETLMM. 
 
In any case, I don't think there is anything in NETLMM that "theoretically" limits its scope to "local" mobility - in theory, I believe that whatever protocol they come up with could apply just fine to global mobility as well. But, the practical limitations of trust relationships among network entities that is needed to achieve realization of a NETMM (note the absence of L here) protocol will force its applicability to be limited (hence the L in NETLMM, I believe). 
 
It is good to have a debate on whether mip4 and mip6 should do network-based mobility or just leave it up to NETLMM - I am not advocating one way or the other yet. But, I do hope that we can have this debate and conclude on one approach rather than doing it everywhere - someone would have to prove that the practical applicability of each is different in scope to warrant separate efforts on this topic. 
 
Vidya

	From: Chowdhury, Kuntal [mailto:[email-masked]] 
	Sent: Wednesday, March 08, 2006 7:15 AM
	To: Giaretta Gerardo
	Cc: [email-masked]; Basavaraj Patil; Junghoon Jee; Vijay Devarapallli; Narayanan, Vidya
	Subject: RE: [Mip6] Draft agenda for WG meeting at IETF65

	Gerardo...the term "macro mobility" is normally used to refer to the mobility event that requires the MN to perform MIP (re-) registration. Micro mobility is the term which is normally used to describe mobility events that do not require the MN to perform MIP (re-) registration e.g. inter base station handoffs within the same base station controller footprint.

	-Kuntal

	From: Giaretta Gerardo [mailto:[email-masked]] 
	Sent: Wednesday, March 08, 2006 8:08 AM
	To: Chowdhury, Kuntal
	Cc: [email-masked]; Basavaraj Patil; Junghoon Jee; Vijay Devarapallli; Narayanan, Vidya
	Subject: RE: [Mip6] Draft agenda for WG meeting at IETF65

	Hi Kuntal,

	--Gerardo

		Gerardo,

		Regards,

		Kuntal

		 

		Hi Kuntal, Vidya, all,

		--Gerardo

---

From: "DENG, HUI -HCHBJ" <[email-masked]>
Date: Sun, 19 Mar 2006 12:34:00 +0800

Hi, Kuntal
 
I don't know whether you saw some drafts which is related to Network based mobility management,
those draft doesn't change MIP6 as you stated here which is different from NETLMM.
 
Those drafts have already been discussed in Mobopts WG twice, 
So I would like to suggest that you could check there.
 
-Hui
 
��Z�g�N��{^��(~�b�隊V�v+lj�Zr���"}��j���w�u�퉩Z�ٚɷ���^rםo)Z���{-j|���������n��ʋ�j��yǢ��m�+���o)��֤z��j��y�(��zX���ajܨ��ޞ�m�觵��y��r*bz{i��zz-������׫o*ަ\����j�(�v���,��^jw]zW�z+_�����ܢjn�����^�)�yؚ��r��y��z�ʋ�����^�{^�ם��"�'��*.��-��\����+��������!�����b��h��ay�'������*-���z�(�hb����ޙ�^z����ߢ�m�G������p��/���~����Z����)�{"n)b�'譩�r���׫�*�br��[z�ڞ�ޮ��o,ʇ�+���