Subject: Re: [Mip6] The test specification that uses IKEv1 with Mobile IPv6

From: "K.Kawaguchi" <[email-masked]>
Date: Mon, 13 Mar 2006 19:13:36 +0900

Hello. 

I am sorry for the response's falling behind.
We will make the test specification intended for two patterns.

However, it is a problem that there might not be interoperability
in two patterns.
We hope for a standard pattern to be clarified by RFC...

Best regards
---
Kiyoaki KAWAGUCHI [email-masked]

"Re: [Mip6] The test specification that uses IKEv1 with Mobile IPv6 "
"Francis Dupont <[email-masked]>" wrote:

>  In your previous mail you wrote:
> 
>    Their ideas are that MN always cares for the maintenance of
>    all SA as well as Home Registration.
> 
> => this seems a very reasonnable idea.
> 
>    In this case, HA to work only as responder on all scenes.
>    (They think that HA used as VPN-GW doesn’t have to equip
>     Initiator functions.)
>    
>    What do you think of this idea?
>    
> => for pratical/deployment reasons you can't fight against it so
> IMHO you can consider it is the default option.
> 
> Regards
> 
> [email-masked]

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Fri, 31 Mar 2006 10:54:52 -0800

> I am making the test specification of Mobile IPv6 in TAHI project.
> 
> 	http://cert.v6pc.jp/mipv6/
> 
> Now, we try to add the test specification that uses IKEv1 with Mobile
> IPv6.  We are making the test specification that secures the 
> interoperability
> based on RFC3776.  Since the IKE operation is not clear in RFC3776,
> we think there could be two implementations based on it.

I believe both cases should be supported and 
Case B must be made mandatory. This means 
support for Case B is a MUST and for Case A
is a SHOULD. The MUST for Case B is needed to
ensure interoperability. 

Vijay

> 
> Please look at the following two cases. 
> 
>   Case.A
>     HA <------------------------------------------> MN
>      IKE: Initiator,Responder                        IKE: 
> Initiator,Responder
>           (It becomes an initiator by own demand.)        (It 
> becomes an initiator by own demand.)
> 
>      HA and MN have Initiator and Responder function of IKE.
>      In this case, HA and MN only have to establish IPsec by using IKE
>      when oneself transmits the Mobile IPv6 signaling.
> 
> 
>   Case.B
>     HA <------------------------------------------- MN
>      IKE: Responder                                  IKE: Initiator
>                                                           (It 
> is always an initiator because it maintains IPsec.)
> 
>      HA have only Responder function.  MN have only Initiator 
> function.
>      (Because MN is Initiator of SA at the first 
> registration, it seems
>       to be natural that MN is Initiator of all SA.)
>      In this case, if MN has not established SA, HA cannot 
> send the Mobile
>      IPv6 signaling.  MN should begin IKE for keeping SA, 
> because MN should
>      always receive the Mobile IPv6 signaling from HA side.
> 
>   Note)
>     HA of Case.A and MN of Case.B have the interoperability.
>     But, HA of Case.B and MN of Case.A don't have the 
> interoperability at time.
> 
> 
> When we say that the Mobile IPv6 device support IKEv1, we 
> want to obtain
> a clear answer as follows. 
> 
>     (1) The Mobile IPv6 device must/should support Case.A.
> 
>     (2) The Mobile IPv6 device must/should support Case.B.
> 
>     (3) Not mandatory. Both Case.A and Case.B are acceptable 
> depending on local system.
> 
> PS.
>   Please give the opinion to me if there are operation other 
> than Case.A and Case.B.
>   Moreover, please give the opinion to me if there are ideas 
> other than (1)-(3).
> 
> 
> 
> Best regards
> ---