Subject: netmip6 and netlmm (was: RE: [Mip6] Draft agenda for WG meeting at IETF65)

From: "Giaretta Gerardo" <[email-masked]>
Date: Wed, 8 Mar 2006 16:23:51 +0100

(changing the subject)
 
Kuntal,
 
I know that :-) 
 
But it seems to me that the term localized mobility management may be somehow misleading on what is NETLMM (at least, in my understanding). NETLMM may not be only covering inter base station handovers with the same base station controller, as an example.
Please, which is the scenario your solution addresses? Not talking about MIP-registration, I just would like to understand which kind of mobility scenarios your proposal is addressing (e.g. inter-access mobility, inter-domain mobility, any type of mobility scenarios)
 
--Gerardo

________________________________

	From: Chowdhury, Kuntal [mailto:[email-masked]] 
	Sent: mercoledì 8 marzo 2006 16.15
	To: Giaretta Gerardo
	Cc: [email-masked]; Basavaraj Patil; Junghoon Jee; Vijay Devarapallli; Narayanan, Vidya
	Subject: RE: [Mip6] Draft agenda for WG meeting at IETF65

	Gerardo...the term "macro mobility" is normally used to refer to the mobility event that requires the MN to perform MIP (re-) registration. Micro mobility is the term which is normally used to describe mobility events that do not require the MN to perform MIP (re-) registration e.g. inter base station handoffs within the same base station controller footprint.

	-Kuntal

________________________________

	From: Giaretta Gerardo [mailto:[email-masked]] 
	Sent: Wednesday, March 08, 2006 8:08 AM
	To: Chowdhury, Kuntal
	Cc: [email-masked]; Basavaraj Patil; Junghoon Jee; Vijay Devarapallli; Narayanan, Vidya
	Subject: RE: [Mip6] Draft agenda for WG meeting at IETF65

	Hi Kuntal,

	I'd like to have a clear definition of what you mean by macro mobility management. This is because the scope of NETLMM is to  define a network-based solution for the mobility within an operator's network: this is what for example is done by GTP in 3GPP networks. This is a local mobility because it does not involve the whole Internet, but only a domain that can span the whole operator's network. I guess this is what you are proposing, too. Or are you proposing a network-based mobility management protocol to handle ubiquitous mobility across any and all access types?

	Concerning leveraging MIP6 protocol, if there are technical reasons to use MIP6 protocol as NETLMM solution I think NETLMM may be based on MIP6 signaling. Personally, I don't see these reasons, but I may be wrong.

	--Gerardo

________________________________

		From: Chowdhury, Kuntal [mailto:[email-masked]] 
		Sent: mercoledì 8 marzo 2006 14.51
		To: Giaretta Gerardo; Narayanan, Vidya
		Cc: [email-masked]; Basavaraj Patil; Junghoon Jee; Vijay Devarapallli
		Subject: RE: [Mip6] Draft agenda for WG meeting at IETF65

		Gerardo,

		I am OK to make a presentation in netlmm since at least the "net" part is common. However, the I-D is not specifically trying to address localized mobility which is a big part of netlmm wg's agenda. 

		I think at this stage, we want to get feedback from both mip6 and netlmm wg members for progress of the work. If netlmm wg decides to leverage mip6 protocol for LMM aspects, that would be alright. We can decide the future home for this work at that time.

		Regards,

		Kuntal

________________________________

		From: Giaretta Gerardo [mailto:[email-masked]] 
		Sent: Wednesday, March 08, 2006 2:56 AM
		To: Narayanan, Vidya; Chowdhury, Kuntal
		Cc: [email-masked]; Basavaraj Patil; Junghoon Jee; Vijay Devarapallli
		Subject: RE: [Mip6] Draft agenda for WG meeting at IETF65

		Hi Kuntal, Vidya, all,
		
		I tend to think that the draft applies to NETLMM or at least it would be useful to have a presentation in NETLMM and not in MIP6. It seems to me that the draft applies also to LMM and NETLMM is currently the only WG in IETF that is developing network-based mobility solution. Concerning the fact that it leverages MIP6 protocol, I guess this is a technical choice that could be taken into consideration also in NETLMM design if there are real advantages.
		
		--Gerardo
		
		> -----Original Message-----
		> From: Narayanan, Vidya [mailto:[email-masked]] 
		> Sent: mercoledì 8 marzo 2006 9.27
		> To: Junghoon Jee; Chowdhury, Kuntal; Vijay Devarapallli
		> Cc: [email-masked]; Basavaraj Patil
		> Subject: RE: [Mip6] Draft agenda for WG meeting at IETF65
		> 
		> While the draft doesn't specifically apply to "LMM", we have to ask
		> ourselves about how many different ways we are going to do 
		> network-based
		> mobility in the IETF? 
		> 
		> Also, is the intent of this draft to use network-based mobility for
		> global mobility? If so, it would be good to see an explanation of why
		> that is needed. 
		> 
		> Thanks,
		> Vidya
		> 
		> > -----Original Message-----
		> > From: Junghoon Jee [mailto:[email-masked]] 
		> > Sent: Tuesday, March 07, 2006 10:46 PM
		> > To: 'Chowdhury, Kuntal'; 'Vijay Devarapallli'
		> > Cc: [email-masked]; 'Basavaraj Patil'
		> > Subject: RE: [Mip6] Draft agenda for WG meeting at IETF65
		> > 
		> > 
		> > > > >
		> > http://www.ietf.org/internet-drafts/draft-chowdhury-netmip6-00.txt
		> > > > >
		> > > > > It shows a way to provide mobility service for IPv6 
		> using a MIP6
		> > > Client
		> > > > > in the network. Note that the proposal re-uses MIP6 protocol
		> > with
		> > > some
		> > > > > inters access router signals. The proposed method will be
		> > > useful to
		> > > > > provide IPv6 mobility service in operator's networks
		> > > where majority
		> > > of
		> > > > > the handsets are not MIP6 capable.
		> > > > 
		> > > > doesnt this belong in NETLMM?
		> > > [KC>] I don't think it applies to NETLMM directly. The 
		> > reason is that 
		> > > "NET" part perhaps is applicable, but the "LMM" part is 
		> not. Another
		> > > difference: this I-D leverages MIP6 protocol as is. 
		> > 
		> > Yes, I agree that this I-D is not tightly related with 
		> "Localized" MM.
		> > 
		> > I would like to have a chance to see the off-line 
		> > presentation about this I-D through the upcoming MIP6 WG 
		> > 
		> > Thanks,
		> > Junghoon
		> > 
		> > 
		> > _______________________________________________
		> > Mip6 mailing list
		> > [email-masked]
		> > https://www1.ietf.org/mailman/listinfo/mip6
		> > 
		> 
		> _______________________________________________
		> Mip6 mailing list
		> [email-masked]
		> https://www1.ietf.org/mailman/listinfo/mip6
		> 

		--------------------------------------------------------------------
		CONFIDENTIALITY NOTICE
		This message and its attachments are addressed solely to the persons
		above and may contain confidential information. If you have received
		the message in error, be informed that any use of the content hereof
		is prohibited. Please return it immediately to the sender and delete
		the message. Should you have any questions, please contact us by
		replying to [email-masked] <mailto:[email-masked]> .
		        Thank you
		                                        www.telecomitalia.it <http://www.telecomitalia.it> 
		--------------------------------------------------------------------

		"This email message and any attachments are confidential information of Starent Networks, Corp. The information transmitted may not be used to create or change any contractual obligations of Starent Networks, Corp. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this e-mail and its attachments by persons or entities other than the intended recipient is prohibited. If you are not the intended recipient, please notify the sender immediately -- by replying to this message or by sending an email to [email-masked] -- and destroy all copies of this message and any attachments without reading or disclosing their contents. Thank you." 

	--------------------------------------------------------------------
	CONFIDENTIALITY NOTICE
	This message and its attachments are addressed solely to the persons
	above and may contain confidential information. If you have received
	the message in error, be informed that any use of the content hereof
	is prohibited. Please return it immediately to the sender and delete
	the message. Should you have any questions, please contact us by
	replying to [email-masked] <mailto:[email-masked]> .
	        Thank you
	                                        www.telecomitalia.it <http://www.telecomitalia.it> 
	--------------------------------------------------------------------

--------------------------------------------------------------------

CONFIDENTIALITY NOTICE

This message and its attachments are addressed solely to the persons above and may contain confidential information. If you have received the message in error, be informed that any use of the content hereof is prohibited. Please return it immediately to the sender and delete the message. Should you have any questions, please contact us by replying to [email-masked].

        Thank you

                                        www.telecomitalia.it

--------------------------------------------------------------------

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Wed, 8 Mar 2006 10:31:29 -0500

Gerardo,

What type of mobility the mip6 protocol (RFC3775) addresses?

-Kuntal

  _____  

From: Giaretta Gerardo [mailto:[email-masked]] 
Sent: Wednesday, March 08, 2006 9:24 AM
To: Chowdhury, Kuntal
Cc: [email-masked]; Basavaraj Patil; Junghoon Jee; Vijay Devarapallli; Narayanan, Vidya
Subject: netmip6 and netlmm (was: RE: [Mip6] Draft agenda for WG meeting at IETF65)

(changing the subject)

Kuntal,

I know that :-) 

--Gerardo

  _____  

	Gerardo.the term "macro mobility" is normally used to refer to the mobility event that requires the MN to perform MIP (re-) registration. Micro mobility is the term which is normally used to describe mobility events that do not require the MN to perform MIP (re-) registration e.g. inter base station handoffs within the same base station controller footprint.

	-Kuntal

  _____  

	Hi Kuntal,

	--Gerardo

  _____  

		Gerardo,

		Regards,

		Kuntal

  _____  

		 

		Hi Kuntal, Vidya, all,

		--Gerardo

---

From: "Giaretta Gerardo" <[email-masked]>
Date: Wed, 8 Mar 2006 17:03:43 +0100

MIP6 can be used to handle mobility across any and all access types. 
 
This is clearly not possible using NETLMM due to limitations of trust relationships (as Vidya mentioned) and NETLMM support in all access networks. But NETLMM can be used to handle mobility across the whole mobile operator's network, even in presence of heterogeneous accesses, since it will be independent from the lower layer. This is mobility over a large area. It seems to me that macro/micro/global/local terms are not clear enough; I'd like just to understand which scenario you want to address with a network based solution.
 
BTW, I'm not opposing having a presentation of your draft in MIP6; I guess it may be useful to have a discussion on this with MIP6 folks. I'm just trying to understand if there are differences in the scope of what you are proposing and what we are working on in NETLMM Design Team.
 
--Gerardo

------------------------------------

From: Chowdhury, Kuntal [mailto:[email-masked]] 
Sent: mercoledì 8 marzo 2006 16.31
To: Giaretta Gerardo
Cc: [email-masked]; Basavaraj Patil; Junghoon Jee; Vijay Devarapallli; Narayanan, Vidya
Subject: RE: netmip6 and netlmm (was: RE: [Mip6] Draft agenda for WG meeting at IETF65)

Gerardo,

-Kuntal

-------------------------------------

(changing the subject)

Kuntal,

I know that :-) 

--Gerardo

CONFIDENTIALITY NOTICE

        Thank you

                                        www.telecomitalia.it