Subject: RE: [Mip6] [issue68] The use of K bit

From: "Narayanan, Vidya" <[email-masked]>
Date: Sun, 5 Mar 2006 22:41:08 -0800

> -----Original Message-----
> From: Vijay Devarapallli [mailto:[email-masked]] 
> Sent: Sunday, March 05, 2006 3:37 PM
> To: Francis Dupont
> Cc: Mip6 issue tracker; [email-masked]
> Subject: Re: [Mip6] [issue68] The use of K bit
> 
> On 3/5/06, Francis Dupont <[email-masked]> wrote:
> >  In your previous mail you wrote:
> >
> >    category: Technical
> >    draft: draft-ietf-mip6-ikev2-ipsec
> >    messages: 208
> >    nosy: vijay
> >    priority: Must fix
> >    status: Pending
> >    title: The use of K bit
> >
> > => I am strongly in favor of the K bit in the IKEv2 case because we 
> > don't want at all have to close/reopen IKE SAs (IKEv2 "session" for 
> > not-IPsec folk) at each handoff, which by side-effect in IKEv2 
> > includes close/reopen all IPsec SAs between the MN and the 
> HA, i.e., 
> > even the transport mode SA pair for BU/BA protection.
> > So clearly a smooth handling of handoff is needed for IKE SAs, and 
> > this is exactly what the K bit stuff does. BTW the K bit stuff is 
> > easier to implement in IKEv2 than in IKEv1 IMHO, there is no orphan 
> > IPsec SA pair for instance (orphan = with no link or a weak 
> link to an IKE SA).
> 
> I agree. perhaps someone from the last TAHI interop can do a 
> presentation at the IETF meeting. there were interoperable 
> implementations of the 'K' bit.

In general, having the K bit makes sense to me. Is there any reason why
MOBIKE would be precluded by the presence of the K bit? I would think
that the K bit can be set to 0 to use MOBIKE with MIP6 if someone wants
to do that. I don't see what we lose by keeping the K bit - in the
absence of MOBIKE, it is only seems like a useful thing. And, one
shouldn't have to deploy MOBIKE in order to allow the IKE SA endpoint
changes in MIP6. 

Vidya

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Francis Dupont <[email-masked]>
Date: Mon, 06 Mar 2006 21:08:34 +0100

In general, having the K bit makes sense to me. Is there any reason why
   MOBIKE would be precluded by the presence of the K bit?

=> I don't think so: we can't get two signalings for the same thing,
i.e., we have to run either MOBIKE or MIP6, but *not* both at the same
time.

   I would think that the K bit can be set to 0 to use MOBIKE with
   MIP6 if someone wants to do that.

=> this doesn't make sense.

Regards
   
[email-masked]