Subject: Network-based Mobility in the IETF (was RE: [Mip6] Draft agenda for WG meeting at IETF65)

From: "Narayanan, Vidya" <[email-masked]>
Date: Mon, 13 Mar 2006 13:32:08 -0800

(Cross-posting this to multiple mailing lists - apologies in advance if
you receive multiple copies as a result). 

Hi Junghoon,
I am fine with discussing this in the MIP6 WG. We definitely need to
discuss the pros and cons of each way of doing network-based mobility.
My point was this - at some point of time, we (IETF) need to have a
discussion on the preferred approach and (hopefully) have only one
protocol to do this. 

So far, I haven't seen any compelling reason to define multiple ways of
doing network-based mobility. NETLMM, given that it is a WG dealing with
this topic, may be the place to talk about the various approaches
(including MIP6-based or MIP4-based), have technical discussions on the
merits and disadvantages of each approach and pick one. I have no
problem with spending time in MIP4 or MIP6 to talk about this as long as
we agree that parallel duplicate efforts in multiple WGs must not be
done. 

OTOH, if there is a difference in requirements among the various
efforts, lets discuss those and see if multiple efforts are actually
warranted. 

Thanks,
Vidya

> -----Original Message-----
> From: Junghoon Jee [mailto:[email-masked]] 
> Sent: Wednesday, March 08, 2006 12:59 AM
> To: Narayanan, Vidya; 'Chowdhury, Kuntal'; 'Vijay Devarapallli'
> Cc: [email-masked]; 'Basavaraj Patil'
> Subject: RE: [Mip6] Draft agenda for WG meeting at IETF65
> 
> Hi Vidya,
> 
> > -----Original Message-----
> > From: Narayanan, Vidya [mailto:[email-masked]]
> > Sent: Wednesday, March 08, 2006 5:27 PM
> > To: Junghoon Jee; Chowdhury, Kuntal; Vijay Devarapallli
> > Cc: [email-masked]; Basavaraj Patil
> > Subject: RE: [Mip6] Draft agenda for WG meeting at IETF65
> > 
> > 
> > While the draft doesn't specifically apply to "LMM", we have to ask 
> > ourselves about how many different ways we are going to do 
> > network-based mobility in the IETF?
> 
> Yes, this a good point we need to think about.
> By the way, we cannot decide _one_ way in this stage.
> The obvious fact is that we need to identify the feasibility 
> and effectiveness of the emerging _network_ based MM ways.
> IMO, seeing and having the discussion about this I-D through 
> MIP6 WG would be helpful to achieve our eternal objective.
> One hint from Kuntal is that "this I-D leverages MIP6 protocol as is".
> 
> Isn't it an interesting point for MIP6 folks can discuss?
> 
> Thanks,
> Junghoon
> 
> > Also, is the intent of this draft to use network-based mobility for 
> > global mobility? If so, it would be good to see an 
> explanation of why 
> > that is needed.
> > 
> > Thanks,
> > Vidya
> > 
> > > -----Original Message-----
> > > From: Junghoon Jee [mailto:[email-masked]]
> > > Sent: Tuesday, March 07, 2006 10:46 PM
> > > To: 'Chowdhury, Kuntal'; 'Vijay Devarapallli'
> > > Cc: [email-masked]; 'Basavaraj Patil'
> > > Subject: RE: [Mip6] Draft agenda for WG meeting at IETF65
> > > 
> > >  
> > > > > >
> > > http://www.ietf.org/internet-drafts/draft-chowdhury-netmip6-00.txt
> > > > > >
> > > > > > It shows a way to provide mobility service for IPv6
> > using a MIP6
> > > > Client
> > > > > > in the network. Note that the proposal re-uses MIP6 protocol
> > > with
> > > > some
> > > > > > inters access router signals. The proposed method will be
> > > > useful to
> > > > > > provide IPv6 mobility service in operator's networks
> > > > where majority
> > > > of
> > > > > > the handsets are not MIP6 capable.
> > > > > 
> > > > > doesnt this belong in NETLMM?
> > > > [KC>] I don't think it applies to NETLMM directly. The
> > > reason is that
> > > > "NET" part perhaps is applicable, but the "LMM" part is
> > not. Another
> > > > difference: this I-D leverages MIP6 protocol as is.  
> > > 
> > > Yes, I agree that this I-D is not tightly related with
> > "Localized" MM.
> > > 
> > > I would like to have a chance to see the off-line
> > presentation about
> > > this I-D through the upcoming MIP6 WG
> > > 
> > > Thanks,
> > > Junghoon
> > > 
> > > 
> > > _______________________________________________
> > > Mip6 mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/mip6
> > > 
> 
> 
> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mip6
> 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "James Kempf" <[email-masked]>
Date: Mon, 13 Mar 2006 15:21:36 -0800

Taking my WG chair hat off for a monment, I think the IETF needs to define 
its mobility architecture. Pekka Nikander and I did a draft in the MIP6 WG 
two years ago in which we described the advantages of a network-based, 
localized mobility management and host-based, global mobility management. 
IETF now has 3 host-based global mobility management solutions (MIP6, HIP, 
and MOBIKE). I'm not sure that a network-based  global mobility management 
solution is necessary, but, in any case, absent a consistent architectural 
reason for doing it, I don't see much reason to standardize. If a good 
architectural case can be made for it, then it should be done.

Maybe we need to get the IAB involved in this discussion.

                       jak
----- Original Message ----- 
From: "Narayanan, Vidya" <[email-masked]>
To: "Junghoon Jee" <[email-masked]>; "Chowdhury, Kuntal" 
<[email-masked]>; "Vijay Devarapallli" <[email-masked]>
Cc: <[email-masked]>; "Basavaraj Patil" <[email-masked]>; 
<[email-masked]>; <[email-masked]>
Sent: Monday, March 13, 2006 1:32 PM
Subject: [netlmm] Network-based Mobility in the IETF (was RE: [Mip6] Draft 
agenda for WG meeting at IETF65)

> netlmm mailing list
> [email-masked]
> https://vesuvio.ipv6.cselt.it/mailman/listinfo/netlmm
>

---

From: "Junghoon Jee" <[email-masked]>
Date: Thu, 16 Mar 2006 11:27:01 +0900

Vidya,

Yes, having discussion at this stage through MIP4 or MIP6 is not
wasting time, I believe. 
Let's first see and then decide through more investigation on this.

Thanks,
-Junghoon

> Sent: Tuesday, March 14, 2006 6:32 AM
> Cc: [email-masked]; Basavaraj Patil; [email-masked]; [email-masked]
> Subject: Network-based Mobility in the IETF (was RE: [Mip6] 
> Draft agenda for WG meeting at IETF65)
> 
> 
> (Cross-posting this to multiple mailing lists - apologies in 
> advance if you receive multiple copies as a result). 
> 
> Hi Junghoon,
> I am fine with discussing this in the MIP6 WG. We definitely 
> need to discuss the pros and cons of each way of doing 
> network-based mobility.
> My point was this - at some point of time, we (IETF) need to 
> have a discussion on the preferred approach and (hopefully) 
> have only one protocol to do this. 
> 
> So far, I haven't seen any compelling reason to define 
> multiple ways of doing network-based mobility. NETLMM, given 
> that it is a WG dealing with this topic, may be the place to 
> talk about the various approaches (including MIP6-based or 
> MIP4-based), have technical discussions on the merits and 
> disadvantages of each approach and pick one. I have no 
> problem with spending time in MIP4 or MIP6 to talk about this 
> as long as we agree that parallel duplicate efforts in 
> multiple WGs must not be done. 
> 
> OTOH, if there is a difference in requirements among the 
> various efforts, lets discuss those and see if multiple 
> efforts are actually warranted. 
> 
> Thanks,
> Vidya
> 
> > The obvious fact is that we need to identify the feasibility and 
> > effectiveness of the emerging _network_ based MM ways.